15:03:47 <bnemec> #startmeeting oslo
15:03:47 <bnemec> Courtesy ping for bnemec, jungleboyj, moguimar, hberaud, stephenfin, kgiusti, johnsom, e0ne, redrobot, bcafarel
15:03:47 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:03:48 <openstack> Meeting started Mon Nov 11 15:03:47 2019 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:52 <openstack> The meeting name has been set to 'oslo'
15:05:43 <moguimar> o/
15:06:56 <bnemec> This might be a quick meeting with only two of us. :-)
15:08:33 <bnemec> #topic Red flags for/from liaisons
15:09:13 <bnemec> Nothing much that I know of on the Oslo side. The main thing is probably that I'm planning to start doing the regular weekly releases again this week.
15:09:59 <moguimar> cool
15:10:39 <moguimar> my team moved a meeting for this same slot, so I'll be multitasking a bit from now on
15:10:49 <moguimar> to*
15:11:18 <bnemec> Bleh. That's annoying.
15:11:22 <moguimar> yeah
15:11:25 <moguimar> no news from Barbican
15:11:45 <moguimar> but I minght touch some oslo.cache bits in the near future
15:11:51 <bnemec> After the time change here this is now scheduled for immediately after my team standup, but at least it doesn't straight up conflict.
15:12:34 <bnemec> Cool.
15:12:55 <moguimar> we are evaluating enabling TLS in memcached
15:13:36 <moguimar> probably for keystone IRC
15:14:05 <bnemec> I don't know if this will be helpful, but kmalloc was pushing for a change in memcached library there: https://review.opendev.org/#/c/634457/
15:14:42 <bnemec> pymemcached is supposed to be a better library in general so it might support TLS better. Or it might not. :-)
15:15:07 <moguimar> cool
15:15:28 <moguimar> I was reading about python-memcached and found out about pymemcached
15:16:19 <bnemec> That work has kind of stalled, so it might be good to sync up with hberaud about it. kmalloc is out on paternity leave right now.
15:16:24 <johnsom> Octavia is mostly looking for the networkx patch to merge
15:16:30 <moguimar> at least based on the number of contributors/commits/forks it feels like pymemcached is indeed more mature
15:16:57 <moguimar> ok bnemec, noted
15:17:02 <bnemec> Yeah, and python-memcached has some janky design we've had to work around.
15:17:18 <bnemec> johnsom: Okay, I think I +2'd that already? Can you drop a link here?
15:18:18 <johnsom> #link https://review.opendev.org/689611
15:18:38 <johnsom> You did. I'm just not sure who else will review... Sigh
15:19:49 <bnemec> johnsom: I'll ping hberaud next time I see him online. There isn't a networkx expert who's going to look at this so he may as well go ahead and +2 it. :-)
15:20:07 <johnsom> Ok
15:20:32 <bnemec> In fact, I'll go ahead and action him on this in case he reads the meeting notes.
15:20:44 <bnemec> #action hberaud to approve https://review.opendev.org/689611
15:21:22 <bnemec> johnsom: Thanks again for doing that.
15:23:11 <bnemec> #topic Releases
15:23:29 <bnemec> As I mentioned earlier, I'm planning to start the weekly release cycle this week.
15:24:06 <bnemec> Up until the week before the summit there weren't any deliverables for ussuri yet and I didn't want to do the first releases right before summit.
15:24:19 <bnemec> Otherwise not much to report here since I haven't been doing them. :-)
15:24:27 <bnemec> #topic Action items from last meeting
15:24:50 <bnemec> "kgiusti to followup with Akira7216 about NATS driver for oslo.messaging"
15:25:14 <bnemec> I believe I saw a spec posted for this.
15:25:36 <bnemec> Alternate drivers for oslo.messaging were kind of a popular summit topic.
15:26:18 <bnemec> Not sure how likely it is that we'll be able to merge them, but we'll see. Might also be a good way to attract some new oslo.messaging contributors.
15:26:32 <bnemec> "Oslo cores to NOT merge py27 removal patches yet"
15:26:55 <bnemec> AFAIK none of them have merged, so \o/
15:27:05 <bnemec> "bnemec send email to list about py27 plan for Oslo"
15:27:07 <bnemec> Done
15:27:23 <bnemec> That was it for action items.
15:27:31 <bnemec> #topic Virtual PTG
15:28:08 <bnemec> So we had a PTG table in Shanghai, but a number of the topics proposed in the etherpad required more of the team to be present for the discussion.
15:28:44 <bnemec> Keystone is in a similar situation with a lof of their contributors not being present at the in-person PTG, so they've been doing virtual PTG video calls.
15:28:57 <bnemec> I'd like to propose that we try doing the same.
15:29:59 <bnemec> Keystone seems to have had the best scheduling luck by doing theirs around their regular meeting time, so I'm thinking we should try to do the same.
15:31:08 <bnemec> I'd like to do maybe 2 hours. Hopefully we can get through the remaining topics in that amount of time.
15:31:30 <bnemec> Ideally for me it would be this hour + the next one, but I know that might be getting late for folks in Europe.
15:32:23 <bnemec> Since we don't have most of the team here today I guess we'll need to do the planning on the list, so I'll send an email about it.
15:32:31 <bnemec> #action bnemec to send email about virtual PTG
15:36:28 <bnemec> #topic Weekly Wayward Review
15:36:39 <bnemec> #link https://review.opendev.org/678771
15:37:13 <bnemec> This one is pretty simple. moguimar, can you give it a second +2 when you're done with your other meeting?
15:37:27 <moguimar> bnemec: sure
15:37:40 <bnemec> moguimar: Thanks!
15:37:47 <bnemec> #topic Open discussion
15:37:59 <bnemec> That's it for the regular agenda.
15:38:06 <moguimar> this and the next hour is fine for me
15:38:12 <moguimar> for the virtual PTG
15:38:45 <bnemec> Cool. Hopefully it will work for everyone else too.
15:39:09 <bnemec> Otherwise I'll have to do one of those massive doodle polls and I'm not super excited about that. :-)
15:41:30 <bnemec> Okay, that should do it for this week.
15:41:39 <bnemec> Thanks for joining moguimar and johnsom!
15:41:42 <bnemec> #endmeeting