15:02:41 <bnemec> #startmeeting oslo
15:02:42 <bnemec> Courtesy ping for bnemec, jungleboyj, moguimar, hberaud, stephenfin, kgiusti, johnsom, e0ne, redrobot, bcafarel
15:02:42 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:02:42 <openstack> Meeting started Mon Nov 18 15:02:41 2019 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:45 <openstack> The meeting name has been set to 'oslo'
15:02:53 <johnsom> o/
15:02:54 <hberaud> o/
15:03:01 <kgiusti> o/
15:03:02 <jungleboyj> Kind of here.
15:03:17 <redrobot> \o
15:03:26 <Akira72> o/
15:03:27 <ansmith_> o/
15:03:32 <bcafarel> o/
15:03:35 <bnemec> jungleboyj: I'm impressed you're awake. :-)
15:03:48 <jungleboyj> :-)  Check with me in 4 hours.  :-)
15:05:10 <bnemec> Okay, good turnout today. Welcome everyone!
15:05:12 <bnemec> #topic Red flags for/from liaisons
15:05:37 <openstackgerrit> Eyal proposed openstack/oslo.messaging master: Make sure minimum amqp is 2.5.2  https://review.opendev.org/694686
15:05:42 <johnsom> Nothing to report from Octavia
15:06:16 <jungleboyj> Nothing from Cinder.
15:06:28 <moguimar> o/
15:07:32 <bnemec> Nothing much from the Oslo side. The major thing was the mask password changes in oslo.utils, but I don't think that affects anyone here.
15:08:09 <bnemec> Although I guess it's worth noting that those changers are making the mask_password functions in strutils case insensitive.
15:08:17 <moguimar> Nothing from Barbican
15:08:32 <hberaud> the tripleo guys seems to facing some related leak of password
15:08:37 <bnemec> I don't expect that to cause any problems, but if it does let use know, of course.
15:09:08 <bnemec> hberaud: Yeah, that's what the mask password stuff is intended to fix.
15:09:19 <hberaud> I suppose this is why they fixed that...
15:09:27 <bnemec> I need to look at the new patches for that too.
15:09:34 <hberaud> ack
15:10:11 <bnemec> Lots of very tripleo-specific keys in there, but I guess it's unavoidable.
15:10:16 <hberaud> and if someone can take a look to the stein and rocky backport too
15:10:33 <hberaud> they are welcome
15:10:39 <hberaud> thanks
15:10:49 <bnemec> I really wish Mistral didn't just log giant dicts all the time.
15:11:01 <bnemec> Yeah, I'll try to keep on top of the backports too.
15:11:11 <hberaud> ty
15:11:51 <bnemec> #topic Releases
15:12:03 <bnemec> I didn't get them done again last week. :-(
15:12:38 <bnemec> There were individual releases for oslo.utils proposed, but I need to make sure everything that has merged in other projects gets released too.
15:12:45 <bnemec> Will try to get that done today.
15:13:14 <bnemec> #topic Action items from last meeting
15:13:33 <bnemec> "hberaud to approve https://review.opendev.org/689611"
15:13:45 <bnemec> Done, thanks!
15:13:52 <bnemec> "bnemec to send email about virtual PTG"
15:14:02 <bnemec> Also done. More on that in a bit.
15:14:29 <bnemec> That was it for action items. Always like it when they're all done. :-)
15:14:40 <bnemec> #topic Virtual PTG
15:14:53 <bnemec> #link https://etherpad.openstack.org/p/oslo-shanghai-topics
15:15:19 <bnemec> I've tentatively scheduled this for next week at this time.
15:15:40 <bnemec> We'll be meeting virtually on the link in the etherpad.
15:15:48 <moguimar> sounds good
15:16:18 <moguimar> we might have more people attending that today due to the short notice
15:16:22 <bnemec> I'm not sure exactly how long it will take. Probably depends on how much discussion is needed.
15:16:43 <bnemec> Yeah, that was my thought as well. I just got one more notification from the Doodle poll this morning.
15:17:12 <bnemec> Speaking of which:
15:17:14 <bnemec> #link https://doodle.com/poll/8bqiv865ucyt8499
15:17:48 <openstackgerrit> Eyal proposed openstack/oslo.messaging stable/train: Make sure minimum amqp is 2.5.2  https://review.opendev.org/694792
15:17:49 <bnemec> So far next week is the winner, but if that doesn't work for you let me know.
15:20:47 <bnemec> I also recommend trying out jitsi ahead of time. It's a less common video conferencing service, but it's open source so it's a better fit for this.
15:21:16 <bcafarel> I will probably lurk in the background, if some liaison stuff is needed for neutron
15:21:18 <bnemec> If we have problems I have a bluejeans meeting we can fall back to as well.
15:21:45 <bnemec> bcafarel: Sounds good, thanks.
15:23:03 <bnemec> Okay, that's all I had about the PTG.
15:23:34 <bnemec> #topic Shanghai PTG Summary
15:23:46 <bnemec> Actually, one more thing just in case anyone missed it on the mailing list.
15:23:48 <bnemec> #link http://blog.nemebean.com/content/oslo-shanghai
15:24:12 <bnemec> I wrote up some thoughts about the event in Shanghai.
15:24:36 <bnemec> The good news is that there seems to be a fair amount of interest in Oslo.
15:24:54 <bnemec> Whether that translates into people actually contributing I don't know. :-)
15:27:42 <bnemec> #topic Weekly Wayward Review
15:27:52 <bnemec> #link https://review.opendev.org/#/c/650915/
15:28:07 <bnemec> My reviewstats instance is down for some reason, but I had that one open and I know it was on the list.
15:28:25 <bnemec> I had left a question back in July, but it wasn't anything critical so I'm inclined to just go ahead and merge it.
15:28:33 <bnemec> Any objections?
15:30:17 <bnemec> Okay, it should be headed to the gate.
15:30:29 <bnemec> #topic Open discussion
15:30:35 <bnemec> Anything else this week?
15:31:50 <Akira72> As you know, I wrote a spec for nats driver of oslo.messaging.
15:32:31 <Akira72> https://review.opendev.org/#/c/692784/
15:33:18 <bnemec> Yep, I really need to review that this week.
15:33:23 <hberaud> Akira72: I will take look soon
15:33:29 <kgiusti> Me also
15:33:38 <Akira72> Thank you all.
15:33:41 <bnemec> I did a bit of investigation last week as I was writing up my PTG summary since the NATS driver came up at the event.
15:34:13 <Akira72> I see.
15:34:23 <Akira72> I found it.
15:34:56 <Akira72> I'll check it tomorrow.
15:35:12 <bnemec> I will try to get my thoughts recorded on the spec review too.
15:35:29 <Akira72> Yes, please.
15:36:48 <bnemec> Thanks for proposing it. It sounds very interesting based on what I've seen so far.
15:37:14 <Akira72> :D
15:38:10 <Akira72> Do I have to write another spec for msgpack_(de)serialize_msg()?
15:38:30 <Akira72> https://review.opendev.org/680628
15:38:34 <bnemec> #action bnemec, hberaud, and kgiusti to review NATS driver spec
15:39:20 <Akira72> NATS driver is using them.
15:40:05 <bnemec> Then I would say we don't need a separate spec. Maybe note in the commit message that the msgpack change is related to the NATS driver.
15:40:23 <bnemec> It doesn't look like that big of a change by itself.
15:41:18 <Akira72> I see. I'll add it.
15:42:05 <bnemec> I wonder if we should consider moving all the drivers to msgpack. If it's that much faster it could have a meaningful impact on OpenStack performance.
15:42:39 <bnemec> Would have to be done over multiple cycles with some compatibility code for rolling upgrades, but I think we could make it work.
15:43:02 <bnemec> I suppose the first thing  would be to do some performance testing with msgpack swapped in for JSON.
15:43:17 <bnemec> Anyway, that's hypothetical future work.
15:43:22 <hberaud> good idea
15:44:35 <Akira72> In the case, we have to consider backward compatibility for migration.
15:45:09 <bnemec> Yeah, but I think we could do it since we have the versioned envelope for oslo.messaging.
15:45:25 <bnemec> We'd have to indicate whether a message is JSON or msgpack and do the right thing during the transition.
15:45:47 <bnemec> However, that's completely separate from the NATS stuff.
15:46:09 <Akira72> Right.
15:46:19 <bnemec> #idea consider replacing JSON serialization with msgpack
15:47:25 <Akira72> I'm also interested in using msgpack for (de)serialize_msg.
15:47:29 <bnemec> I'm also curious how msgpack will handle some of the types we special-cased in jsonutils.
15:47:38 <bnemec> But now I'm getting pretty far down the rabbit hole. :-)
15:48:09 <bnemec> We should discuss this all further on the reviews themselves.
15:48:21 <bnemec> So, anything else before we end the meeting for this week?
15:51:12 <bnemec> Sounds like we're done. Thanks for joining everyone!
15:51:15 <bnemec> #endmeeting