15:00:17 <bnemec> #startmeeting oslo
15:00:17 <bnemec> Courtesy ping for bnemec, jungleboyj, moguimar, hberaud, stephenfin, kgiusti, johnsom, e0ne, redrobot, bcafarel
15:00:17 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:00:18 <openstack> Meeting started Mon Jan  6 15:00:17 2020 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:21 <openstack> The meeting name has been set to 'oslo'
15:00:29 <stephenfin> o/
15:00:29 <johnsom> o/
15:00:40 <jungleboyj> o/
15:00:41 <hberaud> o/ and happy new year folks
15:01:05 <moguimar> o/
15:01:09 <moguimar> happy new year!
15:01:30 <kgiusti> o/
15:01:33 <bcafarel> o/ happy new year!
15:03:17 <bnemec> #topic Red flags for/from liaisons
15:03:28 <moguimar> none from Barbican
15:03:31 <jungleboyj> Happy New Year.  Nothing from Cinder.
15:03:46 <johnsom> Nothing from Octavia
15:03:51 <bnemec> I guess the only thing from Oslo would be that there are two major releases proposed for this week.
15:04:06 <bnemec> Both are removing deprecated functionality.
15:04:43 <bnemec> I don't believe either is still being used in any OpenStack projects though.
15:04:56 <bnemec> Anyway, something to keep an eye out for.
15:04:58 <bcafarel> nothing I am aware of for Neutron (though just came back from PTO :) )
15:05:48 <bnemec> Yeah, I imagine that's the case for a lot of people.
15:06:00 <bnemec> #topic Releases
15:06:19 <bnemec> As I mentioned, there are a couple of major releases proposed and a few others as well.
15:07:11 <bnemec> I also need to check for releases needed on the stable branches, but I didn't get to that last week.
15:07:36 <bnemec> Not much else to say about that.
15:08:12 <bnemec> No action items from last meeting either, so we'll skip that topic.
15:08:57 <bnemec> #topic bnemec spotty availability today
15:09:28 <bnemec> I'm currently at my parents' house and was planning to work from here, but it looks like my home internet is dead so I'm going to have to drive home and deal with that.
15:10:32 <jungleboyj> :-(  That is a bummer.
15:10:35 <bnemec> I'll probably be offline for a few hours. Hopefully nothing noteworthy happens during that time.
15:10:50 <jungleboyj> bnemec:  Need me to go reset it for you?  ;-)
15:10:53 <bnemec> I am quite displeased with Charter right now.
15:11:25 <jungleboyj> MetroNet is coming!
15:11:25 <bnemec> jungleboyj: That's actually kind of tempting.
15:11:45 <jungleboyj> :-)  Ping me after the meeting if I can help.
15:12:28 <bnemec> Thanks :-)
15:13:01 <bnemec> No other topics on the agenda.
15:13:03 <bnemec> #topic Weekly Wayward Review
15:13:25 <bnemec> #link https://review.opendev.org/#/c/679415/
15:13:56 <bnemec> This one and the followup have been sitting around for a long time, probably because nobody knows anything about pycadf. :-)
15:14:09 <hberaud> I will take a look
15:14:21 <bnemec> Unless someone sees something wrong I propose we get them merged.
15:14:26 <bnemec> hberaud: Thanks!
15:14:31 <hberaud> even if I don't have a great experience with pycadf
15:14:50 <bnemec> I don't think anyone who is still around does at this point.
15:15:37 <johnsom> I read up on it once, just enough to add auditing to the Octavia API. Pretty much forgot it all since then.
15:15:56 <moguimar> just commit messages looks quite short
15:16:05 <hberaud> yep I agree
15:16:20 <bnemec> Yeah, my understanding is that it pretty much does what it's supposed to do so normally there isn't a lot of activity.
15:16:25 <hberaud> it doesn't help me to understand things
15:17:47 <moguimar> I guess one thing to do would be looking if the added config looks similar with the default config of other services
15:17:54 <bnemec> AFAICT, there are just a bunch of these config files that tell pycadf how to audit the service's apis.
15:18:04 <bnemec> Swift was missing for some reason.
15:18:13 <bnemec> moguimar: Yeah, that's pretty much what I did.
15:18:25 <moguimar> then I think we can merge it
15:19:23 <bnemec> Cool
15:20:56 <bnemec> #topic Open discussion
15:21:18 <moguimar> I have a clash in this time slot and it has been hard to keep up with both meetings
15:21:48 <bnemec> :-/
15:21:53 <moguimar> so I'll have to prioritize my team's meeting unfortunately
15:22:22 <moguimar> I'll keep reading the minutes and will bring stuff from Barbican when aplicable
15:22:30 <bnemec> We can look at moving it.
15:22:52 <moguimar> if it isn't a pain for the others, I'd appreciate that
15:23:06 <bnemec> Unfortunately I have a meeting right now that's immediately before this so I can't go earlier.
15:23:17 <bnemec> I guess we could also look at other days.
15:24:02 <bnemec> Moving it much later will probably be a problem for people in Europe.
15:24:10 <moguimar> yep
15:24:34 <moguimar> right now I have it at 4-5pm but sometimes it shifts to 5-6pm
15:24:38 <moguimar> depending on DST
15:24:58 <hberaud> maybe we can chose it through a doodle or something like that
15:25:04 <moguimar> yep
15:25:09 <moguimar> doodle it for a month
15:25:11 <hberaud> based on UTZ
15:25:29 <moguimar> and schedule any changes if applicable to Feb
15:25:35 <hberaud> yep
15:25:50 <hberaud> to be sure to reach each of us
15:26:10 <bnemec> Okay, I'll see about setting something up.
15:26:18 <bnemec> #action bnemec to set up doodle poll for meeting time
15:26:23 <moguimar> thanks bnemec
15:26:55 <bnemec> Okay, anything else?
15:27:08 <moguimar> I'll be at FOSDEM
15:27:17 <moguimar> talking about castellan driver for oslo.config
15:27:40 <moguimar> I'm looking forward to see stephenfin there too =D
15:27:47 <stephenfin> likewise
15:27:54 <bnemec> Cool :-)
15:28:08 * stephenfin is there to talk about reno, pbr and...something else I've forgotten about
15:28:09 <moguimar> and that's all on my end
15:28:22 <moguimar> cool
15:28:34 <moguimar> I hope our talks don't clash
15:28:41 <bnemec> stephenfin: That last one should be an interesting talk then. ;-)
15:28:49 <moguimar> I have 2, one in python and one in security room
15:29:25 <moguimar> can we also link the talks videos in the documentation?
15:29:33 <hberaud> do not hesitate to ping if you need some slide reviews
15:29:43 <moguimar> sure
15:30:20 <bnemec> moguimar: Possibly. The video of my talk in Shanghai about it didn't turn out very well though. :-(
15:31:08 <bnemec> The audio was really quiet and the video is too low res to see what's on the screen.
15:31:36 <bnemec> And actually, before we link anything from the documentation we need documentation in the first place.
15:31:50 <bnemec> AFAIK the castellan driver still isn't documented in any published location.
15:32:02 <bnemec> I had to go read the docstrings straight from the code.
15:32:32 <moguimar> yeah, that's my bad. The talk is actually something to push me to do it
15:33:15 <bnemec> +1
15:34:46 <bnemec> I have two open discussions, do I hear three? :-)
15:37:33 <moguimar> that was actually a good number of topics for a first meeting of the year
15:37:55 <bnemec> Yep
15:38:15 <bnemec> Probably helps when we haven't met in 3 weeks. :-)
15:38:39 <moguimar> indeed
15:39:17 <bnemec> Alright, sounds like we're done. Thanks for joining everyone and Happy New Year!
15:39:20 <bnemec> #endmeeting