15:01:10 <bnemec> #startmeeting oslo
15:01:10 <bnemec> Courtesy ping for bnemec, jungleboyj, moguimar, hberaud, stephenfin, kgiusti, johnsom, e0ne, redrobot, bcafarel
15:01:10 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:01:11 <openstack> Meeting started Mon Jan 13 15:01:10 2020 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:14 <openstack> The meeting name has been set to 'oslo'
15:01:16 <hberaud> o/
15:01:23 <bcafarel> o/
15:01:23 <johnsom> o/
15:01:25 <kgiusti> o/
15:02:38 <jungleboyj> o/
15:02:42 <moguimar> o/ also in another meeting
15:03:14 <bnemec> #topic Red flags for/from liaisons
15:03:31 <johnsom> Nothing on the Octavia sid
15:03:34 <johnsom> side
15:03:40 <jungleboyj> Nothing from Cinder.
15:03:40 <moguimar> nothing from Barbican
15:03:55 <bnemec> The main thing from Oslo is that we're probably going to start merging patches to remove py2 support soon.
15:04:20 <bnemec> So if you're still running any py2 jobs it's possible we'll break them.
15:04:28 <jungleboyj> That is good.
15:04:31 <bnemec> But you should stop running py2 jobs anyway. :-P
15:05:00 <johnsom> Yep, we are long down that path already, so remove away!
15:05:17 <bnemec> Oh, and also we did some releases last week that proved problematic.
15:05:34 <bnemec> Specifically oslo.config is breaking some of Glance's unit tests.
15:05:41 <bcafarel> nothing from Neutron either (and we have good progress on py2 jobs cleanup :) )
15:06:31 <bnemec> #link https://review.opendev.org/#/c/701580/
15:06:44 <bnemec> ^the debug patch that is related to the Glance breakage.
15:07:40 <bnemec> Alright, I think that's it for red flags. If you run into any issues related to the above let us know of course.
15:07:49 <bnemec> #topic Releases
15:08:02 <bnemec> As I mentioned, there were some issues with the releases last week.
15:08:15 <bnemec> I also did get stable releases proposed for all of the active branches.
15:08:26 <bnemec> I think they've all merged now so we should be up to date.
15:08:28 <hberaud> double checked
15:08:36 <hberaud> yep
15:09:21 <bnemec> I see there's a release request for oslo.vmware too: https://review.opendev.org/702233
15:09:49 <bnemec> Will take a look at that later.
15:10:00 <hberaud> I will check too
15:10:27 <hberaud> oslo.vmware have received new features last week
15:10:38 <bnemec> Otherwise just expect master releases. I may hold off on oslo.config until we resolve the issues there.
15:11:16 <bnemec> Yeah, I'm guessing this is related to some work going on in Glance.
15:12:25 <bnemec> #topic Action items from last meeting
15:12:32 <bnemec> "bnemec to set up doodle poll for meeting time"
15:12:36 <bnemec> Not done, so...
15:12:39 <bnemec> #action bnemec to set up doodle poll for meeting time
15:12:53 <bnemec> Got distracted by some last-minute travel planning last week.
15:13:13 <bnemec> That was it for action items.
15:13:18 <bnemec> And speaking of travel...
15:13:26 <bnemec> #topic bnemec travelling next week
15:13:56 <bnemec> Monday I'm going to be travelling so I won't be able to run the meeting.
15:14:28 <bnemec> If anyone else wants to do it then great, but otherwise we can cancel.
15:15:34 <bnemec> Ping me if you want to run the meeting, and if no one does then I'll send an email later this week to let everyone know it's not happening.
15:16:03 <bnemec> I'll be out Friday too, FWIW.
15:16:32 <johnsom> I will be out Monday too, so not volunteering
15:16:33 <bnemec> And in f2f meetings Tue-Thur so availability will be dependent on that.
15:17:14 <bnemec> So next week would be an excellent time for py2 removals to break stuff. ;-)
15:17:25 <hberaud> :)
15:17:46 <johnsom> It will all be fixed by the time you are back.... lol
15:17:56 <bnemec> That's the idea. :-)
15:18:18 <bnemec> And another natural segue...
15:18:18 <bnemec> #topic Dropping py27 support
15:18:58 <bnemec> There are some patches up already to drop py2 support from Oslo libs. I had previously asked people to hold off on that because we hadn't reached the phase where libraries could do the removal yet.
15:19:04 <bnemec> We have now though.
15:19:37 <bnemec> I'm good with starting to push those along.
15:19:59 <bnemec> There was a suggestion that we wait and give people more time, but the longer we wait the closer we get to the end of the cycle.
15:20:16 <hberaud> +1
15:20:17 <bnemec> Plus I think it's going to take us a while to get this done for all of the Oslo libs, so I'd rather not wait.
15:20:37 <bnemec> If we break stuff at least we've got time to get it fixed.
15:21:06 <hberaud> I think we need to ask for reno on each dropping, and we will provide a major release for each project, I'm right?
15:21:22 <bnemec> Last week we agreed to bring it up here so our liaisons would have a heads up, and I will also send something to the mailing list.
15:21:34 <bnemec> #action bnemec to send py2 removal email to openstack-discuss
15:21:46 <bnemec> hberaud: Yeah, I think these will need to all be major releases.
15:22:03 <johnsom> We did a major version bump for python-octaviaclient to signal the removal of py27 support
15:22:38 <hberaud> other projects have bumped to major release and reno "update" have been provided too
15:23:08 <hberaud> as far as I seen...
15:23:28 <hberaud> drop py27 side topic: I plan to remove "six" support after the dropping but I think we should wait the end of the milestone 2 before to avoid side effects and possible rushs during this period, thoughts?
15:23:30 <bnemec> A reno is probably good too.
15:24:06 <bnemec> Once py2 support is gone I think removing six is fair game.
15:24:57 <bnemec> It might be good to focus on the py2 removal first and try to get those all done before moving on to six, but both things probably need to happen eventually.
15:25:39 <hberaud> as you want, I just want to avoid side effects related to six during a short sprint
15:26:25 <bnemec> I wouldn't expect six removals to be very high risk.
15:26:45 <bnemec> I guess it will be a lot of code churn in some projects that make heavy use of six.
15:27:53 <hberaud> I already propose to remove six from heat, it's more than 29 patches with 15 files and like 150 changes for each patch...
15:28:05 <bnemec> My stance would be that py2 removal is the top priority, but I'm not concerned enough about six to block people from working on that too if it makes them happy. :-)
15:28:37 <hberaud> example => https://review.opendev.org/#/q/status:open+project:openstack/heat+branch:master+topic:drop-six-and-py27-support
15:28:40 <johnsom> We are also moving forward with pulling six out
15:28:46 <hberaud> ok
15:29:17 <johnsom> https://review.opendev.org/#/c/701290/
15:29:18 <bnemec> Obviously if it turns out six is a big issue or something we can revisit this.
15:31:06 <bnemec> Okay, to wrap up this topic:
15:31:06 <bnemec> #agreed Proceed with py2 removal from Oslo libraries
15:31:06 <bnemec> #agreed Remove six from Oslo libraries as a secondary priority
15:32:25 <bnemec> #topic Weekly Wayward Review
15:32:36 <bnemec> #link https://review.opendev.org/#/c/688251/
15:32:45 <bnemec> hberaud: Do you want to do the honors on that one?
15:33:03 <hberaud> go wild
15:33:58 <hberaud> FYI I started to design a tool to help us to remove six based on python parser and based on python symbol and token => https://github.com/4383/sixectomy/tree/devel if some of you are interested to help me move further, the main idea is to avoid regex, update the needed import, use the native python parser tp detect things to update to avoid errors and check if code is valid too
15:34:27 <bnemec> Ah, nice. I was just wondering if such a thing existed. :-)
15:35:08 <hberaud> during my heat patches I used regex and sed but it's a little bit an annoying so I prefered spend time to implement this project to reuse and secure the things
15:35:55 <bnemec> Yeah, sounds useful.
15:36:18 <bnemec> #topic Open discussion
15:36:27 <bnemec> Seems like we've reached this point in the meeting.
15:37:25 <bnemec> Anything else before we go about our week?
15:38:03 <hberaud> not on my hands
15:39:13 <bnemec> Okay, good discussions again today. Thanks for joining everyone!
15:39:16 <bnemec> #endmeeting