15:11:38 <bnemec> #startmeeting oslo
15:11:38 <openstack> Meeting started Mon Feb 10 15:11:38 2020 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:11:38 <bnemec> Courtesy ping for bnemec, jungleboyj, moguimar, hberaud, stephenfin, kgiusti, johnsom, e0ne, redrobot, bcafarel
15:11:38 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:11:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:11:41 <openstack> The meeting name has been set to 'oslo'
15:11:41 <hberaud> o/
15:11:59 <johnsom> o/
15:12:08 <bnemec> Sorry for the late start.
15:12:41 <kgiusti> o/
15:12:50 <jungleboyj> I am AFK. Helping move some stuff. So not really paying attention.
15:13:00 <jungleboyj> Nothing major to report from Cinder.
15:13:10 <bnemec> jungleboyj: Cool, thanks
15:13:27 <moguimar> o/
15:13:54 <moguimar> multitasking (videconf)
15:14:36 <bnemec> moguimar: Yep, sorry I haven't rescheduled this yet. The past few weeks have been a bit crazy. :-(
15:14:52 <bnemec> #topic Red flags for/from liaisons
15:14:55 <moguimar> no problem ben
15:14:58 <johnsom> We have had some py27 removal pain (UC) but that is to be expected. I.e. oslo-concurrency
15:15:17 <bnemec> johnsom: Do you still have jobs running py2?
15:15:23 <johnsom> No
15:15:39 <johnsom> No open oslo issues now though
15:16:03 <bnemec> Okay, sounds good.
15:16:32 <johnsom> It was an issue with upper-constraints forcing the py2 version on us. It got fixed
15:17:03 <bnemec> Ah, thanks.
15:17:31 <bnemec> #topic Releases
15:18:05 <bnemec> I haven't been doing these while I was out, but a number of the py2 removal releases have happened.
15:18:15 <bnemec> I'm not sure exactly where we stand on that. I think hberaud was tracking it?
15:18:20 <hberaud> I tracked our "drop py27" releases => https://gist.github.com/4383/34d67cfed23945629dd42824b8deabda
15:18:36 <hberaud> and we need to address => https://review.opendev.org/#/q/owner:hberaud%2540redhat.com+status:open
15:19:19 <hberaud> after this I think we will be ~good in oslo world
15:19:28 <bnemec> Okay, looks like good progress, thanks!
15:19:53 <hberaud> bnemec: just please double check if I don't missed some project
15:20:02 <bnemec> #link https://gist.github.com/4383/34d67cfed23945629dd42824b8deabda
15:20:10 <bnemec> So it's easy to find in the meeting notes.
15:20:17 <bnemec> hberaud: Will do.
15:20:20 <hberaud> thanks
15:20:29 <bnemec> Nothing jumped out at me skimming it now though.
15:20:57 <openstackgerrit> Lee Yarwood proposed openstack/oslo.utils master: imageutils: Report format specific details when using JSON output format  https://review.opendev.org/706880
15:21:33 <bnemec> To wrap up releases, I'll try to take a look at what has merged and see if anything needs releasing besides the py2 changes.
15:21:41 <bnemec> #topic Action items from last meeting
15:21:41 <johnsom> hberaud: Thanks for handling taskflow!
15:21:52 <bnemec> "bnemec to set up doodle poll for meeting time"
15:21:55 <hberaud> johnsom: my pleasure
15:22:06 <bnemec> As I said earlier, still not done. :-(
15:22:10 <bnemec> #action bnemec to set up doodle poll for meeting time
15:22:40 <bnemec> And that was it.
15:22:56 <bnemec> #topic Vancouver PTG
15:23:23 <bnemec> As you may have seen on the list, the foundation has started planning for the Vancouver PTG. They need to know if we want a room.
15:23:58 <bnemec> TBH I'm not expecting to be there, so this time I think it will mostly come down to whether anyone else is attending and if they want to have formal Oslo talks.
15:24:33 <bnemec> If so, let me know ASAP so I can get back to them.
15:24:41 <johnsom> I plan to attend, but I am not confirmed yet. Though I will likely be in the Octavia sessions the whole PTG time.
15:24:50 <hberaud> ack
15:24:55 <bnemec> Otherwise I won't request space.
15:25:15 <bnemec> I'll also send an email to the list to catch anyone who's not here.
15:25:34 <bnemec> #action Oslo contributors contact bnemec if they want to have an Oslo room at the PTG
15:25:38 <moguimar> I'm not going
15:25:51 <bnemec> #action bnemec send email to the list about PTG
15:25:55 <moguimar> but I'm still positive about Berlin
15:27:07 <bnemec> I guess it's also worth mentioning that I realize most people may not know for sure if they're going yet.
15:27:48 <bnemec> I tend to err on the side of scheduling space and if we end up not needing it we can always back out.
15:27:52 <hberaud> I think I will go, but I need to validate this internally
15:29:00 <bnemec> Okay, watch for the email thread and otherwise that's all I had on this topic.
15:29:55 <bnemec> #topic bnemec PTO later this week
15:30:09 <bnemec> Unrelated to my other recent absences, I have some PTO that needs to be used by Friday.
15:30:22 <bnemec> I'm planning to be out Tuesday afternoon through the rest of the week.
15:30:37 <bnemec> If you need me for anything I recommend getting ahold of me before then.
15:30:55 <bnemec> After this I will hopefully be back to a more normal schedule.
15:32:27 <bnemec> #topic Weekly Wayward Review
15:32:40 <bnemec> #link https://review.opendev.org/#/c/697693/
15:33:12 <bnemec> This one is in merge conflict.   Wondering if we still need it with the py2 work.
15:33:47 * hberaud look
15:34:17 <bnemec> I guess we do. The sphinx req is still below 2.1.0.
15:34:29 <hberaud> bnemec: I'll rebase and keep the py3 version only
15:34:46 <bnemec> Perfect, thanks!
15:34:52 <bnemec> #action hberaud to rebase https://review.opendev.org/#/c/697693/
15:34:59 <moguimar> ok, I'll add myself to the review
15:35:11 <bnemec> Thanks!
15:35:27 <bnemec> That's a pretty easy one to get off our backlog. :-)
15:35:34 <bnemec> #topic Open discussion
15:35:36 <hberaud> :)
15:35:44 <bnemec> That's it for the scheduled topics. Anything else this week?
15:36:12 <moguimar> yep
15:36:27 <moguimar> Last weekend I was at FOSDEM
15:36:30 <moguimar> #link https://fosdem.org/2020/schedule/event/security_protecting_plaintext_secrets_in_configuration_files/
15:36:47 <moguimar> finally put my posters to a presentation that includes the castellan driver
15:36:54 <hberaud> interesting
15:37:19 <bnemec> Cool!
15:37:32 <moguimar> A guy named Thomas from the debian community said he really liked my talk
15:37:59 <moguimar> that I should write some blog posts about oslo config
15:38:36 <hberaud> concerning my side I'm now core on openstack/releases too so if you've related topics don't not hesitate to ping me if needed
15:38:47 <bnemec> There's a lot going on in oslo.config.
15:39:17 <bnemec> I had thoughts of doing a module of the week thing like Doug did with the stdlib modules, but I ended up getting pulled off on downstream stuff around that time. :-/
15:39:32 <bnemec> hberaud: Oh, nice! Someone new to ping for release requests. :-)
15:39:41 <smcginnis> +1
15:41:14 <bnemec> Okay, anything else?
15:42:25 <moguimar> not on my end
15:42:41 <hberaud> not on my side
15:43:06 <johnsom> Nope, have a great week
15:43:25 <bnemec> Okay, thanks for joining everyone!
15:43:30 <bnemec> #endmeeting