15:01:45 <bnemec> #startmeeting oslo
15:01:45 <bnemec> Courtesy ping for bnemec, jungleboyj, moguimar, hberaud, stephenfin, kgiusti, johnsom, e0ne, redrobot, bcafarel
15:01:45 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:01:46 <openstack> Meeting started Mon Feb 17 15:01:45 2020 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:49 <openstack> The meeting name has been set to 'oslo'
15:02:00 <jungleboyj> o/
15:02:01 <hberaud> o/
15:03:01 <johnsom> o/
15:03:26 <kgiusti> o/
15:03:53 <ansmith> o/
15:04:31 <bnemec> #topic Red flags for/from liaisons
15:04:59 <johnsom> Nothing from Octavia
15:05:08 <bnemec> It looks like there is an issue with my change in oslo.policy to parse cli args.
15:05:35 <smcginnis> I wasn't clear if it was oslo.conf, oslo.policy, or both.
15:05:39 <bnemec> It's failing the upper-constraints tests so it probably won't affect anyone yet, but I see mistral ran into it anyway.
15:05:53 <jungleboyj> Nothing from Cinder.
15:06:03 <smcginnis> Cinder ran into it too.
15:06:13 <smcginnis> Only because we have a misconfigured job.
15:06:37 <johnsom> Ah, we got ping for some UC issues, but I haven’t looked at them yet. I will be doing that today.
15:07:08 <bnemec> Yeah, I'm looking into it. I thought I tested keystone with that change to make sure it wouldn't break consumers, but I may be wrong.
15:08:03 <moguimar> o/
15:08:19 <moguimar> Barbican is quiet too
15:10:27 <bnemec> Cool, thanks.
15:10:42 <bnemec> #topic Releases
15:11:17 <bnemec> cmurphy|afk pointed out on Friday that we released a 1.0 of oslo.limit. We shouldn't have done that. :-(
15:12:11 <bnemec> smcginnis: I'm not sure what we can do about it at this point. We can't really roll back the versioning, right?
15:12:24 <hberaud> oh sorry my bad
15:12:37 <smcginnis> bnemec: No, but we can blacklist any versions that are known to cause issues.
15:12:39 <bnemec> For context, oslo.limit is still under heavy development and we haven't stabilized the api yet.
15:12:59 <smcginnis> Ah, just picking up context. Yeah, that's really... unfortunate.
15:13:50 <bnemec> hberaud: np. For future reference, when a library is still pre-1.0 a "major" version bump is just a bump to the feature component.
15:14:00 <bnemec> So probably 0.1.0 in this case.
15:14:08 <hberaud> bnemec: ack
15:15:01 <bnemec> I can start a mailing list thread too if it would help to get broader input.
15:15:32 <bnemec> At the very least it will let people know that oslo.limit isn't actually ready to be consumed yet.
15:15:41 <smcginnis> ++
15:15:51 <bnemec> #action bnemec to send mail about oslo.limit 1.0
15:16:41 <johnsom> Yeah, a release not comment would be good as well.
15:16:53 <bnemec> Otherwise on the release front I see we're still doing py2 drop releases, so that's good.
15:16:54 <johnsom> Not->note
15:18:16 <bnemec> Good idea. hberaud, could you write a release note for oslo.limit? I'm thinking this probably belongs in the prelude so it's right at the top.
15:18:36 <hberaud> bnemec: yes
15:19:00 <bnemec> Thanks
15:19:12 <bnemec> #action hberaud to write release note for oslo.limit
15:20:04 <bnemec> #topic Action items from last meeting
15:20:10 <bnemec> "bnemec to set up doodle poll for meeting time"
15:20:11 <bnemec> Done
15:20:18 <bnemec> "Oslo contributors contact bnemec if they want to have an Oslo room at the PTG"
15:20:43 <bnemec> Nobody has done this yet, but that may just mean we don't need a room.
15:20:53 <bnemec> "bnemec send email to the list about PTG"
15:20:59 <bnemec> Done (I think...)
15:21:10 <bnemec> "hberaud to rebase https://review.opendev.org/#/c/697693/"
15:21:15 <hberaud> done
15:21:28 <hberaud> (abandonned)
15:21:32 <bnemec> Sort of. :-)
15:21:36 <hberaud> :)
15:21:44 <bnemec> It's off my review list which is what I care about. :-)
15:22:22 <bnemec> That's all the action items we had.
15:22:26 <bnemec> #topic  Vancouver PTG
15:22:55 <bnemec> Just kept this on here as a reminder that if anyone thinks we might want a room in Vancouver they need to contact me ASAP.
15:23:13 <bnemec> Keep in mind that it's probably easier to request a room and then cancel it later than to decide we need a room at the last minute.
15:23:38 <hberaud> +1
15:25:25 <bnemec> So if you even think you _might_ want an Oslo room I'll go ahead and request one. Otherwise we'll have to have Oslo discussions in other project rooms and/or schedule a floating room/table.
15:25:58 <bnemec> That's all I had on that.
15:26:02 <bnemec> #topic  Meeting time poll
15:26:11 <bnemec> #link https://doodle.com/poll/zmyhrhewtes6x9ty
15:26:20 <bnemec> A bunch of people have already filled this out, so thanks!
15:26:52 <bnemec> Unfortunately it's looking...not great. There is not a lot of overlap between our schedules. :-/
15:27:41 <jungleboyj> Yeah, I saw that.
15:29:22 <bnemec> The best option is probably Tue an hour earlier since that's the only time all of the cores are available at once, but it excludes two liaisons and is yellow for two cores.
15:30:05 <bnemec> I might leave it open for another week and then we can discuss it in the meeting next week.
15:31:07 <bnemec> If you have any other thoughts on it, let me know.
15:32:52 <bnemec> #topic Weekly Wayward Review
15:33:03 <bnemec> I just merged https://review.opendev.org/#/c/699659 so I'm calling this topic done. :-)
15:33:26 <hberaud> :)
15:34:12 <bnemec> There are some older reviews for Oslo out there, but I need to take a closer look at them to figure out if they're really ready to go.
15:34:35 <bnemec> Now that I'm probably back working on a regular basis again maybe I'll have time to do that.
15:34:53 <bnemec> #topic Open discussion
15:35:03 <bnemec> And that's it for the scheduled stuff. Anything else this week?
15:35:10 <hberaud> yes
15:35:42 <hberaud> do you know if oslobot on oslo.tools is still useful?
15:35:57 <bnemec> I didn't know we had a bot.
15:36:00 <bnemec> What does it do?
15:36:40 <hberaud> I made some cleaning and refactors on oslo.tools and I can't start him... maybe I missed something but the lib under the hood look broken...
15:36:57 <hberaud> bnemec: this is some sort of IRC bot
15:37:13 <hberaud> bnemec: https://github.com/openstack/oslo.tools/tree/master/oslobot
15:37:27 <bnemec> Ah, Josh wrote this years ago.
15:37:34 <hberaud> yes
15:37:49 <bnemec> I don't know that it was ever run, but it does sound useful.
15:37:58 <hberaud> but I can't run it even by using old versions of errbot
15:38:09 <bnemec> A daily ping with the status of the periodic jobs would be very helpful in getting those visibility.
15:38:19 <bnemec> Ah, that would be a problem.
15:38:37 <bnemec> If it's not working then we either need to remove it or fix it.
15:38:47 <hberaud> I tried to rewind version while but unsuccessfully
15:40:31 <bnemec> I doubt I'm going to have time to look at it.
15:40:41 <hberaud> also another topic I plan to adapt https://github.com/openstack/rpm-packaging-tools/blob/master/tools/rpm-packaging-status.py to oslo (in oslo.tools) to generate some reports about our versions and delta with commits
15:40:49 <bnemec> I guess we can schedule it for removal in $TIME_PERIOD and if someone fixes it before then we keep it.
15:41:29 <bnemec> That sounds like something we should have in the releases repo.
15:41:30 <hberaud> ok, I'll try to continue to debug it and if I fail then I will propose the removal
15:41:51 <bnemec> Sounds good.
15:42:10 <bnemec> #action hberaud to investigate whether to fix or remove oslobot from oslo.tools
15:42:48 <bnemec> What does the rpm-packaging script do that list_unreleased_changes doesn't?
15:44:01 <hberaud> bnemec: you are right I guess it could duplicate some feature I need to check first
15:45:08 <hberaud> bnemec: (I missed this tools)
15:46:03 <bnemec> Yeah, I need to take a look at documenting some of these processes officially. I have a local doc with notes for myself, but it's a cycle goal to get that stuff written down more officially.
15:46:46 <hberaud> bnemec: do not hesitate to ping me if you need some help
15:46:55 <bnemec> FWIW, when I do master releases I run these two commands:
15:46:55 <bnemec> ./tools/list_unreleased_changes.sh master $(.tox/venv/bin/list-deliverables --team oslo -r)
15:46:55 <bnemec> ./tools/list_unreleased_changes.sh master $(.tox/venv/bin/list-deliverables --team oslo -r --series independent)
15:47:26 <hberaud> bnemec: thanks I take note
15:47:59 <bnemec> Okay, anything else?
15:48:09 <hberaud> not on my hands
15:50:43 <bnemec> Sounds good. Thanks for joining everyone!
15:50:46 <bnemec> #endmeeting