15:10:44 <bnemec> #startmeeting oslo
15:10:44 <bnemec> Courtesy ping for bnemec, jungleboyj, moguimar, hberaud, stephenfin, kgiusti, johnsom, e0ne, redrobot, bcafarel
15:10:44 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:10:45 <openstack> Meeting started Mon Feb 24 15:10:44 2020 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:10:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:10:48 <openstack> The meeting name has been set to 'oslo'
15:10:52 <hberaud> o/
15:10:58 <bcafarel> o/
15:11:04 <jungleboyj> o/
15:11:04 <johnsom> o/
15:11:42 <moguimar> o/ (partialy)
15:11:45 <stephenfin> o/
15:12:37 <ansmith> o/
15:13:07 <kgiusti> kgiusti: o/ (must leave early for call)
15:13:17 <bnemec> #topic Red flags for/from liaisons
15:13:31 <johnsom> Nothing from Octavia
15:13:40 <jungleboyj> Nothing from Cinder.
15:13:57 <bnemec> The thing we were discussing a bunch last week was the oslo.limit 1.0 release. It's not actually a 1.0 release. :-)
15:14:16 <bcafarel> nothing from neutron (I think Rodolfo already asked last week about a question he had)
15:14:27 <bnemec> So unless you want to get involved with designing the oslo.limit API (which would be great!), don't use it.
15:14:33 <moguimar> nothing from Barbican
15:15:52 <bnemec> Should maybe just merge this with the releases topic since most of the red flags from our side are around new releases. ;-)
15:16:02 <bnemec> #topic Releases
15:17:05 <bnemec> As noted above, assume oslo.limit is actually pre-1.0 despite the version number until we say otherwise.
15:17:44 <bnemec> FWIW, it seems the consensus is to not try to "fix" this by unpublishing the release.
15:19:06 <bnemec> I probably need to take a look at what needs to be released again this week. I'd been holding off because of all the py2-removal releases, but it seems like those have slowed down and there may be stuff that needs to be released.
15:19:21 <bnemec> Will try to get that done today.
15:19:53 <bnemec> #topic Action items from last meeting
15:20:00 <bnemec> "bnemec to send mail about oslo.limit 1.0"
15:20:00 <bnemec> Done
15:20:06 <bnemec> "hberaud to write release note for oslo.limit"
15:20:14 <hberaud> done
15:20:32 <bnemec> Sorry I haven't reviewed it. :-/
15:20:40 <bnemec> "hberaud to investigate whether to fix or remove oslobot from oslo.tools"
15:20:40 <hberaud> https://review.opendev.org/708326
15:20:45 <hberaud> not done
15:23:42 <bnemec> I approved the release note.
15:23:51 <bnemec> And that was all the action items.
15:23:57 <bnemec> #topic  Vancouver PTG
15:24:29 <bnemec> Still haven't heard from anyone who is going to be there, so at this point I don't expect to ask for a room.
15:24:54 <bnemec> We can maybe do a virtual PTG if the next PTL wants to organize one.
15:25:14 <bnemec> But I'll leave that up to that person. :-)
15:25:37 <jungleboyj> Cinder team is planning to be there.
15:25:38 <bnemec> We already covered oslo.limit so we can skip that one.
15:25:40 <jungleboyj> Just FYI.
15:26:10 <johnsom> I am planning to be there, but will be focused in the Octavia room.
15:26:16 <bnemec> Cool, maybe the Oslo refugees can hang out there. :-)
15:26:49 <bnemec> #topic Meeting time poll
15:27:27 <bnemec> #link https://doodle.com/poll/zmyhrhewtes6x9ty
15:28:05 <bnemec> So there are only two times that work for moguimar.
15:28:26 <moguimar> yeah, but checking on my callendar the meeting will stop to overlap
15:28:31 <moguimar> in about two weeks
15:28:34 <bnemec> One of them doesn't work for me at all because I have a 1-1 at that time that I can't really multitask.
15:28:52 <bnemec> Oh, is this only a daylight savings time conflict?
15:29:00 <openstackgerrit> Nick Maludy proposed openstack/tooz master: Adds heartbeating to the consul driver.  https://review.opendev.org/707681
15:29:28 <moguimar> yeah
15:29:45 <moguimar> it is an issue during nov-feb
15:30:01 <bnemec> It occurs to me that I hadn't even considered the DST change when I filled out the survey...
15:30:03 <moguimar> but my meeting was also migrated to monday during nov
15:30:09 <moguimar> so I didn't catch that until now
15:30:51 <bnemec> Yeah
15:30:56 * bnemec shakes fist at DST
15:30:59 <moguimar> so I guess we can keep this time
15:31:12 <moguimar> and my other meeting might move around before next November
15:31:35 <bnemec> Yeah, and actually the next hour on Monday is the one with the highest number of people available.
15:32:15 <bnemec> So if DST will take care of moving it to then in a few weeks anyway, that seems like the way to go.
15:32:50 <bnemec> That should also reduce the meeting overrun problems I've had lately as my previous meeting shouldn't move.
15:33:36 <openstackgerrit> Merged openstack/oslo.limit master: oslo.limit mistakenly released as 1.0.0 (release note)  https://review.opendev.org/708326
15:33:56 <bnemec> Okay, if no one has any objections then let's let DST solve the conflict for us and leave the meeting where it is UTC-wise.
15:34:05 <moguimar> +1
15:34:13 <bnemec> I don't expect any objections since almost everyone was green on that time. :-)
15:34:24 <bnemec> I'll send a followup email to the list with this result.
15:34:33 <bnemec> #action bnemec send email about Oslo meeting time
15:34:41 <bnemec> Thanks to everyone who filled out the survey!
15:35:32 <bnemec> That's the one-off topics for this week.
15:35:34 <bnemec> #topic Weekly Wayward Review
15:36:30 <bnemec> #link https://review.opendev.org/#/c/699694
15:36:35 <bnemec> I just approved it. :-)
15:36:59 <bnemec> I could swear I had looked at that before, but maybe it was before the py2 drop had happened or something.
15:38:12 <bnemec> If anyone else is looking for something to review, it would be nice to make some progress on https://review.opendev.org/#/c/691820/
15:38:41 <bnemec> This is part of Line's changes to reduce messaging bottlenecks in their deployment.
15:38:54 <bnemec> Would be nice if we could get it available upstream.
15:39:48 <bnemec> Anyway, that's it for the regular agenda.
15:39:49 <bnemec> #topic Open discussion
15:39:53 <bnemec> Anything else this week?
15:40:00 <moguimar> yep
15:40:02 <moguimar> o/
15:40:10 <moguimar> who are our oslo.cache experts?
15:40:22 <moguimar> I'm trying to push TLS support for memcached
15:40:35 <bnemec> With the departure of kmalloc I think that would be hberaud.
15:40:40 <hberaud> bnemec: (or other core) can you validate this one => https://review.opendev.org/#/c/704508/ (backport)
15:40:48 <bnemec> Maybe someone else from the Keystone team too.
15:40:51 <moguimar> got that merged into python-binary-memcached so far
15:41:34 <hberaud> moguimar: I seen your dogpile.cache discussion
15:42:18 <moguimar> I was reading oslo.cache docs last week
15:42:25 <moguimar> and found out that mongodb has TLS support
15:42:28 <moguimar> gotta try it
15:42:40 <moguimar> support already in oslo.config
15:42:45 <moguimar> oslo.cache*
15:43:15 <moguimar> but I also couldn't find many oslo.cache examples
15:43:35 <moguimar> there is only one in the docs and not that straightforward
15:43:55 <moguimar> not just copy-paste and watch it burn
15:44:59 <hberaud> moguimar: what do you thing to start by initialize some etherpad and start centralize things on it and collect our needs etc...?
15:45:00 <moguimar> I'll be synching up with Lance Bragstad later today on this topic
15:45:20 <moguimar> hberaud, we have one already right?
15:45:27 <moguimar> let me find the link
15:45:39 <hberaud> moguimar: ah right I remember now
15:46:15 <moguimar> #link https://etherpad.openstack.org/p/oslo-cache-tls-support-worksheet
15:47:34 <bnemec> A mailing list thread might be good too. I wouldn't be surprised if there are other people interested in this.
15:47:38 <openstackgerrit> Merged openstack/oslotest master: tools: Default to Python 3  https://review.opendev.org/699694
15:48:04 <moguimar> good idea bnemec
15:48:25 <moguimar> I'll prepare something
15:48:46 <bnemec> Which one of the options from the etherpad are you planning to pursue?
15:49:05 <moguimar> python-binary-memcached
15:49:07 <bnemec> Last I heard on the pymemcache change was that we needed to verify it didn't break in the migration from python-memcache.
15:49:13 <moguimar> already got TLS support on it
15:49:20 <moguimar> now moving up to dogpile.cache
15:49:23 <moguimar> and then oslo.cache
15:49:50 <bnemec> Okay, so that's a third memcache client lib?
15:49:52 <moguimar> python-binary-memcached also supports SASL, so we picked it for being "feature-rich"
15:50:07 <bnemec> Is it in global-requirements?
15:51:50 <moguimar> can't find it here
15:51:51 <moguimar> https://opendev.org/openstack/requirements/src/branch/master/global-requirements.txt
15:51:55 <moguimar> am I looking in the right place?
15:52:11 <bnemec> And I guess this assumes we'll move all of oslo.cache to use pbm? I wouldn't think we'd want to use different libs for SSL and non-SSL.
15:52:27 <bnemec> Yeah, that's it.
15:52:33 <bnemec> It was kind of a leading question because I suspected it wouldn't be there. ;-)
15:53:21 <bnemec> If we're not still planning to pursue pymemcache we might want to remove that.
15:53:37 <bnemec> The requirements team doesn't generally like having a bunch of libs that do the same thing.
15:54:37 <moguimar> there are 4 different python clients to memcached
15:54:42 <moguimar> that we have documented
15:55:23 <smcginnis> If we can narrow it down to a couple officially tested in the community, that is preferred.
15:55:40 <moguimar> bnemec, what is pbm/
15:55:42 <moguimar> ?
15:55:59 <bnemec> python-binary-memcached
15:56:03 <moguimar> ah
15:57:13 <moguimar> this is mainly driven by the fact that TLS-Everywhere forgot memcached
15:58:38 <bnemec> Oh, maybe pymemcache isn't only used by oslo.cache.
15:58:49 <bnemec> Apparently it broke the tooz gate at one point: https://opendev.org/openstack/requirements/commit/0297b9936788ac100db6787d048c6d378da377b0
15:59:29 <bnemec> At least if we migrate off python-memcached maybe we can remove that.
15:59:51 <moguimar> both python-memcached and pylibmc rely on libmemcached
16:00:08 <moguimar> a client library to memcached written in C
16:00:18 <moguimar> and it is unmaintained for now
16:00:29 <moguimar> according to folks at #memcached
16:00:37 <bnemec> Yeah, moving away from that is definitely a win.
16:01:15 <moguimar> ok, we are past the top of the hour
16:01:28 <bnemec> If we can do a 1 for 1 swap with memcached libraries then that should be okay with the requirements team.
16:01:34 <moguimar> I'll send the email tomorrow, I'm running out of time today
16:01:51 <bnemec> Sounds good.
16:02:16 <bnemec> Speaking of running out of time, we're past the end of the meeting now.
16:02:27 <bnemec> Anything else we need to talk about quickly?
16:02:40 <bnemec> #action moguimar send email about moving oslo.cache to a different memcached library
16:04:35 <bnemec> Okay, thanks for joining everyone!
16:04:37 <bnemec> #endmeeting