15:00:49 <bnemec> #startmeeting oslo
15:00:49 <bnemec> Courtesy ping for bnemec, jungleboyj, moguimar, hberaud, stephenfin, kgiusti, johnsom, e0ne, redrobot, bcafarel
15:00:49 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:00:50 <openstack> Meeting started Mon Mar  2 15:00:49 2020 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:53 <openstack> The meeting name has been set to 'oslo'
15:00:57 <hberaud> o/
15:01:26 <kgiusti> o/
15:01:45 <bcafarel> o/
15:01:46 <jungleboyj> o/
15:02:02 <ansmith> o/
15:03:21 <johnsom> o/
15:04:53 <moguimar> o/
15:05:11 <bnemec> #topic Red flags for/from liaisons
15:06:49 <bnemec> The only thing I can think of from our side is a new version of oslotest that drops the stestr requirement.
15:07:16 <bnemec> I think everyone was already explicitly depending on it anyway, but if you suddenly have test jobs failing due to missing stestr that could be why.
15:07:45 <moguimar> no flags from Barbican
15:07:48 <bnemec> It also drops support for py2 and some mox stuff that is no longer used.
15:08:47 <smcginnis> \o/
15:09:28 <johnsom> Nothing from the Octavia team
15:09:55 <jungleboyj> Nothing from Cinder.  Sorry.  Got distracted.
15:10:29 <bnemec> No worries. I got pinged right after I started the meeting too. :-)
15:10:36 <bnemec> #topic Releases
15:11:16 <bnemec> Business as usual. I'm probably overdue to look at the stable branches too. Hopefully I'll get to that this week.
15:12:04 <bnemec> #topic Action items from last meeting
15:12:12 <bnemec> "bnemec send email about Oslo meeting time"
15:12:13 <bnemec> Done
15:12:18 <bnemec> "moguimar send email about moving oslo.cache to a different memcached library"
15:12:24 <moguimar> done
15:12:25 <bnemec> I believe I saw that one too.
15:12:32 <moguimar> but no answers so far
15:12:32 <bnemec> moguimar: Cool, thanks.
15:12:37 <bnemec> :-/
15:12:53 <moguimar> people don't like security?
15:12:59 <moguimar> xD
15:13:22 <bnemec> Not usually. :-)
15:14:00 <bnemec> That was all our action items.
15:14:08 <bnemec> #topic Cycle highlights
15:14:38 <bnemec> We are rapidly approaching the end of the cycle, so that means it's cycle highlights time.
15:15:25 <bnemec> This is basically a marketing exercise, so if there's anything we did this cycle that OpenStack users/operators might be interested in please send it to me.
15:15:50 <moguimar> drop of python27?
15:15:57 <bnemec> I haven't really thought about it yet, so I'm not sure if I'll come up with anything.
15:16:29 <bnemec> I'm thinking that one will probably be an overall highlight? I'm not sure every project needs to call it out explicitly.
15:16:50 <hberaud> I think too
15:17:23 <bnemec> Although I guess it may have been a bit more of a task for us due to the number of projects in Oslo.
15:17:56 <bnemec> FWIW, we don't _need_ to have cycle highlights. We frequently don't because so much of Oslo is developer-facing and not that marketable. :-)
15:18:23 <hberaud> could be redundante to speak about the drop in oslo highlight...
15:18:26 <smcginnis> Remember that highlights are by team, not by deliverable.
15:18:33 <smcginnis> So only need to mention dropping py2 support once.
15:19:55 <bnemec> I think the only time we've done cycle highlights during my tenure was this: https://github.com/openstack/releases/blob/master/deliverables/stein/oslo.config.yaml#L9
15:22:37 <bnemec> #topic Weekly Wayward Review
15:22:39 <bnemec> #link https://review.opendev.org/#/c/689482/
15:23:20 <bnemec> I see that one has feedback from us, but no votes. Maybe we should just -1 it if we're don't want to merge it as-is so it's clear something needs to be done?
15:25:00 <hberaud> why not
15:25:20 <hberaud> I could drop my +1 for now
15:26:45 <hberaud> I leave a comment and -1
15:26:56 <bnemec> I think I might be with stephenfin on just dropping the log. If a user asks us to remove a file and at the end of execution the file does not exist then our job is done.
15:27:37 <bnemec> I guess we could leave it at debug in case someone is trying to track down an issue, but info level is probably too high for this anyway.
15:30:15 <hberaud> I agree
15:30:35 <bnemec> Oh, I have another thought about that one. I'll chase it more after the meeting though. Will comment on the review if it pans out.
15:30:45 <bnemec> #action bnemec to follow up on https://review.opendev.org/#/c/689482/
15:30:49 <hberaud> ack
15:31:13 <bnemec> Okay, we've made some progress on that one. Thanks, hberaud.
15:31:15 <bnemec> #topic Open discussion
15:31:21 <bnemec> Anything else this week?
15:32:44 <hberaud> nothing for me
15:33:15 <moguimar> none on my end
15:34:15 <bnemec> Okay, let's call it a meeting then. Thanks for joining, everyone!
15:34:18 <bnemec> #endmeeting