15:22:20 <bnemec> #startmeeting oslo
15:22:20 <bnemec> Courtesy ping for bnemec, jungleboyj, moguimar, hberaud, stephenfin, kgiusti, johnsom, e0ne, redrobot, bcafarel, smcginnis
15:22:20 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:22:21 <openstack> Meeting started Mon Mar 16 15:22:20 2020 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:22:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:22:24 <openstack> The meeting name has been set to 'oslo'
15:22:29 <smcginnis> o/
15:22:30 <bcafarel> o/
15:22:39 <johnsom> o/ lol
15:22:43 <hberaud> o/
15:22:53 <johnsom> I guess it's been a Monday for me too, I didn't notice
15:23:06 <jungleboyj> o/
15:23:19 <bnemec> They keep adding more people to my Monday status meeting downstream, so it keeps taking longer and longer. :-/
15:23:36 <kgiusti> o/
15:25:38 <bnemec> On the plus side, it will be better once Europe goes DST and we add an hour gap between these two meetings.
15:25:40 <bnemec> #topic Red flags for/from liaisons
15:26:38 <johnsom> Nothing from the Octavia team today
15:27:34 <jungleboyj> Nothing from Cinder.
15:27:47 <bnemec> I'm not coming up with anything objectionable that we did last week, but last week was also a bit drama-filled for me so I may be forgetting something. :-)
15:28:14 <jungleboyj> Drama filled?  I think that describes life in general right now.
15:28:50 <bnemec> Yeah, this was piled on top of the "regular" drama that's going on.
15:29:13 <bnemec> I would really like life to be boring for a while.
15:29:30 <jungleboyj> Best of luck with that.
15:30:43 <bnemec> #topic Releases
15:31:07 <bnemec> Pretty sure I forgot to do these last week. Will try to rectify that this week.
15:31:20 <bnemec> So I guess not much to say on this topic.
15:31:28 <bnemec> #topic Action items from last meeting
15:31:43 <bnemec> "bnemec to follow up on https://review.opendev.org/#/c/689482/"
15:31:50 <bnemec> Let's see, did I actually do it this time?
15:32:02 <bnemec> Hey, I did!
15:32:23 <bnemec> That was the only action item last week, so hooray!
15:32:39 <bnemec> #topic Oslo core security team
15:32:43 <hberaud> lol
15:32:54 <bnemec> You may have seen my email about this last week.
15:33:38 <bnemec> There is an oslo-coresec group on Launchpad that is automatically notified of any security bugs in Oslo projects.
15:34:08 <bnemec> It was last updated ~6 years ago and I believe there are only two active contributors to Oslo left on it.
15:34:33 <bnemec> I've removed everyone else since we don't want to be notifying them of private security bugs if they don't need to know.
15:35:00 <bnemec> However, the main reason I wanted to bring it up in the meeting is I am looking for volunteers to be on the team.
15:35:18 <bnemec> There's not a whole lot to it. We don't get so many security bugs that it is a big time commitment.
15:35:45 <smcginnis> bnemec: You can put me on the list. Not sure I will be able to do much with it, but willing to help out if something big comes up.
15:35:53 <bnemec> Fair warning, if I don't get volunteers I'll probably just start adding Oslo cores so we have _someone_ to look at things. ;-)
15:36:10 <bnemec> smcginnis: Great, thanks!
15:36:33 <bnemec> Mostly it's just so we have someone who can pre-review patches before they get proposed to public Gerrit.
15:36:35 <johnsom> lol, volun-told
15:36:57 <bnemec> Generally speaking, the coresec team isn't on the hook to fix every security bug that comes in.
15:37:26 <johnsom> Yeah, I can be on the list, again, I don't have a lot of spare cycles, but can try to help
15:38:03 <johnsom> VMT should do most of the paperwork right? (behind on that e-mail thread)
15:39:03 <bnemec> Yeah, in 6 years I've never had to fill out a CVE disclosure or anything.
15:39:15 <bnemec> And I was actually on two coresec teams for most of that time.
15:39:25 <johnsom> Nice
15:39:30 <kgiusti> bnemec: Add me as well - I really need to work on my insecurities...
15:39:46 <bnemec> lol
15:40:29 <bnemec> Okay, that's a good start. I'll get y'all added shortly.
15:41:07 <bnemec> #action bnemec to add smcginnis, johnsom, and kgiusti to oslo-coresec
15:41:32 <bnemec> I'm open to adding more people so if anyone is interested after the meeting just let me know.
15:42:02 <openstackgerrit> Alan Bishop proposed openstack/tooz master: Add TLS support in etcd3 and etcd3gw drivers  https://review.opendev.org/710539
15:43:00 <bnemec> #topic Weekly Wayward Review
15:43:16 <bnemec> #link https://review.opendev.org/705064
15:43:24 <bnemec> This sounds promising, let's take a look...
15:44:20 <bnemec> Oh, that one's rather large. Might be a bit much to do during the meeting.
15:44:37 <hberaud> bnemec could be improved more but let's cut this into separate patches
15:45:08 <bnemec> hberaud: That would make it an easier review.
15:45:16 <hberaud> bnemec: I also introduced this one > https://github.com/4383/oslo.labs
15:45:31 <hberaud> bnemec: but still fresh paint on
15:46:00 <hberaud> bnemec: I don't know if this is something that we could host officially
15:46:18 <hberaud> and why not merge oslo.tools and oslo.labs
15:46:40 <hberaud> to centralize debug tools and personnal way to tests things on oslo
15:46:57 <bnemec> That's an interesting question. You could potentially go through the new library spec template and see if it helps clarify whether it's a good fit.
15:47:30 <hberaud> bnemec: I know that the major part of us have similar tools and scripts so centralize this could be effortless for all of us
15:47:43 <hberaud> bnemec: ack
15:48:48 <bnemec> Yeah, I don't have an immediate strong opinion one way or another.
15:48:54 <hberaud> bnemec: I want to avoid to reinvent the weel for each of us on our side
15:49:06 <hberaud> s/weel/wheel
15:49:24 <bnemec> We probably don't want to call it oslo.labs, as the oslo. libraries tend to be runtime dependencies for other services (oslo.tools being an exception to that).
15:49:42 <hberaud> bnemec: make sense
15:50:20 <bnemec> I also left some comments on https://review.opendev.org/#/c/707180
15:50:31 <bnemec> Needs a rebase and I'd like to see it added to the test script.
15:50:53 <hberaud> ack
15:51:20 <bnemec> hberaud: So you're going to spilt up https://review.opendev.org/705064, correct?
15:51:28 <hberaud> nope :)
15:52:08 <hberaud> I will continue to try to improve oslo.test but through new commits
15:52:16 <hberaud> follow-up patches
15:53:06 <hberaud> in other words I don't plan to split this one unless you really ask for
15:53:10 <bnemec> Okay, we'll just leave that one as to-review then.
15:53:20 <bnemec> I see smcginnis already did, so we're halfway there. :-)
15:53:29 <hberaud> :)
15:53:48 <bnemec> #topic Open discussion
15:54:01 <bnemec> That's all I had for the week. Anything else in the 7 minutes we have left?
15:54:10 <hberaud> I try to introduce functional tests on oslo.cache
15:54:12 <johnsom> If someone is an expert on oslo.middleware, could you take a look at: https://review.opendev.org/#/c/711127/
15:54:53 <johnsom> I am helping implement the healthcheck code. I ran into some major confusion with how the oslo config is handled in the middleware library.
15:55:44 <johnsom> I have it working, but not sure I'm doing it the best way. There seems to be a chicken/egg with the configuration settings.
15:56:58 <bnemec> How so?
15:57:21 * bnemec is not an expert, but did look at the healthcheck code at one point in the semi-distant past
15:57:46 <johnsom> https://github.com/openstack/oslo.middleware/blob/master/oslo_middleware/healthcheck/__init__.py#L384
15:58:38 <johnsom> The config options don't materialize until the __init__,  then it stevedore loads the backends based on that. So fixture override to test the backends is... interesting
15:58:53 <johnsom> https://github.com/openstack/oslo.middleware/blob/master/oslo_middleware/healthcheck/__init__.py#L388
15:59:25 <johnsom> The backend load is once and done, no mutate, so...  The trick is setting the config settings, before they are needed, etc.
16:00:29 <bnemec> Ah. I don't even remember what backends this supports...
16:00:56 <johnsom> Well, there are two included, but we are adding one. It's really not much of a check without backends
16:01:25 <johnsom> Anyway, it is working, so this is a "if you have interest and time"
16:02:35 <johnsom> I ended up defining those opts twice, which seems to work ok.
16:03:45 <bnemec> Yeah, that might be a case where you just have to pre-register the opt in the test so you can set an override.
16:04:49 <bnemec> Which is not ideal because config opts are generally considered private to their defining project. :-/
16:05:21 <johnsom> Right.
16:05:46 <bnemec> Okay, we're over time. If anyone comes up with a better solution to this let johnsom know.
16:05:59 <bnemec> hberaud: Didn't mean to ignore you. Do you need reviews or help?
16:06:10 <hberaud> Just to summarize the oslo.cache situation, the etcd3gw functional tests works well, but I currently facing some issues with the memcached functional tests who doesn't work (I need to deep dive), and in second time after these tests I reintroduced the dogpile backend based on pymemcache but without removing the python-memcached based backend, so we retrieve a functional oslo.cache, we surround the
16:06:12 <hberaud> situation to avoid similar situation, and we continue to modernize it (the both described parts are still WIP).
16:06:46 <hberaud> just to inform the oslo world of the advancement/situation
16:07:22 <hberaud> bnemec: help could be useful on the memcache functional tests
16:07:44 <bnemec> Okay, thanks for the update.
16:08:13 <bnemec> Sounds like adding tests for the various backends could probably be done separately once the functional testing framework is in place?
16:08:20 <hberaud> bnemec: I don't seen why it fail, so if someone have spare time...
16:08:56 <hberaud> bnemec: yes it could be done separately but we will only win 1 commit
16:09:18 <hberaud> bnemec: but why not :)
16:10:18 <hberaud> bnemec: this is the culprit => https://review.opendev.org/#/c/712479/
16:10:18 <bnemec> Okay, going to make use of a meetbot command that I don't often use since we have a couple of followups.
16:10:18 <bnemec> #help johnsom looking for a better way to override oslo.middleware healthcheck backends opt
16:10:18 <bnemec> #help hberaud looking for assistance on memcache functional testing
16:10:31 <bnemec> #link https://review.opendev.org/#/c/712479/
16:10:32 <hberaud> :)
16:10:59 <hberaud> that's all for me
16:11:06 <bnemec> Okay, sounds good.
16:11:57 <bnemec> We're well over time, so thanks for your patience everyone and catch you all next week.
16:12:07 <bnemec> If we don't all catch coronavirus in the meantime. ;-)
16:12:21 <bnemec> #endmeeting