15:02:32 <bnemec> #startmeeting oslo
15:02:32 <bnemec> Courtesy ping for bnemec, jungleboyj, moguimar, hberaud, stephenfin, kgiusti, johnsom, e0ne, redrobot, bcafarel, smcginnis
15:02:32 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:02:33 <openstack> Meeting started Mon Apr 6 15:02:32 2020 UTC and is due to finish in 60 minutes. The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:36 <openstack> The meeting name has been set to 'oslo'
15:02:40 <hberaud> yo
15:02:42 <johnsom> o/
15:02:45 <smcginnis> o/
15:02:58 <jungleboyj> o/ Multi-tasking.
15:02:59 <ansmith> o/
15:03:18 <kgiusti> o/
15:04:49 <openstackgerrit> Merged openstack/oslo.log master: Use unittest.mock instead of third party mock https://review.opendev.org/716394
15:05:15 <bnemec> #topic Red flags for/from liaisons
15:05:47 <jungleboyj> Nothing that I am aware.
15:05:53 <bnemec> We reverted the oslotest switch to unittest.mock, which should mean that is no longer a concern for other projects.
15:06:03 <openstackgerrit> Merged openstack/oslo.reports master: Use unittest.mock instead of third party mock https://review.opendev.org/716397
15:06:45 <smcginnis> Kind of a red flag, but the new sphinx release appears to be breaking several repo's docs jobs. So no directly oslo related, but something we should be aware of.
15:07:00 <smcginnis> And looks like oslo.config is impacted.
15:07:08 <johnsom> The fix for the oslo policy command line changes seems to work for us.
15:07:09 <bcafarel> late o/
15:07:15 <bcafarel> (nothing I know of from neutron)
15:08:26 <bnemec> johnsom: Awesome. I should maybe send an email out about that because there may be other projects that also need to make changes for it.
15:08:40 <bnemec> Everybody had their own workaround for the cli args issue.
15:09:15 <hberaud> +1 for the wide email
15:09:56 <bnemec> I can link to the Octavia and Keystone changes as examples.
15:10:06 <bnemec> #action bnemec send email about oslo.policy cli change
15:10:41 <hberaud> yep good ideas for the examples
15:10:55 <hberaud> could help users
15:11:50 <bnemec> I had no idea the can of worms I opened when I started digging into this bug. :-)
15:12:03 <hberaud> :)
15:12:09 <openstackgerrit> Merged openstack/oslo.utils master: Use unittest.mock instead of third party mock https://review.opendev.org/716392
15:12:13 <bnemec> #topic Releases
15:12:54 <bnemec> New olsotest and new tooz went out late last week. One to fix a problem, the other as an FFE.
15:13:29 * moguimar is late
15:13:30 <bnemec> Unfortunately I didn't get everything else released before non-client library freeze. Is that going to be a problem, smcginnis?
15:15:38 <openstackgerrit> Merged openstack/oslo.db master: Use unittest.mock instead of third party mock https://review.opendev.org/716385
15:15:48 <smcginnis> bnemec: What else is pending?
15:16:12 <bnemec> A lot of doc and test changes.
15:16:52 <bnemec> I haven't seen any functional changes yet, but if we branch from the latest release of a number of libraries we're going to lose things on the stable branch.
15:16:58 <smcginnis> Doesn't sound too risky. We would just need to post a FFE to the ML I think.
15:17:21 <smcginnis> If it's job config changes, it might be easier to backport those.
15:17:32 <smcginnis> Since they aren't something that needs to be "released" to end users.
15:17:33 <bnemec> Yeah, they're basically going to be administrative releases.
15:17:49 <bnemec> There's kind of a lot of them. :-/
15:18:07 <openstackgerrit> Merged openstack/oslo.vmware master: Use unittest.mock instead of third party mock https://review.opendev.org/716387
15:18:11 <bnemec> We have quite a few libraries that don't see a lot of releases anymore so they pile up over time.
15:18:20 <smcginnis> We're probably early enough that I would think it's OK to do a final release to get those included in a branch.
15:18:48 <bnemec> Okay, I'll write the release patch and send an email to the list for the FFE.
15:18:59 <smcginnis> ++
15:19:33 <bnemec> #action bnemec write final release patch for Oslo libraries and send email to list for FFE
15:20:23 <bnemec> Okay, that should do it for releases.
15:20:36 <bnemec> #topic Action items from last meeting
15:20:54 <bnemec> (none)
15:20:58 <bnemec> Okay, that's easy. :-)
15:21:37 <bnemec> #topic Non-client Library Freeze
15:22:17 <bnemec> We've kind of already discussed this, but just to be explicit: we now need an FFE from the release team for any further Ussuri releases.
15:22:42 <bnemec> That includes bug fixes, so keep that in mind if you're reviewing something until we branch.
15:23:08 <hberaud> ack
15:23:14 <bnemec> Fixes that won't break the initial release can probably wait and be backported.
15:23:17 <openstackgerrit> Merged openstack/oslo.middleware master: Use unittest.mock instead of third party mock https://review.opendev.org/716395
15:23:53 <openstackgerrit> Merged openstack/oslo.i18n master: Use unittest.mock instead of third party mock https://review.opendev.org/716390
15:24:11 <bnemec> #topic PTL Situation
15:24:23 <bnemec> As you may have noticed, nobody ran for Oslo PTL this cycle. :-/
15:25:10 <bnemec> In light of the weird situation the world is in, I have permission from my manager to keep going for a bit longer.
15:25:36 <hberaud> good news
15:25:48 <bnemec> However, we discussed doing some additional delegation to smooth the transition when it does happen.
15:26:18 <bnemec> One thing that would pretty simple and useful would be if we have a rotation of people doing the weekly releases.
15:26:55 <hberaud> how to manage the PTL approval on the release side?
15:27:04 <bnemec> It's not a huge time commitment, but it's a repetitive one so it ends up eating up a decent amount of time when one person is doing all of them.
15:27:12 <hberaud> still on the hands of liaison and PTL during the weeks?
15:28:00 <bnemec> Maybe or maybe not. Anyone can propose a release, it would just need signoff from the PTL/liaison before it could merge.
15:28:12 <hberaud> ack
15:28:35 <bnemec> So, if you're interested in helping out with that, let me know.
15:28:44 <bnemec> If not I'll start reaching out to specific people. :-)
15:28:52 <hberaud> I'm already liaison but I could more commited on that if needed
15:29:32 <bnemec> hberaud: Cool, that would be great!
15:30:11 <bnemec> I've already written up some of the process in the PTL guide, but maybe it can be expanded.
15:30:23 <hberaud> it could help you to focus on other PTL side to tranfer
15:30:52 <hberaud> s/side/sides/
15:31:14 <hberaud> s/tranfer/transfer/
15:31:59 <bnemec> Yep
15:32:42 <bnemec> (my network just blinked, so hopefully I didn't miss anything)
15:33:52 <moguimar> mine "blinked" for an hour, so I lost my last meeting and the start of this one xD
15:34:06 <bnemec> Well, this should be interesting. All of a sudden my wired network connection is flaky. :-/
15:34:34 <bnemec> moguimar: :-)
15:34:51 <bnemec> Fortunately I think we're almost done anyway.
15:35:17 <bnemec> Skipping weekly wayward review since we're in freeze.
15:35:21 <bnemec> #topic Open discussion
15:35:34 <bnemec> So, anything else before we call it?
15:35:45 <hberaud> nope
15:36:54 <moguimar> not here
15:37:19 <bnemec> Alright, thanks for joining everyone!
15:37:22 <bnemec> #endmeeting