15:00:16 <bnemec> #startmeeting oslo
15:00:16 <bnemec> Courtesy ping for bnemec, jungleboyj, moguimar, hberaud, stephenfin, kgiusti, johnsom, e0ne, redrobot, bcafarel, smcginnis
15:00:16 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:00:17 <openstack> Meeting started Mon Apr 13 15:00:16 2020 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:20 <openstack> The meeting name has been set to 'oslo'
15:00:33 <johnsom> o/
15:00:57 <redrobot> \i
15:01:02 <redrobot> \o even
15:01:08 <kgiusti> o/
15:01:10 <ansmith_> o/
15:01:43 <smcginnis> o/
15:03:31 <bnemec> #topic Red flags for/from liaisons
15:03:43 <johnsom> Nothing on the Octavia side
15:05:15 <bnemec> Things should be pretty quiet on the Oslo side now that we're frozen.
15:06:26 <johnsom> I hope so
15:07:08 <bnemec> #topic Releases
15:07:28 <bnemec> The one outstanding issue at this point is the policy deprecation logging change for Nova.
15:07:43 <bnemec> I just pushed a release patch to get the changes out there.
15:08:23 <redrobot> oh dang, I missed the red flags
15:08:28 <bnemec> Other than that I expect no more releases until Victoria opens up.
15:08:32 <redrobot> The latest Castellan release is broken
15:08:42 <redrobot> https://bugs.launchpad.net/castellan/+bug/1872480
15:08:43 <openstack> Launchpad bug 1872480 in castellan "Castellan release 3.0.0 is broken" [Undecided,In progress] - Assigned to Douglas Mendizábal (dougmendizabal)
15:08:44 <bnemec> :-(
15:09:04 <redrobot> Looks like a constant was renamed but not all references were updated
15:09:15 <bnemec> Wow, how did that get through the Castellan gate?
15:09:15 <redrobot> I have a patch to fix it:
15:09:23 <redrobot> https://review.opendev.org/#/c/718775
15:09:37 <redrobot> insufficient functional testing, I think
15:09:58 <redrobot> I need to beef up the Functional tests so we can catch this in case of a regression
15:10:24 <redrobot> We caught it in the Barbican gate
15:11:31 <bnemec> Okay, approved.
15:11:45 <bnemec> I'm surprised the vault functional test didn't catch that.
15:12:05 <redrobot> I think that test suite is more of a unit test suite
15:12:07 <bnemec> It's pretty fundamental to anything using Vault.
15:12:49 <redrobot> Would be awesome if we can get a 3.0.1 release when this patch merges.
15:12:52 <bnemec> We're going to need a release FFE for that too, I guess.
15:12:59 <bnemec> Can you request that?
15:13:11 <redrobot> bnemec, sure, ML message?
15:13:38 <bnemec> Yeah. Probably tag oslo, release, and requirements.
15:13:53 <redrobot> ack, will do
15:14:04 <bnemec> I think we'll need one from requirements too since this will need a u-c bump.
15:14:16 <bnemec> #action redrobot request Castellan FFE on openstack-discuss
15:14:19 <bnemec> redrobot: Thanks
15:14:24 <smcginnis> redrobot: Some info: http://lists.openstack.org/pipermail/openstack-discuss/2020-April/014060.html
15:16:16 <redrobot> smcginnis, looking, thanks
15:17:58 <bnemec> #link https://bugs.launchpad.net/castellan/+bug/1872483
15:17:59 <openstack> Launchpad bug 1872483 in castellan "Vault functional tests not really functional" [Undecided,Confirmed]
15:18:06 <bnemec> for the hole in our testing
15:18:22 <bnemec> Interestingly, I can't triage in castellan.
15:18:43 <bnemec> #action bnemec request castellan 3.0.1 release once Vault fix has merged
15:19:18 <bnemec> Okay, I think we have a plan for that. Just waiting on the gate and FFE approval.
15:19:35 <bnemec> Thanks for the heads up, redrobot.
15:20:07 <bnemec> #topic Action items from last meeting
15:20:28 <bnemec> "bnemec send email about oslo.policy cli change"
15:20:32 <bnemec> Oops, did not do that.
15:20:34 <bnemec> #action bnemec send email about oslo.policy cli change
15:20:56 <bnemec> "bnemec write final release patch for Oslo libraries and send email to list for FFE"
15:21:18 <bnemec> That one is done and everything was released last week.
15:21:32 <bnemec> I guess now we're waiting on oslo.policy and castellan to branch.
15:22:34 <bnemec> And that was it for action items.
15:22:37 <bnemec> #topic Project-specific contributor docs
15:22:57 <bnemec> Kendall pinged me over the weekend to remind me that we never addressed this community goal.
15:23:33 <bnemec> Unfortunately it's going to be a bit more work for us than for most projects because we'll have to make the change in every repo. :-/
15:24:31 <johnsom> Brian's write up for Cinder was nicely done. I highly recommend borrowing from it.
15:24:56 <bnemec> #link https://governance.openstack.org/tc/goals/selected/ussuri/project-ptl-and-contrib-docs.html
15:25:32 <bnemec> johnsom: Cool, thanks. I have to admit I've only vaguely followed this.
15:25:50 <johnsom> #link https://review.opendev.org/711006
15:25:54 <bnemec> The PTL side of it is addressed in https://review.opendev.org/#/c/711784/
15:26:12 <bnemec> I'm wondering if we want to do something similar for contributor docs.
15:26:35 <bnemec> Instead of duplicating them across all repos, just write up a single policy doc and link to it from contributing.rst.
15:26:54 <bnemec> I guess I need to look closer at the template to determine whether that's practical.
15:27:57 <bnemec> I'll try to do that this week, at least enough to figure out a path forward.
15:28:39 <bnemec> I'm probably going to need some help getting all the projects updated though.
15:28:51 <bnemec> If you'd like to volunteer, give me a holler.
15:30:44 <smcginnis> I think at this point, we can just declare that the goal for the cycle was not met.
15:30:52 <smcginnis> And just work towards getting it in place for victoria.
15:30:55 <bnemec> Yeah, it's definitely not getting done for Ussuri.
15:31:13 <bnemec> I've already asked for one mass FFE, I _really_ don't want to do another. :-)
15:31:38 <smcginnis> So that should ease a little pressure on getting it done. We could get one repo done, then should be fairly easy for a volunteer to take that and apply the same template to the rest of the repos over the next ~6 months.
15:31:44 <smcginnis> Haha, yeah. :)
15:32:27 <smcginnis> The nice thing with docs - they get published right after they are merged.
15:32:48 <smcginnis> We _could_ think of backporting to ussuri since it is low risk, but probably not really necessary.
15:32:48 <bnemec> Yep
15:34:18 <bnemec> Okay, I'll hopefully look into that before next week. If anyone else does so in the meantime feel free to ping me with your thoughts.
15:35:11 <bnemec> Kind of ironic that the new home for the docs team failed to complete a doc goal. ;-)
15:35:19 <smcginnis> Hah!
15:35:19 <bnemec> Anyway, that was it for topics this week.
15:35:32 <bnemec> #topic Open discussion
15:35:43 <bnemec> Anything else?
15:36:42 <jungleboyj> Sorry I didn't make the meeting.  Was having to get the kids.
15:37:17 <smcginnis> So jungleboyj has all those actions, right?
15:37:27 <bnemec> smcginnis: Exactly. :-D
15:37:54 * bnemec appoints jungleboyj Oslo PTL
15:38:08 <openstackgerrit> Merged openstack/oslo-specs master: Add PTL Guide to policies  https://review.opendev.org/711784
15:38:21 <openstackgerrit> Merged openstack/oslo-specs master: Additions to the PTL Guide  https://review.opendev.org/716099
15:38:43 <jungleboyj> Ha ha.  I don't think that is going to end well for anyone.
15:40:04 <bnemec> Okay, sounds like we're done. Time to go do some action items. :-)
15:40:11 <bnemec> Thanks for joining, everyone!
15:40:14 <bnemec> #endmeeting