15:16:29 <bnemec> #startmeeting oslo
15:16:30 <bnemec> Courtesy ping for bnemec, jungleboyj, moguimar, hberaud, stephenfin, kgiusti, johnsom, e0ne, redrobot, bcafarel, smcginnis
15:16:30 <openstack> Meeting started Mon Apr 27 15:16:29 2020 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:16:30 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:16:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:16:33 <openstack> The meeting name has been set to 'oslo'
15:16:38 <bnemec> Sorry, distracted by a policy discussion in nova. :-(
15:16:40 <johnsom> o/
15:16:41 <moguimar> o/
15:16:42 <bcafarel> :)
15:16:44 <bcafarel> o/
15:16:45 <jungleboyj> o/
15:16:45 <moguimar> no biggie
15:18:50 <smcginnis> o/
15:19:32 <hberaud> o/
15:21:07 * bnemec wishes we hadn't lost all of our Keystone policy people
15:21:20 <bnemec> #topic Red flags for/from liaisons
15:21:35 <moguimar> nothing from Barbican
15:21:39 <johnsom> Nothing to note from Octavia
15:21:48 <jungleboyj> Nothing to note from Cinder.
15:22:34 <moguimar> bnemec, lbragstad from my team is probably a strong Keystone policy guy
15:22:52 <bnemec> Hopefully things are pretty quiet. I don't think we're released anything recently.
15:23:00 <bnemec> moguimar: Yeah, but he's not on OpenStack as much as he used to be.
15:24:14 <moguimar> whenever needed I can poke him
15:24:20 <bnemec> Anyway, no releases planned either so we'll skip that section.
15:24:37 <bnemec> Yeah, I ping him when necessary, but it would have been better if we could have had a Keystone person driving this policy stuff.
15:24:54 <bnemec> I feel like some things were done that probably were not intended when the policy code was written.
15:25:10 <moguimar> is raildo around?
15:27:03 <bnemec> #topic Action items from last meeting
15:27:08 <bnemec> "bnemec create etherpad for virtual ptg"
15:27:10 <bnemec> Done.
15:27:16 <bnemec> Will talk about that more in a bit.
15:27:22 <bnemec> "bnemec to reply to diablo_rojo about contributor docs goal"
15:27:24 <bnemec> Also done.
15:27:47 <bnemec> #topic  Virtual PTG
15:27:50 <bnemec> Speaking of...
15:28:00 <bnemec> #link https://etherpad.opendev.org/p/oslo-victoria-topics
15:28:18 <bnemec> I created the etherpad, and I see moguimar has added a couple of things. \o/
15:28:44 <bnemec> Since the PTG is virtual, I went ahead and requested a couple of hours for us to meet.
15:28:54 <bnemec> Same time as the previous virtual PTG we did, this hour and the next.
15:29:03 <moguimar> nice
15:29:12 <bnemec> I figure this hour everyone should be available, and if anyone needs to drop for the second hour we can just get their stuff in early.
15:29:18 <moguimar> I'll ask redrobot to request a different slot for Barbican
15:29:36 <moguimar> so I can attend both
15:29:37 <bnemec> Cool
15:29:58 <bnemec> That was another advantage of scheduling early, most slots were still available. :-)
15:30:10 <bnemec> I put the details in the etherpad too.
15:30:16 <moguimar> do you have the link for the schedule?
15:30:28 <bnemec> If that doesn't work for anyone, please let me know ASAP.
15:30:40 <bnemec> Yeah, I should have it. One second...
15:30:55 <moguimar> found it
15:30:57 <moguimar> #link https://ethercalc.openstack.org/126u8ek25noy
15:31:08 <moguimar> I'll place it in the etherpad
15:31:11 <bnemec> Yep, that^ :-)
15:31:18 <bnemec> Thanks
15:31:22 <moguimar> done
15:32:17 <bnemec> I hope nobody is offended that they didn't get to fill out another doodle poll for this. ;-)
15:32:30 <moguimar> xD
15:32:55 <bnemec> #topic  contributor documentation goal
15:33:08 <raildo> moguimar, now, I'm back
15:33:16 <bnemec> I started on this last week.
15:33:18 <bnemec> #link https://review.opendev.org/#/c/723044/
15:33:46 <bnemec> WIP because of the TODO in Contacting the Core Team.
15:33:54 <bnemec> I'd like to keep that information on the wiki so cores can update it themselves without having to wait for review.
15:34:04 <bnemec> Kind of similar to the ping list.
15:34:15 <moguimar> raildo, I'll bring the topic in the open discussion
15:34:27 <bnemec> I don't feel like you need core team signoff to update your timezone or whatever. :-)
15:35:05 <bnemec> If there are no objections I'll go ahead and add that to the wiki somewhere and link it from the docs.
15:35:39 <bnemec> Otherwise, I expect that doc is pretty complete. I pretty much did the bare minimum to fill out the template.
15:36:04 <bnemec> If anybody wants to add more they should feel free to push followups.
15:36:20 <bnemec> Once that goes in, we'll need to update contributing.rst in each repo to point to it.
15:36:21 <moguimar> I can read it once you're done with that -1
15:36:53 <moguimar> I +1 it to get updates
15:37:03 <bnemec> Great, thanks!
15:37:42 <bnemec> (you can also use the add reviewer button to subscribe if you don't want to leave a vote)
15:38:04 <moguimar> yeah, I was lazy this time
15:38:48 <bnemec> Here again, I'm going to take silence as agreement. If no one objects I'll do what I discussed above before next meeting.
15:38:59 <bnemec> Then I'll probably action all of the cores to update their wiki entry.
15:39:36 <bnemec> That's all I had for topics.
15:39:39 <bnemec> #topic Open discussion
15:39:50 <bnemec> Still skipping weekly wayward review for feature freeze.
15:39:55 <bnemec> Anything else?
15:40:05 <hberaud> yep one thing
15:40:17 <hberaud> related to https://review.opendev.org/#/c/723044/
15:40:23 <moguimar> raildo, we need more keystone policy people
15:40:43 <raildo> moguimar, for some specific task or in general?
15:41:02 <moguimar> raildo, I think bnemec can elaborate on that
15:41:22 <hberaud> bnemec: if I correctly understood it the goal is to centralize how to contribute on oslo.*, I'm right?
15:42:06 <bnemec> hberaud: Well, it's part of the community goal to better document how to contribute to each project.
15:42:19 <hberaud> I ask because 10 days ago I submitted some related doc => https://review.opendev.org/#/c/720771/2/CONTRIBUTING.rst
15:42:25 <bnemec> The idea is that it's very specific to Oslo/Nova/Cinder/etc.
15:42:45 <hberaud> bnemec: and my goal was to spread similar changes on oslo.* project
15:42:51 <hberaud> s/projects/
15:43:11 <bnemec> hberaud: Ah, nice!
15:43:24 <bnemec> Full details of the goal are in https://governance.openstack.org/tc/goals/selected/ussuri/project-ptl-and-contrib-docs.html
15:44:13 <bnemec> I think that fits in nicely with the goal. We might need to talk to diablo_rojo about exactly how to combine your work with the goal template.
15:44:58 <bnemec> moguimar: raildo: We're just running into a lot of pain here at the end of the cycle because of the Nova policy migration to the new scope and role-aware policies.
15:45:28 <hberaud> bnemec: ack, I think I'll be more committed on this topic during the next weeks to avoid tu duplicate things
15:45:37 <hberaud> s/tu/to
15:45:58 <bnemec> I feel like there's a lot of confusion about how it was supposed to work, and I think the problem is that the people who originally came up with the migration path are no longer as involved as they used to be.
15:46:00 <raildo> bnemec, yeah, I'm replacing Collen in co-lead the popup team for the policy effort, I'm trying to catch up all the current work and next steps on that front
15:46:07 <bnemec> hberaud: Cool, thanks
15:46:22 <raildo> #link https://review.opendev.org/#/c/722101/
15:46:44 <bnemec> raildo: Nice, thanks for doing that!
15:47:14 <raildo> bnemec, anything urgent on your point of view that I should be focus on?
15:47:18 <bnemec> hberaud: I'll try to communicate stuff better on the mailing list so you can keep up to date.
15:47:24 <bnemec> raildo: Nova :-)
15:47:32 <hberaud> bnemec: thanks
15:47:40 <bnemec> Specifically the discussion that has been going on for the past hour in their channel.
15:48:01 <raildo> bnemec, haha cool, this is top of my list, I'll spoke with nova folks today about it
15:48:01 <bnemec> Apparently people didn't even know that YAML could be used for policies. :-(
15:48:20 <raildo> bnemec, damn... I'll try my best to help them
15:48:41 <bnemec> I guess we didn't communicate that enough back when JSON was semi-deprecated...like 3 years ago. O.O
15:49:31 <raildo> bnemec, we definitely did it, but you know.. ppl don't read deprecated/docs that much hehe
15:49:45 <bnemec> Yeah
15:50:24 <bnemec> Which is what concerns me about the move to suppress the warnings. It relies on people reading the release notes to know that things are changing.
15:51:16 <raildo> bnemec, well.. I would be against removing those warning, at least until we have more projects addressing their default roles approach
15:51:24 <raildo> maybe next cycle-ish?
15:52:02 * bnemec adds policy to the virtual PTG agenda :-)
15:52:18 <raildo> bnemec++
15:52:21 <bnemec> I think we're going to have to re-sync on this because the Nova migration has turned up a lot of issues.
15:53:18 <bnemec> #action bnemec to add policy to PTG agenda
15:53:29 <bnemec> I'll check with keystone too in case they're already planning to discuss it.
15:53:55 <raildo> bnemec, definitely, do we want to have someone for nova here for next week? so we can keep tracking their progress on that side
15:54:42 <bnemec> raildo: I'm not sure we want to even wait a week. The release is imminent and we need to decide how to handle all of this.
15:55:40 <bnemec> I'm not sure where the Nova discussion ended up. I kind of lost track once I moved over here.
15:55:45 <raildo> bnemec, I mean, I'll be working with them on this mean time, but I don't a lot of details in what is remaining to give a call in they can make the release date or not
15:56:48 <bnemec> Yeah, I don't know for sure. I thought we had mostly resolved this, but then the new issues came up today.
15:57:35 <raildo> bnemec, I saw that lbragtad (from Keystone side as well) was talking with the nova folks earlier today, I'll sync with him as well
15:58:59 <bnemec> raildo: Sounds good, thanks.
15:59:28 <bnemec> We're just about out of time (and I have another meeting) and I think we've got a plan for everything, at least.
15:59:34 <bnemec> Anything else in the last 30 seconds?
15:59:44 <moguimar> yep
15:59:57 <moguimar> when can we start merging things in oslo.cache?
16:00:09 <moguimar> specially for the pymemcache_pool backend
16:00:13 <bnemec> I would prefer to wait until after Ussuri ships.
16:00:25 <moguimar> ack
16:00:30 <bnemec> However, if it's a completely separate thing that wouldn't affect backports it's probably fine to do it now.
16:00:51 <moguimar> I'll leave that decision to hberaud
16:01:05 <bnemec> The main thing right now is just to make sure we don't cause ourselves pain if there's a last-second bugfix needed.
16:01:25 <moguimar> ok
16:01:43 <bnemec> Okay, I'm late for a 1-1 with my manager so I need to go.
16:01:48 <bnemec> Thanks for joining everyone!
16:01:50 <bnemec> #endmeeting