15:37:04 <bnemec> #startmeeting oslo
15:37:04 <bnemec> Courtesy ping for bnemec, jungleboyj, moguimar, hberaud, stephenfin, kgiusti, johnsom, e0ne, redrobot, bcafarel, smcginnis
15:37:04 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:37:05 <openstack> Meeting started Mon May 11 15:37:04 2020 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:37:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:37:08 <openstack> The meeting name has been set to 'oslo'
15:37:15 <hberaud> o/
15:37:21 <jungleboyj> o/
15:37:26 <johnsom> o/
15:37:35 <bnemec> Naturally my last meeting ran over too. :-/
15:37:46 <kgiusti> o/
15:37:48 <smcginnis> o/
15:38:13 <bcafarel> o/
15:38:45 <bnemec> I have another meeting in 22 minutes too, so this will probably be a quick one.
15:39:13 <bnemec> Not sure why Monday morning is such a popular meeting time. :-)
15:39:20 <bnemec> #topic Red flags for/from liaisons
15:39:30 <johnsom> Nothing from Octavia
15:39:30 <jungleboyj> Nothing that I am aware of from Cinder.
15:39:46 <bnemec> The Glance team raised an issue with oslo.i18n last week.
15:40:10 <bnemec> It seems that some translations that were previously there no longer are since the move to the stdlib locale list.
15:40:25 <moguimar> o/
15:40:40 <bnemec> I don't know that we've released that change yet, but they have a job running against Oslo master to catch stuff like this early.
15:40:52 <moguimar> nothing from Barbican
15:41:06 <bnemec> I also have this as a standalone topic for later because we need to decide what to do about it.
15:42:57 <bnemec> #topic Releases
15:43:11 <bnemec> Not much since we're in release week.
15:43:23 <bnemec> Thanks to hberaud for proposing releases for stein and train last week!
15:44:26 <bnemec> #topic Action items from last meeting
15:44:34 <bnemec> "Figure out what to put in the contributing.rst for each repo"
15:44:52 <bnemec> I saw hberaud had proposed a patch for this. I haven't looked that closely at it yet. :-/
15:45:23 <bnemec> #action bnemec to look at hberaud's patch for per-project contributing.rst
15:45:26 <hberaud> bnemec: can you take a look to https://review.opendev.org/#/c/725327/ ?
15:45:59 <bnemec> Yeah, that was what I saw.
15:46:13 <hberaud> bnemec: we discused with zaneb about *cookiecutter projects and contrib guide
15:46:24 <bnemec> The main thing I wanted to do was look at the contributing.rst template and see if there are other things we should pull in to each project.
15:46:31 <zaneb> o/
15:46:38 <hberaud> zaneb: o/
15:46:46 <bnemec> Like directly listing the bug tracker and such so people don't have to click through multiple links to find that.
15:46:53 <bnemec> Assuming it's not there already.
15:46:54 <hberaud> zaneb: contrib stuffs ^^^
15:47:16 <zaneb> are we talking about the contributing.rst template or the CONTRIBUTING.rst template?
15:47:21 <zaneb> it gets confusing :/
15:47:56 <bnemec> Indeed.
15:48:45 <bnemec> In the interest of not duplicating changes everywhere, we've documented the main oslo contributing details in https://specs.openstack.org/openstack/oslo-specs/specs/policy/contributing.html
15:49:04 <bnemec> We want each project's contributing.rst to point at that rather than just duplicating everything.
15:49:33 <zaneb> I think the top-level CONTRIBUTING.rst one should be a lightly-edited version of the one from the openstack-cookiecutter repo, pointing to https://specs.openstack.org/openstack/oslo-specs/specs/policy/contributing.html as the 'project-specific' contributing docs
15:50:17 <bnemec> That sounds like what I had in mind.
15:50:32 <zaneb> I agree that we don't want separate contributing docs for each repo, and indeed every project is in this boat because everything has multiple repos (service, client, &c.)
15:51:41 <zaneb> but it might pay to have a contributing page that also links back to the main olso contributing page
15:53:05 <bnemec> Yeah, I wanted to avoid duplicating the information because I don't want 40 patches every time we change the core team, but most of what's in the spec is actually links elsewhere anyway.
15:54:01 <bnemec> So I think I need to take a look at the discussion that has already happened on the patch and maybe we can circle back on this outside the meeting or next week.
15:54:05 <bnemec> Whichever happens first. :-)
15:54:16 <hberaud> +1
15:54:44 <bnemec> #topic Virtual PTG
15:54:49 <bnemec> Just a couple of quick things on this:
15:54:56 <bnemec> #link https://etherpad.opendev.org/p/oslo-victoria-topics
15:55:09 <bnemec> That's the etherpad. If you have anything to discuss please add it there.
15:55:45 <bnemec> Also, we got moved. Last I looked we're in Grizzly now. Same time, just got moved for the sake of more efficient use of virtual rooms.
15:55:57 <moguimar> I hope my trip back to the Czech Republic doesn't get postponed enougth to overlap the summit...
15:56:08 <moguimar> PTG*
15:56:21 <bnemec> The main takeaway from that is to check the location before joining in case it changes again.
15:56:34 <bnemec> I'll keep pestering you with reminders until then too. ;-)
15:57:08 <bnemec> moguimar: Fingers crossed!
15:57:29 <moguimar> every time it gets closer it is +2 more weeks ='(
15:57:43 <bnemec> Yeah
15:57:58 <bnemec> Okay, I have three minutes, so I think we'll postpone the oslo.i18n discussion til next week.
15:58:08 <moguimar> o/
15:58:10 <bnemec> Until we release it it isn't a critical issue.
15:58:20 <bnemec> #topic Open discussion
15:58:38 <bnemec> Anything else in the last minute and a half?
15:58:52 <hberaud> nope
15:59:41 <bnemec> Okay, thanks for joining everyone!
15:59:41 <bnemec> This was a one-off conflict so should be back to normal next week.
15:59:47 <hberaud> bnemec: thanks
15:59:48 <bnemec> #endmeeting