15:00:59 <bnemec> #startmeeting oslo
15:00:59 <bnemec> Courtesy ping for bnemec, jungleboyj, moguimar, hberaud, stephenfin, kgiusti, johnsom, e0ne, redrobot, bcafarel, smcginnis
15:01:00 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:01:01 <openstack> Meeting started Mon May 18 15:00:59 2020 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:04 <openstack> The meeting name has been set to 'oslo'
15:01:10 <kgiusti> o/
15:01:14 <moguimar> o/
15:01:14 <bcafarel> o/
15:01:27 <jungleboyj> o/
15:01:31 <ansmith_> o/
15:03:12 <bnemec> #topic Red flags for/from liaisons
15:03:24 <jungleboyj> Nothing from Cinder.
15:05:04 <hberaud> o/
15:05:38 <bnemec> There was a bit of churn last week with openstackdocstheme.
15:05:47 <bnemec> However, I think that's all resolved now.
15:07:21 <bnemec> #topic Releases
15:07:28 <bnemec> Just openstackdocstheme last week, I think.
15:08:12 <bnemec> However, the deliverables for Victoria are coming soon (if they haven't merged already), so we'll be able to get back on the regular release schedule soon.
15:08:29 <bnemec> #topic Action items from last meeting
15:08:43 <bnemec> "bnemec to look at hberaud's patch for per-project contributing.rst"
15:08:46 <bnemec> Not done. :-(
15:08:48 <bnemec> Sorry
15:08:50 <hberaud> np
15:08:59 <bnemec> #action bnemec to look at hberaud's patch for per-project contributing.rst
15:09:06 <bnemec> Still needs to be done though.
15:09:49 <bnemec> That was it from last week.
15:09:51 <bnemec> #topic  Virtual PTG
15:10:02 <bnemec> #link https://etherpad.opendev.org/p/oslo-victoria-topics
15:10:11 <bnemec> Just my weekly reminder that this is happening. :-)
15:10:55 <bnemec> Also, even though we won't be doing in-person project updates, I'd like to do a virtual project update for this past cycle.
15:11:15 <bnemec> Probably just come up with the regular set of slides and record a presentation of them.
15:11:39 <bnemec> So start thinking about stuff that we got done in the past cycle that you would like highlighted.
15:11:49 * bnemec needs to add that to the PTG etherpad too
15:13:31 <bnemec> Done.
15:13:43 <bnemec> There's a topic on the PTG etherpad now to collect things for the project update.
15:14:19 <bnemec> I'm going to skip the contributor documentation goal topic since that's currently blocked on me.
15:14:28 <bnemec> #topic  Ping list update
15:14:41 <bnemec> As we kick off a new cycle, it's time to refresh the ping list too.
15:15:12 <bnemec> Like last cycle, I'll add a new ping list to the agenda and everyone who wants to continue receiving pings can add their name.
15:15:23 <bnemec> In a couple of weeks we'll switch from the existing ping list to the new one.
15:16:05 <bnemec> This way we don't keep spamming people every week even if they've moved on from Oslo.
15:16:23 <bnemec> I'll send an email once I've updated the wiki.
15:16:32 <bnemec> #action bnemec to create new ping list on meeting agenda
15:16:59 <bnemec> #topic  oslo.i18n translation name changes
15:17:16 <bnemec> #link https://bugs.launchpad.net/oslo.i18n/+bug/1877386
15:17:16 <openstack> Launchpad bug 1877386 in oslo.i18n "Dropping babel broke Glance unit tests" [High,Triaged]
15:17:49 <bnemec> Hopefully I haven't lost everyone because this topic could use your input. :-)
15:18:13 <bnemec> We recently dropped the Babel dependency from oslo.i18n, but in the process it seems we lost some translations.
15:18:26 <hberaud> weird
15:18:51 <bnemec> I don't know that we actually _lost_ them, but they're present under different names than before.
15:19:22 <bnemec> This is somewhat problematic though because it means we might break consumers when we release this change.
15:19:40 <smcginnis> Did babel do something special to match up the names that they now no longer match?
15:20:46 <bnemec> I _think_ what's happening is that the stdlib only includes standard translation names. It looks like Babel had some shorthands (i.e. it for it_IT).
15:21:30 <smcginnis> it_IT does seem "more correct" from what I've seen on other translation projects.
15:21:51 <bnemec> One thought I had was that we could create an alias list in oslo.i18n to map names to the new locations, and maybe log a warning that they're using an unofficial translation.
15:22:27 <smcginnis> That sounds reasonable to me.
15:23:45 <bnemec> Oh hey, there's even a convenient list of the aliases: https://github.com/python-babel/babel/blob/master/babel/core.py#L80
15:24:14 <smcginnis> Copy paste for the win! :)
15:24:32 <bnemec> Okay, so we should pull that into oslo.i18n.
15:24:38 <bnemec> Do we want to consider those deprecated?
15:25:03 <smcginnis> Looks like we just do the same thing here: https://github.com/python-babel/babel/blob/master/babel/core.py#L972
15:25:28 <bnemec> I guess we could also just leave them with a big comment that says "don't add anything to this dict".
15:25:42 <smcginnis> If we deprecate, then we can get rid of extra code eventually. But no harm keeping either.
15:26:55 <bnemec> Yeah, it doesn't really bother me to carry the mapping since it's only for backward compatibility and shouldn't require much in the way of maintenance.
15:27:29 <bnemec> Maybe for the initial patch we just add the aliases, and then if we want to deprecate them we can do that as a followup.
15:27:56 <bnemec> Getting the aliases in is the priority since it will unblock users relying on the old names.
15:28:41 <bnemec> #action Pull babel alias list into oslo.i18n for backward compatibility.
15:28:43 <smcginnis> ++
15:30:01 <bnemec> Okay, cool. That was it for one-off topics.
15:30:02 <bnemec> #topic Weekly Wayward Review
15:30:13 <bnemec> #link https://review.opendev.org/#/c/671309/
15:30:38 <bnemec> hberaud: There was a suggestion on that review. Could you take a look and comment on whether it makes sense to do what they're saying?
15:30:58 <bnemec> It sounds reasonable, but I haven't looked that closely at it.
15:31:05 <hberaud> ack
15:31:19 <hberaud> also if some of you could take a look to https://review.opendev.org/712479
15:32:25 <moguimar> https://review.opendev.org/#/c/718223 to hberaud ?
15:32:36 <moguimar> too*
15:32:41 <hberaud> yep
15:32:57 <hberaud> please
15:33:05 <hberaud> thanks
15:33:38 <moguimar> I would also like to inform that I have a working oslo.cache with TLS memcached =D
15:33:56 <moguimar> sent a patch to pifpaf and another to dogpile.cache
15:34:17 <moguimar> after those are released, I can add the tests
15:35:03 <bnemec> Cool, glad to see oslo.cache getting some attention. :-)
15:36:08 <bnemec> #action hberaud to review comments on https://review.opendev.org/#/c/671309/
15:36:22 <bnemec> #action Oslo team to review series starting at https://review.opendev.org/712479
15:36:32 <hberaud> also I would discuss a bit deeply with you about https://review.opendev.org/#/c/711220/40
15:36:48 <hberaud> maybe not here
15:36:58 <hberaud> or through an etherpad
15:37:08 <hberaud> do you prefer something?
15:37:32 <hberaud> it's about the difference of design between pymemcache and python-memcached
15:38:12 <bnemec> I have been failing to follow that. Would it make sense to discuss at the PTG in real time?
15:38:51 <hberaud> and a tricks on the memcache_pool backend => https://github.com/openstack/oslo.cache/blob/master/oslo_cache/_memcache_pool.py#L246,L249
15:39:04 <hberaud> yep good idea
15:39:43 <bnemec> Okay, can you add it to the etherpad?
15:39:44 <hberaud> I'm not sure how to keep that (and if we need to keep that too) with pymemcached
15:39:51 <hberaud> sure
15:41:38 <bnemec> Okay, sounds like we have a plan.
15:41:41 <bnemec> #topic Open discussion
15:41:48 <bnemec> Anything else this week?
15:42:13 <smcginnis> I was late so missed it, but yes, the victoria deliverable series has opened.
15:42:22 <smcginnis> New releases can commence whenever they are needed.
15:42:33 <hberaud> \o/
15:43:02 <bnemec> Cool. I may hold off until the oslo.i18n thing is resolved, but then we'll get back to weekly releases.
15:43:28 <smcginnis> Good plan.
15:45:01 <bnemec> Anything else before we call it?
15:45:33 <smcginnis> Nothing from me.
15:46:03 <moguimar> not on my end
15:46:27 <hberaud> nope
15:47:27 <bnemec> Alright, thanks for joining everyone!
15:47:30 <bnemec> #endmeeting