15:03:01 <bnemec> #startmeeting oslo
15:03:01 <bnemec> Courtesy ping for bnemec, jungleboyj, moguimar, hberaud, stephenfin, kgiusti, johnsom, e0ne, redrobot, bcafarel, smcginnis
15:03:01 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:03:01 <openstack> Meeting started Mon Jun  8 15:03:01 2020 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:05 <openstack> The meeting name has been set to 'oslo'
15:03:07 <smcginnis> o/
15:03:21 <johnsom> o/
15:03:33 <hberaud> o/
15:03:38 <moguimar> welcome to the Victoria cycle =D
15:03:40 <kgiusti> o/
15:03:55 <bcafarel> o/
15:04:16 <bnemec> Have we not had a meeting since Ussuri shipped?
15:04:26 <moguimar> I mean post PTG
15:04:44 * hberaud have an appointement soon so I will surely eject before the end of the meeting
15:04:49 <bnemec> Ah, fair enough. I think we had one meeting since release.
15:05:18 <bnemec> hberaud: No problem. It'll probably be a quick one since we just had the PTG.
15:05:29 <moguimar> so anything we should focus on before you leave hberaud ?
15:05:58 <hberaud> moguimar: just this one => https://review.opendev.org/#/c/734096/
15:06:34 <hberaud> I would love have all of our feedbacks
15:07:07 <hberaud> but could be done through the review
15:07:31 <moguimar> ack
15:07:41 <moguimar> I'd like to see more in the commit message
15:08:00 <bnemec> I'm fine with that. It doesn't hurt to have it available.
15:08:01 <moguimar> like reason and link for the discussion
15:08:04 <johnsom> We have really liked having that for Octavia
15:08:19 <bnemec> For it to accomplish much someone has to actually look at it, but that can't happen until it exists.
15:08:40 <smcginnis> johnsom: Has it worked out well in Octavia?
15:08:49 <bnemec> #topic Adding Backport-Candidate label to Oslo projects
15:08:55 <bnemec> #link https://review.opendev.org/#/c/734096/
15:09:03 <bnemec> Just to make it official.
15:09:15 <hberaud> bnemec: thx
15:09:18 <johnsom> Yes. We came up with it because we were struggling to keep up with backports. It's a very handy flag to make a list.
15:09:34 <moguimar> johnsom++
15:09:35 <smcginnis> I think it can't hurt. :)
15:09:48 <hberaud> +1
15:10:02 <bnemec> We should probably create an Oslo dashboard for it: https://wiki.openstack.org/wiki/Oslo#Review_Links
15:10:18 <hberaud> bnemec: good idea
15:10:46 <smcginnis> johnsom: Does ocatavia has a process to remove the flag once it's actually been backported?
15:11:04 <smcginnis> That seems like the only issue to track it through.
15:11:15 <hberaud> ah right
15:11:18 <johnsom> Not today. We have talked about it. You can flip it over to -2 once they are all proposed
15:11:30 <bnemec> Wouldn't we just make the dashboard ignore merged patches?
15:11:42 <bnemec> Oh, no that doesn't work, does it?
15:11:47 <hberaud> bnemec: could be a good shortcut
15:11:48 <moguimar> I guess not
15:11:55 <smcginnis> The dashboard would have to show patches that have the flag set. It wouldn't know if it has been backport or not.
15:12:05 <moguimar> cause you see in the list the one which needs backport, not the backport itself
15:12:10 <bnemec> You still need to see the flagged reviews even after they merged.
15:12:12 <bnemec> Right.
15:12:19 <smcginnis> And if we don't remove the flag, that dashboard gets less useful over time because it will fill with irrelevant things.
15:12:39 <bnemec> We should write a tool that can do that, if one doesn't exist already.
15:12:49 <smcginnis> Seems quite possible.
15:13:06 * bnemec is not volunteering, mind you ;-)
15:13:14 * smcginnis neither
15:14:22 * hberaud need to dash, see you soon
15:14:33 <bnemec> o/ hberaud
15:14:56 <bnemec> FWIW, I wrote a tool that interacted with Gerrit a while back: https://github.com/cybertron/tripleo-auto-abandon
15:15:14 <bnemec> You would probably do something similar, except instead of looking at how old the patch is, you look to see if the backport has merged.
15:15:31 <bnemec> The potentially tricky part would be figuring out which review is the backport so you can check its status.
15:15:41 <bnemec> I don't know how Gerrit would represent that.
15:16:02 <smcginnis> If it's backported right, it should have the cherry-pick footer in the commit message.
15:16:55 <bnemec> I'm hoping maybe there's a cherry-picks section in the Gerrit API data that would point you directly to the right review.
15:17:05 <bnemec> But that would be too easy, so it probably doesn't exist. ;-)
15:18:27 <bnemec> #agreed Add Backport-Candidate label to Oslo projects
15:18:50 <bnemec> #idea Write a tool to automatically remove Backport-Candidate label once the backport has been proposed
15:19:10 <bnemec> We don't actually need to wait for the backport to merge. Once it's been proposed the candidate label has done its job.
15:19:37 <bnemec> #topic Red flags for/from liaisons
15:19:44 <bnemec> Sorry for the delay liaisons. Hope you're still with us. :-)
15:20:49 <bnemec> The main thing we've been dealing with lately is the bug in oslo.log that broke a number of projects.
15:21:08 <bnemec> I think backports to all supported branches are merged. Stein still needs to be released, but I believe the others are all in the wild now.
15:21:38 <johnsom> Nothing to mention from Octavia team.
15:23:35 <bnemec> #topic Releases
15:23:46 <bnemec> Master and all the stable branches except Stein got released late last week.
15:24:18 <bnemec> Unless there's an urgent need I'll probably skip release proposals this week. I doubt much has merged in the past couple of days anyway.
15:24:29 <bnemec> Will try to get the Stein oslo.log out there today though.
15:24:48 <bnemec> #action bnemec to release Stein backport(s)
15:25:08 <bnemec> #topic Action items from last meeting
15:25:17 <bnemec> "bnemec to look at hberaud's patch for per-project contributing.rst"
15:25:49 <bnemec> I believe I did that. I think I had concerns that we were duplicating something already covered by the template.
15:26:13 <bnemec> We don't have hberaud right now so we'll have to table that discussion for later.
15:26:19 <bnemec> "bnemec to create new ping list on meeting agenda"
15:26:21 <bnemec> Done
15:26:26 <bnemec> "Pull babel alias list into oslo.i18n for backward compatibility."
15:26:29 <bnemec> Done
15:26:35 <bnemec> hberaud to review comments on https://review.opendev.org/#/c/671309/
15:26:53 <bnemec> Looks like that was done too.
15:27:00 <bnemec> Just needs review now.
15:27:13 <bnemec> "Oslo team to review series starting at https://review.opendev.org/712479"
15:27:31 <bnemec> Done, thanks moguimar and smcginnis
15:27:59 <bnemec> That's all of our action items.
15:28:27 <moguimar> cool, are we making new action items out of PTG discussions?
15:28:50 <moguimar> for tracking purpose
15:29:12 <bnemec> I guess we could. I have a todo to write a followup blog post summarizing what we discussed.
15:29:47 <bnemec> It might be better to open lp bugs for anything longer term so we don't keep repeating the same action items from week to week.
15:31:35 <bnemec> Also, if there's anything we want to revisit in future meetings it should be added to the agenda explicitly. That might be better than using action items.
15:32:13 <bnemec> So I guess my preference for PTG followups would be lp bugs or agenda items.
15:32:25 <bnemec> I won't throw a tantrum if someone adds an action item too though. :-)
15:32:44 <bnemec> #topic Ping list update
15:33:05 <bnemec> Per the action item above, the new ping list is now available on the agenda wiki page.
15:33:18 <bnemec> If you want to keep receiving courtesy pings for this meeting please add your name to the new list.
15:33:30 <bnemec> I'll keep using the old list next week, but after that I'll switch over to the new one.
15:33:58 <bnemec> #action Anyone who wants to continue receiving courtesy pings should add their name to the Victoria list on the agenda wiki
15:34:06 <bnemec> Kind of a wordy action item.
15:34:25 <bnemec> I'll send an email reminder too now that the PTG is over.
15:34:32 <bnemec> #action bnemec send email about Victoria ping list
15:35:08 <bnemec> #topic Oslo core contact details
15:35:20 <bnemec> This was actually something that came out of the contributor documentation goal.
15:35:34 <openstackgerrit> Merged openstack/stevedore master: Remove Travis CI config  https://review.opendev.org/734079
15:35:34 <bnemec> One of this things we're supposed to do for that is create a contact list for Oslo cores.
15:35:46 <bnemec> To that end, I've created some tables on https://wiki.openstack.org/wiki/Oslo#The_Oslo_Team
15:36:12 <bnemec> I'd like to ask all of the Oslo cores to fill in their details there, if they don't mind.
15:36:43 <bnemec> Note that there's also one for the project-specific cores.
15:36:52 <moguimar> ack
15:37:17 <bnemec> I've filled in the names of some of our more active cores, but if you're not there please add yourself.
15:37:33 <johnsom> Done
15:37:43 <bnemec> #action Oslo cores to fill out contact details on https://wiki.openstack.org/wiki/Oslo#The_Oslo_Team
15:37:50 <bnemec> Thanks!
15:39:00 <bnemec> That's the one-off agenda.
15:39:01 <bnemec> #topic Weekly Wayward Review
15:39:08 <bnemec> #link https://review.opendev.org/689482
15:39:39 <bnemec> Gorka replied to the comments on that so it would be nice to get it in.
15:41:25 <bnemec> Alright, +2A. It sounds like everyone is okay with the current version.
15:41:44 <bnemec> If someone wants a debug log for the other cases they can propose a followup and we'll discuss it there.
15:41:56 <bnemec> #topic Open discussion
15:42:09 <bnemec> That's it for our regularly scheduled topics. Anything else before we close?
15:44:19 <smcginnis> *crickets*
15:45:09 <moguimar> not on my end
15:45:30 <bnemec> Okay, thanks for a great PTG last week everyone.
15:45:37 <bnemec> Catch you all next week.
15:45:40 <bnemec> #endmeeting