15:00:58 <bnemec> #startmeeting oslo
15:00:58 <bnemec> Courtesy ping for bnemec, jungleboyj, moguimar, hberaud, stephenfin, kgiusti, johnsom, e0ne, redrobot, bcafarel, smcginnis
15:00:58 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:00:59 <openstack> Meeting started Mon Jun 15 15:00:58 2020 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:04 <openstack> The meeting name has been set to 'oslo'
15:01:05 <smcginnis> o/
15:01:07 <moguimar> o/
15:01:09 <hberaud> o/
15:01:21 <jungleboyj> o/
15:01:22 <bcafarel> o/
15:01:47 <johnsom> o/
15:02:10 <kgiusti> p
15:02:15 <kgiusti> o/, that is
15:02:30 <bnemec> :-)
15:03:22 <bnemec> #topic Red flags for/from liaisons
15:03:50 <johnsom> No issues from Octavia
15:03:58 <jungleboyj> No issues from Cinder.
15:04:21 <bcafarel> none from Neutron
15:04:40 <bnemec> I can't remember anything on our side, but I had a 3 day weekend so I can't remember anything that happened last week. ;-)
15:05:41 <smcginnis> :)
15:05:52 <moguimar> Barbican is fine too
15:06:45 <bnemec> Cool, glad to hear nothing is on fire.
15:06:48 <bnemec> #topic Releases
15:07:12 <bnemec> I released the stein backport of the oslo.log fix last week, so all of the supported releases should be fixed.
15:07:29 <bnemec> I believe hberaud also released a fix for oslo.utils.
15:07:50 <hberaud> right 4.2.1
15:09:26 <bnemec> Otherwise expect the usual set of releases for the week.
15:09:29 <bnemec> #topic Action items from last meeting
15:09:34 <hberaud> I'm waiting for reviews on backports for stables branches for the same fix
15:09:48 <bnemec> Sounds good, thanks
15:09:52 <bnemec> "bnemec to release Stein backport(s)"
15:09:55 <bnemec> Done
15:10:04 <bnemec> "Anyone who wants to continue receiving courtesy pings should add their name to the Victoria list on the agenda wiki"
15:10:18 <bnemec> This is ongoing, but it looks like we have a pretty solid list again so call it good progress.
15:10:24 <bnemec> #action Anyone who wants to continue receiving courtesy pings should add their name to the Victoria list on the agenda wiki
15:10:31 <bnemec> We'll leave it on for another week.
15:10:38 <bnemec> "bnemec send email about Victoria ping list"
15:10:48 <bnemec> Done. Twice actually. :-)
15:11:07 <bnemec> I had already sent one a few weeks ago. I sent a reminder too though.
15:11:18 <bnemec> "Oslo cores to fill out contact details on https://wiki.openstack.org/wiki/Oslo#The_Oslo_Team"
15:11:31 <bnemec> Partially done. Thanks to everyone who has done that.
15:11:36 <bnemec> #action Oslo cores to fill out contact details on https://wiki.openstack.org/wiki/Oslo#The_Oslo_Team
15:11:48 <bnemec> Leaving that one on the list for now too.
15:12:28 <bnemec> That's all of them.
15:12:31 <bnemec> #topic Ping list update
15:12:59 <bnemec> Final reminder that next week we'll be switching to the new ping list.
15:13:11 <bnemec> Looks like most people have re-upped for this cycle, so that's good to see. :-)
15:13:48 <bnemec> Of course, the ping list is always updatable, so if you miss the "deadline" it's not too late.
15:14:10 <bnemec> #topic Oslo core contact details
15:14:30 <bnemec> Just a reminder to please add contact details to https://wiki.openstack.org/wiki/Oslo#The_Oslo_Team
15:14:52 <bnemec> This was part of the contributor docs goal so they know how to get ahold of the core team if necessary.
15:15:11 <bnemec> It's not mandatory, but it would be nice to have.
15:16:22 <bnemec> That's it for one-off topics.
15:16:23 <bnemec> #topic Weekly Wayward Review
15:16:36 <bnemec> #link https://review.opendev.org/716873
15:17:20 <smcginnis> Looks like that's pending responses to hberaud's comments.
15:17:22 <bnemec> Oh, I've seen that bug.
15:17:40 <bnemec> I feel like it indicated something else was wrong though.
15:18:45 <bnemec> Maybe we can just WIP it until hberaud's questions are answered.
15:18:57 <hberaud> +1
15:19:27 <hberaud> also  if some of you have spare time please take a look to => https://review.opendev.org/#/c/730884/
15:19:39 <bnemec> I wish I could remember what solved the issue for me. I'm pretty confident that just addressing the typeerror didn't actually accomplish much because it was a bogus log record.
15:19:57 <bnemec> But if it results in a more clear error maybe it's worth changing anyway.
15:21:17 <bnemec> Oh, eventlet.
15:21:34 <hberaud> yep...
15:22:33 <bnemec> hberaud: So this only fixed test_ssl_server? The others still seem to be skipped.
15:22:57 <hberaud> yep I'll address them trrough follow up patches
15:23:23 <hberaud> but I think the mechanism will be mostly the same for other tests
15:25:23 <bnemec> hberaud: Left a question on the review. Otherwise lgtm.
15:25:33 <hberaud> ack thanks
15:25:58 <bnemec> #topic Open discussion
15:26:11 <bnemec> Okay, that's it for the regular agenda. Anything else before we close it out?
15:26:15 <hberaud> yep, I know several discussions around eventlet switching have been in the past, but I think we should seriously ask us what to do with oslo.service/eventlet in our near future because the list of eventlet issue with recent versions of python is really huge...
15:27:00 <hberaud> eventlet have really difficulties to stay sync with recent python version
15:27:13 <hberaud> and we will facing issues too
15:27:18 <hberaud> (soon)
15:27:41 <bnemec> This isn't something the Oslo team can really decided. It affects all services that use eventlet. Which is...most of them.
15:27:44 <hberaud> like this bug ^^^ and the SSL issue with requests in a monkey patched env
15:28:04 <hberaud> yep I know
15:28:05 <smcginnis> I've seen a lot of people saying we should move away from eventlet, but does anyone know what an alternative would be?
15:28:16 <smcginnis> Might be worth starting a ML thread.
15:28:17 <hberaud> cotyledon
15:28:26 <hberaud> or a new version based on async
15:28:33 <bnemec> Yeah, I think this will need to be a list discussion.
15:28:50 <hberaud> rewrite from scratch...
15:29:03 <bnemec> Cotyledon isn't a drop-in replacement because it changes the threading model which is likely to break all kinds of things in services that assume green threads.
15:29:48 <bnemec> That's always been the problem with moving away from eventlet. It's going to be a huge amount of churn and will probably introduce all kinds of tricky concurrency bugs.
15:30:18 <hberaud> the goal is not to decide alone on oslo but rather try to trigger a move on this topic
15:30:54 <bnemec> Right, so can you start a mailing list thread that discusses the problems and possible options?
15:31:00 <hberaud> sure
15:31:05 <bnemec> Cool
15:31:20 <bnemec> #action hberaud to start mailing list thread about possibly dropping eventlet
15:32:01 <bnemec> Anything else?
15:32:17 <hberaud> nope
15:34:13 <bnemec> Going once...
15:34:33 <bnemec> twice...
15:34:49 <openstackgerrit> Hervé Beraud proposed openstack/oslo.service master: Fix some SSL tests for wsgi module under python 3  https://review.opendev.org/730884
15:34:54 <bnemec> Thanks for joining everyone!
15:34:56 <bnemec> #endmeeting