15:00:47 <bnemec> #startmeeting oslo
15:00:47 <bnemec> Courtesy ping for bnemec, smcginnis, moguimar, johnsom, stephenfin, bcafarel, kgiusti, jungleboyj
15:00:47 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:00:48 <openstack> Meeting started Mon Jul 13 15:00:47 2020 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:51 <openstack> The meeting name has been set to 'oslo'
15:01:00 <johnsom> o/
15:01:13 <kgiusti> o/
15:01:44 <tosky> hi from your friendly zuulv3 community goal volunteer
15:02:03 <moguimar> o/
15:02:17 <bnemec> o/ tosky!
15:04:06 <bnemec> #topic Red flags for/from liaisons
15:04:18 <johnsom> Nothing from the Octavia team
15:04:33 <bnemec> We had a major release of stevedore last week that broke something.
15:04:42 <bnemec> There's a fix slated for release today.
15:05:07 <moguimar> all fine in Barbican land
15:05:21 <smcginnis> o/
15:06:15 <bnemec> Okay, I think that's all of the liaisons, so we can move on.
15:06:16 <bnemec> #topic Releases
15:07:14 <bnemec> hberaud has been handling most of these lately, so I'm a little out of the loop.
15:07:33 <bnemec> Generally speaking, I think our releases should be pretty current though.
15:09:38 <smcginnis> I think that is accurate.
15:09:39 <bnemec> Hmm, no action items for one-off topics.
15:10:19 <bnemec> And my VM that hosts reviewstats seems to be down, so weekly wayward review is problematic.
15:10:45 <moguimar> I have some
15:10:45 <bnemec> #topic Open discussion
15:10:58 <tosky> if I may :)
15:11:06 <moguimar> go on tosky
15:11:08 <bnemec> moguimar: A review or a topic?
15:11:17 <moguimar> I'll bring mine after
15:11:25 <moguimar> I need to colect some links
15:11:33 <bnemec> Sounds good.
15:12:05 <tosky> I'm here for the Zuul v3 porting goal; the overall status of oslo is good, but there are still a few jobs that needs some porting
15:12:39 <bnemec> Cool. Do you have a list?
15:12:46 <tosky> I haven't sent a proper report yet (drafting it right now) but I can share this as a special preview: https://etherpad.opendev.org/p/goal-victoria-native-zuulv3-migration
15:13:03 <tosky> oslo ones are around line 197
15:14:14 <bnemec> We can just kill that zmq job. We don't support that driver anymore and haven't for a while.
15:14:15 <tosky> if I've got all of them, there are 10 legacy jobs, and 4 of them are grenade (which got their native zuul v3 version only recently)
15:14:35 <bnemec> I assume there's a known migration path for grenade?
15:14:41 <tosky> oh, kill the job or close the repository, whatever works for you; I'm fine as long as the job is not around :)
15:15:02 <tosky> yes, grenade job received a native job just before branching ussuri thanks to, uhm
15:15:43 <tosky> this one https://review.opendev.org/#/c/548936/
15:16:23 <tosky> if you look for merged patches with topic:native-zuulv3-migration, you will see a few grenade ones, even pretty complex (see ironic)
15:17:08 <bnemec> Okay, I doubt we're doing anything crazy with it, so hopefully those won't be too hard.
15:17:10 <tosky> just a few random grenade jobs: https://review.opendev.org/#/c/726790/ https://review.opendev.org/#/c/729860/ https://review.opendev.org/#/c/703098/
15:17:33 <tosky> I haven't checked what these jobs do, but I think they won't be complicated to port as well
15:17:44 <tosky> if you have any question please feel free to ping me (and add me as reviewer)
15:17:47 <bnemec> Looking at the list, the ones that may require some Oslo-specific work are the messaging and pbr ones.
15:18:12 <kgiusti> bnemec: I'll take a crack at the messaging ones.
15:18:23 <bnemec> kgiusti: Awesome, thanks!
15:18:32 <tosky> the messaging ones may be easy, if the only things they do is to use oslo.messaging from source
15:18:38 <bnemec> #action kgiusti to look at migrating messaging jobs to zuulv3.
15:18:42 <tosky> just add oslo.messaging to required-projects
15:18:53 <tosky> but again I haven't checked the job in details :)
15:19:35 <kgiusti> tosky: I'll take a look and get back to you with questions
15:19:39 <tosky> sure!
15:19:48 <kgiusti> tosky: thanks :D
15:20:28 <tosky> you probably know that already, but the migration to zuulv3 provides most of the work for the other community goal, the port from bionic to focal
15:20:44 <bnemec> Okay, I've added this topic to the agenda for next week too so hopefully we won't lose track of it like we did with the docs goal...
15:21:14 <bnemec> We'll probably find some obscure deps for one of our drivers that doesn't exist on focal. :-)
15:21:16 <tosky> once the base jobs switch the ubuntu version, all native zuul v3 job are switched as well (which may bring some breakages in tests, but at least the general part is done)
15:21:21 <tosky> eh
15:21:27 <tosky> that's the project-specific part
15:22:02 <bnemec> Yep. We'll whack those moles when they pop their heads up.
15:23:07 <moguimar> you're done tosky ?
15:23:09 <tosky> I think that's it from my side for now, yes
15:23:11 <tosky> thanks!
15:23:14 <moguimar> ack
15:23:23 <bnemec> Thanks tosky!
15:23:27 <moguimar> I was working with herve last week on https://review.opendev.org/#/c/720771/
15:25:37 <moguimar> pre-commit is very good as a tool, but I have my doubts that it will be as effective as a git hook
15:26:05 <moguimar> so while anyone can install the hooks locally, I think we should also enforce pre-commit at gate
15:26:31 <moguimar> usually when you run pre-commit, it will only consider modified/staged files
15:26:55 <moguimar> so at the gate we can either run on all source or in the last commit
15:26:58 <bnemec> If we don't have it in the gate it will most likely get broken over time.
15:27:24 <moguimar> and I think it should go in the pep8 check
15:27:26 <bnemec> Last commit should be fine in the gate, at least once we get the whole project compliant in the first place.
15:28:34 <bnemec> Would you propose adding it to the pep8 tox env then?
15:28:48 <moguimar> in a following patch
15:28:55 <moguimar> replacing the flake8 like
15:29:04 <moguimar> as flake8 is also included in pre-commit checks
15:29:20 <moguimar> https://review.opendev.org/#/c/720771/6/tox.ini
15:29:36 <moguimar> basically replace line 27 with line 35 in a followup patch
15:29:50 <moguimar> with an intermediate patch making everything compliant
15:30:31 <moguimar> so 1st, I need some one else to review this patch, 2nd, get to an agreement for gating
15:30:38 <moguimar> 2nd point shouds positive so far
15:30:39 <bnemec> I don't have any strong objections. It looks like the stuff pre-commit is checking is all sane.
15:31:10 <moguimar> yup, I'd +2 it but then I made some changes on it
15:31:27 <moguimar> with herve's consent
15:31:29 <bnemec> stephenfin: ^might be relevant to your interests since I believe you were advocating for pre-commit too
15:31:48 <moguimar> 3rd point on this is a raise dead from the discuss list
15:32:32 <moguimar> I'd like to, in yet another patch, introduce black through pre-commit
15:32:46 <bnemec> That I object to.
15:32:55 <moguimar> the impact on oslo.cache is around 18 files at first
15:33:02 <bnemec> We've discussed black in the past and didn't want to deal with the churn it would cause.
15:33:20 <moguimar> that was for big projects like openstack sdk
15:33:26 <moguimar> I was looking at the options
15:33:40 <moguimar> we cound have 80 lines and ignore "" vs ''
15:33:41 <smcginnis> Please no black.
15:33:43 <bnemec> I mean, we have 40 projects. Collectively I think that qualifies as "big".
15:34:41 <moguimar> ok, so lets stick to points 1 and 2 then
15:34:41 * stephenfin is in another meeting but agrees with pre-commit integration (reviewed it this morning). Integrating it into the gate seems sound though we didn't bother doing it for nova since pep8 was the only one we really cared about and that was already validated
15:36:38 <moguimar> so do we have a tribute to review https://review.opendev.org/#/c/720771 and I will work on the gating patch?
15:37:16 <bnemec> I've approved that patch.
15:37:38 <moguimar> ach, thanks Ben
15:37:50 <bnemec> We can discuss how to handle the gating on the followup.
15:38:12 <moguimar> I think we can watch pre-commit during this cycle and then decide on applying it to other projects next cycle
15:38:26 <bnemec> I can't remember if there were any objections to gating on it when it was discussed previously.
15:38:30 <moguimar> like a topic in the retrospective or so
15:39:12 <bnemec> I would even make it a standalone topic for the next PTG.
15:39:45 <moguimar> ok
15:40:11 <bnemec> It'll be easier to have that discussion not in the context of the overall retrospective.
15:40:51 <bnemec> #action moguimar to propose patch integrating pre-commit to the gate for oslo.cache
15:41:03 <bnemec> Anything else on this topic for now?
15:41:11 <moguimar> nope
15:41:19 <moguimar> and I don't have anything else
15:42:17 <bnemec> Okay, anything else this week?
15:44:18 <bnemec> Looks like "no". :-)
15:44:22 <bnemec> Thanks for joining, everyone!
15:44:24 <bnemec> #endmeeting