15:00:51 <bnemec> #startmeeting oslo
15:00:51 <bnemec> Courtesy ping for bnemec, smcginnis, moguimar, johnsom, stephenfin, bcafarel, kgiusti, jungleboyj
15:00:51 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:00:52 <openstack> Meeting started Mon Jul 20 15:00:51 2020 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:53 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:55 <openstack> The meeting name has been set to 'oslo'
15:00:56 <moguimar> o/
15:00:58 <johnsom> o/
15:01:06 <bcafarel> o/
15:01:12 <jungleboyj> o/
15:03:04 <kgiusti> o/
15:03:29 <bnemec> #topic Red flags for/from liaisons
15:03:43 <bnemec> Looks like pymysql broke us over the weekend.
15:03:56 <jungleboyj> I am not aware of anything specific to Cinder.
15:03:59 <bnemec> Specifically tooz.
15:04:38 <bcafarel> just a note on neutron side: we got a recent test failure fixed with https://review.opendev.org/#/c/741957/
15:04:42 <bnemec> dtantsur proposed a fix, which I just started looking at. Unfortunately it seems we have no lower-constraints job on that repo so there's nothing verifying that the fix works with older versions too. :-/
15:05:00 <johnsom> Nothing from Octavia
15:05:29 <dtantsur> bnemec: I don't think there is a version that did not have Connection.cursor()
15:05:37 <moguimar> Nothing from Barbican
15:06:14 <bnemec> dtantsur: Yeah, that was my guess.
15:06:50 <bnemec> bcafarel: Ick. I hate eventlet.
15:07:36 <bcafarel> :) yes a nice surprise circular import
15:07:50 <bnemec> Oh, this is because of the stevedore change.
15:08:42 <bnemec> I wonder if there's any other way to break that circular import. Importing stuff before eventlet is monkey patched goes against our documented eventlet best practices.
15:08:51 <bnemec> dhellmann: ^
15:10:05 <bnemec> I guess as long as you're unblocked we can live with it.
15:10:20 <bnemec> #topic Releases
15:10:40 <bnemec> I saw a bunch of release requests from hberaud last week, so I assume we're up to date on that.
15:10:59 <hberaud> o/ sorry to be late
15:11:04 <bnemec> np
15:11:25 <bnemec> Anything to add about releases?
15:11:35 <hberaud> indeed normally we more or less up-to-date
15:12:08 <bnemec> Cool. I guess people can look for a tooz release in the near future to fix the pymysql breakage.
15:12:33 <bnemec> #topic Action items from last meeting
15:12:58 <bnemec> "kgiusti to look at migrating messaging jobs to zuulv3."
15:13:04 <bnemec> I saw some patches related to this.
15:13:14 <hberaud> yep
15:13:16 <bnemec> I think I even reviewed one.
15:13:20 <kgiusti> bnemec: yeah, seems straightforward: https://etherpad.opendev.org/p/goal-victoria-native-zuulv3-migration
15:13:39 <kgiusti> bnemec: hberaud: but Zuul (and tosky) have not had the final say yet :)
15:13:51 <hberaud> ack
15:14:06 <bnemec> Great!
15:14:45 <bnemec> "moguimar to propose patch integrating pre-commit to the gate for oslo.cache"
15:14:54 <moguimar> yes I did
15:14:59 <moguimar> me and hberaud
15:15:18 <moguimar> ah, the gating patch, I guess I didn't do that one
15:15:21 <hberaud> IIRC it was merged, isn't
15:15:23 <hberaud> ?
15:15:31 <moguimar> the precommit is merged
15:15:40 <hberaud> ack
15:15:41 <bnemec> Yeah, this was a followup to that.
15:15:52 <bnemec> Okay, will keep it on the list for next week then.
15:15:55 <bnemec> #action moguimar to propose patch integrating pre-commit to the gate for oslo.cache
15:15:56 <hberaud> ah okay, I missed the last meeting, so I got it
15:16:07 <moguimar> thanks ben
15:16:59 <bnemec> That's all of the action items.
15:17:05 <bnemec> #topic zuulv3 migration
15:17:14 <bnemec> I guess we already kind of covered this too.
15:18:21 <bnemec> Besides the messaging jobs that Ken is handling, we have a couple of grenade jobs that need to be migrated and the pbr jobs.
15:18:30 <bnemec> I think that should be all that's left.
15:18:58 <bnemec> I assume grenade will be relatively easy since there should be a common migration path for that one.
15:19:03 <bnemec> If someone wants to look into it, maybe sync with tosky.
15:19:36 <bnemec> The pbr jobs might be more interesting since I suspect they do some non-standard stuff.
15:19:55 <tosky> yep (grenade probably easy; others not sure)
15:19:59 <stephenfin> the pbr jobs suuuuck
15:20:05 <bnemec> They're testing installation with the proposed pbr patch, so they may not be able to rely on the normal zuul stuff.
15:20:33 <stephenfin> we would probably benefit from recreating them from scratch
15:20:33 * bnemec assigns stephenfin to do that migration ;-)
15:20:49 <bnemec> That's certainly an option.
15:21:17 <stephenfin> Probably a necessity. I can't solve https://review.opendev.org/#/c/719964/ :-\
15:22:16 <bnemec> Ah, delightful.
15:22:40 <bnemec> At least since they're blocking something we shouldn't forget to do this. :-)
15:23:20 <tosky> kgiusti had a question about devstack-plugin-zmq; if support was dropped long ago, shouldn't the repository be retired?
15:23:54 <bnemec> Yeah, I think that's the right thing to do for that repo.
15:24:00 <kgiusti> tosky: most certainly
15:24:06 <bnemec> I guess the only concern would be if we're still using it in an older stable branch.
15:24:17 <bnemec> I don't know that we ever branched the zmq plugin.
15:24:51 <kgiusti> bnemec: dunno - but I doubt whatever tests used it were ever voting
15:25:00 <bnemec> On the other hand, the zmq tests were always super flaky and we're pretty sure the driver didn't work right anyway, so if it turns out that we break a stable branch we can probably just remove the tests.
15:25:02 <kgiusti> bnemec: zmq never really got stable
15:25:11 <smcginnis> It seemed an effort that was kind of dead on arrival.
15:25:11 <bnemec> Yeah
15:25:39 <kgiusti> bnemec: so how does one go about retiring a repo?
15:25:52 <bnemec> There's an infra doc.
15:26:02 <kgiusti> bnemec: kk - I'm just being lazy
15:26:03 <stephenfin> https://docs.openstack.org/project-team-guide/repository.html
15:26:23 <kgiusti> bnemec: stephenfin: most excellent thanks - I have an Action Item for next week then.
15:26:45 <bnemec> Cool, thanks.
15:26:57 <bnemec> #action kgiusti to retire devstack-plugin-zmq
15:28:15 <bnemec> Still some open questions on this, but I think we've got enough planned for the next week at least.
15:28:29 <bnemec> Anything else to cover on the migration topic before we move on?
15:29:44 <bnemec> #topic Weekly Wayward Review
15:30:01 <bnemec> #link https://review.opendev.org/725317
15:30:10 <bnemec> Simple one. I believe the rest of these merged already, right?
15:30:48 <moguimar> done
15:32:22 <bnemec> Thanks!
15:32:53 <bnemec> #topic Open discussion
15:32:58 <hberaud> bnemec: we only have this one now => https://review.opendev.org/#/c/725327/
15:33:08 <hberaud> (similar patch)
15:33:43 <hberaud> but with some debats on it
15:33:55 <hberaud> s/debat/debates/
15:34:44 <bnemec> Did we ever make oslo-cookiecutter reflect the main cookiecutter change?
15:35:21 <bnemec> Since we merged all of the other copies of that patch I think we might as well go ahead with it.
15:35:26 <hberaud> lemme check
15:35:34 <bnemec> Zane makes a good point about keeping our stuff in sync though.
15:36:09 * bnemec had this on his todo list for a long time and never actually did it :-/
15:36:51 <hberaud> bnemec: we don't submit related patches against oslo-cookiecutter
15:37:14 <hberaud> s/submit/submitted/
15:38:01 <moguimar> I think we can go ahead with this one and maybe action item to update oslo-cookiecutter
15:38:03 <bnemec> Okay, so that's another thing we need to do before calling the contributor docs goal done.
15:38:10 <hberaud> yep
15:38:52 <hberaud> I'll try to submit the oslo-cookiecutter patch tomorrow
15:39:02 <bnemec> Great, thanks!
15:39:22 <bnemec> #action hberaud to sync oslo-cookiecutter contributing template with main cookiecutter one
15:40:18 <bnemec> Anything else to discuss this week?
15:40:22 <moguimar> yep
15:40:29 <moguimar> https://review.opendev.org/#/c/640057/
15:40:41 <moguimar> I was poking open patches in oslo.config and castellan
15:40:59 <moguimar> and updated the rst2txt patch to requirements
15:41:16 <moguimar> that one merged and then this patch from stephenfin got unblocked
15:41:34 <openstackgerrit> Merged openstack/oslo.limit master: Align contributing doc with oslo's policy  https://review.opendev.org/725317
15:41:35 <moguimar> but I'm not sure if I just created more work now that is not that big of a priority
15:41:44 <bnemec> I saw some discussion about this lsat week.
15:41:50 <bnemec> *last
15:43:34 <hberaud> also, I want to bring few words about eventlet, and especially about the stdlib SSL issue with monkey patched env, a fix have been merged on eventlet [1] so normally it will improve the situation, but I don't know it will be released (or if it is already) [1] https://github.com/eventlet/eventlet/commit/02fa826d22d0df7f9379c3a1e5cd2192e0ffadd8
15:43:44 <bnemec> It sounds like a good thing, but has the potential to break people if they have invalid rst?
15:44:31 <moguimar> I think stephenfin would be the best person to answer that
15:44:41 <bnemec> hberaud: So we probably want to bump our minimum eventlet to that when it releases? Or at least document that people need that version for sane ssl?
15:44:54 <hberaud> yep
15:45:31 <hberaud> I'll try to track possible advancments and keep us up-to-date about this topic
15:45:32 <stephenfin> bnemec: Sphinx has a context manager you can use when parsing potentially broken rST. We use it for the oslo.config
15:45:37 <stephenfin> ...Sphinx extension
15:46:14 <bnemec> I assume that would make this pretty safe to do?
15:47:14 <bnemec> If I'm understanding the question right, we're trying to decide whether cleaning up the doc output is worth the potential breakage for invalid rst.
15:47:30 <bnemec> If we can eliminate the latter then this seems like a win, right?
15:48:14 <stephenfin> Yup, it should be fine
15:48:41 <bnemec> Okay, cool.
15:48:44 <stephenfin> if is_valid_rst: parse else no_parse
15:48:56 <bnemec> moguimar: ^Does that answer your question?
15:50:06 <openstackgerrit> Rodolfo Alonso Hernandez proposed openstack/oslo.service master: Do not import "oslo.log" in the main module  https://review.opendev.org/741972
15:50:08 <moguimar> my main question is: should we keep this patch on or revert rst2txt from requirements
15:50:41 <moguimar> and abandon it
15:50:46 <bnemec> Seems like a good patch if we can get it working.
15:51:05 <moguimar> ack
15:51:09 <bnemec> It seems like most of the work is done, right?
15:51:26 <stephenfin> Yeah, I think it still makes sense. Just needs the final issues closed out
15:51:49 <moguimar> I guess since we put rst2txt as an extra, we revert the test cases to the original expected
15:51:59 <moguimar> and the patch should go back passing CI
15:52:21 <moguimar> I could do that
15:53:06 <bnemec> Sounds good.
15:53:59 <bnemec> #action moguimar to get https://review.opendev.org/#/c/640057/ in shape to merge
15:54:16 <moguimar> ack
15:54:20 <bnemec> Thanks for going through the patch backlog!
15:54:33 <bnemec> I haven't been doing that much lately.
15:55:02 <bnemec> We're down to about 5 minutes. Anything else before we end the meeting?
15:57:03 <bnemec> Okay, thanks for joining everyone!
15:57:05 <bnemec> #endmeeting