15:00:49 <bnemec> #startmeeting oslo
15:00:49 <bnemec> Courtesy ping for bnemec, smcginnis, moguimar, johnsom, stephenfin, bcafarel, kgiusti, jungleboyj
15:00:49 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:00:50 <openstack> Meeting started Mon Jul 27 15:00:49 2020 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:53 <openstack> The meeting name has been set to 'oslo'
15:00:55 <moguimar> o/
15:01:21 <smcginnis> o/
15:01:22 <johnsom> o/
15:01:36 <moguimar> bnemec, I'll have to leave sooner today, can I get some topics in after liasons?
15:02:54 <hberaud> o/ Sorry I should skip our meeting today, I'll take a look to the logs tomorrow
15:03:17 * hberaud eject
15:03:42 <bnemec> hberaud: Sounds good.
15:03:57 <bnemec> #topic Red flags for/from liaisons
15:04:12 <moguimar> Nothing from Barbican
15:04:41 <johnsom> Nothing from Octavia
15:05:26 <bnemec> moguimar: Yeah, we can do that.
15:05:36 <moguimar> after action items is fine
15:05:42 <moguimar> as some of them are there already
15:05:53 <bnemec> That's when the topics would normally be. :-)
15:06:21 <bnemec> #topic Releases
15:06:44 <bnemec> We released a new oslo.log last week that I think should fix the circular import issue Neutron ran into.
15:07:12 <bnemec> That's the main thing I know of that would be of interest.
15:07:18 <bnemec> #topic Action items from last meeting
15:07:38 <bnemec> "moguimar to propose patch integrating pre-commit to the gate for oslo.cache"
15:07:42 <moguimar> https://review.opendev.org/#/c/742441/
15:07:48 <moguimar> they are there waiting for reviews
15:07:59 <moguimar> the bandit patch merged already
15:08:27 <moguimar> the others in the same thread need review
15:09:27 <bnemec> Sounds good, thanks.
15:09:44 <moguimar> on the bandit side
15:09:45 <bcafarel> o/ sorry for lateness
15:09:53 <moguimar> there were new patches across oslo
15:09:56 <moguimar> https://review.opendev.org/#/q/(topic:bandit+OR+topic:bump-bandit)+(status:open+OR+status:merged)
15:09:56 <bcafarel> (and nothing on fire neutron side)
15:10:07 <moguimar> see the top patches since Jul 24
15:11:09 <bnemec> Looks like they're passing ci, so we just need someone to approve, right?
15:11:26 <moguimar> yep
15:13:18 <bnemec> bcafarel: Cool, thanks. See the note above about a new oslo.log release that might fix your circular import problem without needing changes on the Neutron side.
15:13:27 <bnemec> (I think that was Neutron...)
15:13:37 <bcafarel> ooh nice! yes that was us
15:14:17 <bnemec> While we have moguimar:
15:14:17 <bnemec> "moguimar to get https://review.opendev.org/#/c/640057/ in shape to merge"
15:14:30 <bnemec> Looks like there's been some movement, but still failing unit tests?
15:14:42 <moguimar> the same failure was seen in master
15:14:54 <moguimar> maybe just a recheck now?
15:15:10 <moguimar> I mean, I ran the tests on master and got the same issue
15:15:23 <bnemec> Ah, that was the stevedore thing. Yeah, looks like that should be fixed.
15:15:37 <moguimar> ok, just rechecked it
15:15:51 <bnemec> Okay, so that one should be done then. \o/
15:16:12 <bnemec> "kgiusti to retire devstack-plugin-zmq"
15:16:31 <bnemec> I see no Ken in the channel this week.
15:16:42 <bnemec> We'll keep that one on the list for next time.
15:16:43 <bnemec> #action kgiusti to retire devstack-plugin-zmq
15:16:50 <bnemec> "hberaud to sync oslo-cookiecutter contributing template with main cookiecutter one"
15:17:00 * bnemec looks at open patches to oslo-cookiecutter...
15:17:33 <bnemec> Nothing recent, so we'll keep that one too.
15:17:37 <bnemec> #action hberaud to sync oslo-cookiecutter contributing template with main cookiecutter one
15:17:56 <bnemec> We can get updates next time when hopefully the people involved are available.
15:18:41 <bnemec> That's it for action items.
15:18:50 <moguimar> I have one last topic
15:18:54 <bnemec> moguimar: Anything else you wanted to bring up before we move on to the rest of the agenda?
15:18:59 <moguimar> yup
15:19:02 <moguimar> https://review.opendev.org/#/c/742193/
15:19:05 <moguimar> this fix in oslo.cache
15:19:42 <moguimar> we would like to get some more eyes in that fix
15:19:51 <moguimar> before aproving it
15:21:00 <bnemec> Oh, memcache_pool. The gift that keeps on giving. ;-)
15:21:19 <kevko> :D
15:21:49 <moguimar> fix is yours, right kevko ?
15:22:04 <bnemec> I'm wondering if we need to add a set_defaults for the new opt so Keystone can have it on by default.
15:23:15 * bnemec wishes we still had Morgan around to discuss this too
15:23:47 <moguimar> bnemec, what happened to Morgan?
15:24:20 <bnemec> He moved to a different company, not working on OpenStack anymore.
15:24:41 <moguimar> I asked lbragstad to have a look on it too, but I think he didn't have time for it yet
15:24:59 <moguimar> ah, so we are probably short on both morgan and colleen
15:25:14 <bnemec> Yeah
15:25:22 <moguimar> I'm not sure how active she still is in OpenStack
15:25:43 <bnemec> Colleen is still around, but I don't know that she's likely to dig into something new like this.
15:27:21 <moguimar> I guess we'll have to go find some reviewers at #openstack-keystone
15:28:06 <moguimar> ok, I'm running short on time, gotta leave soon
15:28:26 <bnemec> Okay, I left a comment on the review with a suggestion.
15:28:29 <moguimar> I'll sync with kevko and hberaud tomorrow to decide
15:28:43 <moguimar> thanks guys, have a nice one o/
15:28:52 <bnemec> o/ moguimar
15:29:34 <bnemec> #topic  zuulv3 migration
15:29:40 <bnemec> #link https://etherpad.opendev.org/p/goal-victoria-native-zuulv3-migration
15:29:45 <openstackgerrit> Michal Arbet proposed openstack/oslo.cache master: Do not hardcode flush_on_reconnect, move to oslo.cache config  https://review.opendev.org/742193
15:29:50 <kevko> moguimar: yes, it is mine
15:30:26 <bnemec> oslo.messaging and the kafka devstack plugin are done.
15:30:39 <bnemec> amqp1 devstack needs another reviewer.
15:30:52 <bnemec> zmq will be handled by retiring the repo.
15:31:28 <bnemec> So that leaves us with basically a couple of grenade jobs and the pbr jobs.
15:32:05 <bnemec> I think stephenfin was going to look at the latter.
15:32:17 <bnemec> If you have a change up, can you link it on https://etherpad.opendev.org/p/goal-victoria-native-zuulv3-migration ?
15:32:35 <stephenfin> pbr is on my list, yes. I'm hoping to get to it tomorrow
15:32:43 <stephenfin> not sure about grenade though
15:32:49 <bnemec> And grenade is still on the todo list, although hopefully it will be pretty straightforward.
15:33:11 <bnemec> I think for that one we just need to look what other projects have done to migrate their grenade jobs.
15:33:54 <bnemec> pbr should be the only tricky part of this for us now.
15:33:57 * bnemec knocks on wood
15:35:13 <bnemec> I think we're making good progress on this, so I'm not too concerned about it at this point.
15:35:24 <bnemec> I'll leave it on the agenda so we can sync each week.
15:35:53 <bnemec> #topic bnemec on PTO next week
15:36:03 <bnemec> So I won't be around to run the meeting.
15:36:38 <bnemec> As always, if someone else wants to do it, feel free.
15:37:02 <bnemec> Otherwise I'll be back the following Monday and we can resume then.
15:37:26 <lbragstad> moguimar bnemec catching up - i cracked that patch open last week, but i'm taking another look now
15:38:31 <bnemec> lbragstad: Thanks!
15:39:10 <bnemec> #topic Weekly Wayward Review
15:39:10 <bnemec> I just approved https://review.opendev.org/727530 which was a pretty trivial patch that's apparently been open a long time.
15:39:27 <bnemec> If anyone is looking for stuff to review see moguimar's requests above.
15:40:58 <bnemec> #topic Open discussion
15:41:03 <bnemec> Anything else this week?
15:41:34 <openstackgerrit> Ben Nemec proposed openstack/sphinx-feature-classification master: Cleanup misplaced release note  https://review.opendev.org/741036
15:43:06 <smcginnis> bnemec: The one characters bothered you that much, huh? :)
15:43:36 <bnemec> smcginnis: I just used the Gerrit editor. Took all of five seconds to change. :-)
15:43:58 <smcginnis> Yep, might as well.
15:44:02 <bnemec> And also yes. :-P
15:44:39 * bnemec was the sixth grade spelling bee champ of Fennimore Elementary :-D
15:44:46 <smcginnis> Hah!
15:46:01 <bnemec> Okay, let's call it before I start ranting about the Oxford comma or something. ;-)
15:46:12 <bnemec> Thanks for joining, everyone!
15:46:15 <bnemec> #endmeeting