15:02:46 <bnemec> #startmeeting oslo
15:02:46 <bnemec> Courtesy ping for bnemec, smcginnis, moguimar, johnsom, stephenfin, bcafarel, kgiusti, jungleboyj
15:02:46 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:02:47 <openstack> Meeting started Mon Aug 17 15:02:46 2020 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:51 <openstack> The meeting name has been set to 'oslo'
15:02:52 <bnemec> I hate Mondays. :-P
15:03:28 <hberaud> o/ (here with a really unustable internet conection which back and worth)
15:03:34 <johnsom> o/
15:04:42 <moguimar> o/
15:04:55 <kgiusti> o/
15:06:02 <bnemec> #topic Red flags for/from liaisons
15:06:10 <moguimar> none from Barbican
15:06:11 <smcginnis> o/
15:06:39 <johnsom> Nothing to report from Octavia today
15:06:55 <moguimar> I have a hard stop at half past the hour, so this is going to be a quick meeting (at least on my side)
15:07:11 <bnemec> Last week was pretty quiet, so not much to report from our side either.
15:07:18 <bnemec> moguimar: Sounds good
15:07:51 <bnemec> #topic Releases
15:08:01 <bnemec> I think I said I was going to do these last week and then didn't. :-/
15:08:23 <bnemec> Which may have contributed to the quiet week since nothing new got released. ;-)
15:09:31 <bnemec> So we'll need to get that done this week. Nothing much else to say on this topic.
15:09:35 <bnemec> #topic Action items from last meeting
15:10:08 <bnemec> "bnemec to reply to rpc ping thread with results of meeting discussion"
15:10:10 <bnemec> Done
15:10:40 <bnemec> And it spawned a bunch of good discussion, so that was a good action. :-)
15:10:59 <bnemec> #topic  zuulv3 migration
15:11:09 <bnemec> I saw a patch merged earlier.
15:11:45 <bnemec> Looks like we just have zmq, which we don't care about and are retiring, and pbr left on the list.
15:11:50 <bnemec> #link https://etherpad.opendev.org/p/goal-victoria-native-zuulv3-migration
15:12:00 <tosky> pbr is mostly done
15:12:26 <tosky> the new jobs have been merged, there is just one patch (now running again) to remove the legacy jobs (now unused)
15:12:44 <bnemec> So basically we've just got https://review.opendev.org/#/c/745192/ for the migration to be complete?
15:13:15 <tosky> correct - and the retirement of the zmq repo for real
15:13:34 <tosky> bonus point for the patches being backported, but that's not just part of the stretch goal
15:13:49 <bnemec> Yeah, but at least in that case if something breaks with the legacy job, nobody cares. :-)
15:13:55 <tosky> summary: oslo is in a good shape
15:14:14 <bnemec> Cool, thanks tosky and everyone else who has helped out with this!
15:15:52 <bnemec> #topic oslo.messaging ping endpoint
15:16:43 <hberaud> is this discussion is related to the ping endpoint?
15:16:51 <bnemec> As I mentioned, there was quite a bit more discussion on this on the list last week.
15:17:19 <kgiusti> Yep - an internal ping endpoint provided by the library itself for every RPC server instance
15:17:37 <bnemec> Because of the way the Nova service healthchecking works, I'm more inclined to go ahead with this change after getting some more details about the use cases involved.
15:18:03 <hberaud> ack
15:18:20 <bnemec> Essentially Nova is only checking communication in one direction. This would allow operators to check both sides of the bus.
15:18:47 <kgiusti> Hrmm... I got the sense that the nova folks were not all that thrilled about introducing this traffic on the message bus.
15:19:04 <bnemec> As I said on the list, I'd still eventually like us to have proper healthchecks for all services so that we don't need external stuff like this, but since there's been little movement on that front this is a decent stopgap.
15:19:35 <bnemec> kgiusti: True, but as I noted there's no way to keep operators off the rabbit bus if they want to be there.
15:19:49 <bnemec> I'd rather give them a well-defined, consistent endpoint than have them each implementing their own version of it.
15:20:11 <bnemec> According to ttx, OVH is already doing this successfully.
15:21:03 <kgiusti> bnemec: I'd like to at least reserve the ping target address - using "ping" as the RPC method will break existing projects.
15:21:05 <bnemec> I mean, we can play whack-a-mole with all of the potential healthcheck gaps in services, like the one we discovered in Nova as part of this discussion.
15:21:29 <bnemec> But that's a long and frustrating path to go down.
15:21:37 <bnemec> kgiusti: That's fair.
15:22:06 <bnemec> I think it's reasonable to start talking about the best way to implement this, as opposed to whether to implement it at all.
15:22:15 <kgiusti> bnemec: +1
15:22:27 <kgiusti> bnemec: as the patch stands now I'm pretty sure it will break stuff
15:22:39 <bnemec> The weird thing is it passed tempest.
15:22:50 <bnemec> But like I said, maybe it just broke something tempest doesn't cover.
15:23:31 <kgiusti> bnemec: possibly - I'm just repeating Nova's claim that they use "ping" address internally
15:24:04 <bnemec> Yeah, I don't know much about that. We'll need to work with them to make sure we don't overlap here.
15:24:05 <kgiusti> bnemec: I'd also like to have a ping client added to the oslo.messaging package at some point
15:24:25 <bnemec> That seems reasonable.
15:24:51 <bnemec> If oslo.messaging provided the client for doing the pings then it would mitigate a lot of the danger of having ops sending messages on the rabbit bus.
15:25:13 <kgiusti> bnemec: yeah, worth a follow up patch.
15:25:24 <bnemec> Both ends of the transaction would still be under our control.
15:25:38 <bnemec> Okay, I like that.
15:25:46 <kgiusti> bnemec: but I'm going to review the patch again and -1 until we address the "ping" concern.
15:25:54 <kgiusti> my action for this week :)
15:26:02 <bnemec> Sounds good!
15:26:14 <bnemec> #action kgiusti to review the ping endpoint patch again
15:26:25 <bnemec> Do you also want to raise the suggestion about adding a client?
15:26:44 <bnemec> Maybe on the list so it's clear that we aren't blocking the current patch on that?
15:27:25 <kgiusti> bnemec: sure will do
15:27:42 <bnemec> Great, thanks!
15:28:37 <bnemec> Okay, we have one more topic, but moguimar is coming up on time I believe. Is there anything you wanted to cover before you go?
15:29:05 <moguimar> yup
15:29:08 <moguimar> just a review
15:29:14 <moguimar> https://review.opendev.org/#/c/746130/
15:29:31 <moguimar> this is a first patch and I'll reenable memcached functional tests in the next one
15:29:42 <moguimar> just need some more pushing
15:29:51 <openstackgerrit> Clark Boylan proposed openstack/pbr master: Increase integration test timeout  https://review.opendev.org/746547
15:30:08 <bnemec> That looks pretty easy.
15:30:42 <bnemec> Approved.
15:31:01 <bnemec> I saw the discussion about that last week and I agree with the reasoning to not force a Python version.
15:31:30 <bnemec> Thanks for doing that!
15:31:41 <moguimar> thanks
15:31:53 <bnemec> #topic enable oslo.messaging heartbeat fix by default?
15:31:56 <moguimar> see ya
15:32:03 <bnemec> We tabled this one last week to wait for hberaud's input.
15:33:05 <bnemec> This is about the messaging heartbeat fix using native threads that we put behind an option to let affected users try it out without causing issues for everyone.
15:33:28 <bnemec> It's been in for a while now and I haven't heard any complaints, so I think it may be time to try turning it on by default.
15:33:33 <hberaud> AFAIK we don't got bad feedback since these changes have been introduced so +1
15:34:21 <bnemec> Okay, I think that was the consensus last week as well.
15:34:36 <hberaud> I'll submit a patch
15:34:43 <bnemec> Initially I think we want to just flip the default for the option and deprecate the opt.
15:34:55 <hberaud> ack
15:34:58 <bnemec> That way if it does break someone they can turn it off again.
15:35:08 <bnemec> Then in a cycle or two we can remove the option completely.
15:35:17 <hberaud> make sense
15:35:48 <bnemec> #action hberaud to send patch to enable heartbeat fix by default
15:35:57 <hberaud> I'll put a debtcollector warn too to higlight the future removal
15:36:21 <bnemec> hberaud: There's functionality in oslo.config to mark an opt as deprecated for removal.
15:36:38 <hberaud> ah yes right
15:37:21 <bnemec> I guess we'll need a release note and everything too.
15:37:37 <hberaud> yep
15:39:27 <bnemec> #topic Weekly Wayward Review
15:39:27 <bnemec> #link https://review.opendev.org/#/c/671309
15:39:39 <bnemec> I just WIP'd that because it's actually in merge conflict.
15:40:10 <bnemec> That's not a super useful action though. Let's see if we can find a patch that we can make progress on.
15:40:53 <bnemec> I think we're waiting for extra testing on https://review.opendev.org/#/c/695527/
15:40:53 <hberaud> bnemec: I'll try to spend time on it tomorrow
15:41:30 <bnemec> Okay, there we go: https://review.opendev.org/#/c/734488
15:41:34 <bnemec> Approved. :-)
15:41:48 <hberaud> thanks
15:42:27 <bnemec> hberaud: There is a comment on https://review.opendev.org/#/c/734453/ that would be nice to address before merging that.
15:42:32 <tosky> we mentioned https://review.opendev.org/#/c/745192/ before; it failed, but there is a potential fix: https://review.opendev.org/746547
15:43:39 <bnemec> tosky: Approved
15:43:55 <openstackgerrit> Hervé Beraud proposed openstack/openstack-doc-tools master: Use unittest.mock instead of mock  https://review.opendev.org/734453
15:44:04 <hberaud> bnemec: ^^
15:44:20 <bnemec> Okay, we've cleaned up some old patches, so that should do it for this section.
15:44:24 <bnemec> #topic Open discussion
15:44:27 <bnemec> hberaud: Thanks!
15:45:16 <bnemec> And that one's approved too now. :-)
15:45:25 <bnemec> Merge all the things!
15:45:27 <hberaud> bnemec: thanks
15:45:31 <hberaud> :)
15:45:54 <bnemec> Okay, was there anything else before we call it this week?
15:45:59 <hberaud> I just came back from PTO so nope... nothing on my side
15:48:28 <bnemec> Sounds like we're good then.
15:48:36 <bnemec> Thanks for joining everyone!
15:48:39 <bnemec> #endmeeting