15:00:37 <bnemec> #startmeeting oslo
15:00:37 <bnemec> Courtesy ping for bnemec, smcginnis, moguimar, johnsom, stephenfin, bcafarel, kgiusti, jungleboyj
15:00:37 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:00:37 <openstack> Meeting started Mon Aug 31 15:00:37 2020 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:40 <openstack> The meeting name has been set to 'oslo'
15:00:47 <moguimar> o/
15:00:52 <bcafarel> o/
15:00:55 <johnsom> o/
15:01:34 <kgiusti> o/
15:02:16 <jungleboyj> o/  I am on vacation so not really here.
15:02:48 <bnemec> jungleboyj: What are you doing on IRC on vacation? :-P
15:04:00 <jungleboyj> Well, I had forgotten to let people know I was gone.  So, popped on to send messages.
15:04:38 <bnemec> Fair enough. :-)
15:05:02 <hberaud> o/
15:05:40 <bnemec> #topic Red flags for/from liaisons
15:05:57 <jungleboyj> Your ping reminded me.  :-)  So, I have nothing exciting to report other than that.  Now I am returning to my irregularly scheduled vacation.
15:06:21 <johnsom> Nothing to report from Octavia team
15:06:33 <bnemec> I just got a telemarketer call. Big red flag for me.
15:07:13 <moguimar> Nothing from Barbican
15:07:28 <bnemec> Otherwise I saw gmann was working on the policy JSON to YAML migration last week, so that's something to keep an eye out for.
15:09:03 <bnemec> #topic Releases
15:09:21 <bnemec> hberaud has pretty much taken over doing these. Anything noteworthy this week?
15:10:07 <hberaud> as far as I know nope
15:10:19 <bnemec> Cool.
15:10:33 <hberaud> I think we can release PBR
15:10:44 <bnemec> I guess it's noteworthy that this week will be the final feature releases, with the exception of future FFEs.
15:10:51 <bnemec> We'll talk about that some more later.
15:10:52 <hberaud> I seen many patches merged during the last weeks
15:11:06 <bnemec> That would be good.
15:11:56 <bnemec> We had no action items from last week, so we'll skip that topic.
15:12:07 <bnemec> #topic zuulv3 migration
15:12:15 <bnemec> #link https://etherpad.opendev.org/p/goal-victoria-native-zuulv3-migration
15:12:30 <bnemec> The only thing we had left was the zmq repo, and I saw kgiusti posted patches to retire that.
15:12:43 <kgiusti> bnemec: and pika!
15:12:58 <kgiusti> thanks for the reviews btw
15:13:20 <bnemec> Let me know if there's anything else I need to rubber stamp. :-)
15:13:20 <kgiusti> hberaud: :)
15:13:28 * bnemec gets out his ink pad
15:13:49 <hberaud> :)
15:15:29 <bnemec> #topic Feature Freeze
15:15:39 <bnemec> Oslo feature freeze has started.
15:15:52 <bnemec> Please don't merge anything that will require a feature release without first requesting an FFE.
15:16:23 <bnemec> I should send a followup email to the list as a reminder too.
15:16:30 <bnemec> #action bnemec send feature freeze email
15:17:02 <bnemec> I think we've all been through enough feature freezes at this point that we know the drill.
15:17:10 <bnemec> If you have any questions feel free to ping me though.
15:18:07 <bnemec> #topic Weekly Wayward Review
15:18:20 <bnemec> #link https://review.opendev.org/733881
15:18:43 <bnemec> Which is mine, and I see I need to add a release note for it.
15:19:31 <hberaud> bnemec: Please can you review this one when you will have some spare time => https://review.opendev.org/#/c/746723/
15:20:17 <hberaud> also if some of you can take a look to this backport => https://review.opendev.org/#/c/747907/ I would appreciate get some feedbacks
15:20:24 <bnemec> Yeah, sorry. That's somewhere in my review backlog.
15:20:35 <hberaud> np
15:21:02 <bnemec> The requirements change on that one is going to be problematic on a stable branch.
15:21:05 <hberaud> and to finish please take a look to this backport too => https://review.opendev.org/#/c/747892/ (especially kgiusti)
15:21:27 <hberaud> bnemec: yep I wondering if we need them
15:22:18 <hberaud> bnemec: this fix is something useful but I'm not fan to bump requirements here
15:22:56 <bnemec> hberaud: Has it been reported against train? I think Neutron ran into it as part of their migration, which means it only affects releases going forward.
15:23:06 <hberaud> bnemec: maybe we can backport and leave the bump behind the door, thoughts?
15:23:17 <bnemec> If consumers of privsep were not affected by it in train, I would leave it alone.
15:23:56 <bnemec> I guess the same goes for ussuri.
15:24:06 <hberaud> bnemec: downstream someone reported a bug on OSP16 IIRC
15:24:25 <hberaud> (related to this)
15:24:28 <bnemec> Okay, that's good to know.
15:24:54 <bnemec> Was the requirements change needed for the fix?
15:25:36 <hberaud> hm I wondering if we need them to get the "if monkey_patched"
15:26:05 <bnemec> I'm not sure.
15:26:11 <bnemec> Can you follow up with Rodolfo?
15:26:17 <hberaud> At first glance I don't think requirements are needed
15:26:27 <hberaud> bnemec: ack I'll ping him
15:28:31 <gmann> bnemec: missed the release topic.
15:28:42 <gmann> when you are planning to release oslo.policy and utils ? work needed for JSON to YAML in these lib are merged. Once they are released I will update my Nova patch.
15:29:06 <bnemec> gmann: Yes, we'll release those this week.
15:29:16 <gmann> ok, thanks
15:29:27 <bnemec> We typically release everything in Oslo with changes every week.
15:29:34 <gmann> +1
15:29:35 <hberaud> gmann: I planned to propose releases tomorrow
15:29:50 <gmann> hberaud: cool thanks.
15:30:58 <bnemec> #topic Open discussion
15:31:10 <bnemec> We're kind of already there, but any other topics not on the agenda?
15:31:15 <hberaud> nothing from my side
15:34:21 <bnemec> Okay, everyone enjoy your 26 minutes back then. Thanks for joining!
15:34:24 <bnemec> #endmeeting