15:00:49 <bnemec> #startmeeting oslo
15:00:49 <bnemec> Courtesy ping for bnemec, smcginnis, moguimar, johnsom, stephenfin, bcafarel, kgiusti, jungleboyj
15:00:49 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:00:50 <openstack> Meeting started Mon Sep 14 15:00:49 2020 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:54 <openstack> The meeting name has been set to 'oslo'
15:01:01 <hberaud> o/
15:01:03 <johnsom> o/
15:01:17 <bnemec> Sorry about last week. I forgot to send an email about the US holiday.
15:01:25 <moguimar> o/
15:01:31 <kgiusti> o/
15:02:04 <stephenfin> o/
15:02:57 <jungleboyj> o/
15:03:21 <openstackgerrit> Merged openstack/oslo.config master: Update master for stable/victoria  https://review.opendev.org/751454
15:03:29 <bnemec> #topic Red flags for/from liaisons
15:03:50 <johnsom> Nothing on the Octavia side
15:04:11 <jungleboyj> Nothing from Cinder.
15:05:00 <moguimar> Nothing from Barbican
15:06:21 <bnemec> Hopefully things will be pretty quiet from here out since we're well past library freeze.
15:06:28 <bnemec> #topic Releases
15:06:47 <bnemec> Speaking of which, the (hopefully) final releases for all the Oslo libs went out last week.
15:07:19 <bnemec> I see everything got branched, so if we find any more release blockers in Victoria they'll need to be backported.
15:08:22 <bnemec> So we'll pause releases for a while here until Victoria ships.
15:08:35 <moguimar> one question
15:08:41 <bnemec> Except stable branches. If any releases are needed there we can still do them.
15:09:03 <moguimar> if we're branched already, and new stuff needs to be backported to that branch, how does that interacts with feature freeze?
15:10:38 <bnemec> Same as before branching. Post feature freeze, any new feature changes would need an FFE. It would also need to be backported now.
15:11:04 <bnemec> Bugfixes are fair game, but we might need to clear the releases with the requirements team too now.
15:11:36 <openstackgerrit> Merged openstack/pycadf stable/victoria: Update TOX_CONSTRAINTS_FILE for stable/victoria  https://review.opendev.org/750340
15:11:57 <bnemec> moguimar: Did you have something specific in mind?
15:12:12 <moguimar> not really
15:12:38 <moguimar> just wondering if things could go to master and the FFE be necessary for backports only
15:13:20 <moguimar> that could be a topic for the PTG maybe, I don't know how deeply this has been discussed already
15:13:29 <bnemec> They can, although I try to discourage merging anything major between FF and release, just in case we have an emergency backport that needs to be done.
15:13:42 <bnemec> If some big feature merged, it can make backporting a bugfix harder.
15:13:50 <moguimar> I see
15:14:03 <moguimar> that makes a very good point
15:14:07 <moguimar> thanks Ben
15:14:23 <bnemec> np
15:14:38 <bnemec> #topic Action items from last meeting
15:14:53 <bnemec> "bnemec send feature freeze email"
15:15:09 <bnemec> I believe I did that.
15:15:36 <bnemec> Although since we ended up releasing most stuff again anyway, I guess it didn't mean much. :-)
15:16:17 <bnemec> That was all the action items.
15:16:20 <bnemec> #topic Focal migration
15:16:35 <bnemec> gmann: Since we merged all of these and got them released, was there anything else needed here?
15:18:37 <bnemec> I'm going to say we're done with this one, but we can come back to it if necessary.
15:18:46 <bnemec> #topic zuulv3 migration
15:19:13 <bnemec> Last I saw, I think we were just waiting on reviews of kgiusti's repo retirement patches.
15:19:31 <tosky> the legacy job has been deleted
15:19:38 <tosky> so from the goal's point of view you should be fine
15:19:49 <bnemec> \o/
15:19:55 <kgiusti> huzzah!
15:20:06 <bnemec> #success Oslo has fully migrated to zuulv3!
15:20:08 <openstackstatus> bnemec: Added success to Success page (https://wiki.openstack.org/wiki/Successes)
15:20:10 <tosky> you can still backport some of the patches to the older branches, it should improve the future maintenability
15:20:58 <tosky> I think I proposed some of them, but yeah, feel free to continue, the backports should work at least in train and, apart from grenade, stein
15:21:08 <tosky> thanks for the help!
15:21:14 <bnemec> Good to know, thanks!
15:21:28 <bnemec> And thanks to tosky for coordinating!
15:21:36 <kgiusti> +1 tosky!
15:22:31 * tosky bows
15:23:32 <bnemec> #topic PTG/Forum Planning
15:23:38 <bnemec> #link https://etherpad.opendev.org/p/oslo-wallaby-topics
15:24:05 <bnemec> I've created the etherpad for the PTG. Pretty much the same thing we've used for the past few.
15:24:21 <bnemec> If you have anything you'd like to discuss, please get it added to the list.
15:24:59 <bnemec> Although I've already requested a couple of hours for us, so unless we have a huge number of topics come up I think we'll be covered.
15:25:31 <bnemec> I should send an email out with that too.
15:25:39 <bnemec> #action bnemec send ptg planning email
15:26:33 <bnemec> That's it for topics.
15:26:35 <bnemec> #topic Weekly Wayward Review
15:27:32 <bnemec> #link https://review.opendev.org/#/c/719876/
15:27:52 <bnemec> Looks like this was unblocked by the focal work. We probably need to merge it and then backport.
15:29:01 <bnemec> Okay, step one is done.
15:29:05 <smcginnis> That one should probably be backport to stable/victoria. We have wallaby tests now in master.
15:29:08 <bnemec> #action backport https://review.opendev.org/#/c/719876/
15:29:55 <smcginnis> Er, correction, we will need wallaby tests in master. Looks like that repo didn't get update since it was missing the expected victoria template.
15:30:09 <smcginnis> So we'll need to update master too.
15:30:11 <bnemec> Ah, yeah.
15:30:44 <bnemec> #action Switch oslo.utils to wallaby test template
15:31:04 <gmann> bnemec: that is all for Victoria, thanks again.
15:31:06 <bnemec> Once the patch above merges we can go ahead with that.
15:32:04 <bnemec> gmann: +1. Sorry about the delay getting this goal taken care of.
15:32:32 <bnemec> It's especially bad because I made the same mistake two cycles in a row. :-(
15:32:51 <bnemec> #topic Open discussion
15:33:04 <bnemec> That's all the regular topics. Anything else this week?
15:33:08 <moguimar> I proposed lbragstad a couple of weeks ago for oslo.cache core
15:33:15 <moguimar> any updates here?
15:36:22 <bnemec> Oh, no, we can go ahead and add him. One second.
15:36:38 <stephenfin> I have another one: does https://review.opendev.org/#/c/751031/ qualify as a backport?
15:36:45 <openstackgerrit> Merged openstack/oslo.middleware master: Add Python3 wallaby unit tests  https://review.opendev.org/751484
15:37:32 <stephenfin> On one hand, it's obviously broken at the moment. On the other, it's technically a feature patch since the "feature" didn't work without this change
15:37:45 <stephenfin> *feature-enabling patch
15:38:22 <bnemec> This is needed to enable parallel docs builds in other projects, right?
15:39:18 <stephenfin> yep
15:39:44 <bnemec> I'm okay with backporting it. We've accepted backports of things that are technically features that fix bugs before.
15:40:12 <stephenfin> sweet
15:40:16 <bnemec> And it's just in the sphinxext, so it's not like we're going to break someone's production deployment even if something is catastrophically wrong.
15:40:57 <bnemec> Unless smcginnis objects, of course. :-)
15:41:19 * stephenfin worries about those multi-million dollar business build on our fantastic sphinx extensions
15:41:20 <stephenfin> :)
15:42:01 <openstackgerrit> Merged openstack/oslo.serialization master: Add Python3 wallaby unit tests  https://review.opendev.org/751504
15:42:22 <bnemec> I would love to see how that business model works. :-)
15:42:51 <stephenfin> If Uber can do it...
15:43:16 <smcginnis> bnemec: Seems like a low risk backport.
15:44:09 <bnemec> True. It seems making money is optional in the tech industry. Just as long as you can keep that VC gravy train running.
15:44:23 <bnemec> smcginnis: That was my thought as well.
15:45:29 <bnemec> Sounds like we're all in agreement on this.
15:45:36 <bnemec> Anything else before I end the meeting?
15:46:17 <stephenfin> not from me
15:46:27 <hberaud> nope
15:46:59 <openstackgerrit> Merged openstack/oslo.reports master: Add Python3 wallaby unit tests  https://review.opendev.org/751496
15:47:08 <openstackgerrit> Merged openstack/oslo.db master: Add Python3 wallaby unit tests  https://review.opendev.org/751463
15:48:45 <bnemec> Okay, thanks for joining everyone!
15:48:48 <bnemec> #endmeeting