15:00:24 <bnemec> #startmeeting oslo
15:00:24 <bnemec> Courtesy ping for bnemec, smcginnis, moguimar, johnsom, stephenfin, bcafarel, kgiusti, jungleboyj
15:00:24 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:00:25 <openstack> Meeting started Mon Sep 28 15:00:24 2020 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:29 <openstack> The meeting name has been set to 'oslo'
15:00:34 <johnsom> o/
15:00:36 <smcginnis> o/
15:00:56 <bcafarel> o/
15:01:18 <kgiusti> o/
15:01:18 <hberaud> o/
15:03:15 <bnemec> #topic Red flags for/from liaisons
15:05:04 <bnemec> It's quiet. Too quiet. :-)
15:05:44 <bnemec> I don't expect a whole lot of activity on this right now though. We're well into Oslo FF so things should be pretty stable.
15:05:44 <hberaud> :)
15:06:06 <bnemec> #topic Releases
15:06:17 <bnemec> Nothing much going on here either.
15:06:30 <johnsom> Nothing from Octavia
15:06:50 <bcafarel> neutron we are busy trying to get rc-1 out, but nothing on oslo side
15:06:59 <bnemec> Barring bugs, we won't release master until Victoria ships.
15:07:13 <jungleboyj> o/
15:07:24 <bnemec> Even if Wallaby opens up, we don't want to do a release yet just in case there would be a last-minute issue that requires a feature release.
15:07:27 <jungleboyj> No red flags by the way.  :-)
15:07:40 <bnemec> \o/
15:08:01 <jungleboyj> :-)
15:08:06 <smcginnis> Getting close to the end of Victoria!
15:08:28 <bnemec> Also \o/ :-)
15:08:46 <jungleboyj> No!  I like Victoria.  Don't end her.  ;-)
15:08:51 <smcginnis> :)
15:09:00 <hberaud> :)
15:09:08 <jungleboyj> *bah dum ... chhisshhh*
15:09:22 <hberaud> *applause*
15:09:23 * bnemec was definitely not considering making that same joke...
15:09:48 <jungleboyj> Thank you, thank you.  I will be here all week.  Tip your wait staff.
15:11:00 <bnemec> #topic Action items from last meeting
15:11:09 <bnemec> "merge pre-commit patches"
15:11:28 <bnemec> How did we do on this one? I feel like I saw some stuff go in.
15:12:34 <hberaud> bnemec: I just have 2-3 patches to check/recheck but the majority is now ok
15:12:58 <hberaud> bnemec: I don't know if it is your question
15:13:08 <bnemec> Cool, sounds like we're in good shape then.
15:13:15 <hberaud> yep
15:13:28 <bnemec> That was the only action item.
15:13:38 <bnemec> #topic PTG/Forum Planning
15:13:39 <hberaud> bnemec: By saying Ok I mean they can be merged
15:13:48 <bnemec> #link https://etherpad.opendev.org/p/oslo-wallaby-topics
15:13:49 <hberaud> bnemec: they are not merge
15:13:51 <hberaud> merged
15:14:14 <bnemec> hberaud: Yeah, but if they're blocked by ci then there isn't much to do other than recheck.
15:14:22 <bnemec> Unless something's actually broken, I guess.
15:14:43 <hberaud> bnemec: some are not blocked https://review.opendev.org/#/q/status:open+branch:master+topic:oslo-pre-commit
15:15:23 <bnemec> Ah, so we still have merging to do.
15:15:51 <hberaud> yep
15:17:12 <bnemec> I guess Forum planning is over since I believe the schedule was published.
15:17:33 <bnemec> Still room for PTG discussions. Currently the only topic is still the retrospective.
15:17:45 <bnemec> So this might be a quick PTG if nothing else comes up. :-)
15:18:18 <bnemec> Maybe we can just do a review day and get all of the pre-commit patches in. ;-)
15:18:26 <hberaud> :)
15:19:06 <bnemec> If there's nothing urgent that needs to be addressed I guess that's a good thing too.
15:19:53 <bnemec> #topic PTL election season
15:20:12 <bnemec> Gentle reminder that we still need a PTL for next cycle.
15:20:28 <bnemec> Nominations close soon, so don't wait if you're interested.
15:21:10 <smcginnis> One day left.
15:22:18 <bnemec> If you have any questions about it, feel free to ping me.
15:25:49 <bnemec> #topic Weekly Wayward Review
15:25:49 <bnemec> #link https://review.opendev.org/733881
15:26:22 <bnemec> Picking that one since it's in oslo.limit and not affected by feature freeze since it's not used yet. Also, that was blocking other work on oslo.limit.
15:26:31 <smcginnis> Oooh, now we can call it the Weekly Wayward Wallaby Review.
15:26:56 <jungleboyj> :-)
15:27:08 <bnemec> BRB updating the wiki...
15:30:01 <bnemec> Anyway, take a look at that if you get a chance. I think everyone was onboard with it, just waiting for me to write a release note.
15:30:08 <bnemec> #topic Open discussion
15:30:16 <bnemec> Anything else this week?
15:30:29 <hberaud> nothing on my side
15:30:50 <sboyron_> Hi, I've got something
15:30:53 <sboyron_> I noticed something about using pbr and setuptools. Almost all projects directly import pbr or setuptools, but most depend on pbr only (requirements.txt). Setuptools is only there because its dependency on pdr. I think it might be a good idea to be more explicit and require setuptools as well.
15:31:27 <hberaud> Ah right
15:32:06 <hberaud> we faced some minor concern on rpm-packaging
15:32:11 <hberaud> related to this
15:32:22 <bnemec> That seems reasonable if projects are directly importing setuptools.
15:32:36 <hberaud> where some package rely on setuptools and not other
15:32:54 <hberaud> it could be worth to uniformize this part
15:33:01 <hberaud> to avoid misleading
15:33:12 <hberaud> explicit is better than implicit
15:33:28 <bnemec> We should probably raise this with the requirements team as well, just to make sure they're onboard.
15:33:40 <hberaud> and it could be worth for downstream packagers
15:33:44 <sboyron_> ok
15:33:46 <bnemec> Especially if we're going to patch bomb a lot of projects. :-)
15:33:57 <hberaud> agreed
15:34:04 <sboyron_> ack
15:34:08 <hberaud> sboyron_: do you want to lead that?
15:34:10 <bnemec> sboyron_: Can you send something to the list tagged [requirements][oslo]?
15:34:24 <hberaud> +1
15:34:26 <sboyron_> bnemec, yes
15:34:30 <sboyron_> hberaud, yes
15:34:36 <smcginnis> From a requirements perspective, that's fine. Though setuptools is such a common python thing, it does seem like a lot of patches and churn for little gain.
15:34:36 <dtantsur> lemme re-try my question now that I've caught you on a meeting :) I'm pondering adding group API for MySQL to tooz, any opinions?
15:34:56 <bnemec> #action sboyron_ to send email about setuptools requirement
15:35:37 <bnemec> dtantsur: There's already a mysql driver, right? So you'd just be adding group support to it?
15:35:42 <dtantsur> yep
15:36:00 <dtantsur> it may look a bit ugly since there are no (?) ready-to-use primitives
15:36:11 <dtantsur> but we have been doing it in ironic for many years nonetheless :)
15:37:00 <bnemec> Seems fine to me. I have to think there are other people who would like to use distributed locks without a separate DLM.
15:37:32 <bnemec> I mean besides MySQL, which everyone is already deploying anyway.
15:37:52 <dtantsur> okay, thanks! I'm not sure I'll *actually* get to implementing it, to be clear.
15:38:59 <bnemec> Unacceptable. :-P
15:39:52 <bnemec> Side note: Apparently over the weekend I got dropped off IRC completely, so if I missed anything you'll have to let me know.
15:40:53 <bnemec> Okay, anything else before we close?
15:43:22 <bnemec> Thanks for joining!
15:43:22 <bnemec> #endmeeting