15:00:01 <hberaud> #startmeeting oslo
15:00:02 <openstack> Meeting started Mon Oct 19 15:00:01 2020 UTC and is due to finish in 60 minutes.  The chair is hberaud. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:06 <openstack> The meeting name has been set to 'oslo'
15:00:13 <hberaud> Courtesy ping for bnemec, smcginnis, moguimar, johnsom, stephenfin, bcafarel, kgiusti, jungleboyj, sboyron, damani
15:00:19 <sboyron> o/
15:00:25 <bnemec> o/
15:00:29 <damani> hi
15:00:36 <hberaud> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:00:48 <bcafarel> o/
15:02:47 <moguimar> o/
15:03:19 <smcginnis> o/
15:03:58 <hberaud> #topic Red flags for/from liaisons
15:05:17 <hberaud> we just started wallaby few days ago, so I don't expect lot of topics here
15:05:50 <bcafarel> probably not
15:05:59 <stephenfin> o/ late (in another meeting though)
15:06:28 <hberaud> #topic Releases liaison
15:07:26 <hberaud> Thanks damani for proposed releases
15:07:55 <hberaud> I seen few releases against stable branches
15:08:22 <moguimar> did we get release of oslo.utils?
15:08:22 <damani> you're welcome
15:08:24 <moguimar> =)
15:09:01 <hberaud> moguimar: nope, I don't seen specific changes on oslo.utils or maybe I missed something
15:09:05 <damani> yes i have proposed one release of oslo.messaging for victoria
15:09:18 <moguimar> we have the md5 thing for FIPS
15:09:29 <hberaud> damani: interested?
15:09:36 <moguimar> not on stable branches though
15:09:44 <hberaud> ah
15:09:49 <damani> i have also proposed one release of pobr
15:09:49 <moguimar> we are waiting for a W release
15:09:55 <hberaud> wallaby is under construct
15:10:21 <moguimar> do you have a timeline?
15:10:24 <hberaud> I just proposed a patch early https://review.opendev.org/#/c/758815/
15:10:54 <hberaud> moguimar: for now we waiting for feedback
15:11:10 <moguimar> ok
15:11:13 <hberaud> I think it will be done in few days
15:11:27 <damani> https://review.opendev.org/#/c/758804/
15:11:39 <damani> https://review.opendev.org/#/c/758804/
15:11:57 <hberaud> thanks damani
15:12:14 <hberaud> I think we are done for releases
15:12:17 <hberaud> #topic Security liaison
15:12:34 <hberaud> bnemec: anything to brings there?
15:13:00 <bnemec> Nope
15:13:10 <hberaud> ack thanks
15:13:23 <hberaud> #topic TaCT SIG liaison
15:13:48 <hberaud> sboyron, moguimar: any topics to bring there?
15:14:00 <moguimar> nope
15:14:14 <moguimar> or I didn't see any email
15:14:26 <sboyron> nope not on my side too
15:14:35 <hberaud> ack thanks
15:14:39 <hberaud> #topic Action items from last meeting
15:14:48 <sboyron> but I'm still trying to understand the exact scope of this role TBH
15:15:04 <hberaud> sorry
15:15:09 <sboyron> np
15:15:44 <hberaud> maybe you can start by discussing about https://governance.openstack.org/sigs/tact-sig.html with moguimar
15:16:02 <hberaud> sboyron: it could be an entrypoint for you
15:16:08 <sboyron> but ITUC bnemec was in charge of this previously through PTL role, maybe outside of this meeting I'll need to reach you bnemec to understand better
15:16:35 <bnemec> I think mostly you're just a point of contact in case of ci issues.
15:16:47 <moguimar> that is my understanding
15:16:56 <bnemec> And you probably would have been pinged about stuff like the migration to focal and zuulv3.
15:17:01 <moguimar> that if something goes on fire, we'll get an email
15:17:14 <sboyron> ack
15:17:18 <moguimar> or many emails
15:17:22 <hberaud> lol
15:17:23 <bnemec> :-)
15:17:29 <moguimar> depending on the fire =P
15:17:33 <sboyron> so, nothing is on fire now, we can continue ^^
15:17:46 <hberaud> so, bnemec to keep track of our liaisons on the wiki.
15:17:50 <hberaud> done
15:18:15 <hberaud> I seen your wiki's update
15:18:26 <hberaud> moguimar to reach pre-commit people
15:18:30 <hberaud> any update?
15:18:39 <moguimar> yep
15:18:46 <moguimar> found out where they hide
15:18:53 <moguimar> in a discord server
15:19:03 <hberaud> lol
15:19:03 <sboyron> nice catch !
15:19:10 <moguimar> they asked why we don't cache github too same way we do with pypi
15:19:31 <moguimar> I still need to follow up there
15:19:35 <moguimar> but in the other hand
15:19:48 <moguimar> the last pre-commit patch is just waiting for your reviews =)
15:19:51 <moguimar> https://review.opendev.org/#/c/742160/
15:20:19 <hberaud> #action hberaud to review https://review.opendev.org/#/c/742160/
15:20:33 <hberaud> thanks
15:20:58 <moguimar> even though we had a -1 from Clark in the previous PS, I don't think we should do different than the other 34 patches accross the 34 other oslo repos
15:21:28 <moguimar> so bnemec smcginnis stephenfin ^
15:21:55 <hberaud> agreed, we left enough time to catch this kind of details
15:21:56 <bnemec> Yeah, I think that's fair. We need to address the caching issue across Oslo, not just in pbr.
15:22:23 <stephenfin> I do wonder if pre-commit is even necessary for pbr?
15:22:32 <stephenfin> It's not something that should change much, if at all, now
15:23:04 <smcginnis> Yeah, pbr is a little unique compared to the other oslo repos.
15:23:06 <moguimar> so it wouldn't be much of an overload either
15:23:13 <moguimar> and we keep all repos aligned
15:23:28 <hberaud> agreed
15:24:05 <moguimar> how do we do then? vote for merge/abandon?
15:24:49 <hberaud> I'm in favor to keep pre-commit on pbr
15:24:57 <smcginnis> Fair enough.
15:25:12 <moguimar> keep++
15:25:39 <hberaud> Then please comment on https://review.opendev.org/#/c/742160/
15:26:08 <hberaud> #topic Weekly Wayward Wallaby Review
15:26:42 <hberaud> #link https://review.opendev.org/#/c/747440/
15:26:50 <smcginnis> Wayward Wallaby Weview
15:27:22 <hberaud> W3R
15:27:40 <bnemec> You forgot Weekly.
15:27:44 <bnemec> W4R :-P
15:27:49 <hberaud> :)
15:28:06 <hberaud> so this patch is etcd3gw stuff
15:28:17 <bnemec> Can we temporarily change our mascot to Elmer Fudd? ;-)
15:28:40 <hberaud> feel free :)
15:29:54 <hberaud> I think we need to take a look to the follow up patch too
15:30:15 <hberaud> rechecked
15:30:30 <hberaud> #topic Open discussion
15:30:38 <hberaud> anything else?
15:30:43 * hberaud yes
15:31:11 <bnemec> Not for me.
15:31:48 <hberaud> As you seen I added few topics to our meeting agenda to allow our liaisons to bring topics that they own during our meetings
15:31:50 <moguimar> not on my end
15:32:02 <moguimar> hberaud++
15:32:10 <hberaud> Do you think this format is useful for us?
15:32:15 <moguimar> yep
15:32:51 <hberaud> As we are now a DPL I think it's important to allow to every liaison to raise things
15:32:52 <sboyron> yes
15:34:02 <hberaud> also, don't forget to vote on this patch https://review.opendev.org/#/c/757906/ especially all our liaisons people
15:34:32 <hberaud> moguimar: we want your vote :)
15:35:11 <hberaud> anything else?
15:35:46 <sboyron> not on my side
15:36:14 <hberaud> then I think we are done
15:36:17 <bnemec> +1 to the agenda changes
15:36:49 <hberaud> #endmeeting