16:00:39 <hberaud> #startmeeting oslo
16:00:40 <openstack> Meeting started Mon Jan  4 16:00:39 2021 UTC and is due to finish in 60 minutes.  The chair is hberaud. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:44 <openstack> The meeting name has been set to 'oslo'
16:00:49 <johnsom> o/
16:00:50 <hberaud> Courtesy ping for hberaud, stephenfin, moguimar, jungleboyj, bnemec, johnsom, bcafarel, kgiusti, gmann, valleedelisle
16:00:51 <moguimar> o/
16:01:00 <hberaud> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
16:01:02 * stephenfin lurks
16:01:24 <kgiusti> o/
16:01:26 <bnemec> o/
16:01:54 <bcafarel> o/ happy new year!
16:02:05 <hberaud> Let's start by saying happy new year!
16:02:17 <bnemec> Happy New Year!
16:02:20 <moguimar> yay
16:02:26 <hberaud> I wish you all the best for 2021!
16:02:28 <moguimar> Happy New Year!
16:02:46 <kgiusti> happy happy joy joy!
16:04:03 <hberaud> So let's go!
16:04:05 <hberaud> #topic Red flags for/from liaisons
16:04:26 <johnsom> Nothing from Octavia/Designate (though I have been on vacation)
16:04:35 <bnemec> I saw a commen in the keystone channel that the new oslo.db release broke something.
16:04:38 <bnemec> *comment
16:05:13 <bcafarel> nothing I'm aware of yet for Neutron
16:05:16 <hberaud> yes I seen related discussion on rpm-packaging too
16:05:39 <moguimar> I guess no topics from Barbican, we haven't had a meeting in weeks
16:06:22 <hberaud> however I'm not aware of the exact issue, bnemec any details?
16:07:07 <bnemec> I didn't really look at it yet.
16:07:14 <hberaud> ack np
16:07:39 <bnemec> Just passing it along since my oslo notification pinged me about it. :-)
16:07:46 <hberaud> lol
16:08:17 <hberaud> Ok I think we can move on for now
16:08:20 <hberaud> #topic Releases liaison
16:08:44 <hberaud> Nothing from my side, damani any update?
16:10:28 <hberaud> I guess most of us were on vacation, so I don't expect lot of activity today
16:10:37 <bnemec> Yep
16:10:41 <hberaud> #topic Security liaison
16:11:02 <bnemec> Nothing that I've seen, but I haven't gotten through all of my email yet. ;-)
16:11:12 <hberaud> +1
16:11:27 <hberaud> #topic TaCT SIG liaison
16:12:07 <hberaud> moguimar: any update?
16:12:21 <moguimar> no fires on my side
16:12:36 <hberaud> we've one topic that fit the TaCt SIG http://lists.openstack.org/pipermail/openstack-discuss/2020-December/019521.html
16:13:54 <hberaud> I started to address this one just before the christmas week, but now I need to rewind on it to see where we are now
16:14:41 <hberaud> else nothing else from my side here
16:15:03 <bnemec> Do we want to discuss that as a separate topic? It's a fairly significant discussion.
16:15:50 <hberaud> bnemec: Yes it could be worth
16:16:25 <moguimar> yes
16:16:31 <moguimar> and the cursive discussion too
16:16:37 <hberaud> let's finish the regular agenda
16:16:44 <bnemec> +1
16:16:48 <hberaud> #topic Action items from last meeting
16:17:01 <hberaud> nothing here
16:17:12 <hberaud> #topic Weekly Wayward Wallaby Review
16:18:06 <hberaud> https://review.opendev.org/c/openstack/oslo.config/+/687513
16:18:35 <hberaud> stephenfin: still relevant? ^
16:18:45 * stephenfin looks
16:19:28 <stephenfin> hberaud: I need to respin it. Nothing valuable there yet I'd say
16:19:38 <hberaud> ack np
16:19:52 <hberaud> #topic Open discussion
16:20:21 <hberaud> Anything else?
16:21:20 <moguimar> do we bring cursive and lowerconstraints now?
16:21:45 <bnemec> It would be nice to #topic those just for ease of finding in the future.
16:22:01 <hberaud> #topic hosting Cursive
16:22:30 <hberaud> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-December/019430.html
16:23:23 <moguimar> The barbican team agrees on hosting cursive under oslo and offers help likewise done to castellan
16:23:30 <hberaud> To bring a bit of context here, some people proposed to move the cursive lib under the openstack organization and especially under the oslo team
16:24:42 <bnemec> It makes sense to me. It's a common library that is closely associated with the Barbican team.
16:25:04 <hberaud> +1
16:26:11 <hberaud> moguimar: do you want to lead the officialization of this topic regarding oslo?
16:26:28 <moguimar> what do you need on my end?
16:27:46 <hberaud> moguimar: I think that it could be a simple official email in response on that thread by pointing that discussion
16:27:57 <moguimar> I presume I'd have to talk to people to move the project in opendev
16:28:21 <moguimar> ok
16:28:23 <hberaud> moguimar: IIRC someone already do that, but I'm not sure
16:28:35 <moguimar> I can send the email
16:29:28 <hberaud> moguimar: the goal here is mostly to speak in the behalf of oslo/barbican as you are transversal on these projects
16:29:37 <hberaud> moguimar: thanks
16:30:35 <hberaud> #action moguimar officializing oslo's position concerning the cursive migration
16:31:10 <hberaud> #topic Dropping lower-constraints testing
16:31:32 <hberaud> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-December/019521.html
16:32:22 <hberaud> So the goal was to find a way to manage the new pip resolver issues within oslo
16:33:31 <hberaud> Either we fix all our incompatibility between entries in our *requirements.txt or we drop them
16:34:07 <bnemec> As I mentioned in the channel before break, I think there is value to lower-constraints testing and I would like to keep it. But if it's going to take too much time to fix then it's academic and we have to remove it.
16:34:24 <hberaud> by removing the lower-constraints check
16:34:58 <moguimar> from what I remember from the discussion, keeping the lower-requirements consumes more time than the benefits it provides
16:35:07 <moguimar> due to the large number of repos
16:35:09 <bnemec> Has anyone managed to get a lower-constraints job working so we would have some idea what it will take?
16:35:46 <hberaud> I tried to fix few of them but we rapidly fall in the dependencies hell....
16:37:27 <hberaud> I spent few hours with only few projects and the problem is that some fix should be depends-on of other...
16:37:46 <jungleboyj> o/  Sorry for being late.
16:38:03 <bnemec> Oh, so the problem isn't just fixing our lower-constraints, it's also that all of our deps have issues too?
16:38:06 <hberaud> by example with oslo.messaging that  pull oslo.log etc...
16:38:57 <hberaud> so a deps X version on oslo.messaging should match a specific version on oslo.log etc...
16:39:06 <hberaud> s/deps/dep/
16:40:02 <hberaud> and that on ~34 projects
16:40:45 <bnemec> I guess this isn't necessarily an either/or thing. We can always remove the jobs to unblock the repos now, and if someone wants to tackle the lower-constraints fixes later we can add them back.
16:40:59 <bnemec> So +1 from me to removal.
16:41:10 <hberaud> +1
16:41:10 <moguimar> is it feasible to have a single lower-constraints file to rule them all?
16:41:33 <moguimar> +1
16:42:35 <hberaud> hm maybe by adding a config-dep project pulled by all oslo projects...
16:42:37 <stephenfin> yeah, I don't want to do that work so +1 from me too
16:42:45 <stephenfin> moguimar: That's what we had, back in the day
16:42:47 <stephenfin> iirc
16:43:30 <stephenfin> or maybe not - the death of the openstack proposal bot came about around the same time lower-constraints jobs were introduced, but maybe they weren't the same thing
16:44:16 <hberaud> so if every participant agree with that I'll reply on the thread to summarize our discussion and continue to move further with that
16:45:51 <hberaud> #action hberaud confirm the drop of LC job on oslo by reply on the ML thread
16:46:15 <hberaud> #topic Open discussion
16:46:43 <hberaud> Anything else to discuss today?
16:48:41 <hberaud> OK, thanks everyone. Let's wrap up.
16:49:05 <hberaud> #endmeeting