15:00:02 <raildo> #startmeeting oslo-config-plaintext-secrets
15:00:04 <openstack> Meeting started Tue Apr 10 15:00:02 2018 UTC and is due to finish in 60 minutes.  The chair is raildo. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:09 <openstack> The meeting name has been set to 'oslo_config_plaintext_secrets'
15:00:11 <raildo> #link https://etherpad.openstack.org/p/oslo-config-plaintext-secrets
15:00:35 <dhellmann> o/
15:00:44 <raildo> ping spilla, gagehugo :)
15:00:50 <spilla> o/
15:00:51 <raildo> hey dhellmann!
15:01:20 <raildo> #topic Status check
15:01:35 <raildo> so, I sent a patch for the first work item
15:01:36 <raildo> #link https://review.openstack.org/#/c/560027/3
15:02:05 <dhellmann> I saw that but haven't had time to review it yet
15:02:05 <raildo> hope to have some of your eyes on it later :)
15:02:07 <dhellmann> I'll do that today
15:02:12 <raildo> dhellmann, thanks sir!
15:02:25 <spilla> ill check it out as well
15:02:34 <raildo> also, I saw that spilla have sent one for the second work item
15:02:37 <raildo> #link https://review.openstack.org/#/c/559389
15:02:46 <spilla> thanks! was going to grab that :)
15:02:53 <raildo> so, we can call this a progress! :D
15:02:58 <spilla> working on addressing dhellmann''s comment
15:03:01 <spilla> comments*
15:03:04 <raildo> ack
15:03:14 <gagehugo> o/
15:03:22 <dhellmann> spilla : in your next patch you could rename that module to something shorter, like just "sources.py"
15:03:33 <dhellmann> and raildo we'll want to put your driver class in that same new file
15:03:38 <dhellmann> cfg.py is way too long already
15:03:51 <raildo> dhellmann, makes sense, I'll push that for this new file
15:03:55 <spilla> yep, can do
15:04:07 <dhellmann> I'll look more closely at the new class after lunch
15:04:35 <raildo> dhellmann, no worries, I'll be here all day, so as soon you got some review, I'll update it asap
15:04:41 <dhellmann> k
15:04:45 <raildo> #topic next steps
15:04:56 <raildo> what should we grab on that list?
15:05:26 <raildo> is that something that we can already start before have that patches merged?
15:06:16 <spilla> i think the next steps are the classes that use the base classes for actual implementation, right?
15:06:25 <dhellmann> yes, I think that's right
15:06:35 <dhellmann> those will help us figure out if we have the new base classes fully defined
15:06:47 <raildo> got it
15:07:16 <spilla> and still shouldn't affect much of, if any, of the existing code base so fairly safe
15:07:16 <raildo> spilla, do you have some free time on this next days to take this task, or should I grab that?
15:07:40 <spilla> ive got 4 days of training, so limited time but i can work on the source when im free
15:07:45 <spilla> config source*
15:08:14 <raildo> spilla, ok, so I'll try to send a first patch for it, and you can review/improve it later
15:08:19 <raildo> sound good?
15:08:48 <spilla> works for me :)
15:08:50 <spilla> thanks!
15:08:58 <raildo> awesome
15:09:41 <raildo> I'm felling more confident after this first tasks, so I hope to be more productive in the next days :)
15:10:37 <raildo> #action raildo send a patch with the actual implementation for this basic classes
15:10:40 <dhellmann> nice
15:10:47 <raildo> #topic Open Discussion
15:10:56 <raildo> anything else folks?
15:11:51 <spilla> not from me
15:12:59 <dhellmann> nor i
15:13:21 <raildo> ok, so have an amazing week all!
15:13:25 <raildo> #endmeeting