14:59:38 <raildo> #startmeeting oslo-config-plaintext-secrets
14:59:39 <openstack> Meeting started Tue Jul 10 14:59:38 2018 UTC and is due to finish in 60 minutes. The chair is raildo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:59:43 <openstack> The meeting name has been set to 'oslo_config_plaintext_secrets'
14:59:54 <raildo> #link https://etherpad.openstack.org/p/oslo-config-plaintext-secrets
15:00:41 <moguimar> o/
15:01:37 <moguimar> dhellmann, spilla, bnemec ping
15:01:47 <spilla> o/
15:02:25 <raildo> hello folks :)
15:02:35 <bnemec> o/
15:02:39 <raildo> #topic Remaining work for Rocky
15:03:07 <raildo> so, we're pretty close to hit our goal for rocky
15:03:09 <raildo> #link https://review.openstack.org/#/q/status:open+project:openstack/oslo.config+branch:master+topic:bp/oslo-config-drivers
15:03:29 <dhellmann> o/
15:03:41 * dhellmann is on a call at the same time, so may be slow to respond
15:03:51 <raildo> dhellmann, thanks for the reviews
15:04:10 * raildo at the same call with dhellmann as well
15:04:25 <dhellmann> I've never been in 2 meetings with the same person at the same time. Weird. ;-)
15:04:30 <raildo> haha
15:04:54 <dhellmann> do we have any patches that still need reviews?
15:05:24 <moguimar> this one needs a rebase https://review.openstack.org/#/c/579186/
15:05:25 <raildo> dhellmann, yes, we do
15:05:37 <raildo> #link https://review.openstack.org/#/c/578461/
15:06:09 <raildo> #link https://review.openstack.org/#/c/578144/
15:06:13 <dhellmann> moguimar : oh, thanks for pointing that out. I'll see about doing that
15:06:43 <dhellmann> and I will put those others on my review list for today
15:06:56 <dhellmann> if we don't get the documentation change in right away I think we can live with that
15:07:57 <raildo> agreed, we can improve docs, if needed, in a follow up patch
15:08:16 <raildo> bnemec, do you have some time to review those patches as well?
15:08:28 <bnemec> raildo: Yes, I'll take a look too.
15:08:34 <raildo> bnemec, thanks!
15:09:14 <raildo> #topic Next Steps for Stein
15:09:32 <raildo> so, just an update in what we have in mind for next steps on this work
15:10:13 <raildo> of course we have the castellan driver, and we're evaluating using Vault as a backend for castellan, the discussion have be doing over here: https://etherpad.openstack.org/p/production-vault
15:10:52 <raildo> also, there is the spec explaining this next steps, that any feedback are welcome https://review.openstack.org/#/c/474304/
15:10:56 <raildo> that's all that I have
15:12:42 <raildo> #topic Open Discussion
15:12:48 <raildo> any other topics?
15:12:57 <moguimar> EuroPython
15:13:04 <raildo> moguimar, please, go ahead
15:13:19 <moguimar> I'll be presenting a poster about this work
15:13:39 <moguimar> Hardening Plaintext Secrets in Configuration Files
15:13:55 <moguimar> I'm planning to write the poster this week
15:14:02 <moguimar> and get it printed next week
15:14:19 <moguimar> if I could get some review on the text prior to printing the post would be nice
15:14:27 <moguimar> printing the poster*
15:14:55 <raildo> moguimar, sure, just share with us, maybe via email, and we can review it
15:14:56 <moguimar> we can reuse the poster later on futher events
15:14:59 <raildo> also, thanks for doing that
15:15:11 <moguimar> I'll do it on google docks probably
15:15:26 <moguimar> docs*
15:15:56 <moguimar> my writing is terible today, too much coffee
15:16:23 <moguimar> that's all I have
15:17:10 <raildo> #action moguimar share docs with poster to EuroPython with us, so we can review it during the wekk
15:17:14 <raildo> week*
15:17:55 <raildo> anything else?
15:18:38 <moguimar> badrobot will be back tomorrow
15:18:54 <moguimar> and we'll start planning the castellan phase
15:19:17 <moguimar> s/badrobot/redrobot
15:19:18 <raildo> yeah :) time to focus in the next steps
15:19:29 <moguimar> coffee...
15:19:48 <raildo> anyway, if we don't have anything else
15:19:52 <raildo> have a good week everyone
15:19:57 <moguimar> o/
15:20:01 <raildo> #endmeeting