15:00:13 <raildo> #startmeeting oslo-config-plaintext-secrets
15:00:13 <openstack> Meeting started Tue Oct  2 15:00:13 2018 UTC and is due to finish in 60 minutes.  The chair is raildo. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:16 <openstack> The meeting name has been set to 'oslo_config_plaintext_secrets'
15:00:24 <raildo> #link https://etherpad.openstack.org/p/oslo-config-plaintext-secrets
15:00:25 <moguimar> o/
15:00:56 <dhellmann> o/
15:01:58 <raildo> hey folks :)
15:02:11 <moguimar> me and redrobot are in a call
15:02:29 <moguimar> but I have the irc open =D
15:02:48 <raildo> ack, we are all in more that one call :) multitask feeling
15:02:56 * redrobot is only kinda l/
15:02:58 <redrobot> o/
15:03:04 <spilla> o/
15:03:05 <raildo> let's get it started
15:03:19 <raildo> #topic status review
15:03:46 <raildo> so, I didn't see a lot of movement this last week
15:04:02 <raildo> I'm planning to update the oslo spec, with the minor changes related to the ptg's feedback
15:04:16 <raildo> I'll be sending a new version by the end of the day
15:04:58 <raildo> also we still lacking in the unit tests for the castellan driver
15:05:03 <moguimar> yep
15:05:09 <raildo> #link https://review.openstack.org/#/c/599589/
15:05:20 <moguimar> I was trying to get a barbican instance running
15:05:23 <moguimar> without success
15:05:33 <moguimar> as I have manually tested the driver against vault
15:05:37 <dhellmann> I've been focused in other areas for the last week, but let me know when you have updates ready for review
15:05:41 <moguimar> I also would like to test it against barbican
15:05:51 <dhellmann> ++
15:06:11 <moguimar> about that spec on changing the castellan API to have a prefix in the secret ID
15:06:27 <moguimar> I would like to check if that is also feasible in the barbican side
15:06:39 <moguimar> so, it is also blocked by the barbican stuff
15:07:02 <moguimar> then the barbican team needs me this sprint
15:07:29 <moguimar> so I'm involved in a barbican demand but also on PTO half of this month
15:07:44 <moguimar> I won't be able to start writing unit tests until first week of Nov
15:08:23 <moguimar> also I need to do some prep to help dhellmann in Berlin during the openstack summit
15:08:41 <raildo> moguimar, so, would be nice to update our etherpad with some next steps, adding as much details as you can, so we can estimate or try to find someone else to be working on this during this next weeks
15:08:45 <moguimar> so I'm kinda with a full plate =D
15:08:46 <dhellmann> yeah, I'm waiting to get the previous slide deck from bnemec
15:09:01 <bnemec> o/
15:09:32 <bnemec> I just found out I am going to Berlin, so I can do the project update again.
15:09:40 <dhellmann> then we can go through the user-facing changes in rocky and early stein
15:09:41 <dhellmann> yay!
15:09:43 <raildo> bnemec, awesome :)
15:10:01 <bnemec> Also I forgot to open the etherpad for that.
15:10:24 * bnemec needs to review the action items for last meeting
15:12:20 <raildo> moguimar, so, can you provide a few details with what you have in mind related to the unit tests in the etherpad, before go on PTO?
15:12:29 <moguimar> sure
15:12:36 <raildo> moguimar, awesome
15:12:36 <moguimar> get me an action item for that
15:13:09 <raildo> #action moguimar update the etherpad https://etherpad.openstack.org/p/oslo-config-plaintext-secrets with details about next steps for unit tests in the Castellan driver
15:13:32 <raildo> ok, that's all that I'd for today
15:13:37 <raildo> #topic Open Discussion
15:14:14 <moguimar> I'll have a talk about oslo-config during Python Brasil next month =D
15:15:11 <raildo> moguimar, awesome, do you need our assistance to review or give some feedback for it?
15:15:25 <moguimar> not yet
15:15:33 <moguimar> maybe next tuesday
15:15:42 <moguimar> or I'll send you the slides directly
15:15:50 <moguimar> as they'll be in portuguese
15:15:55 <raildo> ack, if you need something from us, just let us know
15:16:08 <raildo> moguimar, yeah, that should be fine
15:17:17 <raildo> so, let's call it a meeting! have a good week everyone
15:17:54 <moguimar> o/
15:17:57 <raildo> #endmeeting