14:35:45 <mrhillsman> #startmeeting OSOps
14:35:46 <openstack> Meeting started Mon Mar 13 14:35:45 2017 UTC and is due to finish in 60 minutes.  The chair is mrhillsman. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:35:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:35:49 <openstack> The meeting name has been set to 'osops'
14:36:17 <mrhillsman> #topic RollCall
14:36:21 <mrhillsman> o/
14:36:36 <robputt_> hey
14:36:40 <robputt_> \o
14:37:29 <mrhillsman> i sent invite to a few folks
14:37:33 <mrhillsman> will wait a couple moments
14:37:41 <robputt_> :-)
14:37:53 <mrhillsman> i'd like to at least discuss the repo setup
14:38:04 <mrhillsman> we will discuss in milan as well :0
14:38:07 <mrhillsman> :0
14:38:09 <mrhillsman> bah
14:38:19 <robputt_> i won't be in Milan
14:38:25 <mrhillsman> #topic Milan Ops Midcycle
14:38:27 <robputt_> unfortunately, during Milan I will be in Cyprus
14:38:33 <mrhillsman> ah ok
14:38:34 <mrhillsman> no worries
14:38:46 <mrhillsman> #link http://etherpad.openstack.org/p/MIL-ops-osops
14:38:56 <mrhillsman> if you can drop some thoughts there for discussion would be great
14:39:49 <robputt_> alright bookmarked so I can do a brain dump onto there later
14:39:49 <robputt_> :D
14:39:54 <mrhillsman> danke
14:40:03 <mrhillsman> #topic OSOps repos
14:40:13 <robputt_> mrhillsman: i think danke is German, not Italian :P
14:40:17 <mrhillsman> lol
14:40:24 * mrhillsman international guy
14:40:29 <robputt_> hehe
14:40:35 <mrhillsman> regarding the repos
14:40:47 <mrhillsman> i'd like your thoughts around #link https://github.com/major/monitorstack
14:40:58 <robputt_> I looked at this the other day
14:41:12 <mrhillsman> i will forward you an email on this where i asked major and andy plans around it
14:41:24 <mrhillsman> they do not want to put in osops at the moment but i think it makes sense to
14:41:30 <mrhillsman> i told them we would fork it either way
14:41:34 <mrhillsman> so why not just put there
14:41:34 <robputt_> well
14:41:40 <mrhillsman> will discuss with andy in Milan
14:41:45 <robputt_> I think it depends around over all monitoring strategy
14:42:02 <mrhillsman> i will paste reply sec
14:42:37 <mrhillsman> if email decides to load, interwebs are slow today
14:42:55 <robputt_> I think our role is to define a monitoring best practice
14:43:17 <robputt_> and maybe have some plugins for popular monitoring platforms e.g. isinga, nagios, zenoss etc...
14:44:05 <robputt_> and I also think major's stuff is very early days, e.g. it's only really monitoring a few hypervisor related items really...
14:44:05 <mrhillsman> i think this somewhat combines that
14:44:14 <mrhillsman> right
14:44:28 <mrhillsman> i was thinking/looking at the framework aspect of it
14:44:38 <mrhillsman> but of course it is up for discussion :)
14:45:18 <mrhillsman> connection speed is terrible :(
14:46:28 <mrhillsman> ok
14:46:39 <mrhillsman> andy - the main aim is to create a monitoring plugin framework
14:46:58 <mrhillsman> generic and will work with generic monitoring systems, as a result, generic deployments
14:47:10 <robputt_> I get the idea
14:47:49 <robputt_> I am just not sure until its fleshed out a bit more if its massively useful yet...
14:48:00 <mrhillsman> make sense
14:48:08 <mrhillsman> we can just keep an eye at this point :0
14:48:12 <mrhillsman> meh
14:48:23 <izaakk> o/
14:48:26 <robputt_> hey izaakk
14:48:32 <mrhillsman> hey izaakk
14:48:59 <mrhillsman> so robputt_ do you think a doc on monitoring
14:49:10 <mrhillsman> and plugins as stated is good starting point?
14:49:21 <robputt_> I think a doc, with a matrix
14:49:25 <robputt_> of monitoring system
14:49:29 <mrhillsman> cool
14:49:30 <robputt_> metric / threshold
14:49:36 <robputt_> and coverage either red - no coverage
14:49:39 <robputt_> yellow - some coverage
14:49:44 <robputt_> green - complete coverage
14:49:54 <robputt_> and then a folder in the monitoring repo for each monitoring system
14:50:00 <robputt_> with the plugins in for each monitoring system
14:50:10 <mrhillsman> have time to put together that idea?
14:50:21 <mrhillsman> not sure if it would be a blueprint or what not
14:50:21 <robputt_> errrr
14:50:24 <robputt_> difficult at the moment
14:50:32 <mrhillsman> i will add to the osops milan etherpad
14:50:33 <mrhillsman> no worries
14:50:34 <robputt_> i need to get exequor stable before I go on holiday, else my holiday is going to suck
14:50:35 <robputt_> :-(
14:50:40 <robputt_> so next few weeks I am rammed
14:50:40 <mrhillsman> understood
14:50:56 <mrhillsman> can you at least frame the idea somewhat and email me?
14:51:01 <robputt_> yeah
14:51:06 <mrhillsman> cool
14:51:07 <robputt_> i can draw some pretty diagrams and send them to you
14:51:09 <robputt_> :-)
14:51:12 <mrhillsman> lol
14:51:21 * mrhillsman thanks you
14:51:27 <mrhillsman> i like colors and lines a lot
14:51:55 <mrhillsman> #action robputt_ frame monitoring matrix idea and email to mrhillsman
14:52:08 <mrhillsman> so back to the repos
14:52:19 <mrhillsman> do you think we have the changes we'd like flushed out?
14:52:32 <mrhillsman> i will again bring up in milan session
14:52:44 <mrhillsman> i know a few folks who will be in attendance that have expressed ideas before
14:53:24 <mrhillsman> #link http://github.com/osic/ops-generic
14:53:43 <mrhillsman> this is where we are springboarding the conversation from as of right now
14:54:23 <mrhillsman> so, no objections :)
14:54:35 <mrhillsman> ending meeting
14:54:36 <robputt_> no objections from me, its better, not perfect but better
14:54:36 <robputt_> :D
14:54:38 <robputt_> ok
14:54:41 <mrhillsman> cool
14:54:43 <robputt_> have a fun day mrhillsman
14:54:47 <mrhillsman> anything else we need to touch on?
14:55:16 <mrhillsman> apologies again for my tardiness
14:55:20 <robputt_> np
14:55:22 <mrhillsman> ttyl
14:55:28 <mrhillsman> #endmeeting