14:05:01 <mrhillsman> #startmeeting osops
14:05:01 <openstack> Meeting started Mon Apr 10 14:05:01 2017 UTC and is due to finish in 60 minutes.  The chair is mrhillsman. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:05:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:05:04 <openstack> The meeting name has been set to 'osops'
14:05:16 <mrhillsman> Good day everyone
14:05:24 <mrhillsman> #topic RollCall
14:05:42 <serverascode> morning :)
14:06:18 <mrhillsman> who is here for osops meeting?
14:06:37 <serverascode> me
14:06:39 <yankcrime> i am
14:07:10 <mrhillsman> awesome
14:07:22 <mrhillsman> izaakk raddaoui robputt_ around?
14:07:54 <izaakk> o/
14:08:18 <mrhillsman> cool
14:08:29 <mrhillsman> will move on :) hopefully the rest will join in
14:08:49 <mrhillsman> agenda
14:08:52 <mrhillsman> #link https://etherpad.openstack.org/p/osops-meeting
14:09:12 <mrhillsman> #topic repo re-org status
14:09:33 <mrhillsman> izaakk do you mind brain dumping the discussion we had last week
14:10:08 <izaakk> Sure
14:10:10 <mrhillsman> iirc basically we are using #link https://github.com/osic/ops-generic as a model but ideally moving to a framework that is installable via pip
14:10:32 <mrhillsman> will follow the project team guide and project creator guide
14:10:46 <mrhillsman> leave current structure as is for the time being and work to integrate
14:11:12 <yankcrime> given monty had some pretty strong opinions on this in milan, is it worth engaging with him again to see if we can formalise his guidance / opinions? :)
14:11:17 <izaakk> What we discussed with Monty after our discussion in Milan was to use shade and os cloud config to communicate with the cloud, leaving the logic of the task or the tool outside of it
14:11:31 <mrhillsman> yeah @yankcrime we had an ad-hoc meeting with him
14:11:36 <yankcrime> ah, ok cool
14:11:54 <yankcrime> sounds good
14:12:19 <mrhillsman> i think, izaakk correct me if i am wrong, he is going to provide an example of what he suggests
14:12:34 <izaakk> yes! OSIC team is preparing a PoC at the same time we figure out the github/openstack thing
14:12:38 <izaakk> mrhillsman: correct
14:12:41 <mrhillsman> if not already done and we are working to get that moved to github
14:12:44 <mrhillsman> ok cool
14:12:44 <yankcrime> sweet
14:13:07 <mrhillsman> apologies, github/openstack :)
14:13:31 <izaakk> That's pretty much it, I think we will have more when the PoC is ready
14:13:44 <mrhillsman> so i think that is just a status update but we will have time to break it apart and agree/disagree once PoC is up
14:14:06 <mrhillsman> additionally if anyone is interested in discussing perfectly welcome to
14:14:33 <izaakk> +2
14:15:15 <mrhillsman> we will move all further discussions to openstack-operators and i will start an email thread so things are in the open :)
14:15:51 <mrhillsman> #action mrhillsman email thread for repo restructure to invite anyone interested in participating
14:16:19 <mrhillsman> #topic https://etherpad.openstack.org/p/osops-catch-all
14:16:36 <mrhillsman> We discussed having a number of etherpads, i just created this one
14:17:13 <mrhillsman> hangouts ideas, project team guide suggestions, and general involvement in ops stuff
14:17:30 <mrhillsman> if anyone wants to add anything else feel free to
14:17:44 <mrhillsman> was thinking if required/necessary, we could branch off to other pads from this one
14:18:13 <mrhillsman> #action mrhillsman send to ML message about etherpad and encourage participation
14:18:21 <mrhillsman> ^ we can all do that i hope :)
14:18:37 <mrhillsman> but i am down with sending the initial email
14:18:42 <mrhillsman> unless someone else wants to :)
14:18:47 <yankcrime> will there be an etherpad of etherpads to keep track of all these?
14:18:56 <mrhillsman> :)
14:19:04 <mrhillsman> this is the one
14:20:13 <mrhillsman> #topic Operations Guide Assistance
14:20:26 <raddaoui> o/
14:20:38 <mrhillsman> hey raddaoui
14:20:47 <mrhillsman> was talking with Docs PTL Alexandra Settle
14:20:52 <mrhillsman> http://forumtopics.openstack.org/cfp/details/68
14:20:58 <mrhillsman> submitted this forum topic
14:21:22 <mrhillsman> she is wondering if operations and administration guides are even needed entirely or as they currently are
14:21:28 <mrhillsman> rather
14:21:56 <mrhillsman> if you can make it to the forum and this session does not overlap with one you plan on attending, please attend
14:22:08 <mrhillsman> if you cannot make it to the forum, would love some comments there
14:22:38 <raddaoui> I am not going to forum so will go with second option :)
14:22:58 <mrhillsman> :)
14:23:01 <serverascode> plus there is the arch guide
14:23:06 <serverascode> how does that fit in as well
14:23:11 <mrhillsman> +1
14:23:52 <serverascode> do they want to get rid of the admin and ops guides?
14:24:06 <mrhillsman> right now there is a lot of technical debt as i understand from her and rather than creating more, letting it pile on, or whatnot
14:24:34 <mrhillsman> something openstack-ansible team suggested during barcelona was - 'if we started from scratch, what would it look like'
14:24:38 <mrhillsman> maybe not that extreme
14:24:50 <mrhillsman> but i think it is more a matter of efficiency going forward
14:24:58 <serverascode> it seems like the arch guide is starting from scratch, there are no current docs on multistie for example
14:25:12 <mrhillsman> serverascode i do not think they want to get rid of them totally
14:25:44 <mrhillsman> we often try to get folks to participate heavily in the debt but maybe we should declare bankruptcy :)
14:25:45 <raddaoui> so will there be an etherpad for the sessions where we can comment
14:26:12 <mrhillsman> i was thinking that maybe i could provide the template like i did for ops midcycle @raddaoui
14:26:52 <serverascode> I think I get it :) but declaring bankrupcy is, not generally a good thing :)
14:26:56 <mrhillsman> will be a task because there are far more sessions but i could maybe use some script to create them :)
14:27:01 <mrhillsman> hehe
14:27:19 <mrhillsman> yeah, any ideas on go forward plan are welcome
14:28:33 <raddaoui> hehe I will start framing the points in the link in one of the etherpads
14:28:44 <mrhillsman> that's all i had on that, maybe if anyone feels up to fixing some bugs currently or going through some of those 3 mentioned (arch, admin, ops)
14:28:51 <mrhillsman> ok cool
14:29:08 <mrhillsman> #topic Open Discussion
14:29:49 <mrhillsman> i have nothing extra to discuss at this time
14:29:54 <mrhillsman> floor open to anyone else
14:30:20 <mrhillsman> oh, has anyone see the forum schedule?
14:31:05 <serverascode> yeah looked through it
14:31:07 <yankcrime> yup
14:31:31 <mrhillsman> cool, any suggestions concerns welcome, window is tight but still room to adjust
14:31:50 <mrhillsman> additionally we have the extra slots on thursday for any suggestions
14:33:27 <mrhillsman> welp, anything else?
14:33:42 <mrhillsman> can give everyone 20+ minutes back :)
14:34:46 <mrhillsman> alright, then :)
14:35:08 <mrhillsman> thanks everyone for joining
14:35:13 <mrhillsman> #endmeeting