12:00:54 <baoli> #startmeeting PCI Passthrough
12:00:55 <openstack> Meeting started Tue Mar 18 12:00:54 2014 UTC and is due to finish in 60 minutes.  The chair is baoli. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:00:58 <openstack> The meeting name has been set to 'pci_passthrough'
12:01:17 <baoli> Hi
12:10:47 <irenab> hi
12:10:59 <baoli> Hi irenab
12:11:26 <irenab> I didn't realize that the meeting is one hour earlier, sorry
12:11:38 <baoli> no problem
12:11:48 <baoli> It seems that no one else is present at the moment
12:12:07 <irenab> are you sure it shouls be now and not in one hour?
12:12:22 <baoli> It's utc 1300, right?
12:12:36 <baoli> sorry, I'm wrong
12:12:49 <baoli> it's 9:00am our time.
12:12:56 <irenab> I see 12:12
12:13:09 <irenab> its 14:13 afor me
12:13:37 <baoli> I don't know why I am confused today
12:13:42 <irenab> so, meeting in 45 minutes?
12:13:47 <baoli> Yea
13:01:13 <baoli> Hi
13:01:15 <beagles> o/
13:01:22 <heyongli> hello
13:01:22 <rkukura> hi
13:02:09 <irenab> hi
13:02:15 <baoli> I think that we are going to talk about the sr-iov session we are going to have at the summit
13:02:35 <baoli> I registered a session on neutron
13:02:45 <irenab> I would like also to discuss a bit documentation
13:02:47 <baoli> does anyone know how to register a joint session instead?
13:03:06 <baoli> irenab, sure
13:03:31 <irenab> now or later?
13:03:39 <beagles> IIRC there wasn't an actual mechanism for registering a joint session in HK. I just talked to the "other" PTL.
13:04:02 <beagles> but I heard something about a "joint" day so maybe that's changed
13:04:44 <irenab> beagles: any idea which day? I have flight back at Friday noon
13:04:56 <baoli> there is cross-project workshop category
13:05:56 <beagles> baoli, nice
13:06:04 <beagles> irenab, no
13:06:20 <beagles> irenab, I'll see if I can find out during this meeting
13:06:52 <irenab> beagles: thanks
13:07:19 <baoli> So I think that I can move the session under that categary, then
13:08:21 <beagles> I wonder if pinging the respective PTLs as well is frowned upon.. a casual mention at the very least :)
13:08:35 <irenab> baoli: I think it can be good idea to prepare and publish the contennt, links to existing patches, etc, in advance
13:08:41 <heyongli> baoli, i'm change my patch to match the interface you used in your patches as possible , hope it help
13:08:42 <heyongli> any plan?
13:08:44 <heyongli> baoli, you can create design topic with cross project type, is it what you look for?
13:09:25 <baoli> heyongli, folks and PTL suggests joint session
13:09:52 <baoli> irenab, the meeting wiki has everything in there, but it's probably convoluted
13:09:57 <irenab> I also wonder if we need another session to discuss nova api for vnic_type request or it will be covered on same cross project session
13:11:01 <baoli> irenab, are you talking about vnic-type in the 'nova boot' command?
13:11:14 <irenab> baoli: yes
13:11:47 <irenab> it was requested by John that it should be done in some abstract way, some sort of NIC flavors maybe
13:12:03 <baoli> right
13:12:06 <beagles> irenab, first day - Tuesday - unconfirmed, but Friday is such a bad idea, I can't imagine....
13:12:45 <irenab> beagles: so no need to change flight ickets?
13:13:16 <baoli> https://wiki.openstack.org/wiki/Meetings/Passthrough#Recap_of_Discussions. The link recaps what we have discussed so far. Do you guys want to put it in a separate page
13:14:11 <baoli> We can discuss how we want to cover each of them
13:14:42 <baoli> heyongli, I'll take a look at your patch update
13:15:32 <heyongli> not release, boli, i'm changing it, some commts need addressed
13:15:53 <baoli> heyongli, ok
13:16:14 <heyongli> sorry my network quite unstable now...
13:17:04 <irenab> I think we need some clear list of use cases that we handle and design/constructs options we suggest (preferably with code samples)
13:17:04 <baoli> irenab, let me know what's missing in the recap link
13:17:54 <baoli> irenab, agreed. We have use cases in the meeting wiki as well. Can you guys present some use cases that we haven't thought about?
13:18:40 <sadasu> baoli: just one suggestion
13:18:42 <irenab> We probably need to focus on two types of use cases: driven by admin and driven by tenant users
13:19:04 <sadasu> maybe there is no need to bring up the original google doc where there are several authors
13:19:16 <beagles> +1 irenab
13:19:42 <heyongli> +1
13:19:46 <baoli> irenab, agreed
13:20:20 <heyongli> too many details discuss process really block guy want to dive in
13:20:36 <baoli> sadasu, can you clarify your thoughts
13:21:04 <irenab> I'll try to sum up use cases following the wiki/google docs we had and send update; so next week meeting we can go over
13:21:30 <baoli> irenab, cool
13:22:06 <heyongli> thanks, irenab
13:22:19 <sadasu> what you have in https://wiki.openstack.org/wiki/Meetings/Passthrough#Agenda_on_Jan._8th.2C_2014 is a better summarization than the google doc
13:22:49 <sadasu> google doc might be confusing for anyone who is trying to come onboard to this...
13:22:55 <irenab> sadasu: I think we need start from clean
13:23:27 <beagles> yes... I started on this but kept getting distracted (pulled off) to do other stuff
13:23:29 <irenab> we may keep references o existing docs but not require any new people to go over all the existing papers
13:23:55 <beagles> but a focused clean slate would be good...
13:24:28 <baoli> ok, let's start with a new doc.
13:24:50 <irenab> If I understand correctly the idea of design summit it to present what use cases we want to handle and how we want to handle it
13:25:00 <sadasu> ok…and are we starting this off with Irenab's use cases based on admin and tenant views?
13:25:19 <baoli> irenab, +1
13:26:07 <beagles> irenab, I would agree
13:26:07 <irenab> sadasu: I think its one chapter, the other is neutron apis that we already ahve, nova - neutron interaction, nova- scheduler enhancment for SR-IOV devices,...
13:26:50 * beagles thinks of anything he might have that irenab doesn't already just have in her head...
13:26:53 <beagles> probably not
13:27:36 <irenab> beagles: :-)
13:28:38 <sadasu> ireanb: sounds good :-) just want to make sure we are covering everything
13:29:05 <irenab> baoli: can you please provide documentation recap on nova parts that you managed via your patch? I think neutron generic parts are already merged, so need just to describe what neutron expose via api
13:29:05 <sadasu> is this all going to be one session?
13:30:27 <baoli> Irenab, sure. I already had a wiki
13:30:36 <irenab> sadasu: good question
13:30:58 <baoli> I can update if anything is missing. The wiki can be accessed following the links in the recap
13:31:47 <irenab> baoli: great, thanks. Are there any open issues there?
13:33:59 <baoli> irenab, have you tried the patch yet?
13:34:08 <heyongli> in recap chaper , there both group and flavor , i think the flavor is our goal, right?
13:34:49 <irenab> I think that we need to decide if there is one or more sessions and if we need nova session in addition to cross-project session, for nova  apis
13:34:58 <irenab> baoli: still waiting for setup....
13:35:16 <baoli> irenab, ok
13:35:32 <heyongli> irenab, if both get approved, that's will be great,
13:36:09 <irenab> heyongli: the session that you registered supposed to cover nova apis, right?
13:36:23 <heyongli> yeah, common part
13:36:39 <baoli> heyongli, now that we can't make it to Icehouse, my understanding is that it's still open for discussion.
13:36:46 <heyongli> if necessary, even the interaction part can be elimated from this
13:37:18 <heyongli> baoli, maybe, i recap we agree with flavor, supprize me
13:38:19 <irenab> so for now there are two sessions, one cross project and one nova, right?
13:39:09 <heyongli> irenab, if i could choose as like this
13:40:48 <irenab> baoli: heyongli: I am quite lost with all nova group/flavor desicions. Can you please give it some write-up for what is the prefered direction towards Juno?
13:41:41 <heyongli> yunhong and me totally prefer flavor as john might prefer,
13:42:25 <baoli> irenab, I am not sure about the direction
13:43:24 <baoli> Once you have a clear list of use cases in terms of admin/user, it would be used as a guideline for the user interfaces/APIs.
13:43:32 <baoli> s/would/could
13:45:14 <irenab> I'll start with use cases with 'what' part. Then we can proceed with 'how'
13:45:43 <baoli> +1
13:46:03 <heyongli> irenab, thank i will check if  my bp's case covered
13:47:46 <irenab> I just think we need to have prefered way defined before the summit to get people approve/disagree with and not open it for discussion for all alternatives. Otherwise, we will find ourself discussiing it for several months as we did for Icehouse...
13:48:25 <heyongli> irenab, +2, totally agree
13:49:09 <irenab> heyongli: we all agree today, its probably the spring spirit
13:49:43 <irenab> I have small question regarding documentation
13:50:05 <heyongli> sure
13:50:47 <irenab> I was assigned with documentation bug for vnic_type in neutron port and not sure that it should be covered
13:51:28 <irenab> I assume it should be in networking part, covering for port binding details
13:52:20 <irenab> rkukura: are you here?
13:52:27 <rkukura> yes
13:52:46 <irenab> are you going to document binding:profile and vif_details?
13:53:31 <rkukura> irenab: Good question - still focusing on bug fixes, haven't thought about docs for icehouse yet
13:54:09 <rkukura> The API doc should definitely be updated for vif_details, even though its admin-only.
13:54:20 <irenab> rkukura: I was kindly asked to handle vnic_type documentation.
13:54:33 <irenab> I am not sure if we are going to add some general SR-IOV chapter, what do you think?
13:54:37 <rkukura> It should already cover binding:profile.
13:55:21 <rkukura> I think the API doc section on the portbindings extension should be updated.
13:55:46 <irenab> I thought to add vnic_type there, thanks
13:56:11 <irenab> so for now now additional SR-IOV info is not going to be documented, right?
13:56:19 <rkukura> It does seem a user and admin docs for SR-IOV is needed too.
13:56:22 <irenab> ^no
13:57:01 <rkukura> I'm not really clear on whether enough is usable in icehouse to try to cover it in the docs.
13:58:17 <baoli> Time is up, let me record an action item
13:58:21 <baoli> #action identify a clear list of use cases in terms of admin/user. And Irenab will start with a doc for the use cases. Let's work on that in this week. Go over it next week.
13:58:48 <baoli> Irenab, can you send emails about the use cases so that people can add any that could be missing?
13:58:49 <irenab> rkukura: agree
13:59:01 <irenab> baoli: sure
13:59:14 <irenab> I think I can send initial list on Thu
13:59:25 <baoli> irenab, that would be great.
13:59:33 <baoli> Thanks everyone
13:59:58 <irenab> thanks
14:00:01 <baoli> #endmeeting