13:00:20 <baoli> #startmeeting PCI passthrough
13:00:21 <openstack> Meeting started Tue May 20 13:00:20 2014 UTC and is due to finish in 60 minutes.  The chair is baoli. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:24 <openstack> The meeting name has been set to 'pci_passthrough'
13:00:37 <baoli> Hi everyone.
13:00:52 <yjiang51> hi
13:00:54 <baoli> Hope everyone had a good trip back home
13:01:01 <irenab> hi
13:01:03 <beagles> hi
13:01:04 <BrianB_> Hi
13:01:25 <irenab> I came in 2 days delay...
13:01:50 <baoli> irenab, why was your flight getting cancelled?
13:02:05 <yjiang51> irenab: 2 days delay? are you also american airline?
13:02:16 <irenab> yes :-)
13:02:28 <irenab> never again,,,
13:03:08 <irenab> it was bead weather in Philadephia and weather radar not working on the plain
13:03:24 <beagles> wow
13:03:52 <irenab> But at least finally I am back, a little sick though
13:04:50 <irenab> sorry for not having progress on the spec, hope to catch up tomorrow and push for review
13:05:03 <baoli> Irenab, wish you a quick recovery.
13:05:16 <heyongli> hello, sorry late
13:05:16 <irenab> baoli: thanks
13:05:17 <baoli> let's get started with the nova-spec
13:05:28 <baoli> #topic sriov nova-spec
13:05:40 <baoli> irenab, do you need me to edit the spec?
13:06:08 <baoli> heyongli, hi
13:06:11 <irenab> baoli: if you have time today, please do and let me know. I hope can get to it tomorrow
13:06:12 <heyongli> hi
13:06:26 <baoli> irenab, sure, let me start it today, then
13:06:52 <irenab> baoli: fine, let me know by the end of the day if I can assist further
13:07:49 <baoli> irenab, I think initially I will just use the etherpad's contents. the current spec has much more.
13:08:46 <baoli> so the goal is to make it contain what we have discussed to deliver and hopefully to get it approved soon
13:09:17 <beagles> +1
13:09:27 <heyongli> sure
13:09:27 <irenab> baoli: agree, please us the spec we already have, just remove all unneeded content for now
13:09:44 <baoli> irenab, will do.
13:11:33 <baoli> Please take a look at the update once it's pushed up. And if everyone is ok with it, we should contact the cores for approval.
13:11:53 <heyongli> ok
13:11:56 <irenab> baoli: sure
13:12:04 <sadasu> sure
13:12:10 <baoli> Cool
13:12:14 <irenab> any other topics we want to cover today?
13:12:33 <baoli> irenab, yes. let's talk about the real work
13:12:45 <baoli> #topic nova patches
13:13:42 <BrianB_> Can we talk about baoli patch
13:14:35 <irenab> BrianB_: sure
13:14:36 <sadasu> +1 for cleaning up baoli's patch and posting it for review
13:14:36 <BrianB_> irenab, sadasu how has your testing been
13:14:51 <irenab> sadasu: +1
13:15:18 <irenab> BrianB_: faking neutron agent, it did the expected job
13:15:24 <sadasu> I have been working with baoli's patches in my lab setup and having success with it
13:15:59 <irenab> so seems that neutron "consumers" are quite satisfied :-)
13:16:27 <BrianB_> great so baoli can this be pushed up
13:16:43 <BrianB_> to get basic funionality in
13:16:59 <baoli> BrianB_: yes we can
13:17:17 <BrianB_> thanks
13:17:32 <irenab> baoli, heyongli: need to resolve the white_list/pci_stats modifications
13:17:43 <heyongli> i like to take it
13:18:55 <baoli> irenab, that's what i had wanted to talk about during the summit
13:19:13 <yjiang51> baoli: will you split your patch, or simply push it as a big one?
13:19:40 <heyongli> split might better
13:19:49 <irenab> I think we need clarly identify the tasks in the spec, so each one can be picked and pushed as separate patch. It is not mandatory to be done by different people
13:20:13 <yjiang51> irenab: +1
13:20:24 <baoli> irenab, +1
13:20:37 <heyongli> sure
13:20:50 <baoli> yjiang51, heyongli, we should talk about the changes with the changes in the whitelist
13:21:32 <heyongli> what's is it?
13:21:33 <beagles> I haven't gone through all of my email yet (yesterday was a holiday here) - so I'm assuming nobody has done this already, but it just occurred to me that we should've planned on summarizing the outcome and discussions of the summit for those who weren't there.
13:21:43 <beagles> Might reduce confusion and miscommunication
13:22:30 <yjiang51> heyongli: I think baoli is talking about the pci config white list change on your patch and his patch.
13:23:01 <heyongli> ok, what's the concern, baoli?
13:23:11 <baoli> beagles, I assumed that yjiang51 had talked with heyongli about the summit. If not, we can brief heyongli now
13:23:25 <heyongli> yes, we did
13:23:34 <baoli> ok, cool
13:23:44 <yjiang51> heyongli: the signle/multiple tag as discussed yesterday.
13:24:07 <heyongli> ok, for now only phy netowrk, right?
13:24:15 <yjiang51> heyongli: yes
13:24:19 <baoli> heyongli, it's just the changes we made in that area were quite different.
13:24:40 <baoli> heyongli, I gave comments to your patches
13:24:57 <heyongli> recently?
13:27:28 <yjiang51> heyongli: yes, for now only phy network.
13:27:38 <heyongli> i'm fine with it
13:29:25 <irenab> heyongli: can you please briefly describe what is proposed to cover phy net support?
13:29:56 <heyongli> add tag to whitelist, preset it to pci stats
13:30:24 <heyongli> do you expect this?
13:31:22 <irenab> is it same as baoli's suggestion?
13:31:59 <heyongli> no real conflict actually
13:32:43 <heyongli> make sure pci stats contain this tags information, and other information already exist
13:33:03 <irenab> baoli: Are you ok to go with this?
13:34:21 <baoli> irenab, for networking devices, I don't think that we want the vendor_id and product_id in the stats key, if that's what you guys are talking about
13:35:28 <baoli> if the device is tagged, then the tag is used for stats keys
13:35:44 <heyongli> does it crash the sriov?
13:36:10 <baoli> heyongli, can you rephrase?
13:36:45 <yjiang51> baoli: as discussed in summit, the pci stats should not block future potential extension, because we need consider upgrade. so we should keep the pci_stats more generic one. I think the first thing for pci_stats is to make it an object, because the  compute manager objectify is waiting for it.
13:36:55 <heyongli> had that information is not stop sriov, and provide extra info for later enhancement maybe
13:38:04 <baoli> yjiang51, objectifying the pci_stats may be a new BP for it's own.
13:38:21 <baoli> The change allows multiple tags
13:38:42 <baoli> So it doesn't prevent future enhancement such as pci flavor, etc
13:38:57 <heyongli> image will need that
13:39:11 <yjiang51> baoli: Its covered by an existed BP already. If the changes allows multiple tags, it's ok and we can discuss on the review?
13:39:31 <baoli> yjiang51, which review?
13:40:25 <baoli> heyongli, other existing scheudler filters should cover the image requirement you brought up
13:40:58 <yjiang51> baoli: I assume you will split the patch into multiple one, and then one of them will be changes to pci_stats, right? We can review that patch then.
13:41:03 <heyongli> other filter never access pci information now
13:42:13 <baoli> heyongli, so you want to include vid, pid in the stats key as mandatory?
13:42:22 <yjiang51> baoli:  let's put multiple info implementation aside, and only make sure no blocking for future changes. And also, we should split the patch and push them in parrellel. So that if there are disagreement on one patch, others will continue move forward.
13:42:44 <heyongli> +1
13:42:49 <baoli> yjiang51, +1
13:43:27 <irenab> shall we discuss alternative time for this meeting? Everyone can make current time slot?
13:43:31 <baoli> So we'll split my POC up and push them individually?
13:44:32 <yjiang51> baoli: I don't think we can resolve the pci_stats now, but at least we agree wih the white list, and it's a progress now. I had a quick check on the pci_stats part, frankly not quite sure on the changes. If it's splitted, it will be much better.
13:44:53 <irenab> baoli: I think it may help us to move faster
13:45:35 <baoli> cool
13:45:35 <irenab> baoli: you current POC still good to have as is to progress with neutron side implemention
13:46:50 <baoli> So we'll split it up in smaller patches
13:47:04 <baoli> And we will review them individually
13:48:54 <irenab> so this week, let's focus on the spec
13:49:28 <baoli> irenab, yes. let's push it for approval
13:49:55 <baoli> Anything else we want to talk about?
13:50:04 <yjiang51> baoli: heyongli,  for the white list spec, do we still support address regexp?
13:50:41 <baoli> yjiang51, I'd like to use the lspci format that is known to people
13:51:17 <yjiang51> baoli: I remember someone strongly suggested something like 0000.*.3.*, but forgot who give the request. Does your patch support it?
13:51:42 <baoli> yjiang51, yes, and it's using the same format as lspci
13:52:40 <yjiang51> baoli: lspci has no regex, right? And what's the exact difference of lspci format and current implementation? I think currently it's also domain:b:d.f in the code.
13:53:17 <yjiang51> baoli: asking because seems your patch has no support for widecard etc. Of coruse, we can discuss in the patch review.
13:53:39 <baoli> yjiang51, take a look at the lspci man page. basically, it allows the use of . and * in individual fields.
13:54:25 <baoli> yjiang51, we don't have to reinvent it
13:54:40 <yjiang51> baoli: cool, it's ok only if it's supported.
13:54:47 <irenab> yjiang51, baoli: if lspci format provides required flexibility, I think its better to follow it
13:55:11 <baoli> irenab, that's the idea
13:55:28 <irenab> good
13:56:06 <irenab> So to summarize, baoli is planning to work on spec today and push if possible, right?
13:56:33 <baoli> irenab, yes
13:56:35 <irenab> irenab to join the effort on spec tomorrow, all to review one pushed. Agree?
13:56:39 <yjiang51> irenab: what's next meeting?
13:56:59 <irenab> next week, smae time?
13:56:59 <heyongli> irenab, fine
13:57:04 <baoli> #action baoli pushing the sriov nova-spec update
13:57:50 <irenab> yjiang51: can you make this time slotor want alternative time?
13:58:01 <irenab> ^time slot
13:58:45 <yjiang51> irenab: I thought either yongli or me will be in. 6:00 am is still a bit early to me.
13:59:07 <baoli> in that case, would 10:00pm too late for yongli?
13:59:15 <yjiang51> irenab: I will try, but you know, sometimes alerm does not work as expected. I had 3 alarm this morning.
13:59:32 <baoli> it is 9pm for him now
13:59:42 <irenab> yjiang51: :-)
13:59:55 <yjiang51> irenab: let' keep this time, and I will try to attend. I hope NFV meeting will replace this one sooon :)
14:00:16 <yjiang51> baoli: it's 10:00 pm for yongli already.
14:00:37 <heyongli> yeah, now it's 10:00pm
14:00:37 <baoli> yjiang51, I'm talking about the meeting start time
14:00:43 <baoli> sorry for the confusion
14:00:46 <yjiang51> baoli: :)
14:01:01 <irenab> ok, so see you next week same time
14:01:01 <baoli> so, same time next week?
14:01:07 <yjiang51> baoli: yes.
14:01:21 <baoli> thanks everyone. We're making a lot of progress
14:01:24 <baoli> today
14:01:29 <baoli> See you next week
14:01:31 <irenab> thanks!
14:01:35 <baoli> #endmeeting