16:00:01 <DinaBelova> #startmeeting Performance Team
16:00:02 <openstack> Meeting started Tue Mar 15 16:00:01 2016 UTC and is due to finish in 60 minutes.  The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:05 <openstack> The meeting name has been set to 'performance_team'
16:00:08 <DinaBelova> o/
16:00:18 <ilyashakhat> o/
16:00:28 <ozamiatin__> o/
16:00:57 <DinaBelova> rohanion, are you around? :)
16:01:24 <DinaBelova> let's wait for a few moments
16:01:37 <rohanion> yes
16:01:42 <rohanion> hello everyone!
16:01:45 <DinaBelova> yay!
16:01:56 <DinaBelova> well, I think we may start with action items
16:02:07 <DinaBelova> #topic Action Items
16:02:14 <DinaBelova> #link http://eavesdrop.openstack.org/meetings/performance_team/2016/performance_team.2016-03-01-16.00.html
16:02:20 <DinaBelova> ok, last time we had few ones
16:02:34 <DinaBelova> I'll start with my idea to propose two times for this meeting
16:02:42 <DinaBelova> US and European friendly
16:02:57 <DinaBelova> I decided to postpone this proposal due to daylight savings time in US
16:03:07 <DinaBelova> not to mix even more current schedule
16:03:12 <DinaBelova> that's UTC-based
16:03:30 <DinaBelova> so let's postpone this for a while and see if current time is ok or not for our US folks
16:03:44 <DinaBelova> so I'll leave this item on myself
16:03:51 <DinaBelova> #action DinaBelova propose to have to times for this meeting to openstack-dev - US and Europe/China friendly and switch them on weekly basis
16:03:59 <DinaBelova> going to ilyashakhat
16:04:21 <DinaBelova> ilyashakhat: were you able to move performa to openstack/* github namespace?
16:04:32 <ilyashakhat> not yet
16:04:41 <ilyashakhat> the patch is in infra queue
16:04:49 <ilyashakhat> and has one +2 already
16:04:52 <DinaBelova> link please :)
16:05:02 <ilyashakhat> https://review.openstack.org/291657
16:05:09 <DinaBelova> #link 	https://review.openstack.org/291657
16:05:22 <DinaBelova> ok, so let's just leave this action item not to miss it next time
16:05:42 <DinaBelova> #action ilyashakhat move Performa to openstack space (final steps)
16:05:57 <DinaBelova> as for kun_huang's change
16:06:14 <DinaBelova> I've seen he updated it, but there are no (yet) details about lab HW
16:06:25 <DinaBelova> due to the fact lab is still under building stage
16:06:53 <DinaBelova> so I decided to keep this change https://review.openstack.org/#/c/280843 on review till this will be finalized
16:07:14 <DinaBelova> #action kun_huang update https://review.openstack.org/#/c/280843 once lab HW details will be available
16:07:18 <DinaBelova> btw
16:07:32 <DinaBelova> AugieMena: here is short HW description on Mirantis-Intel lab https://review.openstack.org/#/c/292835/3
16:07:36 <DinaBelova> of*
16:08:08 <DinaBelova> we're going to publish some test results soon, so uploaded the description of where are we running these tests
16:08:17 <DinaBelova> ok, so going to final action item
16:08:26 <DinaBelova> rohanion ozamiatin__ - the floor is yours
16:08:48 <DinaBelova> may you please share details about 0MQ driver socet consumption improvement?
16:08:53 <DinaBelova> socket*
16:08:53 <ozamiatin__> DinaBelova, thanks, let rohanion begin
16:09:09 <rohanion> ok thank you
16:09:35 <DinaBelova> rohanion and link to the bug please, if any
16:09:38 <rohanion> sure
16:09:53 <rohanion> 1 minute
16:10:10 <ozamiatin__> https://bugs.launchpad.net/oslo.messaging/+bug/1555007
16:10:10 <openstack> Launchpad bug 1555007 in oslo.messaging "[zmq] ZMQ driver eats too many TCP sockets" [Undecided,In progress] - Assigned to Oleksii Zamiatin (ozamiatin)
16:10:13 <ozamiatin__> this one?
16:10:21 <rohanion> yes, thanks!
16:10:22 <DinaBelova> #link https://bugs.launchpad.net/oslo.messaging/+bug/1555007
16:10:48 <DinaBelova> ok, so any ideas how to deal with it?
16:11:47 <rohanion> We've created a patchset which disables pub/sub listening
16:12:19 <rohanion> and we've reduced the number of oslo-messaging-zmq-receiver processes to three, one per controller node
16:13:05 <ozamiatin__> DinaBelova, rohanion: currently we have all services connected directly to each other which finally gives us full-mesh topology, my proposal is to start using of lightweight proxies which will reduce number of sockets
16:13:12 <rohanion> after measuring the number of used sockets with these patches enabled
16:13:49 <DinaBelova> ozamiatin__ - yeah, that was basement idea you folks proposed last time
16:14:13 <rohanion> we saw that the controllers use 7000 less sockets - 28k vs 35k
16:14:48 <ozamiatin__> DinaBelova, rohanion: yes, the drawback is loose on perfomance, so we need to test what performance degrade we will get finally
16:14:58 <DinaBelova> ozamiatin__ indeed
16:15:11 <DinaBelova> ozamiatin__, rohanion - when are you going to test this proxy approach?
16:15:29 <ozamiatin__> DinaBelova, rohanion: I'm planning to finalize implementing it this week
16:15:36 <DinaBelova> ozamiatin__ ack
16:16:04 <rohanion> probably we won't even outperform rabbitmq but our solution should me more scalable than rabbitmq
16:16:17 <DinaBelova> #info work on https://bugs.launchpad.net/oslo.messaging/+bug/1555007 most probably should be finished ~March 18th
16:16:17 <openstack> Launchpad bug 1555007 in oslo.messaging "[zmq] ZMQ driver eats too many TCP sockets" [Undecided,In progress] - Assigned to Oleksii Zamiatin (ozamiatin)
16:16:20 <rohanion> s/me/be/
16:16:24 <DinaBelova> ack
16:16:32 <DinaBelova> rohanion, ozamiatin__ - thanks for the update
16:16:54 <ozamiatin__> DinaBelova: you are welcome
16:17:07 <rohanion> DinaBelova what about our planned changes in osprofiler?
16:17:25 <DinaBelova> rohanion let's dscuss it when we'll go to osprofiler related topic
16:17:28 <DinaBelova> of this meeting
16:17:31 <rohanion> ok
16:17:38 <DinaBelova> #action rohanion ozamiatin__ collect data about possible performance degradation of light weighted proxies for 0MQ
16:17:49 <DinaBelova> ack, let's go to the test plans
16:17:50 <DinaBelova> #topic Test plans statuses
16:17:57 <DinaBelova> ilyashakhat - please go ahead
16:19:45 <ilyashakhat> DinaBelova, the execution of MQ test plan is still upcoming
16:19:53 <ilyashakhat> pending on lab availability
16:20:24 <DinaBelova> ilyashakhat any estimates on when this can be processed?
16:20:29 <DinaBelova> dur to current situation?
16:20:32 <DinaBelova> due*
16:20:47 <ilyashakhat> the plan is to do it asap
16:21:21 <ilyashakhat> by the next meeting there certainly be some results
16:21:35 <DinaBelova> ilyashakhat ack
16:21:44 <DinaBelova> thanks for the update
16:21:58 <DinaBelova> anything else to share in this section?
16:22:23 <DinaBelova> ok, so let's proceed
16:22:26 <DinaBelova> #topic OSProfiler weekly update
16:22:39 <DinaBelova> ok, so something before we'll switch to rohanion's topic
16:23:01 <DinaBelova> currently (I still think it's possible) https://review.openstack.org/#/c/103368/42 will be merged soon
16:23:10 <DinaBelova> right now it's without DB tracing support
16:23:16 <DinaBelova> there are several reasons for this
16:23:51 <DinaBelova> 1) keystone changed their oslo.db usage -> I need to modify oslo.db/enginefacade module -> this is going to happen only in Newton timeframe
16:24:25 <DinaBelova> 2) it looks like there can be some issues on the profiling side as well, I need to ensure after will finish #1
16:24:57 <DinaBelova> so this change was almost merged when Morgan and I caught some misunderstanding we're trying to solve now :)
16:25:10 <DinaBelova> ok, so going to further osprofiler plans
16:25:32 <DinaBelova> rohanion will continue my work on the multi-drivers approach for the profiler
16:25:40 <DinaBelova> rohanion - anything you'd love to share now?
16:26:03 <rohanion> hi guys :)
16:26:09 <rohanion> yes
16:27:13 <rohanion> so what I'm planning to do is to create a concept of using external services like PostrgreSQL as storage engines for osprofiler notifications
16:27:54 <DinaBelova> and probably something else
16:28:15 <DinaBelova> do you think some etherpad with the proposed drivers will be a good idea?
16:28:41 <DinaBelova> I think we may try to focus on the most prioritized
16:28:48 <DinaBelova> although there might be several variants
16:28:54 <rohanion> of course
16:29:07 <DinaBelova> ack, may you please prepare it before next meeting?
16:29:14 <rohanion> will do
16:29:20 <rohanion> currently we have this idea of creating a class which will initialize osprofiler directly from service
16:29:29 <DinaBelova> #action rohanion prepare list of possible drivers for osprofiler with pros/cons of each one
16:30:01 <DinaBelova> ack, thanks!
16:30:15 <DinaBelova> it looks like we may go to open discussion
16:30:27 <DinaBelova> anything else in profiler-related section?
16:30:47 <DinaBelova> ok
16:30:48 <DinaBelova> #topic Open Discussion
16:31:15 <DinaBelova> so if you have something to say please don't hesitate :)
16:31:58 <DinaBelova> ok, so it looks like we're done for today!
16:32:05 <DinaBelova> thanks everyone for joining!
16:32:10 <DinaBelova> #endmeeting