16:00:01 <DinaBelova> #startmeeting Performance Team
16:00:01 <openstack> Meeting started Tue Mar 22 16:00:01 2016 UTC and is due to finish in 60 minutes.  The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:04 <openstack> The meeting name has been set to 'performance_team'
16:00:09 <DinaBelova> o/
16:00:13 <aleksandr_null> o/
16:00:34 <DinaBelova> let's wait for a few moments to see if others will be here
16:00:58 <rohanion> \o
16:01:30 <DinaBelova> rohanion decided to be not like others :)
16:02:24 <haukebruno> just saying 'hi'
16:02:41 <DinaBelova> :)
16:02:51 <DinaBelova> let's see if ilyashakhat and listomin will join
16:04:43 <DinaBelova> ok, so let's start and if somebody will join in the meanwhile I'll be glad :)
16:05:00 <DinaBelova> today we have standard agenda with action items first
16:05:12 <DinaBelova> #topic Action Items
16:05:39 <DinaBelova> I did not collected enough feedback to separated meeting to two time zones - US and European friendly
16:06:03 <DinaBelova> it looks like after moving to daylight saving time in US everyone became happy with current time
16:06:21 <DinaBelova> so if no complains will come I'll leave this time for a meeting
16:06:30 <DinaBelova> rohanion - what's about your items?
16:06:40 <DinaBelova> #link http://eavesdrop.openstack.org/meetings/performance_team/2016/performance_team.2016-03-15-16.00.html
16:06:48 <DinaBelova> #1 collect data about possible performance degradation of light weighted proxies for 0MQ
16:06:56 <DinaBelova> #2 prepare list of possible drivers for osprofiler with pros/cons of each one
16:07:28 <rohanion> first one - unfortunately nothing, I've been working on osprofiler the whole week
16:08:05 <rohanion> second - almost done with looking for the most inportand driver https://etherpad.openstack.org/p/osprofiler-engines
16:08:09 <rohanion> important*
16:08:40 <DinaBelova> #action everyone take a look on https://etherpad.openstack.org/p/osprofiler-engines and add comments about priority, etc.
16:08:50 <DinaBelova> #link  https://etherpad.openstack.org/p/osprofiler-engines
16:09:30 <DinaBelova> as for Ilya's action item it's still in progress
16:09:31 <DinaBelova> #link https://review.openstack.org/#/c/291657/
16:09:52 <DinaBelova> due to the fact change that will create separated repo for performa is not yet merged to the openstack-infra/project-config
16:10:03 <DinaBelova> ilyashakhat move Performa to openstack space (final steps)
16:10:07 <DinaBelova> #action ilyashakhat move Performa to openstack space (final steps)
16:10:16 <DinaBelova> so let's keep this action item so far
16:10:23 <harlowja_at_home> hi!
16:10:28 <harlowja_at_home> i made it
16:10:28 <DinaBelova> harlowja_at_home wooooow
16:10:29 <harlowja_at_home> lol
16:10:34 <DinaBelova> it's so unusual
16:10:35 <DinaBelova> ЖВ
16:10:38 <harlowja_at_home> lol
16:10:38 <DinaBelova> :D **
16:10:43 <harlowja_at_home> its like a bday present
16:10:46 <harlowja_at_home> josh the bday present
16:10:48 <harlowja_at_home> lol
16:10:52 <DinaBelova> :D
16:11:00 <DinaBelova> ok, very interesting :)
16:11:24 <harlowja_at_home> an idea, btw, do u guys want to start having some of the osprofiler stuff in the oslo weekly meeting to?
16:11:31 <DinaBelova> I do not see kun_huang today (and in fact I did not see him for a whole week... so let's skip his action item for now)
16:11:45 <harlowja_at_home> since i just saw https://etherpad.openstack.org/p/osprofiler-engines
16:11:45 <DinaBelova> harlowja_at_home probably this will be a good idea
16:11:53 <harlowja_at_home> DinaBelova,  or at least the osprofiler stuff there?
16:11:55 <harlowja_at_home> just an idea
16:12:06 <harlowja_at_home> guess i'm PTL of oslo or something, lol
16:12:11 <DinaBelova> harlowja_at_home btw when is the oslo team meeting?
16:12:15 <DinaBelova> harlowja_at_home yeah, I know
16:12:21 <DinaBelova> congrats, man, btw!
16:12:24 <harlowja_at_home> :-P
16:12:26 <harlowja_at_home> thx
16:12:36 <harlowja_at_home> http://eavesdrop.openstack.org/#Oslo_Team_Meeting DinaBelova
16:12:41 <DinaBelova> ack
16:12:43 <rohanion> good job, congrats!
16:12:45 <harlowja_at_home> lol
16:12:54 <harlowja_at_home> thx
16:12:59 <DinaBelova> it's nice time :) Europe friendly
16:13:06 <harlowja_at_home> :-P
16:13:08 <DinaBelova> cool, will add to my calendar
16:13:26 <harlowja_at_home> aren't u supposed to come back to the states sometime?
16:13:26 <harlowja_at_home> lol
16:13:43 <DinaBelova> harlowja_at_home hahah, I need to survive till September somehow anyway
16:13:57 <harlowja_at_home> :)
16:14:12 <DinaBelova> ok, so going to the test plans statuses
16:14:13 <DinaBelova> #topic Test plans statuses
16:14:32 <DinaBelova> I still do not see ilyashkhat, so lemme tell what I know for him
16:14:40 <DinaBelova> #link https://review.openstack.org/#/c/295919/
16:15:10 <DinaBelova> here is current status of the MQ HA test report
16:15:20 <DinaBelova> that he performed using performa :D
16:15:37 <DinaBelova> change is really fresh, so I did not have a chance to look at it - will do this week
16:15:51 <DinaBelova> and I see listomin has joined
16:16:10 <listomin> Yeah, Hello!
16:16:35 <listomin> Here is the test plan and results for docker repositories services https://review.openstack.org/#/c/295308/
16:16:47 <DinaBelova> can you share details about your containers repos testing? that will be useful for people who would like to run containerized OpenStack
16:16:54 <DinaBelova> #link https://review.openstack.org/#/c/295308/
16:17:17 <DinaBelova> still doubt if we do need all *.csv files in raw format
16:17:24 <DinaBelova> 0_0
16:17:40 <DinaBelova> this makes change a bit monstrous
16:17:45 <DinaBelova> listomin what do you think?
16:18:38 <listomin> I believe we need to keep all CSVs because others can use it to perform some calculations. Probably we need to store it in other format
16:19:37 <listomin> As for test results. We have found that we can upload only 5 images at the same time
16:19:45 <DinaBelova> let's probably split the whole change to two: the result+plan and the raw data - and let's rethink where to store this raw data
16:19:52 <listomin> It seems it's limitation in docker 1.10
16:19:54 <DinaBelova> listomin to all of the repos?
16:20:18 <listomin> yep, for each of the repo services
16:20:26 <DinaBelova> ack, it's interesting
16:20:40 <DinaBelova> please keep us updated if that's docker 1.10 or something else
16:20:51 <DinaBelova> if you'll find something out
16:21:12 <listomin> Sure, I've created a place for this note
16:21:19 <listomin> in results
16:22:00 <DinaBelova> ok, so on my side I'm playing with Keystone DB/Cache usage effectiveness - now I have draft result from which I can say that sqlalchemy usage was indeed improved in Mitaka keystone
16:22:17 <DinaBelova> I did not manage to create format test plan yet, going to do it this week
16:22:55 <DinaBelova> #action DinaBelova add keystone testing plan/first results to the performance-docs
16:23:19 <DinaBelova> anything else to cover here?
16:24:00 <DinaBelova> ok, let's proceed
16:24:01 <DinaBelova> #topic OSProfiler weekly update
16:24:30 <DinaBelova> there was bunch of small changes this week
16:24:34 <DinaBelova> related to keystone profiling
16:24:51 <DinaBelova> #info https://review.openstack.org/294515 - Clean thread local profiler object after usage
16:25:01 <DinaBelova> #info https://review.openstack.org/294516 - Add hepler to trace sessions inside _TransactionContextManager
16:25:15 <DinaBelova> #info https://review.openstack.org/294533 - Add possibility to trace _TransactionContext resource
16:25:23 <DinaBelova> #info https://review.openstack.org/294535 - Add DB operations tracing
16:25:40 <DinaBelova> so in fact right now we have argues about #2 and #3
16:25:53 <DinaBelova> in particular where to place this code
16:26:09 <DinaBelova> oslo.db / keystone / osprofiler are possible options for now
16:26:18 <DinaBelova> harlowja_at_home btw please review https://review.openstack.org/294515
16:26:22 <DinaBelova> very funny issue
16:26:42 <harlowja_at_home> yes ma'm
16:27:00 <DinaBelova> harlowja_at_home can you imagine my face when I saw DB operation in the trace on the upper level without any parents in keystone tracing
16:27:01 <DinaBelova> :D
16:27:10 <harlowja_at_home> lol
16:27:13 <harlowja_at_home> i can imagine
16:27:36 <harlowja_at_home> but i don't want to imagine for to long
16:27:38 <harlowja_at_home> lol
16:27:40 <DinaBelova> :D
16:27:45 <DinaBelova> ahaha, that's true
16:28:00 <DinaBelova> so it's 5 lines change that makes game different
16:28:20 <DinaBelova> we did not face it for other projects as they are using greenlets almost everywhere
16:28:33 <DinaBelova> and keystone uses reusable threads pool :)
16:28:50 <DinaBelova> rohanion - any updates on drivers side?
16:31:36 <rohanion> well, none yet
16:32:04 <DinaBelova> rohanion ok, so I suppose you spent time on playing with profiler
16:32:18 <rohanion> but I'm familiar with osprofiler now and I want to merge Dina's commits asap
16:32:26 <harlowja_at_home> DinaBelova, ok, comment added on that review
16:32:38 <harlowja_at_home> merge all my commits asap to :-P
16:32:42 <harlowja_at_home> (in other projects, ha)
16:32:47 <DinaBelova> harlowja_at_home ack - will do
16:32:50 <DinaBelova> :D
16:33:13 <DinaBelova> k, so it looks like that's it for profiler update
16:33:24 <DinaBelova> let's go to the open discussion
16:33:24 <DinaBelova> #topic Open Discussion
16:34:00 <rohanion> i will finish what you've started
16:34:03 <rohanion> http://images.fromupnorth.com/355/566ed31651b13.jpg
16:34:21 <harlowja_at_home> damn DinaBelova u look differerent in that picture
16:34:22 <harlowja_at_home> lol
16:34:24 <DinaBelova> :)
16:34:38 <DinaBelova> harlowja_at_home well you do bot usually see me without makeup :D
16:34:43 <harlowja_at_home> lol
16:35:01 <DinaBelova> we do not have our time slot defined yet for summit
16:35:31 <DinaBelova> although working group sesison was approved, design summit slots are not yet scheduled
16:35:40 <harlowja_at_home> did u guys want someting in oslo?
16:35:42 <harlowja_at_home> https://etherpad.openstack.org/p/newton-oslo-summit-planning
16:35:44 <DinaBelova> so I'll keep you guys updated
16:36:02 <harlowja_at_home> i can try to get one for osprofiler (design summit thing)
16:36:08 <harlowja_at_home> whenever i get to schedule things
16:36:23 <DinaBelova> harlowja_at_home - ack, but I had my proposal already approved
16:36:26 <harlowja_at_home> k
16:36:34 <harlowja_at_home> wellllll let me know
16:36:34 <harlowja_at_home> ha
16:36:34 <DinaBelova> so I think one session will be enough
16:36:39 <DinaBelova> harlowja_at_home sure :F
16:36:42 <DinaBelova> :D
16:37:03 <DinaBelova> harlowja_at_home thanks for the link to oslo newton plans, I'll need to go through it
16:37:12 <harlowja_at_home> k
16:37:12 <harlowja_at_home> np
16:37:21 <DinaBelova> ok, so anything else to cover?
16:37:48 <DinaBelova> ok, cool
16:38:04 <DinaBelova> so thanks everyone (especially harlowja_at_home :D) for attending
16:38:09 <DinaBelova> #endmeeting