16:00:05 <DinaBelova> #startmeeting Performance Team
16:00:09 <openstack> Meeting started Tue May 24 16:00:05 2016 UTC and is due to finish in 60 minutes.  The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:13 <openstack> The meeting name has been set to 'performance_team'
16:00:20 <DinaBelova> hey folks :)
16:00:34 <DinaBelova> let's see how many of us will be around today :)
16:00:45 <hockeynut> \o/
16:01:03 <DinaBelova> AugieMena wow, I'm glad you joined us today :)
16:01:24 <DinaBelova> last time I wanted to ask about one of the action items and missed you :)
16:01:36 <DinaBelova> hockeynut o/
16:01:49 <AugieMena> Dina:  Sorry, wasn't able to make it last time
16:01:59 <DinaBelova> AugieMena np, sir :)
16:02:10 * DinaBelova is glad you're online today :)
16:02:23 <DinaBelova> ok, let's wait for a few moments
16:02:34 <DinaBelova> to give chance everyone interested to join
16:03:03 <DinaBelova> in the meanwhile todays agenda
16:03:03 <rook> heyo!
16:03:06 <DinaBelova> #link https://wiki.openstack.org/wiki/Meetings/Performance#Agenda_for_next_meeting
16:03:09 <DinaBelova> rook o/
16:03:21 <rook> o/
16:04:07 <DinaBelova> k, let's get started
16:04:08 <DinaBelova> #topic Action Items
16:04:27 <DinaBelova> AugieMena so let's start with your promise to share details about some v3 limitations in Rally
16:04:29 <DinaBelova> :)
16:04:58 <DinaBelova> this action item was created on the last meeting before the summit afair
16:04:59 <AugieMena> Sure, basically the issue is captured here:  https://bugs.launchpad.net/rally/+bug/1441379
16:05:00 <openstack> Launchpad bug 1441379 in Rally "Need Rally deployment create support on domain_id or domain_name in order to support keystone v3 test (which needs domain scoped token). The current project scoped token only works in service API but not keystone v3 API (DTUG domain, user, group...)." [Medium,Fix committed]
16:05:12 <DinaBelova> #link https://bugs.launchpad.net/rally/+bug/1441379
16:05:20 <DinaBelova> already fixed!
16:05:28 <DinaBelova> very nice
16:05:32 <AugieMena> hmm, doesn't really seem to address the issue
16:05:46 <DinaBelova> hm?
16:05:58 <AugieMena> that's what we've been trying to work through
16:06:20 <AugieMena> Rally still doesn't have full support for domain-scoped tokens
16:06:28 <DinaBelova> probably because it's not in the newest rally release?
16:06:42 <DinaBelova> or are you using a rally master?
16:06:54 <DinaBelova> boris-42 are you around?
16:06:58 <AugieMena> using rally master
16:07:52 <DinaBelova> interesting, may you please go through the bug once again and reopen it if the issue it should describe is still in place?
16:09:24 <AugieMena> yes, there's been some progress in implementing what we believe is a fix in some of the scenarios, so we'll reopen when we have a good description of the remaining issues an proposed fix
16:09:37 <DinaBelova> ack, thanks
16:09:52 <DinaBelova> ok, let's switch to one more action item we had regarding prioritizing the Networking topologies to go through for the data plane testing
16:09:57 <AugieMena> sure, np
16:10:07 <DinaBelova> I'm talking about the following test plan
16:10:10 <DinaBelova> #link http://docs.openstack.org/developer/performance-docs/test_plans/tenant_networking/plan.html
16:10:22 <DinaBelova> we planned to go through it during Newton timeframe
16:10:35 <DinaBelova> several people put their votes in the https://etherpad.openstack.org/p/newton-performance-team
16:10:37 <DinaBelova> #link https://etherpad.openstack.org/p/newton-performance-team
16:11:06 <DinaBelova> it looks like we'll start with usual Neutron as a baseline, then we have Contrail and Calico to work thorugh
16:11:19 <DinaBelova> and Midokura
16:11:25 <rook> DinaBelova whoever built this, can they add the offloading modes, instead of assuming defaults are the same across distros
16:11:26 <DinaBelova> lezbar are you around?
16:11:51 <lezbar> hi, yes sorry, I'm late
16:11:59 <lezbar> couldn't make it last week
16:12:01 <DinaBelova> rook I guess I'll need to ask you to ping ilyashakhat
16:12:06 <DinaBelova> he's not around today
16:12:13 <DinaBelova> I'll ask him to contact with you
16:12:18 <DinaBelova> for the details
16:12:31 <rook> DinaBelova: ok
16:12:42 <DinaBelova> #action rook ilyashakhat go through the offloading model suggestion
16:13:05 <DinaBelova> lezbar I wanted to ask you about the MidoNet with OVN comparing
16:13:11 * rook has other suggestions but i'll wait for ilyashakhat
16:13:13 <DinaBelova> that you've mentioned in the summit etherpad
16:13:26 <DinaBelova> rook ack
16:13:51 <lezbar> DinaBelova: I haven't started yet since we have been testing on OSIC Lab
16:14:09 <DinaBelova> lezbar ack - may you please start the community part with test plan sharing?
16:14:23 <DinaBelova> to the performance-docs repo?
16:14:48 <DinaBelova> so we can go through the test plan and probably suggest some improvements?
16:15:22 <lezbar> you mean the testplan for the comparison about MidoNet vs OVN, right?
16:15:42 <DinaBelova> yes - so currently we have only one networking related test plan shared
16:15:46 <DinaBelova> that's about dataplane
16:16:01 <DinaBelova> I think your control lpane comparison efforts are worth sharing
16:16:20 <DinaBelova> what do you think?
16:16:42 <DinaBelova> lezbar ?
16:17:03 <lezbar> of course!
16:17:13 <DinaBelova> cool :)
16:17:27 <DinaBelova> lezbar do you think you can prepare test plan review change before next meeting?
16:17:35 <DinaBelova> so nothing too huge
16:17:39 <lezbar> but I have to check our roadmap to see how I can allocate some time to it
16:17:46 <DinaBelova> lezbar cool
16:18:04 <DinaBelova> lezbar so let's assume you'll have this understanding next meeting and share it?
16:18:15 <lezbar> I can try but I cannot commit, since it might not be my decision
16:18:21 <DinaBelova> ack
16:18:43 <lezbar> nice
16:18:55 <DinaBelova> #action lezbar understand if testplan for the comparison about MidoNet vs OVN can be publicly shared
16:19:07 <DinaBelova> and let's see how it'll go
16:19:23 <DinaBelova> ok, so switching to the next topic
16:19:40 <DinaBelova> if nothing needs to be added here :)
16:19:55 <DinaBelova> #topic Current progress on the planned tests
16:20:11 <DinaBelova> so I can share what's going on right now inside Mirantis
16:20:17 <DinaBelova> regarding the planned researches
16:20:36 <DinaBelova> our automatisation for the lab usage is finally mostly in place
16:21:19 <DinaBelova> and listomin and anevenchannyy are going to share several test plans on review next week or so (baseline Rally scenario set we'll be using and Density testing test plan)
16:21:34 <DinaBelova> we're planning to run these ones in Q2
16:21:57 <DinaBelova> as well as the dataplane tests we've mentioned http://docs.openstack.org/developer/performance-docs/test_plans/tenant_networking/plan.html
16:22:21 <DinaBelova> also first steps in 1000 nodes emulation were done
16:22:39 <DinaBelova> we emulated 1000 nodes using containerised env only on 20 nodes
16:22:52 <DinaBelova> the same experiment on 240 physical machines is also planned
16:23:16 <DinaBelova> and we'll run baseline rally tests against it as well to see how control plane will behave
16:23:25 <DinaBelova> on 20 nodes we could do only PoC
16:23:33 <DinaBelova> lab was busy that time :)
16:23:53 <DinaBelova> so 3-4 test plans are going to be published next week or so - stay tuned
16:24:27 <DinaBelova> dataplane tests are currently already in progress
16:24:44 <DinaBelova> all others are planned to be started in a week
16:25:03 <DinaBelova> if no issues will appear with lab usage, automation, etc.
16:25:23 <DinaBelova> I do not see ad_rien_
16:25:37 <DinaBelova> so sadly  I cannot ask him about his 0MQ experiments
16:25:55 <DinaBelova> let's move this question to the next meeting
16:26:06 <DinaBelova> any questions?
16:26:27 <hockeynut> just getting up to speed here :-)
16:27:53 <DinaBelova> hockeynut ok, let's spend some time in the Open Discussion topic to become aquatinted
16:27:58 <DinaBelova> become acquainted*
16:28:07 <hockeynut> sure!
16:28:18 <DinaBelova> ok, so moving forward to the OSprofiler part
16:28:24 <DinaBelova> #topic OSProfiler weekly update
16:29:16 <DinaBelova> Neutron change has been merged :)
16:29:19 <DinaBelova> #link https://review.openstack.org/#/c/273951/
16:29:55 <DinaBelova> so we're left with Nova and Keystone DB calls profiling to be merged to cover all main OpenStack services
16:30:04 <DinaBelova> I think that's pretty cool :)
16:30:22 <DinaBelova> I'll need to do some housekeeping to make it happen for Nova
16:30:40 <DinaBelova> like adding several nice helpers in osprofiler itself, but still
16:30:58 <DinaBelova> btw thanks regXboi for finalizing the Neutron change!
16:31:13 <DinaBelova> it's super cool to return from the vacation and see this patch landed :D
16:31:47 <DinaBelova> it took 28 patch sets and tones of discussions but it was worth it :)
16:32:06 <regXboi> :)
16:32:24 <DinaBelova> as for the drivers part - changes are still on review
16:32:26 <DinaBelova> #link https://review.openstack.org/#/q/status:open+project:openstack/osprofiler+branch:master+topic:multi-backend-support
16:32:41 <DinaBelova> rohanion is fighting through the comments :D
16:33:07 <DinaBelova> so that's still thing in progress, although I would say progress is significant
16:33:24 <DinaBelova> I think I have no more updates around the profiler so far
16:33:58 <DinaBelova> k, going forward
16:34:01 <DinaBelova> #topic Open Discussion
16:34:12 <DinaBelova> hockeynut hey new person :)
16:34:25 <hockeynut> greetings - we met briefly at the summit
16:34:35 <hockeynut> I work @ Rackspace, in OSIC doing QE/QA
16:34:43 <DinaBelova> ok, so what was your real name? :)
16:34:54 <DinaBelova> to map person to the IRC nick
16:34:55 <DinaBelova> ЖВ
16:34:56 <DinaBelova> :D
16:34:57 <hockeynut> LOL - Steve Heyman
16:35:01 <DinaBelova> oh yeah
16:35:09 <DinaBelova> nice to meet you sir here :)
16:35:18 <hockeynut> ditto
16:35:25 <DinaBelova> anything you'd love to share with wider audience?
16:35:32 <DinaBelova> probably around your work?
16:36:09 <hockeynut> just getting started with the performance aspect here
16:36:13 <DinaBelova> ack, cool
16:36:29 <DinaBelova> btw, /me still did not check SpecCloud
16:36:33 <hockeynut> looking at things like time-series performance data for rally
16:36:38 <DinaBelova> still in my todo list
16:37:06 <DinaBelova> ok, cool :)
16:37:10 <bsilverman> DinaBelova, what about ironic testing :)
16:37:33 <DinaBelova> bsilverman a-ha, I need to check it with the Ironic team
16:37:42 <DinaBelova> as this research is leaded by them
16:37:51 <DinaBelova> and frankly speaking i forgot about it at all
16:37:53 <DinaBelova> >_<
16:37:59 <DinaBelova> bsilverman thanks for the reminding
16:38:26 <bsilverman> DinaBelova, it is a project that seems to be gaining momentum in the last quarter, thats why I bring it up.
16:38:33 <DinaBelova> #action DinaBelova check about Ironic scale and performance testing effort progress with Mirantis Ironic team
16:38:33 <bsilverman> DinaBelova, np
16:38:58 <DinaBelova> bsilverman that's true - in fact i know some researches were done by Mirantis Ironic team already, but I missed the result in fact
16:39:04 <DinaBelova> lemme check it and share next week
16:39:19 <DinaBelova> good catch
16:39:33 <bsilverman> Lots of challenges there still but by Newton they should have a way to connect tenant networks to bare metal and then it will be part of the E/W testing.
16:39:50 <DinaBelova> bsilverman btw how are you sir and what's your current focus?
16:41:26 <bsilverman> DinaBelova, I am doing well, trying to get situated in new company. Current focus at my job, or in general?
16:41:46 <DinaBelova> your current focus in terms of performance WG :)
16:42:06 <DinaBelova> as you changed the company I wonder what you're interested in right now :)
16:42:29 <DinaBelova> I know previously 1000 nodes testing was #1 priority for you, I just want to know what might be interesting for you now
16:42:50 <bsilverman> Ahhh, actually I'm looking to help wherever we need it.
16:43:31 <DinaBelova> ok, so nothing specific so far - please ping me if something will make specific interest for you
16:43:33 <bsilverman> I have no "focus" per se now since I've changed, Mike/Bryan haven't brought any scale efforts out here.
16:43:43 <DinaBelova> bsilverman ack
16:43:54 <DinaBelova> just to be sure :)
16:44:05 <bsilverman> DinaBelova, is there any particular area that needs focus?
16:44:31 <DinaBelova> bsilverman nothing that's not mentioned in the https://etherpad.openstack.org/p/newton-performance-team I believe
16:44:54 <bsilverman> DinaBelova, okay, I'll follow up with you offline, I need to send you my new contact info anyway.
16:45:00 <DinaBelova> bsilverman ack
16:45:15 <DinaBelova> ok, so I have no more specific things to be discussed
16:45:24 <DinaBelova> anything you'd love to go through folks?
16:46:10 <DinaBelova> if no, I saved 15 minutes of your life and you have some coffee time freed :)
16:46:58 <DinaBelova> it looks like nothing specific
16:47:09 <DinaBelova> bye! have a nice day/evening :)
16:47:15 <AugieMena> bye :)
16:47:17 <lezbar> bye o/
16:47:19 <DinaBelova> #endmeeting