15:59:41 <DinaBelova> #startmeeting Performance Team
15:59:41 <openstack> Meeting started Tue Aug 16 15:59:41 2016 UTC and is due to finish in 60 minutes.  The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:59:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:59:45 <openstack> The meeting name has been set to 'performance_team'
15:59:49 <DinaBelova> ok, so let's get started :)
16:00:00 <DinaBelova> before we jump to the main part - quick announcement
16:00:27 <DinaBelova> today I have very limited time slot for this meeting, so I need to fit this meeting to 30 minutes
16:00:58 <DinaBelova> sadly I have no variant and found it out about 10 minutes ago, so had no chance to make proper email announcement
16:01:05 <DinaBelova> really sorry for this
16:01:13 <DinaBelova> so let's try to keep it quick
16:01:22 <DinaBelova> #topic Action Items
16:01:29 <DinaBelova> as for action items
16:02:11 <DinaBelova> rcherrueau, msimonin - I really believe that https://review.openstack.org/#/c/254703/41 patch set of Nova profiling can be used against mitaka
16:02:42 <msimonin> ok, cool we'll have a look this week
16:02:43 <DinaBelova> this is the most freshest rebase of this code after mitaka OpenStack mitaka release was cut
16:03:25 <DinaBelova> so you can refer to this particular code version with refs/changes/03/254703/41 branch of https://git.openstack.org/openstack/nova project
16:03:41 <DinaBelova> this should be ok, but please let me know in case of any issues
16:04:13 <rcherrueau> DinaBelova: ok thank you
16:04:23 <DinaBelova> rcherrueau you are welcome
16:04:29 <DinaBelova> regarding second action item - estimating contrail profiling out of Neutron code using osprofiler - sadly I had no opportunity to go through this
16:04:36 <DinaBelova> rohanion did you have a chance?
16:05:19 <rohanion> nope. I was busy with meetings and reading Fuel docs
16:05:39 <DinaBelova> rohanion ack, so let's keep this action item till next meeting
16:05:49 <DinaBelova> #action 1. DinaBelova rohanion check how can we estimate contrail profiling out of Neutron code using osprofiler
16:05:59 <DinaBelova> ok, that's all regarding action items
16:06:20 <DinaBelova> hope next time we'll provide some updates about this action ^^
16:06:32 <DinaBelova> so let's jump to the next topic
16:06:34 <DinaBelova> #topic Current progress on the planned tests
16:07:00 <DinaBelova> from Mirantis side we had bunch of HW problems on both (!) of our test labs (250 and 500 nodes)
16:07:46 <DinaBelova> therefore we do not have much progress on the extended Neutron scale testing (basically, no openstack installed yet against 250 nodes) and we have just fixed 500 nodes together with Intel engineers
16:08:02 <DinaBelova> so baseline performance testing is only upcoming for 500 nodes
16:08:32 <DinaBelova> if nothing critical will appear this week, I'll provide more meaningful update next week regarding Mirantis testing :)
16:08:41 <DinaBelova> rcherrueau msimonin - do you have something to share folks?
16:09:02 <msimonin> We are fixing some scalability issues we have
16:09:24 <msimonin> like tuning apache / neutron
16:09:33 <DinaBelova> #info No many updates from Mirantis side this week - HW issues faced of both testing labs. Right now 500 nodes lab seems to be fixed -> baseline 500 nodes performance testing upcoming
16:10:10 <DinaBelova> #info update from Inria: scalability issues fixing is in progress (e.g. tuning apache/neutron)
16:10:22 <DinaBelova> msimonin so no active testing has been start yet, am I right?
16:10:38 <msimonin> DinaBelova:  not yet
16:10:51 <DinaBelova> msimonin ack, fully understand the challenge you're facing
16:10:55 <DinaBelova> :)
16:10:55 <msimonin> yep :)
16:11:35 <DinaBelova> ok, so let's hope (:D) both Mirantis and Inria are going to have some progress this week, otherwise I'm truly going to go mad :D
16:12:04 <msimonin> We hope so
16:12:13 <msimonin> DinaBelova: one question regarding your experiment
16:12:18 <DinaBelova> msimonin sure
16:12:42 <msimonin> Why are you going to make  another experiment with several VM perserver instead of using the fake driver ?
16:13:34 <DinaBelova> msimonin this time we want to run also some basic dataplane tests (like tenant networking stuff), and this require real VMs to be on the lab
16:14:32 <msimonin> DinaBelova ack, ok I see
16:14:38 <ad_rien_> Hi folks
16:14:50 <ad_rien_> DinaBelova:  just to be sure, are you still using kolla for this experiment ?
16:15:03 <ad_rien_> (i.e. the one with real VMs)
16:15:08 <DinaBelova> + we're going to run extended rally suit (not just VM boot and delete) against virtual 1000 nodes, so really operational VMs are crucial to understand the comparative time between real VM creation
16:15:35 <DinaBelova> ad_rien_ - most probably we'll run 1000 nodes emulation with VMs, not containers. Although it's still up to decide by engineering team
16:16:45 <DinaBelova> ad_rien_ we have kolla folks inside mirantis, so they are going to consult us on various aspects
16:16:58 <ad_rien_> DinaBelova:  ack, we had an exchange last week with kolla persons and they strongly encouraged us to deploy first vms and then kolla on top of this virtual infrastructure (i.e. embedded VMs)
16:17:07 <DinaBelova> and we'll find out what version will be more appropriate regarding the time line we need to fit to
16:17:17 <DinaBelova> ad_rien_ interesting
16:17:29 <DinaBelova> do you have some notes from this conversation?
16:17:54 <DinaBelova> I'd go through it with great interest
16:18:03 <DinaBelova> ad_rien_ ^^
16:18:11 <ad_rien_> I'm wondering how such a testbed is representative to conduct performance evaluations (we have to discuss that on the Inria side but we have some doubts for instance if you want to boot several VMs
16:18:23 <DinaBelova> indeed
16:18:55 <DinaBelova> in my opinion containers on top of VMs sounds a bit strange
16:19:02 <ad_rien_> so we need to discuss and confirm from our side if doing in such a manner is correct. Maybe this can be  ok for some test but completely wrong for tohers.
16:19:21 <ad_rien_> DinaBelova:  exactly we share the same viewpoint
16:19:21 <DinaBelova> ad_rien_ ok, please keep us updated
16:19:44 <ad_rien_> the same from your side ;)
16:19:46 <DinaBelova> so lemme jump to the next topic (s said, really sorry, but I have to go in 10 minutes)
16:19:50 <DinaBelova> ad_rien_ ack :D
16:19:57 <DinaBelova> #topic Performance docs update
16:20:08 <ad_rien_> rcherrueau:  may I ask you to copy/paste the link to the kolla irc discussion
16:20:19 <DinaBelova> during previous week several changes making life easier were merged
16:20:26 <DinaBelova> some updates
16:20:47 <rcherrueau> ad_rien_: I'm on it, wait a minute
16:21:05 <DinaBelova> #info 1) all index pages with test plans / test results are auto generated right now -> no rebase hell will be met next merge party
16:21:29 <DinaBelova> #info 2) I've updated several test plans and results to fit each other and present real plans statuses
16:22:07 <DinaBelova> #info 3) one more important change making navigation easier https://review.openstack.org/#/c/354251/ is on review, think final version will be born later today
16:22:28 <DinaBelova> rcherrueau thank you sir, please post it with the #link starting
16:22:30 <rcherrueau> ad_rien_: DinaBelova: https://htmlpreview.github.io/?https://raw.githubusercontent.com/wiki/BeyondTheClouds/Wiki/misc/openstack-kolla-20160810.html?token=ABPby6x3q8PxX9vt_bF0loSdIHyOLo1Xks5XtGctwA%3D%3D
16:22:38 <ad_rien_> #link https://htmlpreview.github.io/?https://raw.githubusercontent.com/wiki/BeyondTheClouds/Wiki/misc/openstack-kolla-20160810.html?token=ABPby6x3q8PxX9vt_bF0loSdIHyOLo1Xks5XtGctwA%3D%3D
16:22:38 <DinaBelova> #link https://htmlpreview.github.io/?https://raw.githubusercontent.com/wiki/BeyondTheClouds/Wiki/misc/openstack-kolla-20160810.html?token=ABPby6x3q8PxX9vt_bF0loSdIHyOLo1Xks5XtGctwA%3D%3D
16:22:41 <DinaBelova> :D ahaha
16:22:43 <DinaBelova> ok :)
16:22:46 <rcherrueau> ad_rien_: DinaBelova: https://htmlpreview.github.io/?https://raw.githubusercontent.com/wiki/BeyondTheClouds/Wiki/misc/openstack-kolla-20160810.html?token=ABPby6x3q8PxX9vt_bF0loSdIHyOLo1Xks5XtGctwA%3D%3D
16:22:46 <rcherrueau> 
16:22:46 <rcherrueau> 
16:22:46 <rcherrueau> [Mar aoĆ» 16 2016]
16:22:51 <rcherrueau> *** You have joined channel #openstack-performance                      [17:57]
16:22:54 <rcherrueau> *** Topic for #openstack-performance: OpenStack performance discussions -
16:22:57 <rcherrueau> testing, bottlenecks, etc. Performance-related changes on review -
16:23:00 <rcherrueau> https://etherpad.openstack.org/p/perf-zoom-zoom (tools, bottlenecks, etc.)
16:23:00 <rcherrueau> *** #openstack-performance: topic set by DinaBelova!~DinaBelov@frostman.ru,
16:23:01 <DinaBelova> thank you sir :)
16:23:03 <rcherrueau> 2015-11-16 20:18:03
16:23:06 <rcherrueau> *** Users on #openstack-performance: rcherrueau hieulq_ hockeynu_ luzC
16:23:10 <rcherrueau> msimonin markvoelker rfolco bvanhav v12aml f13o bwallis harlowja dims
16:23:11 <DinaBelova> wow
16:23:15 <rcherrueau> furlongm rook kragniz Cassowary itsuugo rpodolyaka afranc bapalm_
16:23:18 <rcherrueau> meteorfox serverascode malos openstackgerrit ggherdov- Anticimex doffm sai
16:23:21 <rcherrueau> linuxgeek lmiccini cgross HenryG klindgren notmyname xek__ amit213 quasar
16:23:21 <rcherrueau> DuncanT anevenchannyy ishant|away boris-42 ossifrath fyxim bogdando
16:23:24 <rcherrueau> beisner med_ mikal yarkot1 kun_huang alaski
16:23:26 <DinaBelova> ahaha, stop this :)
16:23:28 <rcherrueau> *** Users on #openstack-performance: andreykurilin__ dimtruck mgagne toan
16:23:32 <rcherrueau> yarkot SpamapS dmitryme openstack andreaf @ChanServ johnthetubaguy
16:23:35 <rcherrueau> DinaBelova odyssey4me haukebruno
16:23:38 <rcherrueau> *** #openstack-performance modes: +cnt
16:23:41 <rcherrueau> *** #openstack-performance was created on 2015-10-29 14:36:44
16:23:45 <rcherrueau> *** aignatyev (b00f7a2b@gateway/web/freenode/ip.176.15.122.43) has joined
16:23:48 <rcherrueau> channel #openstack-performance                                      [17:58]
16:23:51 <rcherrueau> <DinaBelova> rcherrueau, bvanhav, aignatyev o/                          [17:59]
16:23:51 <rcherrueau> <rcherrueau> hello
16:23:53 <rohanion> shit
16:23:54 <rcherrueau> <msimonin> hi
16:23:57 <rcherrueau> <aignatyev> hi
16:24:03 <rohanion> what's happening?
16:24:08 <msimonin> wrong copy/paste ?
16:24:14 <DinaBelova> rohanion msimonin yep :D
16:24:34 <DinaBelova> rcherrueau found the only way to stop it - leave IRC really quick :)
16:24:39 <beisner> lol, hi all ;-)
16:24:44 <DinaBelova> :D
16:24:47 <msimonin> lol
16:25:04 <DinaBelova> ok, so it looks like we may jump to the osprofiler update section
16:25:05 <DinaBelova> #topic OSProfiler weekly update
16:25:11 <DinaBelova> rohanion any updates?
16:25:15 <DinaBelova> rcherrueau it was fun
16:25:23 <rcherrueau> I'm really sorry, my emacs goes wrong
16:25:33 <rohanion> hm. IRC plugin for emacs?
16:25:38 <rcherrueau> Did you see my link
16:25:44 <rcherrueau> rohanion: yep
16:25:47 <DinaBelova> #info from my side I can congratulate everyone with new 1.4.0 osprofiler release
16:25:51 <DinaBelova> rcherrueau yep, it was ok
16:25:54 <rohanion> available on MELPA?
16:26:24 <DinaBelova> rohanion rcherrueau can you please discuss plugins *after* a meeting? :)
16:26:32 <rohanion> sure
16:26:32 <DinaBelova> we have only few minutes left :)
16:26:35 <rcherrueau> sure
16:26:37 <DinaBelova> ok, cool
16:26:42 <rohanion> DinaBelova: I've discussed with performance team what do they want from osprofiler
16:26:59 <DinaBelova> rohanion ok, can you provide some list of must have things?
16:27:00 <rohanion> they came up with 2 ideas
16:28:02 <rohanion> 1. InfluxDB driver - will be very helpful. they can aggregate data with grafana using native data from InfluxDB
16:29:02 <rohanion> 2. Fuel plugin for OSprofiler - changes the osprofiler section in cluster's config files, specifies the connection string and HMAC secret key
16:30:07 <rohanion> so I've spent a whole day yesterday learning how to create a fuel plugin
16:30:25 <DinaBelova> rohanion thank you sir for the udpate
16:30:35 <DinaBelova> folks, I have to run right now
16:30:38 <DinaBelova> to the next meeting
16:30:42 <DinaBelova> I'm really sorry
16:31:17 <DinaBelova> thanks rcherrueau rohanion msimonin for coming!
16:31:31 <DinaBelova> thanks ad_rien_
16:31:32 <DinaBelova> #endmeeting