15:30:05 <DinaBelova> #startmeeting Performance Team
15:30:06 <openstack> Meeting started Tue Nov 29 15:30:05 2016 UTC and is due to finish in 60 minutes.  The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:09 <openstack> The meeting name has been set to 'performance_team'
15:30:17 <DinaBelova> ok, hello folks :)
15:30:27 <DinaBelova> let's find out who's around :)
15:30:32 <ad_rien_> o/ hi DinaBelova
15:30:37 <DinaBelova> o/
15:31:42 <DinaBelova> akrzos?
15:31:47 <DinaBelova> are you here?
15:32:19 <akrzos> DinaBelova: hello
15:32:24 <DinaBelova> yay :)
15:32:39 <msimonin> o/
15:32:44 <DinaBelova> o/ ok, let's get started, probably someone will join later
15:32:50 <DinaBelova> #topic Action Items
15:32:59 <DinaBelova> let's go through action items first
15:33:18 <DinaBelova> #link http://eavesdrop.openstack.org/meetings/performance_team/2016/performance_team.2016-11-22-15.30.html
15:33:27 <DinaBelova> as for the one on ad_rien_ - that was completed, thank you
15:33:36 <ad_rien_> you're welcome
15:34:05 <DinaBelova> akrzos any ideas when  OpenStack telemetry test plan will land to performance-docs?
15:34:21 <akrzos> I intend on having that commit in before the end of the week
15:34:30 <akrzos> i started it last week just need to wrap it up
15:34:49 <DinaBelova> akrzos ack, lemme keep action item for you for one more week :)
15:34:57 <akrzos> thanks
15:35:07 <DinaBelova> #action akrzos publish OpenStack telemetry team plan to performance-docs
15:35:17 <DinaBelova> ok, as for the action item on me
15:35:43 <DinaBelova> @msimonin in fact we published the original version of grafana dashboards already
15:35:47 <DinaBelova> lemme share the links
15:36:00 <DinaBelova> #link https://grafana.net/dashboards/932
15:36:11 <DinaBelova> #link  https://grafana.net/dashboards/938
15:36:18 <DinaBelova> #link  https://grafana.net/dashboards/941
15:36:34 <DinaBelova> that was an original version, now they have been changed
15:36:39 <msimonin> Great ! they look awesome :)
15:36:40 <DinaBelova> ans not (yet) updated
15:36:44 <DinaBelova> msimonin :)
15:36:58 <DinaBelova> msimonin mostly more system data will be added
15:37:07 <akrzos> I should probably contribute our dashboards but they are evolving over time so best to deploy via our ansible framework
15:37:11 <DinaBelova> all others won't change that much
15:37:24 <DinaBelova> akrzos indeed, the same situation
15:37:30 <DinaBelova> our boards are changing now
15:37:41 <DinaBelova> so that was an original first version
15:38:03 <DinaBelova> okay, it looks like we may proceed
15:38:18 <DinaBelova> #topic Current progress on the planned tests
15:38:29 <DinaBelova> msimonin can you continue? :)
15:39:02 <DinaBelova> with the current progress?
15:39:06 <msimonin> sure,
15:39:19 <msimonin> Not so much was done during the week
15:39:52 <msimonin> actually we are in a rush about the enos paper (deadline tomorrow)
15:40:06 <msimonin> we integrated shaker in it
15:40:19 <msimonin> for the record :
15:40:36 <msimonin> #link https://github.com/BeyondTheClouds/enos
15:40:44 <msimonin> is our performance evaluation framework
15:41:39 <ad_rien_> white paper should be available by the end of the week hopefully
15:41:46 <DinaBelova> yeah, good luck guys with finishing work on the documentation
15:41:46 <msimonin> =)
15:42:11 <DinaBelova> it's usually hard enough to make it clear and technical at the same time :)
15:42:39 <msimonin> So I think it's pretty much all from our side
15:42:50 <DinaBelova> thank you
15:42:51 <DinaBelova> akrzos anything from you sir? probably something to share about current experiments and progress on Browbeat?
15:43:26 <akrzos> I'm in progress on adding SSL/TLS public endpoints comparsion dashboards in kibana
15:43:48 <DinaBelova> wow, good thing to add
15:44:07 <DinaBelova> any links to the patch sets?
15:44:22 <akrzos> so you can run browbeat against a cloud without SSL/TLS and then again with it and then compare via kibana
15:44:33 <akrzos> https://review.openstack.org/#/c/403906/
15:44:41 <DinaBelova> #link https://review.openstack.org/#/c/403906/
15:44:43 <DinaBelova> thank you
15:46:18 <DinaBelova> ok, from Mirantis side not too many updates this week. Monitoring task is still in progress, we're trying to cover as much measurements as possible. we're preparing several environments for the kubernetes tests now, and trying to deploy huge (~900 nodes) OpenStack cluster on top of k8s
15:46:44 <DinaBelova> and there were several issues in our k8s config, so we had to fix it before going further
15:47:17 <DinaBelova> as fuel-ccp uses affinity and anti-affinity k8s placement features, we're observing issues with scheduling performance
15:47:31 <msimonin> scheduling performance of kubernetes ?
15:47:35 <DinaBelova> yep
15:47:46 <DinaBelova> if affiniti/anti-affiniti is used
15:47:56 <DinaBelova> or, sorry, affinity*
15:48:15 <msimonin> interesting
15:48:15 <DinaBelova> our k8s team is trying to figure our what's going on
15:48:32 <DinaBelova> well, on smaller envs this is not something we're observing
15:48:37 <msimonin> does it perform the scehduling at the end or just fails ?
15:48:55 <DinaBelova> it performs, just the speed is really crazy
15:49:04 <DinaBelova> like 5 seconds for one pod scheduling
15:49:22 <DinaBelova> that's not a good idea when you're having thousands on pods :)
15:49:38 <msimonin> Do you know if Openstack scheduling is better on this area ?
15:50:01 <msimonin> I'm just curious
15:50:14 <DinaBelova> msimonin well, we never tried experiments with affinity/anti-afifnity in openstack
15:50:26 <DinaBelova> so no clue frankly speaking
15:50:44 <msimonin> DinaBelova:  ack
15:51:07 <DinaBelova> so that's basically all from my side
15:51:13 <DinaBelova> it was kinda a debug week
15:51:35 <DinaBelova> it looks like we may proceed to the open discussion
15:51:48 <DinaBelova> #topic Open Discussion
15:51:57 <DinaBelova> ad_rien_ any thoughts about PTG?
15:52:07 <ad_rien_> nothing more than last week
15:52:16 <ad_rien_> I would like to make progress within the other WGs
15:52:27 <ad_rien_> (NFV and Massively distributed)
15:52:32 <DinaBelova> ack, got it
15:52:42 <ad_rien_> If we succeed to define concrete experiement scenarios
15:52:56 <ad_rien_> with the two other WGs, then it may make sense to arrange a face to face meeting
15:53:08 <ad_rien_> so I would prefer to wait a bit more
15:53:15 <DinaBelova> ad_rien_ ack
15:53:36 <ad_rien_> is there any strong deadline for requesting f-2-f meeting room ?
15:54:07 <DinaBelova> ad_rien_ they were all requested already  - otherwise the PTG location won't be chosen :)
15:54:17 <DinaBelova> so right now there is combo request from Rally / performance team
15:54:35 <ad_rien_> :)
15:54:44 <ad_rien_> ok
15:55:22 <DinaBelova> akrzos we're talking about possible meeting in PGT (Atlanta) - do you think it can be a good idea to have face to face meeting there? we can discuss different tools roadmaps - including rally and browbeat for instance
15:56:30 <akrzos> DinaBelova: I don't have too much to add to this discussion at this point, I'd have to find out if we have the budget etc to go
15:56:39 <DinaBelova> akrzos ack
15:56:42 <DinaBelova> thank you sir
15:56:46 <akrzos> np
15:57:06 <DinaBelova> ok, so it let's see if we'll have such meeting :)
15:57:15 <DinaBelova> in fact that's all from my side
15:57:18 <DinaBelova> any questions/
15:57:20 <DinaBelova> ?
15:57:49 <DinaBelova> it looks like nope
15:57:54 <ad_rien_> not from our side I guess
15:57:55 <DinaBelova> thank you folks
15:57:58 <ad_rien_> thanks
15:58:00 <DinaBelova> #endmeeting