15:30:57 <DinaBelova> #startmeeting Performance Team
15:30:58 <openstack> Meeting started Tue Dec 13 15:30:57 2016 UTC and is due to finish in 60 minutes. The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:59 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:31:01 <openstack> The meeting name has been set to 'performance_team'
15:31:10 <DinaBelova> hey folks o/
15:31:24 <msimonin> o/
15:31:27 <vbala> hi
15:31:31 <rcherrueau> o/
15:31:50 <DinaBelova> let's wait for a couple of moments
15:32:00 <DinaBelova> and see if someone else is gonna join
15:32:52 <DinaBelova> ok, so let's get started
15:33:00 <DinaBelova> today we have no action items to cover
15:33:09 <DinaBelova> so we may jump to the tests section
15:33:14 <DinaBelova> #topic Current progress on the planned tests
15:33:21 <DinaBelova> msimonin the floor is yours :)
15:33:50 <msimonin> ok
15:33:52 <msimonin> :)
15:34:07 <msimonin> So we are progressing on multisite deployment
15:34:14 <msimonin> multiregion I mean
15:34:51 <DinaBelova> how many regions are you planning to have now?
15:35:06 <msimonin> we now have a first version of the deployment script that allows multiregion deployment and latencies enforcement
15:35:18 <msimonin> it's still under discussion
15:35:24 <DinaBelova> ack :)
15:35:38 <msimonin> basically we will evaluate different scenario of distribution of openstack services
15:35:56 <msimonin> multiregion is one scenario possible since it's supported by Openstack by default
15:36:47 <msimonin> another example would be to put every control services somewhere and compute far from them
15:36:59 <msimonin> far in term of latencies and bandwidth
15:37:15 <DinaBelova> yeah, it looks interesting - I think you can try to use shaker to evaluate this
15:37:21 <msimonin> Sure !
15:37:25 <DinaBelova> :)
15:37:35 <msimonin> By the way I answered to Ilya in the ml
15:37:49 <DinaBelova> ack - personally I did not take a look
15:37:56 <DinaBelova> I need to check it
15:37:57 <DinaBelova> thanks
15:38:03 <msimonin> What is preferable, answering in the ml or answering in gerrit ?
15:38:14 <DinaBelova> gerrit is ok :)
15:38:24 <DinaBelova> and less official :D
15:38:29 <msimonin> even for prospective discussion ?
15:38:40 <msimonin> ah ok :)
15:38:52 <DinaBelova> well, in fact you can try whatever variant is ok for you :)
15:39:23 <DinaBelova> ok, anything else to share?
15:39:30 <msimonin> By the way I've uploaded the whitepaper to hal.inria.fr
15:39:44 <msimonin> The link should be ok
15:39:48 <msimonin> Let me check
15:40:02 <msimonin> #link https://hal.inria.fr/hal-01415522
15:40:12 <DinaBelova> ack, I see it
15:40:14 <DinaBelova> thanks
15:40:23 <msimonin> cool
15:41:00 <msimonin> This doesn't include multisite consideration yet
15:41:16 <DinaBelova> sure, you just started :)
15:41:24 <spn> o/
15:41:27 <DinaBelova> spn o/
15:42:12 <DinaBelova> msimonin anything else sir?
15:42:24 <msimonin> I think that's all
15:42:27 <msimonin> I have
15:42:30 <DinaBelova> ack, thank you
15:42:35 <DinaBelova> ok, from Mirantis side we're still collecting issues we observed so far in one place
15:43:00 <spn> are these issues posted somewhere ?
15:43:14 <DinaBelova> and proceeding with workloads testing - so the basic idea is to have bunches of VMs (slices) having different apps installed on each one
15:43:22 <DinaBelova> like magento, wordpress, etc
15:43:36 <DinaBelova> and run these apps specific traffic aganst those VMs
15:43:57 <DinaBelova> and see through monitoring how the overall health of the cloud looks like
15:44:10 <DinaBelova> on all layers - system, k8s, OpenStack
15:44:21 <DinaBelova> right now env deployment is in progress :)
15:44:49 <DinaBelova> I guess in December we should have several results to share
15:45:09 <DinaBelova> and published to performance docs
15:45:16 <DinaBelova> I'll keep you folks updated on this
15:45:30 <DinaBelova> for now that's all from my side
15:45:40 <DinaBelova> spn not yet sir
15:45:45 <DinaBelova> as we're collecting them so far
15:45:48 <msimonin> I think I forgot, what is your monitoring stack ?
15:45:54 <msimonin> prometheus + ?
15:46:03 <DinaBelova> msimonin prometheus + collectd + telegraf
15:46:17 <DinaBelova> and grafana for visualization
15:46:20 <msimonin> DinaBelova: ack
15:46:23 <msimonin> thanks
15:46:34 <DinaBelova> sure
15:47:02 <DinaBelova> do we have akrzos here?
15:47:26 <DinaBelova> any news sir regarding the tests / experiments running in Red Hat? :)
15:47:26 <akrzos> Hello
15:47:28 <akrzos> I'm here
15:47:48 <akrzos> I have hardware to run Telemetry Scale with Ceph now
15:47:53 <DinaBelova> yay! :)
15:48:00 <akrzos> so I have begun some experiements with it
15:48:24 <DinaBelova> #info akrzos has started experiments with new HW for Telemetry Scale with Ceph
15:48:26 <akrzos> I beleive I'll be able to share results in the performance-docs repo when I complete it
15:48:36 <DinaBelova> akrzos thanks, good to know
15:48:44 <DinaBelova> I guess LDT folks will be really happy :)
15:48:55 <spn> dinabelova just wondering what is is your backend for grafana?
15:49:28 <DinaBelova> spn need to check, don't know for sure :) that part was done by one of my teammates, will double check
15:49:54 <DinaBelova> #action DinaBelova check what grafana backend is Mirantis using
15:49:55 <akrzos> I thought you guys had influx and promotheus
15:50:18 <DinaBelova> oh, spn did you mean where do we collect data?
15:50:26 <DinaBelova> yeah, akrzos is right
15:50:36 <akrzos> or the actuall database that grafana uses I beleive is sqlite
15:50:46 <spn> ya like graphite-whisper, influx innodb etc
15:50:47 <akrzos> (stores dashboards, snapshots)
15:51:22 <DinaBelova> spn, yeah that should be influx with prometheus-specific data
15:51:35 <spn> I had problems with whisper not retaining more than a year worth of data
15:51:44 <spn> dinabelova that sounds good
15:51:45 <akrzos> spn: I'm using a carbon/graphite/whispher with collectd (collection)
15:52:28 <spn> akrzos me too same but grafana does not shown if the data is too old and is on whisper
15:52:52 <DinaBelova> interesting, akrzos do you observe the same?
15:52:56 <akrzos> spn: perhaps your storage schema expires after ~180 days?
15:53:13 <akrzos> ex storage schema - https://github.com/openstack/browbeat/blob/master/ansible/install/roles/graphite/files/storage-schemas.conf#L16
15:53:24 <akrzos> 1 hour for 180days
15:53:26 <spn> akrzos thanks I will look at that
15:53:49 <spn> can that retention be like forever?
15:54:12 <akrzos> you'll have to whispher re-size to get your metrics to stick around longer if you want to keep what you already have and create a "larger" schema
15:54:25 <akrzos> spn: so whispher allocates upfront
15:54:42 <akrzos> so you can't really configure "forever"
15:55:03 <akrzos> we have been debating switching out of grpahite because of this similiarlly
15:55:42 <akrzos> i can discuss our reasoning why but don't want to take over the meeting!
15:55:55 <spn> akrzos I agree
15:56:01 <DinaBelova> ack :) thank you folks
15:56:18 <DinaBelova> it looks like we may smoothly go to the next item
15:56:25 <DinaBelova> #topic New core position in OSprofiler
15:56:37 <DinaBelova> this might be interesting for tovin07__
15:56:38 <DinaBelova> :)
15:56:49 <DinaBelova> we have new core position in OSprofiler
15:56:50 <tovin07__> oh
15:56:56 <DinaBelova> congratulations vbala :)
15:57:09 <DinaBelova> so tovin07__ - more reviews are going to come :)
15:57:10 <vbala> thanks :)
15:57:18 <tovin07__> congratulations vipin
15:57:30 <tovin07__> DinaBelova: yes
15:57:31 <DinaBelova> vbala has been really active in osprofiler in last several months
15:57:41 <DinaBelova> #link http://stackalytics.com/?user_id=vbala&module=osprofiler&metric=marks
15:57:42 <vbala> thanks tovin07__
15:57:50 <DinaBelova> #link http://stackalytics.com/?user_id=vbala&module=osprofiler&metric=commits
15:58:09 <DinaBelova> so that's good thing to have him having core reviewers rights now
15:58:22 <DinaBelova> vbala I'll add you to the Gerrit core reviewers group today
15:58:39 <vbala> ok
15:58:39 <DinaBelova> #info vbala has become a new core reviewer in OSProfiler
15:59:06 * tovin07__ feel so promising
15:59:11 <DinaBelova> vbala and from my side - I'm really glad you're joining me :)
15:59:14 <DinaBelova> tovin07__ ;)
16:00:00 <DinaBelova> I guess that was a small congratulations topic with no much comments to be added :)
16:00:09 <DinaBelova> so we may go to open discussion
16:00:16 <tovin07__> +1
16:00:17 <DinaBelova> #topic Open Discussion
16:00:29 <DinaBelova> any topics for cover olks?
16:00:33 <DinaBelova> folks***
16:00:43 <DinaBelova> msimonin akrzos vbala ?
16:00:57 <msimonin> One small thing
16:01:07 <akrzos> I may have forget to mention I uploaded a json grafana dashboard a week or two ago into grafana.net for any other to use
16:01:09 <DinaBelova> sure
16:01:20 <DinaBelova> akrzos link please :)
16:01:25 <spn> thats nice
16:01:34 <spn> i am living on grafana these days.
16:01:38 <akrzos> DinaBelova: https://grafana.net/dashboards/1021
16:01:46 <DinaBelova> #link https://grafana.net/dashboards/1021
16:02:01 <DinaBelova> #info Grafana board used by akrzos ^^
16:02:18 <DinaBelova> msimonin what did you want to mention sir?
16:02:19 <msimonin> I just received a mail asking to upload the slides for the Barcelona summit presentation
16:02:31 <spn> akrzos can you share the collectd.conf as well ?
16:02:49 <msimonin> You should have received it as well
16:02:56 <DinaBelova> msimonin interesting :) did not notice it
16:02:57 <msimonin> I can upload the slides
16:03:09 <DinaBelova> msimonin can you send me please an email topic?
16:03:13 <DinaBelova> and feel free to upload slides for sure
16:03:19 <msimonin> If it's fine with you and alex
16:03:39 <DinaBelova> yes, sure, from whom was the email? from OpenStack folks?
16:03:45 <msimonin> DinaBelova: Important Speaker Information for OpenStack Summit in Barcelona, Spain
16:03:53 <DinaBelova> ack, lemme check
16:04:00 <akrzos> Yeah i got one too
16:04:05 <msimonin> from OpenStack Speaker Support team (do-not-reply@openstack.org)
16:04:11 <DinaBelova> oh, I see
16:04:17 <DinaBelova> sure, please upload the lides
16:04:22 <DinaBelova> slides***
16:04:27 <msimonin> ok I'll do it
16:04:39 <DinaBelova> thank you sir :)
16:04:57 <DinaBelova> yeah, I got this email about 30 minutes ago :)
16:05:00 <DinaBelova> whn meeting has started
16:05:06 <DinaBelova> so I did not see it :)
16:05:56 <DinaBelova> akrzos going back to spn 's question - can you share the collectd.conf you're using?
16:07:11 <DinaBelova> it looks like akrzos was lost in sending the slides :)
16:07:44 <msimonin> DinaBelova: uploaded ours :)
16:07:52 <DinaBelova> msimonin ack
16:08:21 <akrzos> sorry back
16:08:24 <DinaBelova> #action akrzos check if collectd.conf can be shared to complete the monitoring picture (request from spn)
16:08:29 <DinaBelova> ah :)
16:08:30 <akrzos> it should be attached
16:08:33 <akrzos> to grafana.net
16:08:42 <DinaBelova> spn ^^
16:09:01 <spn> yes. I just saw it. sorry for the noise
16:09:05 <akrzos> no worries
16:09:12 <DinaBelova> ok, anything else folks?
16:09:39 <DinaBelova> it looks like we're done for today
16:09:48 <DinaBelova> thanks everyone for joining
16:09:53 <DinaBelova> #endmeeting