15:30:01 <DinaBelova> #startmeeting Performance Team
15:30:01 <openstack> Meeting started Tue Jan 31 15:30:01 2017 UTC and is due to finish in 60 minutes.  The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:04 <openstack> The meeting name has been set to 'performance_team'
15:30:13 <DinaBelova> hello folks :)
15:30:21 <DinaBelova> spn is here already :)
15:30:28 <spn> o/
15:30:45 <tovin07> hello o/
15:30:58 <DinaBelova> akrzos tovin07 rook o/
15:31:08 <akrzos> o/
15:31:21 <rook> o/
15:31:23 * tovin07 in a vacation…
15:31:33 <msimonin1> o/
15:31:46 <DinaBelova> tovin07 msimonin1 o/
15:31:49 <DinaBelova> tovin07 ack :)
15:32:23 <DinaBelova> ok, so let's get started with the action items
15:32:30 <DinaBelova> #topic Action Items
15:32:38 <DinaBelova> #link http://eavesdrop.openstack.org/meetings/performance_team/2017/performance_team.2017-01-24-15.30.html
15:32:43 <DinaBelova> last time we had a bunch of them
15:33:13 <DinaBelova> rook let's start with yours regarding Neutron API Performance results
15:33:27 <rook> They are complete, just need to create the rst
15:33:29 <rook> and ship it!
15:33:48 <DinaBelova> rook yay! :) cool, will leave as an action item for the next time
15:34:05 <DinaBelova> #action rook add Neutron API Performance results to performance docs
15:34:34 <DinaBelova> msimonin don't you know status of ad_rien 's action item?
15:34:50 <DinaBelova> regarding the info about OpenStack in a WAN context presentation
15:35:16 <msimonin> yes
15:35:27 <msimonin> sorry my client has some issues
15:35:32 <spn> is the method of neutron perf is also included inthe doc?
15:35:44 <DinaBelova> np sir
15:35:46 <msimonin> DinaBelova: we wrote a proposal
15:35:52 <msimonin> I can share the link
15:36:06 <DinaBelova> yes please, I think it'll be interesting for people here
15:36:23 <msimonin> https://pad.inria.fr/p/sfBMUvWOpKtmfXT8
15:36:55 <DinaBelova> msimonin thanks
15:37:15 <DinaBelova> so lemme create an action item at least on myself to review it - probably I canleave some comments
15:37:24 <msimonin> cool thanks !
15:37:26 <DinaBelova> #action DinaBelova review https://pad.inria.fr/p/sfBMUvWOpKtmfXT8
15:37:41 <DinaBelova> and of course everybody else is also welcome to do so as well :)
15:38:00 <DinaBelova> ok, so regarding my action items
15:38:13 <DinaBelova> I've reviewed sai 's and akrzos 's changes
15:38:30 <DinaBelova> akrzos I belive if no more comments will appear I'll merge it in  a few days
15:38:38 <DinaBelova> as right now it looks good to me
15:38:40 <akrzos> sounds good
15:39:05 <akrzos> sizes on images looks much better, also now i know how to view the preview of it :)
15:39:07 <DinaBelova> regarding workloads testing status I wanted to share last week
15:39:15 <DinaBelova> akrzos ;)
15:39:47 <DinaBelova> sadly our Intel co-dev partners yet do not add clarity on what can be shared and what's not
15:40:29 <DinaBelova> moreover, it might be a chance that we (Mirantis team) won't be able to use those tests at all (after ~month of working on them)
15:40:40 <DinaBelova> I hope some clarity will appear this week, but no updates here so far
15:40:50 <DinaBelova> so I'll leave action item untouched
15:40:59 <DinaBelova> #action DinaBelova share status of workloads testing methodology/results sharing
15:41:20 <DinaBelova> and regarding last action item - https://review.openstack.org/#/c/294535/ was merged to keystone :)
15:41:31 <DinaBelova> so that's a good news
15:41:54 <tovin07> yes
15:42:11 <DinaBelova> it looks like we may jump to the next section
15:42:30 <DinaBelova> #topic Current progress on the planned tests
15:42:36 <DinaBelova> msimonin - the floor is yours :)
15:42:49 <msimonin> ok
15:42:50 <msimonin> :)
15:43:07 <msimonin> To follow up the proposal we have
15:43:42 <msimonin> We discussed with Pierre Riteau (from chameleon cloud) to join the presentation
15:44:49 <msimonin> Second thing is that we have made some validation on using Traffic Control to emulate the delay/bw between nodes
15:44:56 <msimonin> the first set of results are promising
15:45:36 <msimonin> the idea was to check if the way we enfore networkj constraints is consistent with what we expect when using tools like flent
15:46:17 <msimonin> Some people were actually interested in this feature
15:46:32 <DinaBelova> how were the initial results?
15:46:48 <msimonin> let me link some summary of them
15:46:56 <DinaBelova> sure
15:47:10 <msimonin> #link https://github.com/BeyondTheClouds/enos/issues/48
15:47:56 <DinaBelova> ok, thank you sir
15:48:22 <msimonin> so we wanted to make sure that we got the same latency/bw constraints for the dataplane
15:48:29 <DinaBelova> akrzos would you like to share anything?
15:48:50 <DinaBelova> msimonin yeah, I see
15:48:55 <akrzos> I'm working on Gnocchi Rally plugins that i'd like to contribute to upstream rally at some point
15:49:23 <akrzos> that is in conjunction with a test plan for scaling further with telemetry services
15:49:24 <DinaBelova> akrzos good news for Rally :)
15:49:41 <DinaBelova> Andrei (Rally PTL) loves things being upstreamed :)
15:50:14 <akrzos> I know i just want to make sure what i put together is easy to use/consume before publishing elsewhere
15:50:26 <akrzos> and does what i expect :)
15:50:29 <DinaBelova> ack
15:50:52 <DinaBelova> akrzos I've shared your results with LDT lead, but strangely no response yet. I'll double check if I used the right contact, but t was right :)
15:50:54 <akrzos> but idea is to show that Gnocchi is responsive at the high loads vs the older cielometer
15:51:10 <akrzos> yeah I met Matt at the last Summit
15:51:41 <DinaBelova> akrzos I'll keep you updated if I'll be able to ping him using other channels
15:52:09 <akrzos> ok cool
15:52:20 <akrzos> do you kno wif LDT has a PTG function/event?
15:52:31 <DinaBelova> akrzos thanks
15:53:24 <DinaBelova> ok, from Mirantis side we're switching a bit back to k8s itself (from containerized OpenStack on top of it) - we'd like to measure the limitations of k8s control plane to find out how is it responsive with high resource density
15:53:33 <DinaBelova> akrzos I don't know about it if so
15:53:45 <akrzos> ok cool no worries
15:53:52 <DinaBelova> I believe some folks will attend, but not as an organized group
15:54:29 <DinaBelova> going back to our tests - we're going to prepare the environment somewhen this week
15:54:30 <DinaBelova> and get started with it
15:54:48 <DinaBelova> at some point we'll switch back to OpenStack on top of k8s
15:55:45 <DinaBelova> spn btw I've tsarted the initiative of pushing Intel folks
15:55:53 <DinaBelova> to try SPEC cloud benchmark
15:56:33 <DinaBelova> Intel is big, so people I'm usually working with and people working on SPEC are not the same :D even not the same department :D
15:56:38 <DinaBelova> so it goes slow
15:56:39 <spn> DinaBelova: thats good
15:57:08 <DinaBelova> but I think there might be a good chance to agree on something
15:57:16 <DinaBelova> spn will keep you updated
15:57:21 <spn> I am using spec fulltime and I can help folks onboard if needed :)
15:57:38 <DinaBelova> spn thank you sir :)
15:57:45 <spn> This is more of real life use case based performance
15:57:56 <DinaBelova> I'll keep you updated regarding status of the discussion
15:57:58 <spn> DinaBelova: yw
15:58:29 <DinaBelova> anything else to cover before going to open discussion?
15:58:55 <DinaBelova> ok, so let's proceed
15:58:56 <DinaBelova> #topic Open Discussion
15:59:02 <spn> earlier I had this question abou the neutron performance rook was mentioning. Is there a document I can read to understand the process of performance
15:59:29 <DinaBelova> rook can you please give a link to the test plan?
16:00:57 <DinaBelova> tovin07 I've reviewed bunch of your changes to osprofiler
16:01:13 <DinaBelova> thank you for lots of improvements :)
16:01:19 <tovin07> yes, np
16:01:28 <DinaBelova> some yet left on review, I believe I'll go through them this week
16:01:34 <tovin07> thanks :D
16:02:28 <DinaBelova> spn I believe rook will send you a link once he'll be back :)
16:02:41 <spn> DinaBelova: sure
16:03:23 <DinaBelova> just a reminder - the call for speakers for OpenStack summit ends on Feb 6th
16:03:42 <DinaBelova> so please do not forget to propose your presentations if there is a wish to
16:03:55 <DinaBelova> anything else to cover?
16:04:29 <DinaBelova> it looks like we're done for today :)
16:04:37 <DinaBelova> thanks everyone for attending :)
16:04:44 <DinaBelova> bye o/
16:04:47 <akrzos> thanks
16:04:51 <DinaBelova> #endmeeting