15:31:31 <DinaBelova> #startmeeting Performance Team
15:31:32 <openstack> Meeting started Tue Mar 21 15:31:31 2017 UTC and is due to finish in 60 minutes.  The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:31:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:31:36 <openstack> The meeting name has been set to 'performance_team'
15:31:42 <DinaBelova> hey folks!
15:31:48 <tovin07_> hi o/
15:31:54 <DinaBelova> let's see who's around :)
15:32:38 <DinaBelova> akrzos rook o/
15:32:54 <rook> around :)
15:33:02 <DinaBelova> :D cool :)
15:33:20 <DinaBelova> I see none from Inria for now, probably they won't be able to attend
15:33:30 <DinaBelova> in the meanwhile let's go through action items
15:33:35 <DinaBelova> #topic Action Items
15:33:42 <DinaBelova> the first one was on myself
15:34:01 <DinaBelova> tovin07_ I've contacted Vipin - he's in the middle of relocation to US now
15:34:14 <DinaBelova> but he'll be working on osprofiler in future as well
15:34:42 <tovin07_> yes, good news :D
15:34:43 <DinaBelova> so he's going to continue being active after some time
15:35:08 <DinaBelova> tovin07_ one more action item was on you
15:35:09 <DinaBelova> regarding "evaluate what needs to be done to add result of the function or sql evaluation in the *-stop part of osprofiler trace"
15:35:13 <DinaBelova> any news here?
15:35:24 <tovin07_> Yes
15:35:32 <DinaBelova> please go ahead
15:35:34 <tovin07_> This week, I’m working on that
15:35:55 <tovin07_> Plan to push some information later this week
15:36:04 <DinaBelova> tovin07_ ack
15:36:12 <DinaBelova> lemme keep this action item for next week as well
15:36:19 <tovin07_> Yup
15:36:27 <DinaBelova> #action tovin07_ evaluate what needs to be done to add result of the function or sql evaluation in the *-stop part of osprofiler trace
15:36:36 <DinaBelova> also one more action item was on msimonin
15:36:39 <tovin07_> rcherrueau: o/
15:36:42 <rcherrueau> o/
15:36:43 <DinaBelova> but I do not see him here
15:36:48 <DinaBelova> rcherrueau o/
15:37:08 <DinaBelova> rcherrueau don't you know status of msimonin action item?
15:37:09 <DinaBelova> that was about "ping Rally PTL regarding adding osprofiler support to rally code base"
15:37:41 <rcherrueau> I don't think he did it, sorry about that
15:37:46 <DinaBelova> it's ok
15:37:52 <DinaBelova> lemme keep it for the next week as well
15:37:59 <DinaBelova> #action msimonin ping Rally PTL regarding adding osprofiler support to rally code base
15:38:16 <DinaBelova> ok. so we're done with action items
15:38:23 <DinaBelova> #topic Current progress on the planned tests
15:38:28 <DinaBelova> rcherrueau any news?
15:38:52 <rcherrueau> Yes one
15:39:31 <rcherrueau> msimonin did an OpenStack provider for enos, the tool we develop for measuring OpenStack
15:39:46 <rcherrueau> it means we can deploy an OpenStack over an OpenStack
15:40:03 <spn> o/
15:40:34 <DinaBelova> rcherrueau just curious - for what use case specifically? I guess there might be lots of reasons but still :)
15:40:37 <rcherrueau> and then measure it. He did it because we are currently working on Chameleon testbed
15:41:09 <DinaBelova> rcherrueau ok, gotcha
15:41:10 <rcherrueau> Chameleon is a testbed provided by university of Chicago
15:41:32 <rcherrueau> and Chameleon is operated though an OpenStack
15:41:44 <rcherrueau> through*
15:42:17 <rcherrueau> that's all for our side
15:42:23 <DinaBelova> ack, thanks
15:43:09 <DinaBelova> rook any updates from RedHat? :) we all are curious if akrzos was able to puch Gnocchi margins further :)
15:44:18 <DinaBelova> it looks like rook went afk for a while :)
15:44:24 <rook> DinaBelova: I have been head down doing a scale deployment in CNCF
15:44:33 <DinaBelova> rook wow
15:45:01 <akrzos> DinaBelova: wrt to Gnocchi
15:45:08 <DinaBelova> what scale are we talking about?
15:45:13 <akrzos> I'm working with Ocata bits and intend on getting another test ruig setup
15:45:23 <akrzos> s/ruig/rig/
15:45:33 <akrzos> in the near future
15:45:36 <akrzos> before Summit
15:45:37 <rook> DinaBelova Install and OpenStack scale -- and OpenShift on OpenStack scale
15:45:39 <DinaBelova> akrzos ack, thank you sir
15:45:52 <DinaBelova> rook wow, huge task
15:45:53 <akrzos> i have a question though
15:45:56 <akrzos> wrt to Rally
15:46:05 <akrzos> Gnocchi is moving out of big tent
15:46:12 <DinaBelova> rook good luck man :) those tasks are usually really tricky :)
15:46:20 <DinaBelova> akrzos oh, interesting
15:46:24 <DinaBelova> did not know about this
15:46:25 <akrzos> will it still be able to sit inside rally or will rally no longer want it if it's not in OpenStack Big Tent?
15:47:09 <DinaBelova> akrzos please ping andreykurilin about this
15:47:15 <DinaBelova> akrzos in #openstack-rally channel
15:47:55 <DinaBelova> akrzos btw, don't you know the details?
15:47:55 <akrzos> ok will do
15:48:05 <DinaBelova> why gnocchi is moving out from BT?
15:48:35 <akrzos> they are looking toget more contributors and it's not glued to OpenStack
15:48:48 <akrzos> meaning you can deploy it outside of OpenStack
15:48:50 <openstackgerrit> Oleg Basov proposed openstack/performance-docs master: Influx HA as an external storage for Prometheus  https://review.openstack.org/442020
15:49:05 <akrzos> let me fine the mail message
15:49:23 <DinaBelova> akrzos ok, thanks - it looks like I missed the announcement about this
15:50:17 <akrzos> #link http://lists.openstack.org/pipermail/openstack-dev/2017-March/114300.html
15:50:23 <DinaBelova> akrzos thanks
15:50:36 <akrzos> np
15:51:13 <DinaBelova> ok, from mirantis side - no many updates from me today. we still have all k8s and containerized openstack related activities in progress. this is going to be a long process anyway :D so we're working through the deployment issues and test cases for now
15:51:39 <DinaBelova> and frankly speaking that's all from my side for now
15:52:05 <DinaBelova> it looks like we may jump to open discussion
15:52:06 <DinaBelova> #topic Open Discussion
15:52:14 <rook> how is the performance of containerized services?
15:52:19 <rook> big differences?
15:53:08 <DinaBelova> rook I won't say so
15:53:14 <DinaBelova> sometimes we observed issues, but they were related more to the networking setup
15:53:37 <rook> the virt networking?
15:53:53 <rook> or do you guys pass the networking stack to the container?
15:54:19 <tovin07_> from OSprofiler, patches in Zun were merged last week
15:54:19 <tovin07_> I’m continue to work with other patches
15:54:27 <DinaBelova> sometimes we observed slow container creation and scheduling on scale, but that's more about k8s and docker, it needs to be cooked right
15:54:33 <DinaBelova> rook indeed
15:54:44 <DinaBelova> we're experimenting with Calico networking mostly
15:55:09 <DinaBelova> due to the fact that was a request from our k8s team
15:55:51 <DinaBelova> rook and it's having several setup options that are use-case specific, OpenStack is indeed very specific applicaiotn
15:55:59 <rcherrueau> rook: @inria, we have a PhD student on that specific topic. Her first work was on VM, in particular, the impact of I/O with and without virtio. She recently start a same job with container. Hope I can link to her conclusion soon.
15:56:01 <DinaBelova> tovin07_ thanks
15:56:29 <DinaBelova> rcherrueau that is going to be a good research, are you planning to share it in community?
15:57:15 <rcherrueau> Yes, of course, but she has, first, to publish in a scientific conference.
15:57:53 <DinaBelova> rcherrueau cool, please give us links once they will be available :)
15:58:07 <rcherrueau> I will do
15:58:14 <DinaBelova> thanks
15:58:27 <DinaBelova> anything else to cover today? we had fast meeting :)
15:58:32 <tovin07_> besides, DinaBelova, did you discuss with vipin about proposing me as core contributor in OSprofiler?’
15:58:49 <DinaBelova> tovin07_ sadly nope, Vipin is not that available those days due to the relocation
15:59:09 <DinaBelova> will make sure it'll happen this week anyway
15:59:14 <DinaBelova> tovin07_ don't worry :)
15:59:26 <tovin07_> seems like he’s very busy
15:59:37 <rcherrueau> DinaBelova: There will be a dedicated slot for performance WG at Boston?
15:59:41 <tovin07_> Okay, thanks :D
16:00:08 <DinaBelova> rcherrueau it's not going to be a usual summit where some design sessions were held
16:00:27 <DinaBelova> so that's going to be only main, presentation / market place part of the summit
16:00:27 <rcherrueau> DinaBelova: maybe a Forum
16:00:39 <DinaBelova> rcherrueau nope, for now it's not planned
16:00:52 <rcherrueau> DinaBelova: Ok thanks
16:01:09 <DinaBelova> although we still can hand somewhere to discuss most recent stuff in person anyway
16:01:15 <DinaBelova> hang*
16:01:33 <DinaBelova> it looks like we're done for today
16:01:45 <DinaBelova> thanks everyone for participating
16:01:50 <tovin07_> thanks
16:01:54 <DinaBelova> #endmeeting