15:30:00 <DinaBelova> #startmeeting Performance Team
15:30:00 <openstack> Meeting started Tue Apr 25 15:30:00 2017 UTC and is due to finish in 60 minutes.  The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:04 <openstack> The meeting name has been set to 'performance_team'
15:30:11 <DinaBelova> hello folks :)
15:30:15 <DinaBelova> let's see who is around
15:30:20 <tovin07_> o/
15:30:28 <DinaBelova> tovin07 akrzos msimonin1 o/
15:31:04 <DinaBelova> tovin07 let's see if we're alone today or nope :)
15:31:05 <rcherrueau> o/
15:31:08 <DinaBelova> rcherrueau yay
15:31:12 <DinaBelova> hello sir
15:31:20 <rcherrueau> hello
15:31:36 <msimonin1> o/
15:31:40 <DinaBelova> I think we need to get started with the people who are right here
15:31:43 <DinaBelova> #topic Action Items
15:31:52 <DinaBelova> rcherrueau I'm going to be annoying right now :)
15:32:01 <DinaBelova> rcherrueau any updates on your action item sir? :)
15:32:26 <DinaBelova> regarding publishing WAN-centric OpenStack testing methodology?
15:32:50 <rcherrueau> DinaBelova: Still focusing on the experimentation. We got some results but it's too soon to write a testing methodology
15:33:01 <DinaBelova> rcherrueau ack, thank you sir
15:33:06 <DinaBelova> lemme keep it for now
15:33:14 <DinaBelova> #action rcherrueau add OpenStack testing under networking delays (e.g. multisite deployment) methodology to performance docs (openstack under WAN)
15:33:21 <DinaBelova> we did not have any other action items
15:33:24 <DinaBelova> so let's proceed
15:33:26 <rcherrueau> (And I do not really have the time to write it right now!)
15:33:34 <DinaBelova> #topic Current progress on the planned tests
15:33:45 <DinaBelova> rcherrueau sure :) how is your summit preparaiton going?
15:34:06 <DinaBelova> anything to share on current progress today?
15:34:06 <rcherrueau> We do nice progress
15:34:39 <rcherrueau> Lets take a look at the sequence diagram we automatically generated based on an OSProfiler trace
15:34:48 <rcherrueau> #link https://github.com/rcherrueau/osp-utils/blob/master/tests/rsc/out.svg
15:35:04 <rcherrueau> It is based on an `openstack server create`
15:35:17 * DinaBelova looking
15:35:36 <rcherrueau> blue links are rest call, green ones are rpc call and blacks are python call
15:35:58 <rcherrueau> we did that using the parser I presented last time.
15:36:08 * DinaBelova trying to enlarge the image somehow :D
15:36:15 <msimonin> :)
15:36:20 <rcherrueau> We have a small query language that lets us filter and fold some trace on a predicate
15:36:29 <rcherrueau> DinaBelova: you should use inkscape
15:36:32 <msimonin> you'll maybe have to wget it and open it with a svg viewer
15:36:57 <DinaBelova> yeah, I got it :)
15:37:15 <DinaBelova> was it run with some networking delay?
15:37:46 <rcherrueau> We produces several traces with different delay
15:37:54 <rcherrueau> produced*
15:38:04 <tovin07_> whao, it’s so large
15:38:12 <DinaBelova> yeah it is :) it should
15:38:16 <DinaBelova> although looks really well
15:38:25 <DinaBelova> I mean the chart itself
15:38:29 <DinaBelova> rcherrueau good work
15:38:37 <rcherrueau> But the time to accomplish a call is missing on the sequence diagram
15:38:51 <rcherrueau> any way, this give you a good vision of the workflow
15:39:05 <DinaBelova> true
15:39:37 <rcherrueau> We will present this at the summit, with a focus on rest and rpc call
15:40:00 <DinaBelova> rcherrueau it's sad I won't be able to attend :( I'll have to look on the recording
15:40:11 <rcherrueau> yes sure
15:40:37 <DinaBelova> okay, it looks like we don't have RehHat folks presented today...
15:41:23 <DinaBelova> from Mirantis side we're trying new deployment tool (Mirantis Cloud Platform, MCP) on our small environments and working on making those deployments automated against our envs - so mostly preparation work for now
15:41:46 <DinaBelova> anything else to add in "current progress" or we can move to open discussion?
15:42:12 <DinaBelova> it looks like we can :)
15:42:18 <DinaBelova> #topic Open Discussion
15:42:24 <DinaBelova> tovin07 please go ahead
15:42:26 <tovin07_> o/
15:42:34 <tovin07_> [tovin07] Rally + OSprofiler spec: https://review.openstack.org/#/c/456278/
15:42:38 <tovin07_> rcherrueau: thanks
15:42:39 <tovin07_> :D
15:43:00 <rcherrueau> tovin07_: you are welcome
15:43:03 <DinaBelova> tovin07 congrats on the merged spec :)
15:43:05 <tovin07_> Andrey has a spec for your nee
15:43:09 <tovin07_> *nee
15:43:12 <tovin07_> *need
15:43:55 <msimonin> tovin07: will you work on it ?
15:44:00 <msimonin> do you need help ?
15:44:31 <tovin07_> oh yes, I’ll work on it (somehow), andrey is main asignee for that task
15:45:04 <msimonin> let us know we can at least review part of it :)
15:45:05 <tovin07_> I think that I can help. Anw, if you guys can help, that’s awesome
15:45:11 <msimonin> ok
15:45:32 <msimonin> From our side, we'll have more time after the summit
15:45:41 <tovin07_> +1
15:46:02 <rcherrueau> Speaking about OSProfiler, do you manage to get a trace that includes glance events?
15:46:25 <rcherrueau> In all traces I produced, glance is always missing and I don't know why.
15:46:25 <tovin07_> glance events?
15:46:34 <tovin07_> Oh
15:46:41 <tovin07_> I know that issue
15:46:43 <rcherrueau> osprofiler event for glance
15:46:50 * tovin07_ getting link
15:47:20 <DinaBelova> is osprofiler included to the grance api extensions  pipeline by default?
15:47:29 * DinaBelova does not remember
15:47:30 <rcherrueau> DinaBelova: yes it is
15:47:33 <tovin07_> #link Glance events is not showed because of this patch https://review.openstack.org/#/c/316799/
15:48:01 <DinaBelova> tovin07_ oh ok, so we need this patch landed
15:48:33 <rcherrueau> tovin07_: OK thanks. Any advice here to remove this patch?
15:48:59 <DinaBelova> rcherrueau I suspect you need to add this patch :)
15:49:08 <DinaBelova> tovin07_ am I wrong?
15:49:08 <tovin07_> you have to use ceilometer + rabbitmq + panko as driver for OSprofiler to avoid this patch
15:49:09 <rcherrueau> Oh, I get wrong I have to apply it :D
15:49:42 <rcherrueau> tovin07_: OK, in our deployment we go with mongo. This is why.
15:49:42 <DinaBelova> :)
15:49:53 <tovin07_> rcherrueau: yup
15:50:02 <tovin07_> that’s why :D
15:50:25 <tovin07_> okie, let’s move to the next item
15:50:36 <DinaBelova> +1
15:50:41 <tovin07_> [tovin07] Integrate OSprofiler into Ceilometer, Swift (hope it will be landed in Pike)
15:51:05 <tovin07_> I will continue to work to integrate OSprofiler to other OpenStack projects in Pike
15:51:31 <tovin07_> Speaking of Ceilometer, DinaBelova, do you have any idea for that?
15:52:01 <DinaBelova> tovin07_ I'm out of Ceiloemter for a while, so I suspect it's all new for me now
15:52:15 <tovin07_> hmm, that’s sad :(
15:52:54 <tovin07_> Anw, I want to inform that to you guys. I’ll try to do those things.
15:52:57 <DinaBelova> tovin07_ I supect that it's going to be quite challenging with all new aodh, panko, gnocchi, etc.
15:53:05 <DinaBelova> tovin07_ thank you so much for your effort
15:53:22 <tovin07_> At the first step, just try with Ceilometer first
15:53:47 <DinaBelova> tovin07_ and the last item - I see you've added OpenTracing item
15:53:52 <tovin07_> yes
15:53:56 <DinaBelova> can you please dig to some details here?
15:54:02 <tovin07_> [tovin07] Make OSprofiler compatible with OpenTracing API
15:54:13 <tovin07_> #link OpenTracing: http://opentracing.io/
15:54:26 <tovin07_> $link OpenTracing Specification: https://github.com/opentracing/specification/blob/master/specification.md
15:54:36 <tovin07_> #link OpenTracing Specification: https://github.com/opentracing/specification/blob/master/specification.md
15:55:29 <tovin07_> TL;DR: I saw that OpenTracing is becomming the standard for distributed tracing for now (OpenTracing is a member of CNCF)
15:56:32 <tovin07_> Uber Jaeger, Google Dapper, Twitter Zipkin, LightStep, Hawkular,… etc have the same philosophy with OSprofiler in OpenStack
15:56:58 <DinaBelova> tovin07_ true
15:57:02 <DinaBelova> tovin07_ do you want to implement this API in osprofiler?
15:57:12 <tovin07_> recently, Google publish this https://cloudplatform.googleblog.com/2017/04/distributed-tracing-for-Go.html
15:57:32 <tovin07_> DinaBelova: I have a draft plan for the implementation
15:57:48 <DinaBelova> tovin07_ really cool, I think it's gonna to be a great approach
15:57:50 <tovin07_> I think it will be awsome for us
15:57:55 <DinaBelova> +1
15:57:58 <tovin07_> *awesome
15:58:28 <DinaBelova> tovin07_ can you please share his draft plan?
15:58:33 <DinaBelova> his -> this
15:58:35 <tovin07_> becaus we can display OSprofiler trace in other UI, not just OSprofiler HTML output
15:58:42 <tovin07_> DinaBelova: yes
15:59:16 <tovin07_> I will publish it in launchpad this week and hope that you guys can review it to make it better
15:59:24 <DinaBelova> tovin07_ ack, thank you sir
15:59:51 <DinaBelova> tovin07_ thanks for lots of interesting discussion topics today
16:00:01 <tovin07_> rcherrueau, msimonin: I hope that you can help in this task (testing, reviewing, comment,...)
16:00:09 <msimonin> sure
16:00:12 <rcherrueau> Yes, with pleasure
16:00:20 <tovin07_> :D
16:00:34 <rcherrueau> going with an open standard is always a good idea.
16:00:34 <DinaBelova> okay, one more moment
16:00:35 <tovin07_> That’s all from my side for this week
16:00:39 <DinaBelova> that I wanted to cover
16:00:58 <DinaBelova> I won't be able to attend next week meeting, and the week after next is OpenStack suummit
16:01:08 <DinaBelova> does it make sense for us to skip next 2 weeks?
16:01:21 <tovin07_> rcherrueau, msimonin?
16:01:30 <tovin07_> I’m OK with it :D
16:01:36 <rcherrueau> I have a lot to focus on, so this is ok for me
16:02:08 <msimonin> it's ok from my side
16:02:10 <DinaBelova> ok, so let's do it
16:02:16 <tovin07_> +1
16:02:35 <DinaBelova> #info we're skipping next two meetings, next one will be on May 16th
16:02:58 <tovin07_> ack
16:02:58 <DinaBelova> thanks everyone!
16:02:59 <DinaBelova> #endmeeting