15:30:03 <DinaBelova> #startmeeting Performance Team
15:30:04 <openstack> Meeting started Tue May 16 15:30:03 2017 UTC and is due to finish in 60 minutes.  The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:07 <openstack> The meeting name has been set to 'performance_team'
15:30:19 <DinaBelova> hello folks!
15:30:35 <DinaBelova> msimonin akrzos tovin07 o/
15:30:46 <tovin07> hello o/
15:31:07 <DinaBelova> I was hoping to have Boston-summit related conversation today
15:31:18 <DinaBelova> to collect opinions from people who were able to attend
15:31:39 <msimonin> hello
15:32:20 <DinaBelova> let's wait for a few more moments
15:32:37 <DinaBelova> #topic Action Items
15:32:46 <DinaBelova> last time we had only one action item
15:33:06 <DinaBelova> on rcherrueau
15:33:15 <DinaBelova> msimonin any news about when OpenStack testing under networking delays (e.g. multisite deployment) methodology is going to be proposed to performance docs?
15:33:56 <msimonin> I guess rcherrueau is taking some rest after the summit
15:34:19 <tovin07> or may be jetlag :)
15:34:23 <msimonin> I know he started before the submit but was a bit busy to finish it
15:34:33 <DinaBelova> msimonin ack, I think I'll still keep this action item - will ping rcherrueau once he'll be back
15:34:35 <msimonin> yeah jetlag definitely
15:34:42 <DinaBelova> #action rcherrueau add OpenStack testing under networking delays (e.g. multisite deployment) methodology to performance docs (openstack under WAN)
15:34:48 <msimonin> yes let's keep it, I can actually help on this
15:35:06 <DinaBelova> msimonin ack, thanks you
15:35:07 <DinaBelova> #topic Boston summit: people's impression, sessions, etc.
15:35:08 <DinaBelova> msimonin can you share your opinion?
15:35:14 <DinaBelova> and links to the session video :)
15:35:21 <msimonin> I didn't attend this time :(
15:35:30 <DinaBelova> oh, sorry
15:35:33 <msimonin> np :)
15:35:45 <DinaBelova> I thought you were taking part together with rcherrueau :)
15:36:01 <msimonin> _ad_rien_ was
15:36:02 <DinaBelova> ok, so it looks like we have no people today, who were attending in person :)
15:36:11 <DinaBelova> looks like everyone is resting after the summit
15:36:32 <DinaBelova> msimonin but I do not see him in the IRC channel as well :)
15:37:14 <DinaBelova> #info it looks like people who were attending the summit won't be presented today on the meeting
15:37:25 <DinaBelova> ok, so let's skip this discussion till next time
15:37:37 <DinaBelova> #topic Open Discussion
15:37:48 <DinaBelova> it looks like today it's going to be really quick session :D
15:37:52 <tovin07> yes
15:37:52 <DinaBelova> tovin07 anything to share?
15:38:19 <rama_y__> Hi tovin07, DinaBelova
15:38:23 <DinaBelova> rama_y__ o/
15:38:35 <tovin07> currently, I’m still working on Swift + OSprofiler and OpenTracing compatible for OSprofiler
15:38:38 <tovin07> hi rama_y__
15:39:01 <tovin07> that’s all
15:39:16 <DinaBelova> tovin07 ok, thank you sir, please keep us updated
15:39:24 <DinaBelova> msimonin anything to share from your side?
15:40:00 <msimonin> We'll be ready for this I think :
15:40:10 <msimonin> #link  https://review.openstack.org/#/c/456278/1/doc/specs/in-progress/osprofiler.rst
15:40:31 <msimonin> We maybe need to discuss with tovin07
15:40:40 <tovin07> yes sir
15:40:41 <DinaBelova> msimonin sure, please go ahead
15:40:56 <msimonin> I know that rcherrueau has a quick and dirty patch for this
15:41:07 <msimonin> It's maybe time to clean the thing :)
15:41:30 <tovin07> that’s good news
15:41:41 <msimonin> so tovin07 do you plan to work on this or do you let us take this ?
15:41:58 <msimonin> It's up to you actually, I think we can put some effort on this
15:42:05 <tovin07> oh, I think I will help on reviewing
15:42:14 <tovin07> and testing
15:42:16 <msimonin> tovin07: ack
15:42:23 <msimonin> we'll maybe need sole testing
15:42:27 <msimonin> some guidance*
15:42:34 <tovin07> :D
15:42:39 <msimonin> :)
15:42:47 <msimonin> I was reading and writing
15:43:16 <msimonin> so we have a plan :)
15:43:47 <DinaBelova> #info msimonin and rcherrueau are going to work on https://review.openstack.org/#/c/456278/1/doc/specs/in-progress/osprofiler.rst
15:43:54 <DinaBelova> #info tovin07 to help to review and testing
15:44:00 <DinaBelova> ok, looks like a plan :)
15:44:12 <DinaBelova> I think we're done for today :D
15:44:16 <DinaBelova> really quick meeting
15:44:20 <DinaBelova> thanks tovin07 and msimonin
15:44:26 <msimonin> Do you know where will be the next PTG ?
15:44:34 <tovin07> maybe Aug
15:44:34 <DinaBelova> no idea so far :(
15:44:37 <tovin07> at Denver
15:44:37 <rama_y__> Hi, DinaBelova, tovin07, question on sql tracing in Ironic
15:44:46 <DinaBelova> rama_y__ yes?
15:45:09 <tovin07> yes rama_y__ , continue sir
15:45:29 <rama_y__> I tried wrapping in Ironic similar to keystone
15:45:47 <rama_y__> I get error saying object doesn't have events
15:46:06 <rama_y__> as OSProfiler tries to listen on the events for sql tracing
15:46:18 <tovin07> the idea is simple like this
15:46:30 <rama_y__> https://github.com/openstack/ironic/blob/master/ironic/db/sqlalchemy/api.py#L56
15:46:58 <tovin07> we add “event listener” to before execute and after execute sql command
15:47:37 <tovin07> so, you have to find where is Ironic initialize sql connection
15:48:27 <rama_y__> tovin07, ok, I will check.
15:48:33 <tovin07> https://github.com/openstack/glance/blob/master/glance/db/sqlalchemy/api.py#L89-L92
15:48:42 <tovin07> Something like this
15:49:30 <DinaBelova> rama_y anything else?
15:50:31 <rama_y__> I was going to say, I tried this: https://github.com/openstack/keystone/blob/39c6b0ff537b822486d4fc187159464ea04bf912/keystone/common/sql/core.py#L252
15:51:11 <tovin07> msimonin: next PTG will be Denver :D
15:51:52 <msimonin> tovin07: thx :)
15:51:59 * tovin07 reading
15:52:33 <DinaBelova> rama_y I suspect you need to get either the session object or engine from the facade
15:53:41 <rama_y__> DinaBelova, Ironic has session_for_read and write and that is where I tried
15:54:21 <tovin07> can you provide error trace?
15:54:44 <DinaBelova> rama_y__ but due to what I see it's enginefacade.reader - are you sure it's the session class object from the sqlalchemy?
15:55:06 <DinaBelova> I just don't know, it's easier to check on the env
15:56:15 <rama_y__> tovin07, I don;t have the trace
15:57:01 <tovin07> i mean the error that you got “error saying object doesn't have events”
15:57:10 <rama_y__> yes
15:57:58 <DinaBelova> rama_y__ just copy us full error please
15:58:07 <rama_y__> sure
15:59:09 <rama_y__> Will be back shortly, thx!
16:01:52 <DinaBelova> folks, I'm really sorry, I have to run to other meeting....
16:02:00 <tovin07> np
16:02:04 <DinaBelova> tovin07 lemme end meeting, but please help rama_y
16:02:10 <tovin07> yes
16:02:13 <DinaBelova> thanks rama_y tovin07 msimonin
16:02:17 <DinaBelova> #endmeeting