15:30:11 <DinaBelova> #startmeeting Performance Team
15:30:12 <openstack> Meeting started Tue May 23 15:30:11 2017 UTC and is due to finish in 60 minutes.  The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:16 <openstack> The meeting name has been set to 'performance_team'
15:30:22 <DinaBelova> hello folks :)
15:30:28 <DinaBelova> let's see who is around
15:30:28 <tovin07> hello DinaBelova
15:30:31 <vbala> hi
15:30:35 <DinaBelova> tovin07 vbala o/
15:30:38 <DinaBelova> msimonin rcherrueau o/
15:30:39 <rcherrueau> hi
15:30:41 <tovin07> vbala: long time :D
15:30:58 <msimonin> hello
15:31:17 <DinaBelova> do we have someone from red hat today? akrzos ?
15:32:12 <DinaBelova> it looks like nope :)
15:32:16 <DinaBelova> let's proceed
15:32:19 <akrzos> sorry i'm here
15:32:29 <DinaBelova> akrzos hey! good to see you :)
15:32:34 <DinaBelova> #topic Action Items
15:32:36 <akrzos> been a long time!
15:32:46 <DinaBelova> akrzos true
15:32:47 <DinaBelova> :)
15:33:01 <DinaBelova> let's start with action items and then switch to summit impressions :)
15:33:08 <DinaBelova> we had only one action item
15:33:10 <DinaBelova> on rcherrueau
15:33:15 <msimonin> :)
15:33:17 <rcherrueau> :)
15:33:34 <DinaBelova> about sharing your networking delays methodology in perf docs :)
15:33:40 <DinaBelova> rcherrueau any estimates? :)
15:33:42 <rcherrueau> my apologise ...
15:34:06 <DinaBelova> it's ok :D summit is a huge distraction :)
15:34:10 <rcherrueau> Yes, I am working on it with Paul-Andre Raymond (a folk from Massively Distributed WG)
15:34:20 <DinaBelova> rcherrueau do you think there is a chance to finally upload it on review?
15:34:30 <DinaBelova> this week?
15:34:42 <rcherrueau> end of the week is OK?
15:34:46 <DinaBelova> sure :)
15:34:52 <rcherrueau> good
15:35:03 <DinaBelova> #action rcherrueau add OpenStack testing under networking delays (e.g. multisite deployment) methodology to performance docs (openstack under WAN)
15:35:09 <DinaBelova> okay, thank you sir!
15:35:19 <DinaBelova> #topic Boston summit: people's impression, sessions, etc.
15:35:33 <DinaBelova> today we have rcherrueau and akrzos who attended the summit
15:35:38 <DinaBelova> anything to share folks?
15:36:06 <DinaBelova> it's the first summit in non-design-summit format
15:36:07 <rcherrueau> personally, I mostly attended to session relative to fog/edge computing
15:36:08 <tovin07> I think vbala too
15:36:09 <akrzos> I think Julien and I's presentation went well
15:36:16 <DinaBelova> vbala too, sorry :)
15:36:38 <vbala> lot of interest on osprofiler
15:36:54 <vbala> there were questions on performance overhead, safety of security key, querying historical profile IDs
15:37:03 <DinaBelova> akrzos tovin07 vbala I wonder if there were many people on technical sessions? as right now summit is slowly becoming more marketing event I suppose
15:38:06 <DinaBelova> or was it about the same as on usual summits?
15:38:23 <DinaBelova> rcherrueau ^^
15:38:49 <akrzos> I don't think the "crowd" persay was that much less technical
15:39:13 <DinaBelova> akrzos okay :) good to know
15:39:20 <rcherrueau> I participated to olso sessions and there were full of developer so, I guess like an usual summit
15:39:43 <rcherrueau> they were*
15:39:57 <akrzos> most booths in market place were hard to find technical people
15:40:06 <DinaBelova> akrzos btw, will you upload results of your Telemetry research on perf-docs as well?
15:40:09 <akrzos> but probably to be expected since it's called market place
15:40:34 <DinaBelova> rcherrueau akrzos ack, thanks for sharing
15:40:45 <vbala> i attended the upstream sessions mostly and i felt it same like the usual summit
15:40:53 <akrzos> i should be able to share it
15:40:59 <akrzos> just a matter of time to put it in that format
15:41:03 <DinaBelova> vbala ack, thanks
15:41:16 <DinaBelova> akrzos ok, lemme create a note and ask you next time :)
15:41:41 <DinaBelova> #info akrzos to transform telemetry research to the rst format and upload it to perf docs
15:42:13 <DinaBelova> okay :)
15:42:26 <DinaBelova> thanks vbala rcherrueau akrzos for sharing summit info
15:42:32 <DinaBelova> #topic Current progress
15:42:57 <rcherrueau> I am pretty sure msimonin gave the link last week, but there was also our talk that folks from this WG should find interesting
15:43:32 <rcherrueau> #link https://youtu.be/xwT08H02Nok
15:44:05 <DinaBelova> thanks for sharing
15:44:07 <DinaBelova> we did not see this link last time :)
15:44:17 <msimonin> I'm pretty sure I forgot :)
15:44:21 <DinaBelova> :D
15:44:25 <DinaBelova> I think that from performance researches perspective it's too early to speak about some progress right after summit, but still
15:44:44 <DinaBelova> msimonin rcherrueau akrzos anything new to share since summit research?
15:45:15 <msimonin> Last week we talk about this osprofiler integration to rally with tovin07
15:45:28 <tovin07> yes
15:45:33 <DinaBelova> msimonin tovin07 yes, any progress here?
15:45:33 <msimonin> A first version is under review
15:45:41 <DinaBelova> link please :)
15:45:43 <msimonin> #link https://review.openstack.org/#/c/467252/
15:46:09 <msimonin> Mirantis Ci is bad to me :(
15:46:25 <DinaBelova> yeah, I see it's too cruel
15:46:34 <DinaBelova> lemme add Andrei to the reviewrs
15:46:40 <tovin07> I added myself
15:47:14 <akrzos> not much for me to share
15:47:14 <DinaBelova> cool, let's take a look on it
15:47:25 <DinaBelova> akrzos ack, no worries
15:47:46 <DinaBelova> tovin07 anything else to share on osprofiler?
15:47:54 <tovin07> yes
15:48:10 <tovin07> I continue to work on OSprofiler with Swift
15:48:21 <tovin07> and have a very fisrt version too
15:48:36 <DinaBelova> yay :) link please :)
15:48:37 <tovin07> #link PoC OSprofiler in Swift https://tovin07.github.io/swift/swift-list.html
15:49:07 <tovin07> I discussed with notmyname (Swift PTL), serveral weeks ago
15:50:07 <tovin07> He want to minimize the number of new libraries if ww want to add OSprofiler to Swift
15:50:46 <tovin07> OSprofiler have alot of dependencies (and nested)
15:51:29 <tovin07> i’m trying to minimize
15:51:33 <DinaBelova> although all of them are really standard
15:51:38 <DinaBelova> #link https://github.com/openstack/osprofiler/blob/master/requirements.txt
15:51:45 <DinaBelova> I mean standard for OpenStack :)
15:51:54 <tovin07> yes
15:52:02 <tovin07> for OpenStack but not Swift
15:52:18 <tovin07> Swift do not use Oslo-things
15:52:19 <DinaBelova> true enough
15:52:27 <tovin07> *does
15:53:02 <DinaBelova> well, frankly speaking I doubt that huge optimization is possible here
15:53:14 <DinaBelova> tovin07 how do you feel about it?
15:53:39 <tovin07> optimization for swift or osprofiler>
15:54:11 <tovin07> in osprofiler, we can refactor alot of code :D
15:54:36 <DinaBelova> tovin07 true, but not really clear if we need doing this for only one project
15:54:45 <tovin07> yes
15:55:11 <DinaBelova> okay, anything else?
15:55:13 <tovin07> I will discuss with notmyname
15:55:22 <tovin07> that’s all from my side for now
15:55:28 <DinaBelova> thanks tovin07
15:55:36 <DinaBelova> it looks like we may jump to open discussion
15:55:41 <DinaBelova> #topic Open Discussion
15:55:47 <DinaBelova> there is one Item I wanted to raise
15:56:06 <DinaBelova> upcoming in Sept PTG
15:56:14 <DinaBelova> it's going to be done in Denver
15:56:31 <DinaBelova> I wonder if there is an interest to gather together this time
15:56:58 <DinaBelova> msimonin rcherrueau akrzos tovin07 vbala - let's have an action item to think about
15:57:06 <msimonin> DinaBelova: ack
15:57:33 <vbala> DinaBelova: ok
15:57:42 <rcherrueau> DinaBelova: ok
15:57:46 <tovin07> okay
15:58:07 <DinaBelova> #info *all* to think about upcoming PTG (Denver, ~September) and decide if that is needed for us to meet in person next ptg
15:58:07 <DinaBelova> so that's all from my side
15:58:09 <akrzos> ack
15:58:15 <DinaBelova> anything else to discuss?
15:59:05 <DinaBelova> it looks like nope :)
15:59:18 <msimonin> :)
15:59:19 <DinaBelova> thanks everyone for coming today :)
15:59:23 <tovin07> :D
15:59:26 <DinaBelova> have a nice evening / day!
15:59:29 <msimonin> thanks DinaBelova
15:59:29 <DinaBelova> bye
15:59:32 <rcherrueau> thanks
15:59:33 <tovin07> thanks DinaBelova
15:59:33 <vbala> bye
15:59:34 <DinaBelova> #endmeeting