15:30:21 <DinaBelova> #startmeeting Performance Team
15:30:21 <openstack> Meeting started Tue Jun  6 15:30:21 2017 UTC and is due to finish in 60 minutes.  The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:25 <openstack> The meeting name has been set to 'performance_team'
15:30:45 <DinaBelova> let's see who is around today :)
15:31:24 <DinaBelova> interesting, I see none from Inria today :)
15:31:33 <DinaBelova> And do not see tovin07 :)
15:31:55 <DinaBelova> akrzos are you here? :) it looks like others were not able to join today
15:32:54 <DinaBelova> interesting :)
15:34:08 <DinaBelova> okay, I'll wait for a few moments in the channel - is no one will join, I'm canceling meeting due to technical reasons today :)
15:34:19 <rcherrueau> o/
15:34:22 <DinaBelova> rcherrueau wow :)
15:34:28 <DinaBelova> you are the first one to join
15:34:29 <DinaBelova> :D
15:34:34 <rcherrueau> wow
15:35:01 <DinaBelova> rcherrueau do you have any topics to be discussed today? due to lack of people I am thinking we can cancel meeting today :D
15:35:20 <rcherrueau> I'm pinging msimonin
15:35:29 <DinaBelova> as right now it's only me and you
15:35:30 <DinaBelova> ok
15:35:31 <rcherrueau> yes, just one
15:35:56 <DinaBelova> msimonin rcherrueau :)
15:36:01 <msimonin> hey o/
15:36:05 <msimonin> Hello
15:36:06 <DinaBelova> hello :)
15:36:18 <DinaBelova> msimonin rcherrueau you are my only guests this time :D
15:36:22 <DinaBelova> #topic Current progress
15:36:29 <DinaBelova> rcherrueau msimonin anything to share?
15:36:30 <rcherrueau> I wanna let you know that we want to conduct an experiment around alternatives for AMQP bus
15:36:45 <msimonin> (qpid dispatch router)
15:36:56 <rcherrueau> I know you (Mirantis) already start something in that direction
15:37:14 <DinaBelova> #info Inria wants to conduct an experiment around alternatives for AMQP bus
15:37:20 <rcherrueau> but we plan to test qpid in particular
15:37:30 <DinaBelova> rcherrueau can you please give more info? is this something folks from RedHat were doind?
15:37:42 <rcherrueau> yep exactly
15:37:53 <DinaBelova> rcherrueau a-ha, in fact we were planning to try it
15:37:58 <msimonin> :)
15:38:00 <DinaBelova> but we never had opportunity to
15:38:11 <msimonin> ah ok otherwise we could have joined our effort
15:38:26 <DinaBelova> msimonin rcherrueau I think you guys need to be pioneers here :D
15:38:29 <DinaBelova> sorry :D
15:38:35 <msimonin> I see :)
15:39:09 <rcherrueau> DinaBelova: In the FEMDC WG are working with RedHat folks to test it with EnOS.
15:39:18 <DinaBelova> any specific testing plans?
15:39:36 <tovin07> o/
15:39:39 <DinaBelova> tovin07 o/
15:39:47 <rcherrueau> The idea is then reuse WAN scenario we presented during the summit, but with qpid dispatch router.
15:40:01 <msimonin> not yet I think this will be discussed soon with kgisuti and ansmith
15:40:11 <DinaBelova> msimonin rcherrueau ack
15:40:48 <DinaBelova> this seems to be a great activity
15:40:59 <msimonin> This will be fun
15:41:02 <DinaBelova> :D
15:41:14 <msimonin> No more rabbit hunting
15:41:27 <DinaBelova> msimonin true :) anything else to share?
15:42:22 <msimonin> not from my side
15:42:26 <rcherrueau> me neither
15:42:32 <DinaBelova> ack
15:42:41 <DinaBelova> tovin07 - can you please give us your update?
15:43:10 <tovin07> oh, just nothing new
15:43:27 <tovin07> last week, i got a fever, so … :D
15:44:34 <DinaBelova> tovin07 oh, I hope you're ok now
15:44:55 <tovin07> yes, thanks
15:45:27 <DinaBelova> from my side I have no special news so far as well - we're trying to get k8s 1.6 running against 500 nodes, but lab issues / connectivity issues make me crazy sometimes
15:45:37 <DinaBelova> anyway, it's not very OpenSTack'ish so far :(
15:45:44 <msimonin> as long as it doesn't give you fever
15:45:54 <DinaBelova> heh, true enough
15:45:58 <DinaBelova> #topic Open Discussion
15:46:34 <msimonin> I've several thing
15:46:34 <DinaBelova> tovin07 msimonin rcherrueau - it looks like we have only three of you today :)
15:46:35 <msimonin> s
15:46:35 <DinaBelova> do you have something on your mind to tell about?
15:46:40 <DinaBelova> msimonin shoot
15:46:44 <msimonin> thanks
15:46:56 <msimonin> first one quesiton about rally
15:46:59 <msimonin> question*
15:47:28 <msimonin> it seems deployment/credentials… are abstracted, is there a plan to address anything else than openstack using rally ?
15:48:09 <DinaBelova> msimonin if I'm not mistaken, this was done abstract in case if something else will require to be needed (e.g. k8s or whatever else)
15:48:30 <msimonin> Ok I see
15:48:34 <DinaBelova> but if we are talking about current roadmap, I think we need to check it with Andrei Kurilin
15:48:50 <msimonin> ok
15:48:52 <DinaBelova> I'm not sure they have adding more platforms in nearest roadmap
15:48:53 <msimonin> let me know
15:48:53 <msimonin> :)
15:49:04 <DinaBelova> msimonin ack
15:49:13 <msimonin> Second about osprofiler
15:49:51 <msimonin> We intensively filter out the traces here (to get only  either RPC, DB)
15:50:04 <msimonin> we do it from the big JSON
15:50:39 <msimonin> is it something on the roadmap for osprofiler (do filtering) ?
15:50:51 <tovin07> it will be a little bit lag with big JSON
15:51:06 <tovin07> roadmap for filtering, currently no
15:51:32 <DinaBelova> msimonin we discussed it with tovin07 some time ago, but right now it's not clear who can do it
15:51:45 <DinaBelova> in fact I think we'll be glad if someone will step in
15:51:50 <DinaBelova> and implement this
15:52:13 <tovin07> however, I think about a very naive way is that we can filter it when we call osprofiler to get the output
15:52:19 <msimonin> This has to be  discussed/ defined I guess
15:52:44 <msimonin> do you think this is something that will come for free if osprofiler conform wi opentracing ?
15:53:17 <tovin07> however, data that stored in driver (redis, mongo,…) should be re-structrured to make it easier to query
15:53:31 <DinaBelova> msimonin I think neither me or tovin07 are against this functionality - the question right now is more about on what layer to do this, and who will implement it
15:53:45 <tovin07> msimonin: agree that we should discuss more
15:53:49 <DinaBelova> ++
15:53:50 <msimonin> DinaBelova:  yes of course :)
15:54:14 <tovin07> msimonin: opentracing will help us alot in this :D
15:54:34 <DinaBelova> tovin07 what's your insight on this task?
15:54:54 <msimonin> tovin07: ok it's maybe better to check opentracing first
15:55:11 <tovin07> DinaBelova: about filtering, currently, there is no clear idea yet
15:55:19 <DinaBelova> tovin07 ack
15:55:29 <DinaBelova> tovin07 msimonin should we agree to share ideas next time?
15:55:35 <msimonin> ok
15:55:40 <tovin07> yes
15:55:54 <DinaBelova> #action tovin07 msimonin DinaBelova prepare ideas on how requests filtering can be implemented in osprofiler
15:56:34 <DinaBelova> ok, logged :)
15:56:41 <DinaBelova> msimonin I like your questions :) do you have more? :D
15:57:08 <msimonin> I'm keeping them for next time :p
15:57:12 <DinaBelova> :D
15:57:16 <DinaBelova> ahaha, got it
15:57:20 <DinaBelova> rcherrueau tovin07 ?
15:57:33 <rcherrueau> nop
15:57:36 <tovin07> nope
15:57:42 <msimonin> maybe one thing
15:57:51 <DinaBelova> msimonin sure
15:57:58 <msimonin> I saw that etcd is now officially a base service
15:59:23 <msimonin> I guess there will be some new oslo driver soon
15:59:42 <DinaBelova> msimonin it's quite possible
16:00:16 <msimonin> I'll try to keep an eye on it
16:00:35 <DinaBelova> msimonin ack, let's have this in our vision
16:01:06 <msimonin> that's all
16:01:25 <DinaBelova> msimonin tovin07 rcherrueau I do not have any specific items as well
16:01:38 <DinaBelova> okay, thank you folks - I was afraid that none will join :D
16:01:44 <DinaBelova> but you came and it's good :)
16:01:49 <DinaBelova> have a nice evening!
16:01:54 <DinaBelova> #endmeeting