15:30:10 <DinaBelova> #startmeeting Performance Team
15:30:10 <openstack> Meeting started Tue Jul 11 15:30:10 2017 UTC and is due to finish in 60 minutes. The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:15 <openstack> The meeting name has been set to 'performance_team'
15:30:22 <tovin07> hello DinaBelova o/
15:30:22 <DinaBelova> hello folks :)
15:30:29 <DinaBelova> tovin07 o/
15:30:37 <DinaBelova> ilyashakhat o/
15:30:39 <ilyashakhat> salut!
15:31:06 <DinaBelova> let's wait for a few moments to see if anyone else will join :)
15:33:38 <DinaBelova> it looks like we have none from Inria today
15:34:11 <tovin07> oops, looks like that :(
15:34:41 <DinaBelova> okay, so let's proceed with current audience
15:35:06 <DinaBelova> #topic Action Items
15:35:07 <DinaBelova> last time we had several action items
15:35:33 <DinaBelova> tovin07 we promised to review https://review.openstack.org/#/c/358142/
15:35:46 <DinaBelova> obviously we had few iterations here
15:35:56 <tovin07> yes
15:36:18 <DinaBelova> fo I think we can assume it is done for a while
15:36:18 <tovin07> actually, I am a co-author of this patch
15:36:23 <DinaBelova> yeah :)
15:36:35 <DinaBelova> so let's keep our attention around this patch
15:36:57 <tovin07> i saw a +2 Jay Faulkner (for a long time ago)
15:37:06 <DinaBelova> but I think we have quite good progress here
15:37:08 <DinaBelova> :D
15:37:15 <DinaBelova> we need to reproduce it :D
15:37:17 <tovin07> :D
15:37:42 <DinaBelova> the second action item was also on you tovin07 :)
15:38:02 <DinaBelova> it was regarding preparing plan on how to implement osprofiler filtering use case
15:38:21 <tovin07> yes
15:38:45 <tovin07> but, there is none of Inria guys here today :/
15:39:18 <DinaBelova> true, so let's keep it in the action items
15:39:27 <DinaBelova> #action tovin07 take a look on the osprofiler filtering use cases #1 and #2 and share implementation ideas
15:39:39 <DinaBelova> #topic Current progress
15:39:45 <DinaBelova> tovin07 the floor is yours :)
15:40:03 <tovin07> thanks :D
15:40:23 <tovin07> recently, i mainly focus on PoC OSprofiler with OpenTracing compatible
15:40:49 <tovin07> I has published a patch related to this
15:40:56 <ilyashakhat> interesting :) do you plan to adopt OpenTracing API?
15:41:02 <tovin07> #link OSprofiler with OpenTracing compatible https://review.openstack.org/#/c/480018/
15:41:06 <DinaBelova> yes, this is an idea :)
15:41:25 <tovin07> #link a simple image for this patch https://tovin07.github.io/opentracing/jaeger-openstack-image-list.png
15:42:06 <tovin07> I make it work with OpenTracing API in simple cases, and chose Jaeger as a tracer/back-end
15:42:32 <DinaBelova> it looks really nice :)
15:42:47 <ilyashakhat> so it's mostly about the way osprofiler outputs data, right?
15:43:03 <tovin07> however, there are some troubles that I faced, I’ll try to fix them
15:43:32 <tovin07> I also discuss with other guys in OpenTracing community for the idea and best practices for implementation
15:44:02 <tovin07> DinaBelova: at this time, yes, it’s mostly about OSprofiler outputs data
15:44:29 <DinaBelova> ilyashakhat ^^
15:44:39 <ilyashakhat> cool to have it in a standard way
15:44:56 <tovin07> in the future, I think that we need to go further, not just output it to other backend as an OSprofiler driver
15:45:08 <DinaBelova> true :) thanks tovin07 for your efforts!
15:45:36 <tovin07> ilyashakhat: yes, I will make it fully compatible with OpenTracing API :D
15:46:16 <tovin07> and really welcome to anyone who wants to work with this
15:46:28 <DinaBelova> ilyashakhat are you interested? ;)
15:46:55 <ilyashakhat> do you (maybe) have plans to polish internal osprofiler APIs (like serialization a state into RPC)
15:47:05 <ilyashakhat> which is copy-pasted in all projects
15:47:13 <ilyashakhat> ?
15:47:29 <DinaBelova> i think this might be really useful, but right now no candidates to work on this
15:47:35 <tovin07> ilyashakhat: yes
15:47:51 <tovin07> we have (not should) to do it soon
15:48:34 <tovin07> DinaBelova: yup, no candidates to work on this right now
15:48:36 <ilyashakhat> yes, it would be really nice to have
15:49:05 <DinaBelova> so ilyashakhat if you're interested in helping, this is your chance :)
15:49:13 <tovin07> that’s the current progress on my work
15:49:31 <DinaBelova> tovin07 thank you sir
15:49:34 <ilyashakhat> DinaBelova, I'll take into consideration
15:49:42 <DinaBelova> ilyashakhat thanks :)
15:50:13 <ilyashakhat> but most probably this will go to the next release only?
15:50:28 <DinaBelova> ilyashakhat I believe so
15:50:49 <tovin07> yes, pike is around the corner
15:52:24 <DinaBelova> on my side: right now we've started work on adopting new internal Mirantis cloud for testing purposes (to have unified way of virtualized scale deployments) - so this is going to be a big work on tools preparation and our environments management :) so right now we're busy mostly with the technical debt stuff
15:53:06 <DinaBelova> ilyashakhat anything to share with us? what are you currently working on
15:53:08 <ilyashakhat> "virtualized scale" hmmm
15:53:25 <ilyashakhat> well, I'm mostly observing
15:53:54 <ilyashakhat> but there's one thing - performance docs are not published anymore
15:54:11 <ilyashakhat> I guess we need to migrate it to new doc style or so
15:54:18 <ilyashakhat> right?
15:54:33 <DinaBelova> ilyashakhat well, we used to do it on our on through some automatizations around Vms creation and management (as well as containerization), but right now there is a big wish to adopt our internal Mirantis cloud as much as possible, so we're working on it - to move "N thousand nodes" emulation testing to it
15:54:56 <ilyashakhat> DinaBelova, got it :)
15:55:06 <DinaBelova> ilyashakhat on performance docs - I believe you're right
15:55:31 <ilyashakhat> will take care of them
15:55:41 <DinaBelova> :thumbsup:
15:55:54 <tovin07> thanks ilyashakhat :D
15:55:59 <DinaBelova> #action ilyashakhat take a look and fix broken perf-docs publishing mechanism
15:56:28 <DinaBelova> okay, it looks like we're done for this section
15:56:37 <DinaBelova> #topic Open Discussion
15:57:04 <tovin07> Ideas for Sydney Summit (Nov 6 - 8)?
15:57:06 <DinaBelova> we have one item in the list of what to discuss
15:57:09 <DinaBelova> yeah
15:57:19 <DinaBelova> I think it might be ilyashakhat who proposed it?
15:57:31 <ilyashakhat> me?
15:57:37 <DinaBelova> nope? :)
15:57:45 <DinaBelova> okay, so that was not me :)
15:57:49 <DinaBelova> but is useful anyway
15:58:00 <tovin07> me :D
15:58:01 <DinaBelova> July 14th is the last day to propose the submissions
15:58:05 <DinaBelova> okay :D
15:58:34 <ilyashakhat> Australia is too far, attending the summit does not look realistic
15:59:06 <DinaBelova> so right now as my team is working on lots of technical debt stuff not sure if we'll be able to prepare materials for this summit as well. although ew have few more days to figure it out
15:59:20 <DinaBelova> ilyashakhat true, travel expenses will be crazy
15:59:24 <tovin07> DinaBelova: got it
15:59:25 <tovin07> however
15:59:38 <DinaBelova> tovin07 yeah, please share - do you have something to propose?
15:59:52 <tovin07> I proppsed a talk
16:00:00 <tovin07> related to OSprofiler with OpenTracing
16:00:13 <DinaBelova> this might be a good catch, yes
16:00:38 <tovin07> just cannot share the link (looks like it is not published to copy yet)
16:00:49 <tovin07> but the idea is that D:
16:00:51 <tovin07> :D
16:01:05 <DinaBelova> tovin07 good to know, thanks
16:01:16 <DinaBelova> I believe links will be available once submissions will be closed
16:01:38 <tovin07> DinaBelova: will you plan to have a “project status update”, or something like that?
16:02:08 <DinaBelova> tovin07 thinking on it right now, but I believe one OSproifler related talk submission will be most probably be enough
16:02:16 <DinaBelova> combined with project update
16:02:26 <DinaBelova> not so many details to be shared
16:02:33 <tovin07> maybe I should ask vipin too
16:03:06 <DinaBelova> as for performance docs - both Mirantis and RedHat and Inria had lots of internal things to do this cycle
16:03:08 <DinaBelova> obviously this lead to lack of public visibility on perf docs
16:03:15 <DinaBelova> tovin07 good idea, yes
16:04:27 <DinaBelova> okay, ilyashakhat tovin07 anything left to discuss today?
16:04:29 <tovin07> DinaBelova: can you review some remaining patches in OSprofiler?
16:04:36 <DinaBelova> tovin07 sure
16:04:43 <tovin07> I saw that ilyashakhat proposed 2 patches
16:04:51 <ilyashakhat> tovin07, while we are here https://review.openstack.org/#/c/476186/
16:05:06 <DinaBelova> #action DinaBelova review osprofiler patches left in queue
16:05:11 <tovin07> loading…
16:05:12 <DinaBelova> yeah, please ping me folks, when something needs to be reviewed. I'm a bit doomed with internal Mirantis things now :)
16:05:47 <ilyashakhat> I believe Alexey added these fields during refactoring and in fact they are not used...
16:05:56 <tovin07> ilyashakhat: I agree with you in this patch :D
16:06:23 <tovin07> we should refactor it
16:06:41 <ilyashakhat> ok)
16:07:20 <tovin07> okay, that’s all from me for now
16:07:40 <ilyashakhat> from my side too
16:07:45 <DinaBelova> thank you folks :)
16:07:51 <DinaBelova> have a nice evening
16:07:58 <DinaBelova> #endmeeting