15:30:25 <DinaBelova> #startmeeting Performance Team
15:30:26 <openstack> Meeting started Tue Sep 12 15:30:25 2017 UTC and is due to finish in 60 minutes. The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:30 <openstack> The meeting name has been set to 'performance_team'
15:30:38 <DinaBelova> hello folks :)
15:30:45 <DinaBelova> let's see who is around today :)
15:30:57 <tovin07> me o/
15:31:00 <rcherrueau> o?
15:31:01 <tovin07> hello DinaBelova
15:31:04 <DinaBelova> rcherrueau tovin07 o/
15:31:33 <DinaBelova> ilyashakhat o/
15:31:34 <DinaBelova> msimonin o/
15:31:40 <msimonin> o/
15:31:41 <ilyashakhat> o/
15:32:13 <DinaBelova> okay, so let's get started :)
15:32:17 <DinaBelova> #topic Action Items
15:32:24 <DinaBelova> last time we had two action items
15:32:53 <DinaBelova> one was regarding making osprofiler review queue a bit less :) thanks to Vipin and Boris it actually happened
15:33:34 <DinaBelova> tovin07 two more patches from you are almost ready to be merged, may you please fix them?
15:33:35 <DinaBelova> so we can actually do it
15:33:51 <tovin07> yes
15:33:53 <tovin07> :D
15:34:25 <DinaBelova> the second action item was about adding details to the https://etherpad.openstack.org/p/performance-team-q-release-ideas but frankly speaking it is a failure :) none has aded anything :D so it looks like we need to duplicate this action item again :)
15:34:56 <msimonin> oups
15:34:57 <DinaBelova> #action ilyashakhat msimonin rcherrueau tovin07 rajulk DinaBelova add ideas to https://etherpad.openstack.org/p/performance-team-q-release-ideas
15:35:01 <msimonin> totally forgot about this
15:35:12 <DinaBelova> it looks like all we did :D
15:35:26 <ilyashakhat> still have it on todo list
15:35:30 <msimonin> actually there is one idea : tovin07 :)
15:35:36 <tovin07> :))
15:35:43 <DinaBelova> let's try to be more productive next week :D
15:36:04 <DinaBelova> so let's go further
15:36:06 <DinaBelova> #topic Current status
15:36:13 <DinaBelova> tovin07 please go ahead
15:36:45 <tovin07> I has nothing for last week. It was my national holiday :D
15:37:34 <DinaBelova> tovin07 okay :) it's a good thing anyway :)
15:37:57 <DinaBelova> msimonin rcherrueau any news on the current testing / cockroachdb work?
15:38:36 <msimonin> is rcherrueau here ?
15:38:47 <DinaBelova> he was :D
15:38:56 <rcherrueau> yep
15:39:43 <rcherrueau> I pushed an email last week
15:39:51 <rcherrueau> #link http://lists.openstack.org/pipermail/openstack-dev/2017-September/121779.html
15:40:09 <rcherrueau> that explains the status of the POC we made
15:41:10 <rcherrueau> I also wanna write a test plan for cockroachdb, so I asked some help to CockroachDB guys.
15:41:46 <rcherrueau> that's all on my side
15:42:14 <DinaBelova> thanks rcherrueau
15:42:19 <DinaBelova> msimonin ? :)
15:42:36 <msimonin> First One thing regarding what rcherrueau said
15:43:03 <msimonin> there was a feedback about how the migrations were made in Keystone
15:43:31 <msimonin> it seems that Keystone is using an old(deprecated) project to handle the database migrations
15:43:39 <msimonin> this breaks hardly with cockroach
15:43:51 <msimonin> the suggestion was to move to alembic to manage the migrations
15:44:16 <msimonin> any idea on the effort it requires to move to alembic ?
15:44:28 <msimonin> it seems some other projects did it
15:44:57 <DinaBelova> msimonin well, it's major change in fact. And this requires separate development effort to get it done
15:45:17 <msimonin> This is what I thought :)
15:45:58 <DinaBelova> so I'd say this is about a 1-2 weeks or so to get it POC-level working , and then nobody-knows-how-much time to get it approved to the keystone itself :)
15:46:23 <msimonin> I see
15:46:55 <msimonin> So from the performance point of view there will be an evaluation on using cockroach
15:46:55 <DinaBelova> but frankly speaking I'm surprised :) I did not take a look on keystone for a while, but 2 years ago they were planning to migrate to alembic eventually
15:47:09 <msimonin> yes they eventually do
15:47:11 <msimonin> :)
15:47:12 <DinaBelova> it looks like this "eventually" never came to reality
15:47:14 <DinaBelova> :D
15:48:47 <DinaBelova> okay, msimonin, this was "first one thing" :) and the second one?
15:49:42 <msimonin> We are still preparing the amqp1.0 evaluation
15:50:16 <msimonin> No significant progress (some more tooling as usual)
15:50:45 <msimonin> That's all :)
15:50:55 <DinaBelova> thank you for the update :)
15:51:04 <DinaBelova> ilyashakhat anything from your side to share?
15:51:52 <ilyashakhat> no - I dedicated some time to os-faults, and that's all I did for community this week
15:52:13 <DinaBelova> ilyashakhat thank you sir, good to know :)
15:52:31 <DinaBelova> okay, it looks like we're really quick today :)
15:52:39 <DinaBelova> let's jump to the open discussions
15:52:42 <DinaBelova> #topic Open Discussion
15:53:01 <DinaBelova> msimonin rcherrueau tovin07 ilyashakhat - anything to raise on the discussion?
15:53:22 <rcherrueau> Maybe one request regarding osprofiler
15:53:23 <ilyashakhat> tovin07, do you have any specific plans for completing opentracing initiative?
15:53:23 <tovin07> this time, I have got travel support from OpenStack Foundation
15:53:43 <tovin07> ilyashakhat: yes
15:55:06 <rcherrueau> There are two kind of messages: rpc and notify. I think that osprofiler traces both as rpc ones.
15:55:12 <tovin07> will anyone attend Sydney Summit this Nov?
15:55:52 <DinaBelova> tovin07 any ideas when opentracing will be completed? :) as for the Sydney summit - it's not yet clear for me :(
15:55:54 <tovin07> rcherrueau: rpc and notify?
15:56:14 <rcherrueau> yes, oslo.messaging.rpc and oslo.messaging.notify
15:57:14 <tovin07> DinaBelova: hope it will be finished in this Q-cycle
15:57:27 <tovin07> rcherrueau: can you give me a link for that?
15:57:29 <rcherrueau> and inside rpc there are two kinds of call: call and cast
15:57:34 <DinaBelova> tovin07 ack
15:59:08 <rcherrueau> tovin07: https://docs.openstack.org/oslo.messaging/latest/reference/index.html
15:59:31 <tovin07> rcherrueau: hmm, okay, let make this as an action item for me :D
16:00:08 <rcherrueau> I am particularly interested by making the difference between rpc.call and rpc.cast
16:00:12 <DinaBelova> rcherrueau I believe you're right. We do not have this separation from the osprofiler standpoint. But in reality we do not trace notify, am I right? Notify i using by openstack services that would like to notify something else about whatever. But if we're tracing the api call to openstack project, we're using call to call remotely other service?
16:00:57 <DinaBelova> so notify is out of tracing here, as it's not related (please correct me if I'm wrong) to the OpenStack api tracing
16:01:24 <rcherrueau> DinaBelova: I don't take a look for a while. I guess you're right.
16:01:33 <DinaBelova> as for the diff between call/cast - it makes sense to set up this differentiation I belive
16:02:10 <rcherrueau> Thanks, diff between call/cast will be really helpful
16:02:16 <DinaBelova> tovin07 rcherrueau so it looks like it makes sense to take a look on how to separate cast/call in oprofiler
16:02:18 <DinaBelova> yeah
16:02:23 <tovin07> yep
16:02:40 <DinaBelova> tovin07 shoul I create an action item?
16:02:46 <tovin07> yes
16:03:08 <DinaBelova> #action tovin07 identify how to separate call/cast rpc calls within osprofiler tracing
16:03:34 <DinaBelova> msimonin rcherrueau ilyashakhat tovin07 anything else?
16:03:44 <tovin07> nope
16:03:59 <rcherrueau> nope
16:04:09 <msimonin> thanks for the meeting !
16:04:11 <DinaBelova> okay, it looks like we're done for today. Thanks everyone for participating :) Have a nice evening / day!
16:04:16 <DinaBelova> #endmeeting