15:30:01 <DinaBelova> #startmeeting Performance Team
15:30:02 <openstack> Meeting started Tue Oct 10 15:30:01 2017 UTC and is due to finish in 60 minutes.  The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:05 <openstack> The meeting name has been set to 'performance_team'
15:30:15 <DinaBelova> ilyashakhat o/
15:30:33 <ilyashakhat> DinaBelova, hi/
15:30:54 <DinaBelova> hm, it looks like we do not have any other folks sin irc channel so far :)
15:31:05 <DinaBelova> let's wait for a few moments
15:32:31 <DinaBelova> msimonin hey o/
15:32:42 <msimonin> hey DinaBelova :)
15:32:50 <msimonin> you are here :p
15:32:57 <DinaBelova> :D you too :D
15:33:00 <msimonin> ll
15:33:03 <msimonin> lol*
15:33:28 <DinaBelova> okay, it looks like we have ilyashakhat and msimonin - sad that I do not see tovin07 so far
15:33:52 <DinaBelova> hm, well, it looks like we'll have kinda quick session now
15:34:11 <DinaBelova> #topic Action Items
15:34:33 <ilyashakhat> do we have any?
15:34:42 <DinaBelova> last time we had only one action item on tovin07, so lemme keep it this time as well, as he does not seem to join today
15:35:01 <DinaBelova> #action tovin07 identify how to separate call/cast rpc calls within osprofiler tracing
15:35:17 <DinaBelova> so we can proceed for now
15:35:21 <DinaBelova> #topic Current status
15:35:35 <DinaBelova> msimonin I see you've uploaded new version of the test plan on review :)
15:35:49 <DinaBelova> msimonin anyway - what's current status on your side? :)
15:35:58 <msimonin> oh yes we made one more iteration with kgiusti
15:36:10 <msimonin> This test plan is ready for reviews
15:36:21 <msimonin> #link https://review.openstack.org/#/c/491818
15:36:27 <DinaBelova> #action DinaBelova ilyashakhat review https://review.openstack.org/#/c/491818/
15:36:36 <msimonin> Now we'll start implementing it
15:36:53 <msimonin> with rmq and qpid-dispatch
15:38:18 <DinaBelova> msimonin as it looks like you're only person from inria today - any news on performance study of the databases ? including cockroachDB research?
15:38:58 <msimonin> yes rcherrueau won't join today
15:39:01 <msimonin> not too much
15:39:29 <DinaBelova> msimonin ack
15:39:37 <msimonin> I think we need to formalize a plan as well
15:39:48 <DinaBelova> ilyashakhat so let's switch to you, sir :) any news on current progress?
15:39:57 <DinaBelova> msimonin ack, let us review it
15:40:08 <ilyashakhat> nothing new from my side, sorry :(
15:40:20 <DinaBelova> msimonin I believe we'll give some feedback this week
15:41:03 <msimonin> oh great :)
15:41:06 <DinaBelova> msimonin anything else to share, sir?
15:41:26 <msimonin> we had a pad about Q release plan
15:41:40 <DinaBelova> #link https://etherpad.openstack.org/p/performance-team-q-release-ideas
15:42:28 <msimonin> oh they are some +1 :)
15:42:53 <msimonin> From my side there are things related to fog/edge
15:43:01 <msimonin> line 11-13
15:43:06 <DinaBelova> yeah, from plans perspective it looks like we have a pack of things that you folks are planning to do (you're going to do it anyway, but i'll set my +1s there :D)
15:43:15 <DinaBelova> yes
15:43:22 <msimonin> I've put a note at the end
15:43:29 <msimonin> about "continuous benchmarking tool"
15:43:39 <DinaBelova> oh, I missed this particular item
15:43:49 <msimonin> I'm curious to know if it has already been discussed in the OpenStack community
15:44:02 <DinaBelova> hm, I did not see much about this
15:44:31 <DinaBelova> if we'll skip what rajulk2 is doing
15:44:49 <ilyashakhat> they even have a name for a project: https://openstack-lcoo.atlassian.net/wiki/spaces/LCOO/pages/13393034/Eris+-+Extreme+Testing+Framework+for+OpenStack
15:44:56 <msimonin> I've copy/paste the comment from mriedem
15:45:08 <ilyashakhat> BTW, DinaBelova do we have any relations with LCOO team?
15:45:28 <DinaBelova> ilyashakhat I believe not that much
15:46:21 <ilyashakhat> as I understand they took some ideas from Timur's session in Barcelona and moved forward with it
15:46:36 <DinaBelova> msimonin I see. Well, from scale testing perspective my folks swithced to virtualized envs for the scale testing, this means that high scale + high number of VMs is not anymore possible on our virtualized labs
15:47:23 <DinaBelova> ilyashakhat it looks like this, I see stepler among the tools to be used
15:47:57 <ilyashakhat> yep, and I even saw a report that looks similar to reliability that I made last year
15:48:02 <msimonin> DinaBelova: you mean you don't have access to bare metal ressources anymore ?
15:48:06 <ilyashakhat> a moment, will find a link again
15:49:06 <DinaBelova> msimonin yes, for large scale. We do have specific HW labs for particular performance researches, but it's not about high-scale bm
15:49:37 <DinaBelova> it's kinda costy, and yet mostly deployment architecture is usually verified, so it's ok to run those tests on vms usually
15:49:56 <msimonin> Ok I see
15:51:29 <msimonin> btw, do we have any plan to evaluate the CellV2 ?
15:51:43 <ilyashakhat> DinaBelova, will you be interested in measuring performance impact of profiling?
15:52:17 <DinaBelova> msimonin not from my side, my team will be kinda busy with other items to be covered
15:52:27 <DinaBelova> ilyashakhat I like this item, yes
15:52:34 <msimonin> ilyashakhat: me too :)
15:52:45 <ilyashakhat> cool :)
15:53:06 <DinaBelova> ilyashakhat but I guess I can provide very little of myself to participate in this :D
15:53:07 <DinaBelova> I believe tovin was also interested
15:53:11 <DinaBelova> even in taing active part
15:53:15 <msimonin> Do you envision the way you can evaluate the impact ?
15:53:16 <DinaBelova> taking*
15:54:44 <ilyashakhat> I would start with comparing duration of long operations like VM creation
15:55:02 <msimonin> using Rally ?
15:55:25 <DinaBelova> + resource consumption of openstack services and the osprofiler storage
15:55:36 <ilyashakhat> Rally can be an option
15:56:22 <ilyashakhat> profiling can be enabled directly in Rally scenario, so it's easy to use now
15:57:06 <DinaBelova> ilyashakhat i believe it will be the most convinient option now, yes
15:58:57 <ilyashakhat> here's the HA testing report from LCOO: https://openstack-lcoo.atlassian.net/wiki/download/attachments/13393034/TestResultsAnalysis-2.docx?version=1&modificationDate=1500988830906&cacheVersion=1&api=v2
15:59:11 <ilyashakhat> quite impressive
15:59:52 <DinaBelova> ilyashakhat it looks right like you did with reliability testing once :)
15:59:54 <DinaBelova> I mean charts
16:00:01 <ilyashakhat> yep
16:00:12 <DinaBelova> looks really nice, I agree
16:00:15 <msimonin> thanks for findind it :)
16:00:22 <msimonin> finding*
16:00:32 <ilyashakhat> I keep an eye on them :)
16:00:44 <DinaBelova> cool
16:01:06 <DinaBelova> I guess let's go back to https://etherpad.openstack.org/p/performance-team-q-release-ideas next time once tovin will join uss next time
16:01:25 <msimonin> ack
16:01:32 <DinaBelova> #topic Open Discussion
16:01:48 <DinaBelova> okay, any more interesting items to cover?
16:02:22 <DinaBelova> ilyashakhat thanks for sharing LCOO details
16:02:55 <ilyashakhat> np
16:03:11 <DinaBelova> it looks like we do not have anything else to cover today :) ilyashakhat msimonin ?
16:03:18 <ilyashakhat> a moment :)
16:03:47 <DinaBelova> ack
16:03:49 <ilyashakhat> DinaBelova, do you have an insight whether you/your colleagues using os-faults?
16:04:10 <ilyashakhat> I was going to make some changes, but it's hard to say who is using it
16:04:15 <ilyashakhat> except me :)
16:04:31 <DinaBelova> our OpenStack core team should be using it if i'm not mistaken
16:04:46 <ilyashakhat> okey, than I'll be careful
16:05:11 <ilyashakhat> that's all from me :)
16:05:24 <DinaBelova> ack, thank you sir :)
16:05:35 <msimonin> Can you express link failure in os-faults ?
16:05:50 <ilyashakhat> http://os-faults.readthedocs.io/en/latest/
16:05:52 * msimonin should read the doc :)
16:06:32 <ilyashakhat> but the purpose is better described in performance-docs
16:06:59 <ilyashakhat> https://docs.openstack.org/developer/performance-docs/test_plans/reliability/version_2/plan.html
16:07:50 <msimonin> ilyashakhat: thanks, I'll go through this
16:09:01 <msimonin> I'm done for today from my side
16:09:14 <DinaBelova> thank you folks
16:09:17 <DinaBelova> have a good evening
16:09:24 <ilyashakhat> goodbye!
16:09:27 <DinaBelova> #endmeeting