15:30:24 <DinaBelova> #startmeeting Performance Team
15:30:26 <openstack> Meeting started Tue Oct 17 15:30:24 2017 UTC and is due to finish in 60 minutes.  The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:30 <openstack> The meeting name has been set to 'performance_team'
15:30:37 <DinaBelova> hello folks! ilyashakhat msimonin tovin07 o/
15:31:36 <msimonin> o/
15:32:14 <DinaBelova> okay, let's wait till other folks will join
15:32:23 <msimonin> sure :)
15:32:43 <tovin07_> hi
15:32:53 <DinaBelova> o/
15:32:55 <tovin07_> o/
15:33:00 <msimonin> hi tovin07_
15:33:16 <DinaBelova> in the meanwhile we can go through our action items
15:33:20 <DinaBelova> #topic Action Items
15:33:28 <DinaBelova> last time we had 2 action items
15:33:38 <DinaBelova> tovin07_ let's start with yours :)
15:33:47 <tovin07_> yes
15:33:49 <DinaBelova> it's kinda old one
15:33:54 <DinaBelova> identify how to separate call/cast rpc calls within osprofiler tracing
15:34:16 <DinaBelova> any news here?
15:34:31 <tovin07_> sadly, I cannot find the way to separate them at this moment
15:34:52 <msimonin> I've one question with regards to this topic
15:35:15 <msimonin> a naive one actually
15:35:41 <DinaBelova> sure, shoot
15:36:13 <msimonin> as far as I remember, I see method instrumented quite high in the stack, not in oslo_messaging
15:36:20 <msimonin> Am I wrong ?
15:37:17 <DinaBelova> yes, wrapping rpc requests is happening in each project separately (as each openstack project uses oslo.messaging in its own, unique way :D )
15:38:17 <msimonin> sure but every project calls the rcp_call/cast from om ?
15:39:04 <msimonin> I guess each project instantiate an RPCClient and call the cast or call method on this object
15:39:36 <DinaBelova> well, they do, but to make it happen we need to introduce context serializer in each project in the way, unique for this project
15:39:42 <DinaBelova> most commonly it looks like this
15:39:42 <tovin07_> yes
15:39:45 <DinaBelova> https://github.com/openstack/nova/blob/bedb33ef04bf5710657fc46bceb68817dcbf83eb/nova/rpc.py#L144
15:40:45 <msimonin> concretely it's not possible to instrument oslo_messaging ?
15:41:53 <DinaBelova> it might be possible, but adding osprofiler to the oslo.messaging requirements will be tricky I guess
15:43:05 <tovin07_> another example about call/cast in magnum https://github.com/openstack/magnum/blob/master/magnum/common/rpc_service.py#L97
15:43:51 <DinaBelova> tovin07_ I guess adding understanding or either cast or call was processed is possible, but it will require now either adding profile() to all openstack projects functions that run this cast/call (as in big projects, e.g. nova, there are always custom wrappers, etc.) or hacking oslo,messagnig itself to add profiling on its level
15:44:10 <tovin07_> agree with that
15:44:14 <msimonin> the same : )
15:44:38 <DinaBelova> heh, option #1 is too complex imho
15:44:40 <tovin07_> but, I think we should find the way to change in OSprofiler only
15:44:57 <tovin07_> not all other project or trick in oslo_messaging
15:45:26 <msimonin> option #1 is painfull and hardly maintainable
15:45:39 <DinaBelova> #1 is not an option, agree here
15:45:44 <msimonin> :)
15:46:15 <DinaBelova> as for tovin07_ 's suggestion - well, we should, but I'm not sure we'll be able to - as to understand what is happening - cast or call is defined one level lower than we're wrapping RPC in the projects
15:46:21 <DinaBelova> in most of the projects
15:46:46 <msimonin> plus : profiling oslo_messaging could be interesting in itself (beyond cast/calls)
15:47:11 <DinaBelova> so from my perspective it might make sense to prepare poc of adding profiling functionality and try communicating with oslo folks to see if that's possible to adopt
15:47:37 <DinaBelova> i mean profiling functionality in oslo.messaging
15:48:15 <DinaBelova> tovin07_ should we leave this action item " identify how to separate call/cast rpc calls within osprofiler tracing" on you for a while longer? :)
15:48:41 <tovin07_> I think you should
15:48:46 <DinaBelova> :D
15:48:57 <DinaBelova> #action tovin07_  identify how to separate call/cast rpc calls within osprofiler tracing
15:49:00 <DinaBelova> okay :D
15:49:18 <DinaBelova> as for other action item it was on myself and ilyashakhat for reviewing https://review.openstack.org/#/c/491818/
15:49:37 <DinaBelova> it lgtm, but did not see ilyashakhat review so far
15:49:45 <DinaBelova> so lemme leave this on him
15:49:51 <DinaBelova> #action  ilyashakhat review https://review.openstack.org/#/c/491818/
15:49:54 <msimonin> thanks for your review
15:50:12 <msimonin> It seems there's something wrong with my titles (one test fails)
15:50:15 <DinaBelova> well, it looks good, full and with lots of details imho
15:50:24 <DinaBelova> yeah, need to check it
15:50:42 <msimonin> I'll have a look soon
15:50:58 <DinaBelova> ack
15:51:01 <DinaBelova> #topic Current status
15:51:10 <DinaBelova> tovin07_ the floor is yours :)
15:51:55 <tovin07_> hmm, I have nothing :D
15:52:18 <tovin07_> this time, I spent time mostly on my company's work
15:53:39 <DinaBelova> :)
15:53:45 <DinaBelova> okay, gotcha
15:53:52 <DinaBelova> msimonin anything interesting from your side?
15:54:12 <msimonin> hmm :)
15:54:31 <msimonin> Actually working on the implemetation of the testplan
15:54:46 <msimonin> but nothing relevant so far
15:54:56 <DinaBelova> ack, thank you sir
15:55:03 <DinaBelova> #topic Open Discussion
15:55:35 <DinaBelova> okay, msimonin tovin07_ anything to share as part of open discussion? I do not have any items myself
15:56:21 <tovin07_> nope
15:56:38 <DinaBelova> ack, so let's wrap-up for today :)
15:56:46 <DinaBelova> thank you folks for sharing your activities :)
15:56:47 <DinaBelova> #endmeeting