15:30:01 <DinaBelova> #startmeeting Performance Team
15:30:02 <openstack> Meeting started Tue Oct 31 15:30:01 2017 UTC and is due to finish in 60 minutes. The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:06 <openstack> The meeting name has been set to 'performance_team'
15:30:09 <tovin07_> o/
15:30:13 <DinaBelova> hello tovin07_ o/
15:30:20 <rcherrueau> o/
15:30:20 <DinaBelova> msimonin ilyashakhat o/
15:30:23 <DinaBelova> rcherrueau o/
15:30:36 <msimonin> Hello
15:30:46 <DinaBelova> let's wait for a couple of moments and then get started
15:31:51 <DinaBelova> okay, so let's start with action items :)
15:31:55 <DinaBelova> #topic Action Items
15:32:02 <DinaBelova> last time we actually had two
15:32:08 <DinaBelova> one quite old one of tovin07_ :)
15:32:20 <DinaBelova> about call/cast rpc calls within osprofiler tracing
15:32:25 <DinaBelova> tovin07_ any news about it?
15:32:33 <tovin07_> yes, I still not have time to do that :'(
15:32:47 <tovin07_> sorry
15:33:29 <DinaBelova> tovin07_ okay, so I guess my question is the following - are you going to pick this item and work on it?
15:33:29 <msimonin> Anything we can do ?
15:33:42 <DinaBelova> or you need any help?
15:33:50 <DinaBelova> if so we can ask msimonin to help
15:33:53 <DinaBelova> for example
15:33:55 <tovin07_> maybe, other one should pick this :D
15:34:32 <msimonin> Last time we talked about adding osprofier in oslo_messaging
15:34:42 <msimonin> Is there any known blocking point ?
15:35:10 <DinaBelova> msimonin not known to me
15:35:41 <DinaBelova> I guess it's a typical "try and see if anything will be blocking"
15:35:49 <msimonin> :) I see
15:36:23 <DinaBelova> tovin07_ msimonin okay guys - who should I place this action item on?
15:36:49 <tovin07_> msimonin can you work on it?
15:37:05 <msimonin> Not sure if I can dedicate time on this but I can try to
15:37:24 <DinaBelova> okay, so let's assign this to you for now
15:37:35 <DinaBelova> #action msimonin identify how to separate call/cast rpc calls within osprofiler tracing
15:37:48 <DinaBelova> the second action item was on ilyashakhat to review https://review.openstack.org/#/c/491818/
15:38:07 <DinaBelova> msimonin actually now there are few comments with minor improvements from him there
15:38:16 <DinaBelova> as well as couple of other minor comments as well
15:38:17 <msimonin> yes I need to address those
15:38:39 <msimonin> I'll probably fix them in the next days
15:38:49 <DinaBelova> yeah msimonin may you please address them and I believe we're quite good to merge this commit
15:39:08 <msimonin> DinaBelova: ack
15:39:19 <DinaBelova> #action msimonin address all comments in https://review.openstack.org/#/c/491818/ so it cam be merged
15:39:28 <DinaBelova> okay, so let's proceed further
15:39:32 <DinaBelova> #topic Current status
15:39:40 <DinaBelova> msimonin let's start with you :)
15:39:56 <msimonin> We have now someone working on the test plan
15:40:19 <msimonin> We'll hopefully have some result soon
15:40:46 <DinaBelova> msimonin ack, please keep us updated :)
15:41:04 <msimonin> Beside that I've some questions regarding os-faults :) I'll wait the open discussion
15:41:31 <DinaBelova> msimonin yeah, the best person to ask questions about it is ilyashakhat but I'm not sure he is around today
15:41:36 <DinaBelova> okay, anyway
15:41:37 <DinaBelova> rcherrueau anything from your side sir?
15:42:08 <rcherrueau> no, some question on osprofiler, but I will wait open discussions
15:42:37 <DinaBelova> okay, thanks :)
15:42:54 <DinaBelova> tovin07_ I suspect you were busy with some internal work, but still - any progress on perf/scale action items from your side?
15:43:05 <tovin07_> from my side, there is nothing new, mostly internal work
15:43:09 <tovin07_> this week, I saw ilyashakhat published some patches in osprofiler, and I agree with them, and there are some comments from Vipin
15:43:52 <DinaBelova> tovin07_ yeah, I need to review current osprofiler commits queue :D
15:43:54 <tovin07_> this week, I am preparing presentation for a lighting talk in Sydney summit
15:44:36 <DinaBelova> #action DinaBelova review https://review.openstack.org/#/q/project:openstack/osprofiler+status:open
15:44:37 <DinaBelova> tovin07_ yeah, summit is next week already
15:44:39 <DinaBelova> #topic Open Discussion
15:44:42 <tovin07_> that's all from me for now, hope that I will have more time for osprofiler after summit
15:44:48 <msimonin> tovin07_: do you have a link to your presentation ?
15:45:06 <tovin07_> currently no
15:45:19 <tovin07_> I will upload it to (somewhere) this week
15:45:38 <tovin07_> It will be a very short talk (only 10 min) :D
15:45:59 <DinaBelova> yeah, first thing I wanted to propose is to not holding our sync next week due to the summit
15:46:11 <DinaBelova> I suspect people will be too busy
15:46:41 <msimonin> I'll be home :)
15:47:01 <DinaBelova> okay, so tovin07_ will be on summit
15:47:12 <DinaBelova> I don't know about ilyashakhat and rcherrueau
15:47:34 <rcherrueau> I cannot go also
15:47:45 <DinaBelova> hm, so it looks like we can have a meeting :)
15:47:52 <DinaBelova> okay, so let's have it :)
15:48:12 <tovin07_> yes
15:48:13 <DinaBelova> #info next week meeting will be hold despite the fact of OpenStack summit
15:48:37 <DinaBelova> okay, so we decided here
15:48:38 <DinaBelova> msimonin please proceed with your topics
15:49:01 <msimonin> Yeah I had some questions about os-faults
15:49:32 <DinaBelova> let's just keep them here, I'll try to ping ilyashakhat later to answer them
15:49:35 <msimonin> ok
15:50:00 <msimonin> Is there a plan to support docker as a service driver ?
15:50:37 <DinaBelova> msimonin hm, I've seen some talks about it quite a while ago, but never saw it landed as a real thing
15:50:42 <msimonin> kill/restart docker containers
15:50:53 <msimonin> DinaBelova: ok
15:51:16 <DinaBelova> msimonin, lemme check it with ilyashakhat and some of the folks, who are using os-faults within mirantis now
15:51:25 <msimonin> ok great, thanks
15:51:31 <DinaBelova> I'll have more info next week
15:51:44 <msimonin> second question is :
15:51:56 <DinaBelova> #action DinaBelova check with ilyashakhat if docker will be supported as a service driver within os-faults
15:52:17 <msimonin> It seems that I can use os-fault with other applications than openstack using the universal driver
15:52:34 <msimonin> As long as you describe where your services are
15:52:36 <DinaBelova> msimonin this was the original idea, yes
15:52:40 <msimonin> ok :)
15:52:54 <DinaBelova> msimonin yes, this was the idea
15:52:55 <msimonin> Last question is more political
15:52:56 <msimonin> :)
15:53:15 <msimonin> Ansible is GPLv3
15:53:30 <msimonin> os-faults is Apache2
15:53:39 <msimonin> but use the internal API of Ansible
15:53:47 <msimonin> is it possible ?
15:53:54 <msimonin> (to be apache2)
15:54:36 <DinaBelova> well, not sure
15:54:39 <msimonin> :)
15:54:40 <DinaBelova> I just found https://www.apache.org/licenses/GPL-compatibility.html
15:54:44 <DinaBelova> right now
15:54:47 <tovin07_> iirc, kolla project faced this issue too
15:54:57 <DinaBelova> so I need to read it to check
15:55:10 <tovin07_> https://governance.openstack.org/tc/reference/licensing.html
15:55:16 <DinaBelova> The Free Software Foundation considers the Apache License, Version 2.0 to be a free software license, compatible with version 3 of the GPL. The Software Freedom Law Center provides practical advice for developers about including permissively licensed source.
15:55:19 <msimonin> kolla makes system calls to ansible
15:55:31 <DinaBelova> msimonin so it looks like it's ok
15:56:05 <DinaBelova> GPLv3 software cannot be included in Apache projects, but it's not icluding of projects themselves, but the API calls
15:56:37 <DinaBelova> anyway to have ansible working you need to install it somewhere before using gpl
15:57:05 <DinaBelova> although it's still a tricky question for me, I do not have the 100% answer to you here
15:57:14 <DinaBelova> sorry msimonin
15:57:26 <msimonin> Actually this sounds wrong to me to apply apache2 license here
15:57:36 <msimonin> but the same from my side I'm not 100% sure
15:58:30 <tovin07_> I think you should ask legal team for sure
15:58:37 <DinaBelova> if we'll find ilyashakhat next time let's ask him :D
15:58:56 <msimonin> yes this would be the first step, legal team sounds too formal for now :)
15:59:25 <DinaBelova> okay
15:59:25 <tovin07_> agree
15:59:26 <msimonin> let's wait ilyashakhat :)
15:59:36 <DinaBelova> rcherrueau I know you have some topic as well
15:59:52 <rcherrueau> yep, my question if for tovin07_
16:00:08 <tovin07_> yep, i'm here :D
16:00:22 <rcherrueau> tovin07_: I wanna use the feature that gives results in osprofiler
16:01:02 <tovin07_> yes
16:01:09 <rcherrueau> I tried to set it up by adding `[profiler]\nhide_result = false` in, e.g., nova.conf
16:01:27 <rcherrueau> but nothing
16:01:46 <tovin07_> what is your osprofiler version?
16:01:48 <rcherrueau> any idea?
16:02:09 * rcherrueau check
16:02:36 <rcherrueau> version of osprofiler packaged with kolla/pike
16:02:56 <tovin07_> do you have a version number?
16:03:14 <tovin07_> maybe via pip list
16:03:31 <rcherrueau> maybe 1.12, but I am not sure, I have to perform a deployment to check
16:03:56 <rcherrueau> (jump into nova container and then pip freeze should do the job)
16:04:25 <rcherrueau> but I cannot tell you the version right now, I have no deployment.
16:04:30 <tovin07_> okay, let me check which osprofiler version have this feature
16:04:37 * tovin07_ checking
16:06:19 <tovin07_> I think osprofiler packaged with pike is 1.12.0, and 1.12.0 has that feature
16:06:36 <rcherrueau> hum...
16:06:53 <tovin07_> but, I'm not sure which osprofiler version that kolla packaged in kolla-pike
16:07:02 <msimonin> Status: Downloaded newer image for beyondtheclouds/centos-source-nova-compute:5.0.1
16:07:02 <msimonin> ()[nova@de3c46ab6901 /]$ pip freeze | grep osprofiler
16:07:02 <msimonin> osprofiler==1.11.0
16:07:23 <rcherrueau> thanks msimonin
16:07:31 <msimonin> This is what I have for 5.0.1 series (this should be pike)
16:07:41 <tovin07_> oh, 1.11.0 do not has that feature
16:07:52 <rcherrueau> so, the problem comes from the version packaged by kolla
16:07:57 <tovin07_> yes
16:08:00 <tovin07_> I think so
16:08:32 <msimonin> weird because this should be installed from pip
16:08:33 <rcherrueau> And adding `[profiler]\nhide_result = false` is the correct way to ask for getting results?
16:09:02 <tovin07_> yes
16:09:14 <rcherrueau> tovin07_: OK, good. Thanks
16:09:26 <tovin07_> rcherrueau you're welcome :D
16:09:50 <DinaBelova> okay, msimonin tovin07_ rcherrueau anything else folks?
16:09:52 <rcherrueau> msimonin: The problem may come from the upper-constraint file
16:10:25 <rcherrueau> DinaBelova: that's good for me
16:10:37 <DinaBelova> msimonin tovin07_ ?
16:10:49 <msimonin> Thanks for the meeting !
16:11:07 <tovin07_> rcherrueau you means this? https://github.com/openstack/requirements/blob/master/upper-constraints.txt#L25
16:11:21 <rcherrueau> tovin07_: yep
16:11:44 <rcherrueau> looks its 1.11 for stable/pike
16:11:54 <rcherrueau> look it is*
16:11:55 <msimonin> oh yes :(
16:12:01 <DinaBelova> oh :(
16:12:15 <tovin07_> yup, it 1.11.0 for pike
16:12:47 <tovin07_> that's sad
16:13:46 <DinaBelova> folks, sorry, I have to run
16:13:50 <DinaBelova> lemme end the meeting
16:14:01 <DinaBelova> and please stay here and discuss more if needed
16:14:10 <tovin07_> no problem
16:14:13 <DinaBelova> thanks msimonin tovin07_ rcherrueau for participating
16:14:13 <tovin07_> bye DinaBelova
16:14:18 <rcherrueau> bye
16:14:36 <DinaBelova> #endmeeting