15:30:04 <DinaBelova> #startmeeting Performance Team
15:30:04 <openstack> Meeting started Tue Dec  5 15:30:04 2017 UTC and is due to finish in 60 minutes.  The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:08 <openstack> The meeting name has been set to 'performance_team'
15:30:19 <DinaBelova> hello tovin07 msimonin ilyashakhat o/
15:31:09 <tovin07> hi all
15:31:11 <tovin07> o/
15:31:36 <DinaBelova> tovin07 hey :) let's see if other folks are around :)
15:32:41 <DinaBelova> hm, probably not :D
15:32:55 <DinaBelova> anyway, let's go quickly through the action items
15:32:59 <DinaBelova> #topic Action Items
15:33:09 <DinaBelova> tovin07 one of the action items was on you
15:33:15 <tovin07> yes
15:33:20 <DinaBelova> >>> take a look on https://bugs.launchpad.net/osprofiler/+bug/1731864 and try to find out the root cause
15:33:20 <openstack> Launchpad bug 1731864 in osprofiler "class decorator isn't enabled in nova for some service" [Undecided,Confirmed]
15:33:30 <DinaBelova> please share the update
15:33:55 <tovin07> root cause, it's the same with msimonin and ilyashakhat mentioned last week
15:34:10 <DinaBelova> okay, then it was confirmed, good
15:34:18 <tovin07> yes
15:34:24 <DinaBelova> any plans to fix it? ;)
15:34:44 <tovin07> however, the solution is not quite clear, and I'm finding it
15:34:48 <DinaBelova> ack
15:34:53 <DinaBelova> so let's rephrase
15:35:11 <DinaBelova> lemme add action item on you to fix it, so you can continue research on it
15:35:17 <tovin07> okay
15:35:21 <tovin07> :D
15:35:25 <DinaBelova> #action tovin07 fix https://bugs.launchpad.net/osprofiler/+bug/1731864
15:35:25 <openstack> Launchpad bug 1731864 in osprofiler "class decorator isn't enabled in nova for some service" [Undecided,Confirmed]
15:35:32 <DinaBelova> okay, other action item was on msimonin
15:35:51 <DinaBelova> as it looks like he's not around the laptop, lemme keep it
15:35:53 <DinaBelova> as is
15:36:01 <DinaBelova> #action msimonin contact oslo.messaging team and propose them direct osprofiler integration to the library
15:36:07 <tovin07> yep
15:36:09 <msimonin> I'm here :)
15:36:11 <msimonin> sorry
15:36:16 <DinaBelova> oh :)
15:36:26 <DinaBelova> so please share the status on the action item :)
15:36:53 <msimonin> ok I speak informally with kgiusti on having osprofiler in oslo messaging
15:37:16 <msimonin> We agreed on the fact that I should go to the PTG :)
15:37:31 <DinaBelova> :D
15:37:32 <msimonin> and talk f2f with om cores there
15:37:34 <tovin07> next PTG will be in Dublin
15:38:22 <msimonin> tovin07: regarding  https://bugs.launchpad.net/osprofiler/+bug/1731864
15:38:22 <openstack> Launchpad bug 1731864 in osprofiler "class decorator isn't enabled in nova for some service" [Undecided,Confirmed]
15:38:27 <DinaBelova> #info msimonin spoke to kgiusti on having osprofiler in oslo messaging - this has to be pushed through the PTG discussion
15:38:45 <msimonin> what do you think to put the patch code in the __call__ method of the metaclass ?
15:39:06 <msimonin> and use a metaclass to decorate nova functions
15:40:08 <DinaBelova> tovin07 ^^
15:40:23 <tovin07> msimonin yep
15:40:27 <tovin07> I think so
15:41:07 <tovin07> it will solve some cases
15:41:10 <tovin07> however
15:42:10 <tovin07> if we create an object of a class before CONF is read, it still not work
15:42:35 <tovin07> but, I think, maybe we will not cover that case this time :D
15:44:07 <DinaBelova> should we proceed to the current status section?
15:44:33 <DinaBelova> i guess so :)
15:44:37 <DinaBelova> #topic Current status
15:44:40 <DinaBelova> tovin07 please go ahead
15:44:48 <msimonin> tovin07:  ack
15:45:37 <tovin07> that's all from me for now
15:45:39 <tovin07> :D
15:46:15 <DinaBelova> ok :)
15:46:22 <DinaBelova> msimonin - anything to share, sir?
15:47:00 <msimonin> I'm running out of brain today
15:47:07 <DinaBelova> :D
15:47:17 <DinaBelova> heh, it happens sometimes :D
15:47:46 <msimonin> more seriously I'll probably make an informal presentation of all the tools used in the performance team in my team soon
15:48:07 <DinaBelova> good to know :)
15:48:08 <msimonin> Just  need to prepare the slide deck :(
15:48:13 <DinaBelova> oh yeah
15:48:19 <DinaBelova> it's the most difficult part usually
15:48:26 <msimonin> *boring*
15:48:30 <DinaBelova> true
15:48:38 <msimonin> I'll let you know :)
15:48:46 <msimonin> I don't have more for today
15:48:54 <DinaBelova> thank you sir
15:49:19 <DinaBelova> okay, so let's jump to the last section
15:49:22 <DinaBelova> #topic Open Discussion
15:49:35 <DinaBelova> tovin07 msimonin any addition items?
15:49:45 <tovin07> currently not
15:49:53 <tovin07> I am a little bit sick today :))
15:49:58 <tovin07> flu
15:50:07 <msimonin> bad luck tovin07 !
15:50:07 <DinaBelova> okay, so let's wrap up then
15:50:08 <DinaBelova> tovin07 please get well
15:50:09 <DinaBelova> thank you for coming
15:50:15 <DinaBelova> and have a nice evening
15:50:18 <msimonin> yes
15:50:18 <DinaBelova> #endmeeting